]> git.pld-linux.org Git - packages/ocaml.git/blob - ocaml.spec
- BR
[packages/ocaml.git] / ocaml.spec
1 #
2 # Conditional build:
3
4 %bcond_without emacs    # emacs subpackage
5 %bcond_without x        # without X11 support 
6 %bcond_without tk       # tk support
7 %bcond_with db3         # use db3 instead of db 4.x
8
9 # --without x11 implies --without tk
10 %{!?with_x:%undefine    with_tk}
11
12 %define p4ver 3.06
13
14 Summary:        The Objective Caml compiler and programming environment
15 Summary(pl):    Kompilator OCamla (Objective Caml) oraz ¶rodowisko programistyczne
16 Name:           ocaml
17 Version:        3.07
18 Release:        3
19 License:        distributable
20 Vendor:         Group of implementors <caml-light@inria.fr>
21 Group:          Development/Languages
22 Source0:        http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}.tar.gz
23 # Source0-md5:  2dd038055f5e1350078ad81270411b78
24 Source1:        http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.html.tar.gz
25 # Source1-md5:  9ac1f7e9e381b95504f0e7868d9fbf52
26 Source2:        http://caml.inria.fr/distrib/%{name}-%{version}/%{name}-%{version}-refman.ps.gz
27 # Source2-md5:  09a9ac4bc1ec90ca4d16743ffbe76c78
28 Source3:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.html.tar.gz
29 # Source3-md5:  21370bae4e7f6435b38aeb21db7ce8bb
30 Source4:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-manual.dvi.gz
31 # Source4-md5:  035915d1a530aa7ec9b194d9a7d258eb
32 Source5:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.html.tar.gz
33 # Source5-md5:  96d8eb4ca5abd58c9a280ba59f73b192
34 Source6:        ftp://ftp.inria.fr/INRIA/Projects/cristal/camlp4/camlp4-%{p4ver}-tutorial.dvi.gz
35 # Source6-md5:  fcd87c235109364242a0c9ccf176dff8
36 Source7:        http://www.oefai.at/~markus/ocaml_sources/pure-fun-1.0.4.tar.bz2
37 # Source7-md5:  567bc681b4cc1cfcbbfb6fa5f012019b
38 Source8:        http://www.oefai.at/~markus/ocaml_sources/ds-contrib.tar.gz
39 # Source8-md5:  77fa1da7375dea1393cc0b6cd802d7e1
40 Patch0:         %{name}-build.patch
41 Patch1:         %{name}-db3.patch
42 Patch2:         %{name}-objinfo.patch
43 Patch3:         %{name}-mano.patch
44 Patch4:         %{name}-unused-var-warning.patch
45 Patch5:         %{name}-3.07-patch2.diffs
46 URL:            http://caml.inria.fr/
47 %{?with_x:BuildRequires:                XFree86-devel}
48 %{?with_db3:BuildRequires:      db3-devel}
49 %{!?with_db3:BuildRequires:     db-devel >= 4.1}
50 %{?with_tk:BuildRequires:               tk-devel}
51 %if %{with emacs}
52 BuildRequires:  emacs
53 BuildRequires:  xemacs
54 BuildRequires:  xemacs-common
55 BuildRequires:  xemacs-fsf-compat-pkg
56
57 %endif
58 Requires:       ocaml-runtime = %{version}-%{release}
59 Provides:       ocaml-ocamldoc
60 Obsoletes:      ocaml-ocamldoc
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Objective Caml is a high-level, strongly-typed, functional and
65 object-oriented programming language from the ML family of languages.
66
67 This package comprises two batch compilers (a fast bytecode compiler
68 and an optimizing native-code compiler), an interactive toplevel
69 system, Lex&Yacc tools, a replay debugger, and a comprehensive
70 library.
71
72 %description -l pl
73 OCaml (Objective Caml) jest funkcyjnym, obiektowo zorientowanym jêzykiem
74 wysokiego poziomu z silnym typowaniem. Nale¿y do rodziny jêzyków ML.
75
76 Ten pakiet zawiera dwa kompilatory (szybki kompilator do bajtkodu
77 oraz optymalizuj±cy kompilator do kodu natywnego), interaktywne ¶rodowisko
78 pracy, narzêdzia do tworzenia analizatorów leksykalnych oraz sk³adniowych
79 (ocamllex, ocamlyacc), odpluskwiacz (ocamldebug) i biblioteki.
80
81 %package doc-ps
82 Summary:        PostScript documentation for OCaml
83 Summary(pl):    Dokumentacja dla OCamla w formacie PostScript
84 Group:          Development/Tools
85
86 %description doc-ps
87 PostScript documentation for OCaml. HTML documentation is in main package.
88
89 %description doc-ps -l pl
90 Dokumentacja dla OCamla w formacie PostScript. Dokumentacja HTML jest
91 w g³ównym pakiecie.
92
93 %package emacs
94 Summary:        Emacs mode for OCaml
95 Summary(pl):    Tryb OCamla dla Emacsa
96 Group:          Development/Tools
97 Requires:       %{name} = %{version}
98
99 %description emacs
100 Emacs mode files for Objective Caml language.
101
102 %description emacs -l pl
103 Pliki trybu OCamla dla Emacsa.
104
105 %package runtime
106 Summary:        Runtime system for OCaml
107 Summary(pl):    ¦rodowisko uruchomieniowe dla OCamla
108 Group:          Libraries
109
110 %description runtime
111 This package contains binaries needed to run bytecode OCaml programs:
112 ocamlrun bytecode interpreter, and basic dynamic link libraries.
113
114 %description runtime -l pl
115 Pakiet ten zawiera binaria potrzebne do uruchamiania programów w
116 OCamlu skompilowanych do bajtkodu: interpreter bajtkodu (ocamlrun) oraz
117 podstawowe bibliotki linkowane dynamicznie.
118
119 %package labltk-devel
120 Summary:        LablTk library for OCaml
121 Summary(pl):    Biblioteka LablTk dla OCamla
122 Group:          Development/Libraries
123 Requires:       %{name}-labltk = %{version}-%{release}
124
125 %description labltk-devel
126 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
127 contains files needed to develop OCaml programs using LablTk.
128
129 %description labltk-devel -l pl
130 Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
131 Tcl/Tk. Pakiet ten zawiera pliki niezbêdne do tworzenia programów
132 u¿ywaj±cych LablTk.
133
134 %package labltk
135 Summary:        Runtime for LablTk library
136 Summary(pl):    ¦rodowisko uruchomieniowe dla biblioteki LablTk
137 Group:          Libraries
138 Requires:       %{name} = %{version}-%{release}
139
140 %description labltk
141 LablTk gives OCaml program access to Tcl/Tk GUI widgets. This package
142 contains files needed to run bytecode OCaml programs using LablTk.
143
144 %description labltk -l pl
145 Biblioteka LablTk daje programom napisanym w OCamlu dostêp do widgetów
146 Tcl/Tk. Pakiet ten zawiera binaria potrzebne do uruchamiania programów
147 u¿ywaj±cych LablTk.
148
149 %package x11graphics-devel
150 Summary:        X11 graphic output for OCaml
151 Summary(pl):    Dostêp do X11 dla OCamla
152 Group:          Development/Libraries
153 Requires:       %{name}-x11graphics = %{version}-%{release}
154
155 %description x11graphics-devel
156 x11graphics module gives OCaml program access to drawing in X11
157 windows. This package contains files needed to develop OCaml programs
158 using x11graphics.
159
160 %description x11graphics-devel -l pl
161 Modu³ x11graphics daje programom napisanym w OCamlu mo¿liwo¶æ
162 korzystania z interfejsu graficznego X11. Pakiet ten zawiera pliki
163 niezbêdne do tworzenia programów u¿ywaj±cych x11graphics.
164
165 %package x11graphics
166 Summary:        X11 graphic output for OCaml
167 Summary(pl):    Dostêp do X11 dla OCamla
168 Group:          Development/Libraries
169 Requires:       %{name} = %{version}-%{release}
170
171 %description x11graphics
172 x11graphics module gives OCaml program access to drawing in X11
173 windows. This package contains files needed to run bytecode OCaml
174 programs using x11graphics.
175
176 %description x11graphics -l pl
177 Modu³ x11graphics daje programom napisanym w OCamlu mo¿liwo¶æ
178 korzystania z interfejsu graficznego X11. Pakiet ten zawiera binaria
179 potrzebne do uruchamiania programów u¿ywaj±cych x11graphics.
180
181 %package camlp4
182 Summary:        Objective Caml Preprocessor
183 Summary(pl):    Preprocesor OCamla
184 Group:          Development/Languages
185 Requires:       %{name} = %{version}-%{release}
186 Provides:       camlp4 = %{version}-%{release}
187 Obsoletes:      camlp4
188
189 %description camlp4
190 Camlp4 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
191 tools for syntax (grammars) and the ability to modify the concrete
192 syntax of the language (quotations, syntax extensions).
193
194 Camlp4 can parse normal Ocaml concrete syntax or any other
195 user-definable syntax. As an example, an alternative syntax is
196 provided, named revised, because it tries to fix some small problems
197 of the normal syntax.
198
199 Camlp4 can pretty print the normal Ocaml concrete syntax or the
200 revised one. It is therefore always possible to have a version of your
201 sources compilable by the Objective Caml compiler without
202 preprocessing.
203
204 %description camlp4 -l pl
205 Camlp4 jest preprocesorem OCamla. Oferuje narzêdzia do manipulowania
206 sk³adni± (gramatyki) oraz mo¿liwo¶æ modyfikowania oryginalnej sk³adni
207 jêzyka (cytowania, rozszerzenia).
208
209 Camlp4 mo¿e sparsowaæ oryginaln± sk³adniê Ocamla lub dowoln± inn±
210 definiowaln± przez u¿ytkownika. Jako przyk³ad podana jest alternatywna
211 sk³adnia (revised syntax), która próbuje poprawiæ drobne problemy
212 wystêpuj±ce w sk³adni oryginalnej.
213
214 Camlp4 umie ³adnie formatowaæ ¼ród³a zarówno w oryginalnej jak i
215 poprawionej sk³adni OCamla. Potrafi tak¿e t³umaczyæ programy z jednej
216 sk³adni na drug±.
217
218 %package compiler-objects
219 Summary:        Compiled parts of OCaml compiler
220 Summary(pl):    Skompilowane czê¶ci kompilatora OCamla
221 Group:          Development/Languages
222 Requires:       %{name} = %{version}-%{release}
223 Obsoletes:      ocaml-devel
224
225 %description compiler-objects
226 This package contains *.cmi and *.cmo files being parts of OCaml
227 compiler. They are needed to compile some programs.
228
229 %description compiler-objects -l pl
230 Pakiet ten zawiera pliki *.cmi oraz *.cmo bêd±ce cze¶ciami kompilatora
231 OCamla. S± one wymagane do kompilacji niektórych programów.
232
233 %package ocamldoc-devel
234 Summary:        Files needed to develop programs using ocamldoc
235 Summary(pl):    Pliki potrzebne do tworzenia programów u¿ywaj±cych ocamldoc
236 Group:          Development/Languages
237 Requires:       %{name} = %{version}-%{release}
238
239 %description ocamldoc-devel
240 You need this package if you are going to write ocamldoc front end or
241 something like that.
242
243 %description ocamldoc-devel -l pl
244 Bêdziesz potrzebowaæ tego pakietu, je¶li zamierzasz pisaæ front end
245 dla ocamldoc lub co¶ podobnego.
246
247 %package lib-source
248 Summary:        Sources of OCaml standard library
249 Summary(pl):    ¬ród³a biblioteki standardowej OCamla
250 Group:          Development/Languages
251 Requires:       %{name} = %{version}-%{release}
252
253 %description lib-source
254 This sources come helpful during debugging of user programs with ocamldebug.
255
256 %description lib-source -l pl
257 ¬ród³a te s± przydatne przy odpluskwianiu programów u¿ytkownika
258 z u¿yciem ocamldebug.
259
260 # maybe we'll want to add some more stuff here?
261 %package examples
262 Summary:        Example source code for OCaml
263 Summary(pl):    Przyk³adowe kody ¼ród³owe w OCamlu
264 Group:          Development/Languages
265 Requires:       %{name} = %{version}-%{release}
266
267 %description examples
268 This packages contains sources for Okasaki's Purely Functional
269 Datastructures in OCaml, along with some contributions.
270
271 %description examples -l pl
272 Pakiet ten zawiera ¼ród³a Czysto Funkcyjnych Struktur Danych
273 autorstwa Okasaki'ego, napisane w OCamlu, wraz z dodatkami.
274
275 %prep
276 %setup -q -a1 -a3 -a5
277 mkdir examples
278 tar xjf %{SOURCE7} -C examples
279 tar xzf %{SOURCE8} -C examples
280 # order mess with docs somewhat
281 mkdir docs
282 mkdir docs/html
283 mv htmlman docs/html/ocaml
284 cp %{SOURCE2} docs/ocaml.ps.gz
285 mv camlp4-%{p4ver}-manual.html docs/html/camlp4
286 cp %{SOURCE4} docs/camlp4.ps.gz
287 mv camlp4-%{p4ver}-tutorial.html docs/html/camlp4-tutorial
288 cp %{SOURCE6} docs/camlp4-tutorial.ps.gz
289 %patch0 -p1
290 %patch1 -p1
291 %patch2 -p1
292 %patch3 -p1
293 %patch4 -p1
294 %patch5 -p1
295
296 %build
297 ./configure \
298         -cc "%{__cc} %{rpmcflags}" \
299         -bindir %{_bindir} \
300         -libdir %{_libdir}/%{name} \
301         -mandir %{_mandir}/man1 \
302         -host %{_host} \
303         %{!?with_tk:-no-tk} \
304         -with-pthread
305
306 %{__make} world bootstrap opt.opt
307 %{__make} -C tools objinfo
308
309 %install
310 rm -rf $RPM_BUILD_ROOT
311 install -d $RPM_BUILD_ROOT{%{_includedir},%{_examplesdir}/%{name}-{labltk-,}%{version}}
312
313 %{__make} install \
314         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
315         LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} \
316         MANDIR=$RPM_BUILD_ROOT%{_mandir}
317
318 cat > $RPM_BUILD_ROOT%{_libdir}/%{name}/ld.conf <<EOF
319 %{_libdir}/%{name}/stublibs
320 %{_libdir}/%{name}
321 EOF
322
323 %if %{with emacs}
324 %{__make} -C emacs DESTDIR=$RPM_BUILD_ROOT install \
325         EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
326                 else echo xemacs; fi`" \
327         EMACSDIR="$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp"
328 %endif
329
330 # symlink .opt versions of compilers (if present)
331 # warning: don't do that with camlp4 (can't load extensions then)
332 for f in ocamlc ocamlopt ocamldoc ocamllex; do
333         if test -f $RPM_BUILD_ROOT%{_bindir}/$f.opt; then
334                 mv -f $RPM_BUILD_ROOT%{_bindir}/$f \
335                         $RPM_BUILD_ROOT%{_bindir}/$f.byte
336                 ln -sf %{_bindir}/$f.opt $RPM_BUILD_ROOT%{_bindir}/$f
337         fi
338 done
339
340 # move includes to the proper place
341 mv -f $RPM_BUILD_ROOT%{_libdir}/%{name}/caml $RPM_BUILD_ROOT%{_includedir}/caml
342 # but leave compatibility symlink
343 ln -s ../../include/caml $RPM_BUILD_ROOT%{_libdir}/%{name}/caml
344
345 # compiled sources of compiler, needed by some programs
346 for f in {asm,byte}comp parsing typing utils ; do
347         install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
348         cp $f/*.{cmi,cmo,cmx,o} $RPM_BUILD_ROOT%{_libdir}/%{name}/compiler/$f
349 done
350
351 # this isn't installed by default, but is useful
352 install tools/objinfo $RPM_BUILD_ROOT%{_bindir}/ocamlobjinfo
353 cp -r examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
354 cp -r otherlibs/labltk/examples* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-labltk-%{version}
355 ln -sf %{_libdir}/%{name}/{scrape,add}labels $RPM_BUILD_ROOT%{_bindir}
356
357 # shutup checkfiles
358 rm -rf $RPM_BUILD_ROOT%{_mandir}/man3
359 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/labltk/{labltktop,pp}
360
361 %clean
362 rm -rf $RPM_BUILD_ROOT
363
364 %files runtime
365 %defattr(644,root,root,755)
366 %attr(755,root,root) %{_bindir}/ocamlrun
367 %dir %{_libdir}/%{name}
368 %dir %{_libdir}/%{name}/stublibs
369 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dll*.so
370 %exclude %{_libdir}/%{name}/stublibs/dllgraphics.so
371 %if %{with tk}
372 %exclude %{_libdir}/%{name}/stublibs/dlllabltk.so
373 %exclude %{_libdir}/%{name}/stublibs/dlltkanim.so
374 %endif
375
376 %files
377 %defattr(644,root,root,755)
378 %doc LICENSE Changes README Upgrading
379 %doc docs/html/ocaml
380 %attr(755,root,root) %{_bindir}/ocaml*
381 %{!?_without_tk:%exclude %{_bindir}/ocamlbrowser}
382 %exclude %{_bindir}/ocamlrun
383 %attr(755,root,root) %{_bindir}/*labels
384 %{_includedir}/caml
385 %{_libdir}/%{name}/caml
386 %{_libdir}/%{name}/threads
387 %dir %{_libdir}/%{name}/vmthreads
388 %dir %{_libdir}/%{name}/vmthreads/*.cm*
389 %dir %{_libdir}/%{name}/vmthreads/*.a
390 %{_libdir}/%{name}/*.a
391 %{_libdir}/%{name}/*.o
392 %{_libdir}/%{name}/*.cm*
393 %exclude %{_libdir}/%{name}/*graphics*
394 %{_libdir}/%{name}/ld.conf
395 %{_libdir}/%{name}/camlheader
396 %{_libdir}/%{name}/camlheader_ur
397 %dir %{_libdir}/%{name}/ocamldoc
398 %{_libdir}/%{name}/ocamldoc/*.hva
399 %attr(755,root,root) %{_libdir}/%{name}/expunge
400 %attr(755,root,root) %{_libdir}/%{name}/extract_crc
401 %attr(755,root,root) %{_libdir}/%{name}/*labels
402 %{_mandir}/man1/*ocaml*
403
404 %files lib-source
405 %defattr(644,root,root,755)
406 %{_libdir}/%{name}/*.ml
407 %{_libdir}/%{name}/*.mli
408 %{_libdir}/%{name}/*/*.mli
409
410 %files examples
411 %defattr(644,root,root,755)
412 %{_examplesdir}/%{name}-%{version}
413
414 # they are poor, html is much better
415 #%files manpages
416 #%%{_mandir}/man3/*
417
418 %files compiler-objects
419 %defattr(644,root,root,755)
420 %{_libdir}/%{name}/compiler
421
422 %files camlp4
423 %defattr(644,root,root,755)
424 %doc docs/html/camlp4*
425 %attr(755,root,root) %{_bindir}/*camlp4*
426 %attr(755,root,root) %{_bindir}/ocpp
427 # Not installed since 3.05, is is needed?
428 #%attr(755,root,root) %{_bindir}/odyl
429 %{_libdir}/%{name}/camlp4
430 %{_mandir}/man*/*camlp4*
431 %{_mandir}/man*/*ocpp*
432
433 %if %{with tk}
434 %files labltk-devel
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_bindir}/labltk
437 %attr(755,root,root) %{_bindir}/ocamlbrowser
438 %dir %{_libdir}/%{name}/labltk
439 %{_libdir}/%{name}/labltk/*.cm*
440 %{_libdir}/%{name}/labltk/*.a
441 %attr(755,root,root) %{_libdir}/%{name}/labltk/tkcompiler
442 %{_examplesdir}/%{name}-labltk-%{version}
443
444 %files labltk
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlllabltk.so
447 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dlltkanim.so
448 %endif
449
450 %if %{with x11}
451 %files x11graphics-devel
452 %defattr(644,root,root,755)
453 %{_libdir}/%{name}/graphics*.cm*
454 %{_libdir}/%{name}/graphics.a
455 %{_libdir}/%{name}/libgraphics.a
456
457 %files x11graphics
458 %defattr(644,root,root,755)
459 %attr(755,root,root) %{_libdir}/%{name}/stublibs/dllgraphics.so
460 %endif
461
462 %if %{with emacs}
463 %files emacs
464 %defattr(644,root,root,755)
465 %{_datadir}/emacs/site-lisp/*.el*
466 %endif
467
468 %files ocamldoc-devel
469 %defattr(644,root,root,755)
470 %{_libdir}/%{name}/ocamldoc/*.cm*
471 %{_libdir}/%{name}/ocamldoc/*.a
472
473 %files doc-ps
474 %defattr(644,root,root,755)
475 %doc docs/*.ps.gz
This page took 0.070349 seconds and 3 git commands to generate.