]> git.pld-linux.org Git - packages/ocaml.git/blob - ocaml.spec
166ef273d0cee522d8ff61a9c4852c322bfb5f62
[packages/ocaml.git] / ocaml.spec
1 Summary:        The Objective Caml compiler and programming environment
2 Summary(pl):    Kompilator Objektowego Caml oraz ¶rodowisko programistyczne
3 Name:           ocaml
4 Version:        3.01
5 Release:        1
6 URL:            http://pauillac.inria.fr/caml/
7 Vendor:         Group of implementors <caml-light@inria.fr>
8 Source0:        ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}.tar.gz
9 Source1:        ftp://ftp.inria.fr/lang/caml-light/%{name}-%{version}-refman.html.tar.gz
10 Copyright:      Distributable
11 Group:          Development/Languages
12 Group(de):      Entwicklung/Sprachen
13 Group(pl):      Programowanie/Jêzyki
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Objective Caml is a high-level, strongly-typed, functional and
18 object-oriented programming language from the ML family of languages.
19
20 This package comprises two batch compilers (a fast bytecode compiler
21 and an optimizing native-code compiler), an interactive toplevel
22 system, Lex&Yacc tools, a replay debugger, and a comprehensive
23 library.
24
25 %description -l pl
26 Objektowy Caml jest funkcjonalnym, obiektowo zorientowanym jêzykiem
27 wysokiego poziomu rodziny jêzyków ML.
28
29 Ten pakiet zawiera dwa kompilatory (szybki kompilator bytecode oraz
30 zoptymalizowany natywny kompilator), interaktywny g³ówny system,
31 narzêdzia Lex&Yacc, odpluskwiacz i biblioteki.
32
33 %package emacs
34 Summary:        Emacs mode for OCaml
35 Summary(pl):    Tryb Emacsa dla OCaml
36 Group:          Development/Tools
37 Group(de):      Entwicklung/Werkzeuge
38 Group(fr):      Development/Outils
39 Group(pl):      Programowanie/Narzêdzia
40 Requires:       %{name} = %{version}
41 # xemacs doesn't have Provide emacs ?
42 #BuildRequires: emacs
43
44 %description emacs
45 Emacs mode files for Objective Caml language
46
47 %description -l pl emacs
48 Pliki trybu Emacsa dla jêzyka Objektowego Caml
49
50 %prep
51 %setup -q -T -b 0
52 %setup -q -T -D -a 1
53
54 %build
55 ./configure \
56         -cc "%{__cc} %{rpmcflags}" \
57         -bindir %{_bindir} \
58         -libdir %{_libdir}/%{name} \
59         -mandir %{_mandir}/man1 \
60         -host %{_host_alias} \
61         -with-pthread
62
63 %{__make} world bootstrap opt ocamlc.opt ocamlopt.opt
64
65 %install
66
67 rm -rf $RPM_BUILD_ROOT
68 umask 022
69 echo    BINDIR=$RPM_BUILD_ROOT%{_bindir} >> config/Makefile
70 echo    LIBDIR=$RPM_BUILD_ROOT%{_libdir}/%{name} >> config/Makefile
71 echo    MANDIR=$RPM_BUILD_ROOT%{_mandir}/man1 >> config/Makefile
72 make    install 
73 %{__make} -C emacs install \
74         EMACS="`if [ -x %{_bindir}/emacs ]; then echo emacs; \
75                 else echo xemacs; fi`" \
76         EMACSDIR="$RPM_BUILD_ROOT%{_libdir}/emacs/site-lisp"
77 cp -p {parsing/{location,longident,parsetree},typing/typecore}.{cm,ml}i \
78         $RPM_BUILD_ROOT%{_libdir}/%{name}
79                         
80 gzip -9nf LICENSE Changes README
81
82 cd $RPM_BUILD_ROOT%{_bindir}
83 mv -f ocamlc            $RPM_BUILD_ROOT%{_bindir}/ocamlc.byte
84 mv -f ocamlc.opt        $RPM_BUILD_ROOT%{_bindir}/ocamlc
85 mv -f ocamlopt          $RPM_BUILD_ROOT%{_bindir}/ocamlopt.byte
86 mv -f ocamlopt.opt      $RPM_BUILD_ROOT%{_bindir}/ocamlopt
87 rm -f                   $RPM_BUILD_ROOT%{_libdir}/%{_name}/*.ml
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc htmlman *.gz
95 %attr(755, root, root) %{_bindir}/*
96 %{_libdir}/%{name}
97 %{_mandir}/man*/*
98
99 %files emacs
100 %defattr(644,root,root,755)
101 %{_libdir}/emacs/site-lisp/*.el
This page took 0.034795 seconds and 3 git commands to generate.