]> git.pld-linux.org Git - packages/ocaml-net.git/commitdiff
- updated to 3.7.7 auto/th/ocaml-net-3.7.7-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 16 Nov 2014 11:04:00 +0000 (12:04 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 16 Nov 2014 11:04:00 +0000 (12:04 +0100)
- dropped obsolete patches
- dropped gtk1 support

ocaml-net-apache24.patch [deleted file]
ocaml-net-lablgtk2.patch
ocaml-net-zip.patch [deleted file]
ocaml-net.spec

diff --git a/ocaml-net-apache24.patch b/ocaml-net-apache24.patch
deleted file mode 100644 (file)
index f5af772..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
---- ocamlnet-3.6/src/netcgi2-apache/apache.c~  2012-07-20 01:25:25.000000000 +0200
-+++ ocamlnet-3.6/src/netcgi2-apache/apache.c   2013-05-06 09:02:42.545701688 +0200
-@@ -212,7 +212,7 @@
-     raise_not_found ();                         \
- }
--CONNECTION(remote_ip)
-+CONNECTION(client_ip)
- CONNECTION(remote_host)
- /*----- Request structure. -----*/
---- ocamlnet-3.6/src/netcgi2-apache/netcgi_apache.ml~  2012-07-20 01:25:25.000000000 +0200
-+++ ocamlnet-3.6/src/netcgi2-apache/netcgi_apache.ml   2013-05-06 09:10:47.898274743 +0200
-@@ -469,7 +469,7 @@
-   method cgi_path_translated = "" (* FIXME: don't know how to get it *)
-   method cgi_auth_type = try Request.auth_type r with Not_found -> ""
-   method cgi_remote_addr =
--    try Connection.remote_ip(Request.connection r) with Not_found -> ""
-+    try Connection.client_ip(Request.connection r) with Not_found -> ""
-   method cgi_remote_host =
-     try Connection.remote_host(Request.connection r) with Not_found -> ""
-   method cgi_remote_user = try Request.user r with Not_found -> ""
---- ocamlnet-3.6/src/netcgi2-apache/netcgi_apache.mli~ 2012-07-20 01:25:25.000000000 +0200
-+++ ocamlnet-3.6/src/netcgi2-apache/netcgi_apache.mli  2013-05-06 09:11:14.894941214 +0200
-@@ -79,8 +79,8 @@
-   sig
-     type t (** Apache [conn_rec] structure. *)
--    external remote_ip : t -> string  = "netcgi2_apache_connection_remote_ip"
--      (** [conn_rec] [remote_ip] field.
-+    external client_ip : t -> string  = "netcgi2_apache_connection_client_ip"
-+      (** [conn_rec] [client_ip] field.
-           @raise Not_found if NULL. *)
-     external remote_host : t -> string = "netcgi2_apache_connection_remote_host"
-       (** [conn_rec] [remote_host] field.
---- ocamlnet-3.6/src/netcgi2-apache/netcgi_apache_mod.ml.in~   2012-07-20 01:25:26.000000000 +0200
-+++ ocamlnet-3.6/src/netcgi2-apache/netcgi_apache_mod.ml.in    2013-05-06 09:11:43.708274338 +0200
-@@ -88,7 +88,7 @@
-   struct
-     type t                            (* Actual conn_rec structure. *)
--    external remote_ip : t -> string = "netcgi2_apache_connection_remote_ip"
-+    external client_ip : t -> string = "netcgi2_apache_connection_client_ip"
-     external remote_host : t -> string = "netcgi2_apache_connection_remote_host"
-   (* ... etc ... *)
-@@ -237,7 +237,7 @@
-   let _server_admin = Server.admin
-   let _server_is_virtual = Server.is_virtual
--  let _connection_remote_ip = Connection.remote_ip
-+  let _connection_client_ip = Connection.client_ip
-   let _connection_remote_host = Connection.remote_host
-   let _request_connection = Request.connection
---- ocamlnet-3.6/src/netcgi2-apache/netcgi_apache_mod.mli~     2012-07-20 01:25:25.000000000 +0200
-+++ ocamlnet-3.6/src/netcgi2-apache/netcgi_apache_mod.mli      2013-05-06 09:12:00.441607551 +0200
-@@ -57,7 +57,7 @@
-   module Connection :
-   sig
-     type t (** Apache [conn_rec] structure. *)
--    external remote_ip : t -> string  = "netcgi2_apache_connection_remote_ip"
-+    external client_ip : t -> string  = "netcgi2_apache_connection_client_ip"
-     external remote_host : t -> string = "netcgi2_apache_connection_remote_host"
-   end
index 367266ed2c92e848b02c0519a1d0b0be3925cc3c..97808e20ffb8c5713511ef77d785b8274a6f4a82 100644 (file)
@@ -1,11 +1,11 @@
---- ocamlnet-3.3.4/configure~  2011-07-12 17:37:46.000000000 +0200
-+++ ocamlnet-3.3.4/configure   2011-07-18 11:31:34.518459688 +0200
-@@ -629,7 +629,7 @@
+--- ocamlnet-3.7.7/configure~  2014-11-16 11:54:23.000000000 +0100
++++ ocamlnet-3.7.7/configure   2014-11-16 11:57:03.500179144 +0100
+@@ -708,7 +708,7 @@
  EOF
      # Note: this newer API is never broken in the sense checked below, i.e.
      # such lablgtk2 versions do not exist.
--    if ocamlfind ocamlc -package unix,lablgtk2 -linkpkg -o tmp/gtk tmp/gtk.ml >/dev/null 2>/dev/null && tmp/gtk; then
-+    if ocamlfind ocamlc -package unix,lablgtk2 -linkpkg -o tmp/gtk tmp/gtk.ml >/dev/null 2>/dev/null; then
+-    if ocamlfind ocamlc -package unix,lablgtk2 -linkpkg -o tmp/gtk tmp/gtktest.ml >/dev/null 2>/dev/null && tmp/gtk; then
++    if ocamlfind ocamlc -package unix,lablgtk2 -linkpkg -o tmp/gtk tmp/gtktest.ml >/dev/null 2>/dev/null; then
          echo "yes"
-         gtk2_io_add_watch_supports_lists="-ppopt -DGTK2_IO_ADD_WATCH_SUPPORTS_LISTS"
+         gtk2_io_add_watch_supports_lists="-GTK2_IO_ADD_WATCH_SUPPORTS_LISTS"
      else
diff --git a/ocaml-net-zip.patch b/ocaml-net-zip.patch
deleted file mode 100644 (file)
index 9985da1..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- ocamlnet-3.3.4/configure~  2011-07-18 11:35:27.050459634 +0200
-+++ ocamlnet-3.3.4/configure   2011-07-18 11:37:58.059459600 +0200
-@@ -698,7 +698,7 @@
- if [ $enable_zip -gt 0 ]; then
-     printf "%s" "Checking for camlzip... "
--    if ocamlfind query camlzip >/dev/null 2>/dev/null; then
-+    if ocamlfind query zip >/dev/null 2>/dev/null; then
-         echo "found"
-       with_netzip=1
-     else
---- ocamlnet-3.3.4/src/netzip/META.in~ 2011-07-12 17:37:47.000000000 +0200
-+++ ocamlnet-3.3.4/src/netzip/META.in  2011-07-18 11:38:49.961459588 +0200
-@@ -1,5 +1,5 @@
- version = "@VERSION@"
--requires = "netstring,camlzip"
-+requires = "netstring,zip"
- archive(byte) = "netzip.cma"
- archive(native) = "netzip.cmxa"
- archive(native,gprof) = "netzip.p.cmxa"
---- ocamlnet-3.3.4/src/netzip/Makefile~        2011-07-12 17:37:47.000000000 +0200
-+++ ocamlnet-3.3.4/src/netzip/Makefile 2011-07-18 11:39:01.235459586 +0200
-@@ -8,6 +8,6 @@
- include $(TOP_DIR)/Makefile.rules
--REQUIRES += camlzip
-+REQUIRES += zip
- include depend
index d535d6084a158dea363330ecb1a1931d36b98d81..adb3a2e773c0950740d13ade8baf32d383cd81f7 100644 (file)
@@ -3,17 +3,15 @@
 Summary:       Modules for Internet programming in OCaml
 Summary(pl.UTF-8):     Moduły ułatwiające pisanie programów internetowych w OCamlu
 Name:          ocaml-net
-Version:       3.6
-Release:       7
+Version:       3.7.7
+Release:       1
 License:       GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
 Group:         Libraries
 Source0:       http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
-# Source0-md5: c6a42744c456b3b336c7613f5481650a
+# Source0-md5: e15e0961d09057f0bbe4f69d6055506c
 Patch0:                %{name}-buildfix.patch
 Patch1:                %{name}-lablgtk2.patch
-Patch2:                %{name}-zip.patch
-Patch3:                %{name}-apache-link.patch
-Patch4:                %{name}-apache24.patch
+Patch2:                %{name}-apache-link.patch
 URL:           http://projects.camlcity.org/projects/ocamlnet.html
 BuildRequires: %{apache}
 BuildRequires: %{apxs}
@@ -25,7 +23,6 @@ BuildRequires:        ocaml-cryptgps-devel
 BuildRequires: ocaml-cryptokit-devel
 BuildRequires: ocaml-findlib
 BuildRequires: ocaml-findlib-devel
-BuildRequires: ocaml-lablgtk-devel
 BuildRequires: ocaml-lablgtk2-devel >= 2.14.2
 BuildRequires: ocaml-labltk-devel
 BuildRequires: ocaml-pcre-devel
@@ -108,29 +105,6 @@ modułu obsługi zdarzeń na deskryptorach plików.
 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
 biblioteki equeue.
 
-%package equeue-gtk-devel
-Summary:       GTK event queue library for OCaml
-Summary(pl.UTF-8):     Biblioteka obsługująca kolejkę zdarzeń GTK dla OCamla
-License:       BSD-like
-Group:         Development/Libraries
-Requires:      %{name}-equeue-devel = %{version}-%{release}
-Requires:      ocaml-lablgtk-devel
-%requires_eq   ocaml
-
-%description equeue-gtk-devel
-Equeue provides a generic event queue module, and a specific module
-for file descriptor events.
-
-This package contains files needed to develop OCaml programs using GTK
-equeue library.
-
-%description equeue-gtk-devel -l pl.UTF-8
-Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
-modułu obsługi zdarzeń na deskryptorach plików.
-
-Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
-biblioteki equeue GTK.
-
 %package equeue-gtk2-devel
 Summary:       GTK2 event queue library for OCaml
 Summary(pl.UTF-8):     Biblioteka obsługująca kolejkę zdarzeń GTK2 dla OCamla
@@ -617,13 +591,11 @@ Interfejs dla protokołu SMTP opisanego w RFC 2821.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
-%patch4 -p1
 
 %build
 # no %%configure, please
 ./configure \
-       -enable-gtk \
+       -disable-gtk \
        -enable-gtk2 \
        -enable-ssl \
        -enable-zip \
@@ -657,8 +629,7 @@ for f in e* n* p* r* shell smtp ; do
 done
 cd ..
 
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/500netcgi_apache.info
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/META
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi2-apache/500netcgi_apache.info
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/mod_netcgi_apache.so*
 
 install -p src/netcgi2-apache/mod_netcgi_apache.so $RPM_BUILD_ROOT%{_apachepkglibdir}/mod_netcgi.so
@@ -727,13 +698,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/ocaml/site-lib/equeue
 %{_examplesdir}/%{name}-equeue-%{version}
 
-%files equeue-gtk-devel
-%defattr(644,root,root,755)
-%dir %{_libdir}/ocaml/equeue-gtk1
-%{_libdir}/ocaml/equeue-gtk1/*.cm[ixao]*
-%{_libdir}/ocaml/equeue-gtk1/*.a
-%{_libdir}/ocaml/site-lib/equeue-gtk1
-
 %files equeue-gtk2-devel
 %defattr(644,root,root,755)
 %dir %{_libdir}/ocaml/equeue-gtk2
@@ -856,6 +820,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/ocaml/netsys/*.cm[ixao]*
 %{_libdir}/ocaml/netsys/*.a
+%{_libdir}/ocaml/netsys/netsys_c_event.h
 %{_libdir}/ocaml/site-lib/netsys
 
 %files netzip-devel
This page took 0.03692 seconds and 4 git commands to generate.