]> git.pld-linux.org Git - packages/ocaml-net.git/blob - ocaml-net.spec
- update META file and unidata locations
[packages/ocaml-net.git] / ocaml-net.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4 %bcond_with     apache          # build apache module
5
6 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
7 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
8 %undefine       with_ocaml_opt
9 %endif
10
11 %define         apxs    /usr/sbin/apxs
12 %define         apache  /usr/sbin/httpd
13 Summary:        Modules for Internet programming in OCaml
14 Summary(pl.UTF-8):      Moduły ułatwiające pisanie programów internetowych w OCamlu
15 Name:           ocaml-net
16 Version:        4.1.8
17 Release:        2
18 License:        GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
19 Group:          Libraries
20 Source0:        http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
21 # Source0-md5:  0a76da5734e1861175f575c4e4ed3896
22 Patch0:         %{name}-buildfix.patch
23 Patch1:         %{name}-lablgtk2.patch
24 Patch2:         %{name}-apache-link.patch
25 URL:            http://projects.camlcity.org/projects/ocamlnet.html
26 %if %{with apache}
27 BuildRequires:  %{apache}
28 BuildRequires:  %{apxs}
29 BuildRequires:  apache-devel >= 2.0
30 %endif
31 BuildRequires:  ncurses-devel
32 BuildRequires:  ocaml >= 1:3.09.2
33 BuildRequires:  ocaml-camlp4
34 BuildRequires:  ocaml-cryptokit-devel
35 BuildRequires:  ocaml-findlib
36 BuildRequires:  ocaml-findlib-devel
37 BuildRequires:  ocaml-lablgtk2-devel >= 2.14.2
38 BuildRequires:  ocaml-labltk-devel
39 BuildRequires:  ocaml-pcre-devel
40 BuildRequires:  ocaml-ssl-devel
41 BuildRequires:  ocaml-zip-devel
42 BuildRequires:  tcl-devel
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _apachepkglibdir        %(%{apxs} -q LIBEXECDIR 2>/dev/null)
46 %define         _apachesysconfdir       %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
47
48 %description
49 Modules for Internet programming in OCaml.
50
51 %description -l pl.UTF-8
52 Moduły ułatwiające pisanie programów internetowych w OCamlu.
53
54 %package doc
55 Summary:        ocaml-net documentation
56 Summary(pl.UTF-8):      Dokumentacja dla pakietów ocaml-net
57 License:        BSD-like
58 Group:          Development/Libraries
59
60 %description doc
61 ocaml-net documentation.
62
63 %description doc -l pl.UTF-8
64 Dokumentacja dla pakietów ocaml-net.
65
66 %package netcgi-devel
67 Summary:        Common Gateway Interface library
68 Summary(pl.UTF-8):      Biblioteka do tworzenia skryptów CGI
69 License:        LGPL v2+ (mod_caml), BSD-like (the rest)
70 Group:          Development/Libraries
71 Requires:       %{name}-netplex-devel = %{version}-%{release}
72 Requires:       %{name}-netstring-devel = %{version}-%{release}
73 Requires:       %{name}-netsys-devel = %{version}-%{release}
74 Obsoletes:      ocaml-net-cgi-devel
75 %requires_eq ocaml
76
77 %description netcgi-devel
78 Common Gateway Interface library, part of Ocamlnet. This package
79 contains files needed to develop OCaml programs using netcgi library.
80
81 %description netcgi-devel -l pl.UTF-8
82 Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Ten
83 pakiet zawiera pliki niezbędne do tworzenia programów używających
84 biblioteki netcgi.
85
86 %package -n apache-mod_netcgi
87 Summary:        Apache module
88 Summary(pl.UTF-8):      Moduł Apache'a
89 Group:          Networking/Daemons/HTTP
90 Requires:       apache(modules-api) = %apache_modules_api
91
92 %description -n apache-mod_netcgi
93
94 %description -n apache-mod_netcgi -l pl.UTF-8
95
96 %package equeue-devel
97 Summary:        Event queue library for OCaml
98 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla
99 License:        BSD-like
100 Group:          Development/Libraries
101 Requires:       %{name}-netsys-devel = %{version}-%{release}
102 %requires_eq ocaml
103 Obsoletes:      ocaml-equeue-devel
104
105 %description equeue-devel
106 Equeue provides a generic event queue module, and a specific module
107 for file descriptor events.
108
109 This package contains files needed to develop OCaml programs using
110 equeue library.
111
112 %description equeue-devel -l pl.UTF-8
113 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
114 modułu obsługi zdarzeń na deskryptorach plików.
115
116 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
117 biblioteki equeue.
118
119 %package equeue-gtk2-devel
120 Summary:        GTK2 event queue library for OCaml
121 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń GTK2 dla OCamla
122 License:        BSD-like
123 Group:          Development/Libraries
124 Requires:       %{name}-equeue-devel = %{version}-%{release}
125 Requires:       ocaml-lablgtk2-devel
126 %requires_eq ocaml
127
128 %description equeue-gtk2-devel
129 Equeue provides a generic event queue module, and a specific module
130 for file descriptor events.
131
132 This package contains files needed to develop OCaml programs using
133 GTK2 equeue library.
134
135 %description equeue-gtk2-devel -l pl.UTF-8
136 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
137 modułu obsługi zdarzeń na deskryptorach plików.
138
139 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
140 biblioteki equeue GTK2.
141
142 %package equeue-tcl
143 Summary:        Event queue library for OCaml, Tcl support
144 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
145 License:        BSD-like
146 Group:          Libraries
147 %requires_eq ocaml-runtime
148 %requires_eq ocaml-labltk
149 Obsoletes:      ocaml-equeue-tcl
150
151 %description equeue-tcl
152 This package makes it possible to let Equeue cooperate with the event
153 queue implementation of Tcl.
154
155 This package contains files needed to run bytecode executables using
156 equeue-tcl library.
157
158 %description equeue-tcl -l pl.UTF-8
159 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
160 w Tcl.
161
162 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
163 używających biblioteki equeue-tcl.
164
165 %package equeue-tcl-devel
166 Summary:        Equeue Tcl support - development part
167 Summary(pl.UTF-8):      Wsparcie dla Tcl-a w equeue - cześć programistyczna
168 License:        BSD-like
169 Group:          Development/Libraries
170 Requires:       %{name}-equeue-devel = %{version}-%{release}
171 Requires:       %{name}-equeue-tcl = %{version}-%{release}
172 %requires_eq ocaml-labltk-devel
173 %requires_eq ocaml
174 Obsoletes:      ocaml-equeue-tcl-devel
175
176 %description equeue-tcl-devel
177 This package makes it possible to let Equeue cooperate with the event
178 queue implementation of Tcl.
179
180 This package contains files needed to develop OCaml programs using
181 this library.
182
183 %description equeue-tcl-devel -l pl.UTF-8
184 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
185 w Tcl.
186
187 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
188 biblioteki equeue-tcl.
189
190 %package netcamlbox-devel
191 Summary:        Fast IPC mechanism for OCaml
192 Summary(pl.UTF-8):      Szybki mechanizm IPC dla OCamla
193 License:        BSD-like
194 Group:          Development/Libraries
195 Requires:       %{name}-netsys-devel = %{version}-%{release}
196 %requires_eq ocaml
197
198 %description netcamlbox-devel
199 Camlboxes are a fast IPC mechanism to send Ocaml values from one
200 process to another. Source and destination processes must run on the
201 same machine (no network). The Ocaml value is copied to a shared
202 memory object where it can be directly accessed by the receiver
203 without unmarshalling step. This means the sender writes the value
204 into the shared memory in a format that can immediately interpreted by
205 the receiver.
206
207 This package contains files needed to develop OCaml programs using
208 netcamlbox library.
209
210 %description netcamlbox-devel -l pl.UTF-8
211 Camlboxy są szybkim mechanizmem IPC do przesyłania danych Ocamla
212 pomiędzy procesami. Nadawca i odbiorca muszą być uruchomione na tej
213 samej maszynie. Dane Ocamla są kopiowane do segmentu pamięci
214 dzielonej, gdzie mogą byc bezpośrednio odczytywane przez odbiorcę.
215
216 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
217 biblioteki netcamlbox.
218
219 %package netclient-devel
220 Summary:        HTTP 1.1 client for OCaml
221 Summary(pl.UTF-8):      Klient HTTP 1.1 dla OCamla
222 License:        BSD-like
223 Group:          Development/Libraries
224 Requires:       %{name}-equeue-devel = %{version}-%{release}
225 Requires:       %{name}-netstring-devel = %{version}-%{release}
226 %requires_eq ocaml
227 Obsoletes:      ocaml-netclient-devel
228
229 %description netclient-devel
230 Implements much of HTTP/1.1. Implements the following advanced
231 features: chunked messages; persistent connections; connections in
232 pipelining mode ("full duplex" connections); modular authentication
233 methods, currently Basic and Digest; event-driven implementation;
234 allows concurrent service for several network connections.
235
236 This package contains files needed to develop OCaml programs using
237 netclient library.
238
239 %description netclient-devel -l pl.UTF-8
240 Biblioteka netclient implementuje większość HTTP/1.1, a także
241 następujące zaawansowane właściwości: komunikaty w kawałkach;
242 połączenia stałe; połączenia w trybie "full duplex"; modularne metody
243 uwierzytelniania, obecnie Basic i Digest; implementacja oparta na
244 zdarzeniach; umożliwia jednoczesną obsługę kilku połączeń.
245
246 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
247 biblioteki netclient.
248
249 %package netgss-system
250 Summary:        GSS-API generic definition
251 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu GSSAPI
252 License:        GPL v2+
253 Group:          Libraries
254 Requires:       %{name}-netstring = %{version}-%{release}
255 Requires:       %{name}-netsys = %{version}-%{release}
256 %requires_eq ocaml
257
258 %description netgss-system
259 GSSAPI library, part of Ocamlnet. This package contains the files
260 needed to develop OCaml programs using netgss-system library.
261
262 %description netgss-system -l pl.UTF-8
263 Biblioteka do obsługi protokołu GSSAPI, część pakietu Ocamlnet. Ten
264 pakiet zawiera pliki niezbędne do tworzenia programów używających
265 biblioteki netgss-system.
266
267 %package netgss-system-devel
268 Summary:        GSS-API generic definition
269 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu GSSAPI
270 License:        GPL v2+
271 Group:          Development/Libraries
272 Requires:       %{name}-netgss-system-devel = %{version}-%{release}
273 Requires:       %{name}-netstring-devel = %{version}-%{release}
274 Requires:       %{name}-netsys-devel = %{version}-%{release}
275 %requires_eq ocaml
276
277 %description netgss-system-devel
278 GSSAPI library, part of Ocamlnet. This package contains the files
279 needed to develop OCaml programs using netgss-system library.
280
281 %description netgss-system-devel -l pl.UTF-8
282 Biblioteka do obsługi protokołu GSSAPI, część pakietu Ocamlnet. Ten
283 pakiet zawiera pliki niezbędne do tworzenia programów używających
284 biblioteki netgss-system.
285
286 %package nethttpd-devel
287 Summary:        HTTPd library
288 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu HTTP
289 License:        GPL v2+
290 Group:          Development/Libraries
291 Requires:       %{name}-equeue-devel = %{version}-%{release}
292 Requires:       %{name}-netcgi-devel = %{version}-%{release}
293 Requires:       %{name}-netplex-devel = %{version}-%{release}
294 %requires_eq ocaml-pcre-devel
295 %requires_eq ocaml
296
297 %description nethttpd-devel
298 HTTPd library, part of Ocamlnet. This package contains the files
299 needed to develop OCaml programs using nethttpd library.
300
301 %description nethttpd-devel -l pl.UTF-8
302 Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Ten
303 pakiet zawiera pliki niezbędne do tworzenia programów używających
304 biblioteki nethttpd.
305
306 %package netmulticore-devel
307 Summary:        Multi-processing for compute jobs
308 Summary(pl.UTF-8):      Obsługa wieloprocesorowych obliczeń
309 License:        GPL v2+
310 Group:          Development/Libraries
311 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
312 Requires:       %{name}-netplex-devel = %{version}-%{release}
313 %requires_eq ocaml
314
315 %description netmulticore-devel
316 Netmcore library, part of Ocamlnet. This package contains the files
317 needed to develop OCaml programs using netmulticore library.
318
319 %description netmulticore-devel -l pl.UTF-8
320 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
321 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
322 używających biblioteki netmulticore.
323
324 %package netplex
325 Summary:        Server framework
326 Summary(pl.UTF-8):      Szkielet serwerowy
327 License:        BSD-like
328 Group:          Libraries
329 %requires_eq ocaml-runtime
330 %requires_eq ocaml-labltk
331
332 %description netplex
333 Server framework.
334
335 This package contains files needed to run bytecode executables using
336 netplex library.
337
338 %description netplex -l pl.UTF-8
339 Szkielet serwerowy.
340
341 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
342 używających biblioteki netplex.
343
344 %package netplex-devel
345 Summary:        Server framework - development part
346 Summary(pl.UTF-8):      Szkielet serwerowy - cześć programistyczna
347 License:        BSD-like
348 Group:          Development/Libraries
349 Requires:       %{name}-equeue-devel = %{version}-%{release}
350 Requires:       %{name}-netplex = %{version}-%{release}
351 Requires:       %{name}-netstring-devel = %{version}-%{release}
352 Requires:       %{name}-netsys-devel = %{version}-%{release}
353 Requires:       %{name}-rpc-devel = %{version}-%{release}
354 %requires_eq ocaml
355
356 %description netplex-devel
357 Server framework.
358
359 This package contains files needed to develop OCaml programs using
360 netplex library.
361
362 %description netplex-devel -l pl.UTF-8
363 Szkielet serwerowy.
364
365 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
366 biblioteki netplex.
367
368 %package netshm-devel
369 Summary:        Shared memory support - development package
370 Summary(pl.UTF-8):      Obsługa pamięci dzielonej - pakiet programistyczny
371 License:        BSD-like
372 Group:          Development/Libraries
373 Requires:       %{name}-netsys-devel = %{version}-%{release}
374 %requires_eq ocaml
375
376 %description netshm-devel
377 Shared memory support.
378
379 This package contains files needed to develop OCaml programs using
380 netshm library.
381
382 %description netshm-devel -l pl.UTF-8
383 Obsługa pamięci dzielonej.
384
385 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
386 biblioteki netshm.
387
388 %package netstring
389 Summary:        String processing library
390 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
391 License:        BSD-like
392 Group:          Libraries
393 Requires:       %{name}-netsys-devel = %{version}-%{release}
394 %requires_eq ocaml-pcre-devel
395 %requires_eq ocaml
396
397 %description netstring
398 String processing library, part of Ocamlnet.
399
400 %description netstring -l pl.UTF-8
401 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet.
402
403 %package netstring-devel
404 Summary:        String processing library
405 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
406 License:        BSD-like
407 Group:          Development/Libraries
408 Requires:       %{name}-netstring = %{version}-%{release}
409 Requires:       %{name}-netsys-devel = %{version}-%{release}
410 %requires_eq ocaml-pcre-devel
411 %requires_eq ocaml
412
413 %description netstring-devel
414 String processing library, part of Ocamlnet. This package contains
415 files needed to develop OCaml programs using netstring library.
416
417 %description netstring-devel -l pl.UTF-8
418 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Ten
419 pakiet zawiera pliki niezbędne do tworzenia programów używających
420 biblioteki netstring.
421
422 %package netsys
423 Summary:        OS-specific functions
424 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego
425 License:        BSD-like
426 Group:          Libraries
427 %requires_eq ocaml-runtime
428
429 %description netsys
430 OS-specific functions.
431
432 This package contains files needed to run bytecode executables using
433 netsys library.
434
435 %description netsys -l pl.UTF-8
436 Funkcje specyficzne dla systemu operacyjnego.
437
438 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
439 używających biblioteki netsys.
440
441 %package netsys-devel
442 Summary:        OS-specific functions - development part
443 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego - cześć programistyczna
444 License:        BSD-like
445 Group:          Development/Libraries
446 Requires:       %{name}-netsys = %{version}-%{release}
447 %requires_eq ocaml
448
449 %description netsys-devel
450 OS-specific functions.
451
452 This package contains files needed to develop OCaml programs using
453 netsys library.
454
455 %description netsys-devel -l pl.UTF-8
456 Funkcje specyficzne dla systemu operacyjnego.
457
458 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
459 biblioteki netsys.
460
461 %package netzip-devel
462 Summary:        Gzip channels - development part
463 Summary(pl.UTF-8):      Funkcje do kompresji kanałow - cześć programistyczna
464 License:        BSD-like
465 Group:          Development/Libraries
466 Requires:       %{name}-netstring-devel = %{version}-%{release}
467 %requires_eq ocaml
468
469 %description netzip-devel
470 Gzip channels functions.
471
472 This package contains files needed to develop OCaml programs using
473 netzip library.
474
475 %description netzip-devel -l pl.UTF-8
476 Funkcje do kompresji kanałow.
477
478 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
479 biblioteki netzip.
480
481 %package rpc
482 Summary:        Remote Procedure Call (RPC) libraries
483 Summary(pl.UTF-8):      Biblioteki do obsługi RPC
484 License:        BSD-like
485 Group:          Development/Libraries
486 %requires_eq ocaml
487
488 %description rpc
489 Remote Procedure Call (RPC) libraries.
490
491 %description rpc -l pl.UTF-8
492 Biblioteki do obsługi RPC.
493
494 %package rpc-devel
495 Summary:        Remote Procedure Call (RPC) libraries - development part
496 Summary(pl.UTF-8):      Biblioteki do obsługi RPC - część programistyczna
497 License:        BSD-like
498 Group:          Development/Libraries
499 Requires:       %{name}-rpc = %{version}-%{release}
500 %requires_eq ocaml
501
502 %description rpc-devel
503 Remote Procedure Call (RPC) libraries - development part.
504
505 %description rpc-devel -l pl.UTF-8
506 Biblioteki do obsługi RPC - część programistyczna.
507
508 %package shell-devel
509 Summary:        Unix shell functions
510 Summary(pl.UTF-8):      Funkcje powłoki uniksowej
511 License:        BSD-like
512 Group:          Development/Libraries
513 Requires:       %{name}-equeue-devel = %{version}-%{release}
514 Requires:       %{name}-netsys-devel = %{version}-%{release}
515 %requires_eq    ocaml
516
517 %description shell-devel
518 Unix shell functions.
519
520 %description shell-devel -l pl.UTF-8
521 Funkcje powłoki uniksowej.
522
523 %package netunidata-devel
524 Summary:        Unicode lookup tables
525 License:        BSD-like
526 Group:          Development/Libraries
527 Requires:       %{name}-netstring-devel = %{version}-%{release}
528 Requires:       %{name}-netunidata-devel = %{version}-%{release}
529 %requires_eq    ocaml
530
531 %description netunidata-devel
532 Unicode lookup tables.
533
534 %prep
535 %setup -q -n ocamlnet-%{version}
536 %patch0 -p1
537 %patch1 -p1
538 %patch2 -p1
539
540 %build
541 # no %%configure, please
542 ./configure \
543         -datadir %{_datadir}/%{name} \
544         -disable-gtk \
545         -enable-gtk2 \
546         -enable-zip \
547         -enable-gssapi \
548 %if %{with apache}
549         -enable-apache \
550 %else
551         -disable-apache \
552 %endif
553         -enable-tcl \
554         -equeue-tcl-libs "-ltcl" \
555         -with-nethttpd \
556         -apxs %{apxs} \
557         -apache %{apache}
558
559 %{__make} -j1 all %{?with_ocaml_opt:opt}
560
561 %install
562 rm -rf $RPM_BUILD_ROOT
563 install -d $RPM_BUILD_ROOT{%{_libdir}/ocaml/stublibs,%{_apachepkglibdir},%{_apachesysconfdir}}
564
565 %{__make} -j1 install \
566         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
567         DESTDIR=$RPM_BUILD_ROOT
568
569 %if %{with apache}
570 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi2-apache/500netcgi_apache.info
571 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/mod_netcgi_apache.so*
572
573 install -p src/netcgi2-apache/mod_netcgi_apache.so $RPM_BUILD_ROOT%{_apachepkglibdir}/mod_netcgi.so
574 cat <<EOF >$RPM_BUILD_ROOT%{_apachesysconfdir}/90_mod_netcgi.conf
575 LoadModule netcgi_module     modules/mod_netcgi.so
576
577 <IfModule netcgi_module>
578         NetcgiLoad pcre/pcre.cma
579         NetcgiLoad netsys/netsys.cma
580         NetcgiLoad netstring/netstring.cma
581         NetcgiLoad str.cma
582         NetcgiLoad netcgi2/netcgi.cma
583         NetcgiLoad netcgi2-apache/netcgi_apache.cma
584
585         NetcgiHandler Netcgi_apache.bytecode
586         AddHandler ocaml-bytecode .cma
587
588 #       Alias /caml-bin/ /path/to/your/scripts/
589 #       <Location /caml-bin>
590 #               SetHandler ocaml-bytecode
591 #               NetcgiHandler Netcgi_apache.bytecode
592 #               Options ExecCGI
593 #               Allow from all
594 #       </Location>
595 </IfModule>
596 EOF
597 %endif
598
599 # not sure about *.o
600 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
601
602 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{netcgi,equeue,netcamlbox,netmulticore,netclient,nethttpd,rpc}-%{version}
603 cp -r examples/camlbox/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcamlbox-%{version}
604 cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcgi-%{version}
605 cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
606 cp -r examples/multicore/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netmulticore-%{version}
607 cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
608 cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
609 cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
610
611 %clean
612 rm -rf $RPM_BUILD_ROOT
613
614 %files doc
615 %defattr(644,root,root,755)
616 %doc LICENSE* ChangeLog RELNOTES doc/html-main
617
618 %files netcgi-devel
619 %defattr(644,root,root,755)
620 %dir %{_libdir}/ocaml/netcgi*
621 %{_libdir}/ocaml/netcgi*/META
622 %{_libdir}/ocaml/netcgi*/*.cm[ixao]*
623 %if %{with ocaml_opt}
624 %{_libdir}/ocaml/netcgi*/*.a
625 %endif
626 %{_examplesdir}/%{name}-netcgi-%{version}
627
628 %if %{with apache}
629 %files -n apache-mod_netcgi
630 %defattr(644,root,root,755)
631 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_apachesysconfdir}/*_mod_netcgi.conf
632 %attr(755,root,root) %{_apachepkglibdir}/mod_netcgi.so
633 %endif
634
635 %files equeue-devel
636 %defattr(644,root,root,755)
637 %dir %{_libdir}/ocaml/equeue
638 %{_libdir}/ocaml/equeue/META
639 %{_libdir}/ocaml/equeue/*.cm[ixao]*
640 %if %{with ocaml_opt}
641 %{_libdir}/ocaml/equeue/*.a
642 %endif
643 %{_examplesdir}/%{name}-equeue-%{version}
644
645 %files equeue-gtk2-devel
646 %defattr(644,root,root,755)
647 %dir %{_libdir}/ocaml/equeue-gtk2
648 %{_libdir}/ocaml/equeue-gtk2/META
649 %{_libdir}/ocaml/equeue-gtk2/*.cm[ixao]*
650 %if %{with ocaml_opt}
651 %{_libdir}/ocaml/equeue-gtk2/*.a
652 %endif
653
654 %files equeue-tcl
655 %defattr(644,root,root,755)
656 %dir %{_libdir}/ocaml/equeue-tcl
657 %{_libdir}/ocaml/equeue-tcl/META
658 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_tcl.so
659 %{_libdir}/ocaml/stublibs/dllequeue_tcl.so.owner
660
661 %files equeue-tcl-devel
662 %defattr(644,root,root,755)
663 %{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
664 %{_libdir}/ocaml/equeue-tcl/libequeue_tcl*.a
665 %if %{with ocaml_opt}
666 %{_libdir}/ocaml/equeue-tcl/equeue_tcl*.a
667 %endif
668
669 %files netcamlbox-devel
670 %defattr(644,root,root,755)
671 %dir %{_libdir}/ocaml/netcamlbox
672 %{_libdir}/ocaml/netcamlbox/META
673 %{_libdir}/ocaml/netcamlbox/*.cm[ixao]*
674 %if %{with ocaml_opt}
675 %{_libdir}/ocaml/netcamlbox/*.a
676 %endif
677 %{_examplesdir}/%{name}-netcamlbox-%{version}
678
679 %files netclient-devel
680 %defattr(644,root,root,755)
681 %dir %{_libdir}/ocaml/netclient
682 %{_libdir}/ocaml/netclient/META
683 %{_libdir}/ocaml/netclient/*.cm[ixao]*
684 %if %{with ocaml_opt}
685 %{_libdir}/ocaml/netclient/*.a
686 %endif
687 %{_examplesdir}/%{name}-netclient-%{version}
688
689 %files netgss-system
690 %defattr(644,root,root,755)
691 %dir %{_libdir}/ocaml/netgss-system
692 %{_libdir}/ocaml/netgss-system/META
693 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetgss-system.so
694 %{_libdir}/ocaml/stublibs/dllnetgss-system.so.owner
695
696 %files netgss-system-devel
697 %defattr(644,root,root,755)
698 %{_libdir}/ocaml/netgss-system/*.cm[ixao]*
699 %if %{with ocaml_opt}
700 %{_libdir}/ocaml/netgss-system/netgss-system*.a
701 %endif
702 %{_libdir}/ocaml/netgss-system/libnetgss-system*.a
703
704 %files nethttpd-devel
705 %defattr(644,root,root,755)
706 %dir %{_libdir}/ocaml/nethttpd
707 %{_libdir}/ocaml/nethttpd/META
708 %{_libdir}/ocaml/nethttpd/*.cm[ixa]*
709 %if %{with ocaml_opt}
710 %{_libdir}/ocaml/nethttpd/*.a
711 %endif
712 %{_examplesdir}/%{name}-nethttpd-%{version}
713
714 %files netmulticore-devel
715 %defattr(644,root,root,755)
716 %dir %{_libdir}/ocaml/netmulticore
717 %{_libdir}/ocaml/netmulticore/META
718 %{_libdir}/ocaml/netmulticore/*.cm[ixa]*
719 %if %{with ocaml_opt}
720 %{_libdir}/ocaml/netmulticore/*.a
721 %endif
722 %{_examplesdir}/%{name}-netmulticore-%{version}
723
724 %files netplex
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_bindir}/netplex-admin
727 %dir %{_libdir}/ocaml/netplex
728 %{_libdir}/ocaml/netplex/META
729 %if %{with ocaml_opt}
730 %{_libdir}/ocaml/netplex/*.o
731 %endif
732
733 %files netplex-devel
734 %defattr(644,root,root,755)
735 %{_libdir}/ocaml/netplex/netplex-packlist
736 %{_libdir}/ocaml/netplex/*.cm[ixao]*
737 %if %{with ocaml_opt}
738 %{_libdir}/ocaml/netplex/*.a
739 %endif
740
741 %files netshm-devel
742 %defattr(644,root,root,755)
743 %dir %{_libdir}/ocaml/netshm
744 %{_libdir}/ocaml/netshm/META
745 %{_libdir}/ocaml/netshm/*.cm[ixao]*
746 %if %{with ocaml_opt}
747 %{_libdir}/ocaml/netshm/*.a
748 %endif
749
750 %files netstring
751 %defattr(644,root,root,755)
752 %dir %{_libdir}/ocaml/netstring
753 %{_libdir}/ocaml/netstring/META
754 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetaccel_c.so
755 %{_libdir}/ocaml/stublibs/dllnetaccel_c.so.owner
756 %if %{with ocaml_opt}
757 %{_libdir}/ocaml/netstring/*.o
758 %endif
759
760 %files netstring-devel
761 %defattr(644,root,root,755)
762 %{_libdir}/ocaml/netstring/*.cm[ixao]*
763 %{_libdir}/ocaml/netstring/libnetaccel_c.a
764 %if %{with ocaml_opt}
765 %{_libdir}/ocaml/netstring/netstring*.a
766 %endif
767
768 %files netsys
769 %defattr(644,root,root,755)
770 %dir %{_libdir}/ocaml/netsys
771 %{_libdir}/ocaml/netsys/META
772 %{_libdir}/ocaml/netsys/*.o
773 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetsys.so
774 %{_libdir}/ocaml/stublibs/dllnetsys.so.owner
775
776 %files netsys-devel
777 %defattr(644,root,root,755)
778 %{_libdir}/ocaml/netsys/*.cm[ixao]*
779 %{_libdir}/ocaml/netsys/libnetsys*.a
780 %if %{with ocaml_opt}
781 %{_libdir}/ocaml/netsys/netsys*.a
782 %endif
783 %{_libdir}/ocaml/netsys/netsys_c_event.h
784
785 %files netzip-devel
786 %defattr(644,root,root,755)
787 %dir %{_libdir}/ocaml/netzip
788 %{_libdir}/ocaml/netzip/META
789 %{_libdir}/ocaml/netzip/*.cm[ixao]*
790 %if %{with ocaml_opt}
791 %{_libdir}/ocaml/netzip/*.a
792 %endif
793
794 %files rpc
795 %defattr(644,root,root,755)
796 %attr(755,root,root) %{_bindir}/ocamlrpcgen
797 %dir %{_libdir}/ocaml/rpc-auth-local
798 %{_libdir}/ocaml/rpc-auth-local/META
799 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so
800 %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so.owner
801
802 %files rpc-devel
803 %defattr(644,root,root,755)
804 %dir %{_libdir}/ocaml/rpc
805 %{_libdir}/ocaml/rpc/META
806 %dir %{_libdir}/ocaml/rpc-generator
807 %{_libdir}/ocaml/rpc-generator/META
808 %{_libdir}/ocaml/rpc-generator/rpcgen-packlist
809 %{_libdir}/ocaml/rpc*/*.cm[ixao]*
810 %{_libdir}/ocaml/rpc*/librpc_auth_local*.a
811 %if %{with ocaml_opt}
812 %{_libdir}/ocaml/rpc*/rpc*.a
813 %endif
814 %{_examplesdir}/%{name}-rpc-%{version}
815
816 %files shell-devel
817 %defattr(644,root,root,755)
818 %dir %{_libdir}/ocaml/shell
819 %{_libdir}/ocaml/shell/META
820 %{_libdir}/ocaml/shell/*.cm[ixao]*
821 %if %{with ocaml_opt}
822 %{_libdir}/ocaml/shell/*.a
823 %endif
824
825 %files netunidata-devel
826 %defattr(644,root,root,755)
827 %dir %{_libdir}/ocaml/netunidata
828 %{_libdir}/ocaml/netunidata/META
829 %{_libdir}/ocaml/netunidata/*.cm[ixao]*
830 %if %{with ocaml_opt}
831 %{_libdir}/ocaml/netunidata/*.a
832 %{_libdir}/ocaml/netunidata/*.o
833 %endif
834 %{_datadir}/ocaml-net
This page took 0.180022 seconds and 3 git commands to generate.