]> git.pld-linux.org Git - packages/ocaml-net.git/blob - ocaml-net.spec
66b2a971ce824ea2e873afc50a3794c655051c5c
[packages/ocaml-net.git] / ocaml-net.spec
1 #
2 # Conditional build:
3 %bcond_without  ocaml_opt       # skip building native optimized binaries (bytecode is always built)
4 %bcond_with     apache          # build apache module
5
6 # not yet available on x32 (ocaml 4.02.1), remove when upstream will support it
7 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
8 %undefine       with_ocaml_opt
9 %endif
10
11 %define         apxs    /usr/sbin/apxs
12 %define         apache  /usr/sbin/httpd
13 Summary:        Modules for Internet programming in OCaml
14 Summary(pl.UTF-8):      Moduły ułatwiające pisanie programów internetowych w OCamlu
15 Name:           ocaml-net
16 Version:        3.7.7
17 Release:        5
18 License:        GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
19 Group:          Libraries
20 Source0:        http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
21 # Source0-md5:  e15e0961d09057f0bbe4f69d6055506c
22 Patch0:         %{name}-buildfix.patch
23 Patch1:         %{name}-lablgtk2.patch
24 Patch2:         %{name}-apache-link.patch
25 URL:            http://projects.camlcity.org/projects/ocamlnet.html
26 %if %{with apache}
27 BuildRequires:  %{apache}
28 BuildRequires:  %{apxs}
29 BuildRequires:  apache-devel >= 2.0
30 %endif
31 BuildRequires:  ncurses-devel
32 BuildRequires:  ocaml >= 1:3.09.2
33 BuildRequires:  ocaml-camlp4
34 BuildRequires:  ocaml-cryptgps-devel
35 BuildRequires:  ocaml-cryptokit-devel
36 BuildRequires:  ocaml-findlib
37 BuildRequires:  ocaml-findlib-devel
38 BuildRequires:  ocaml-lablgtk2-devel >= 2.14.2
39 BuildRequires:  ocaml-labltk-devel
40 BuildRequires:  ocaml-pcre-devel
41 BuildRequires:  ocaml-ssl-devel
42 BuildRequires:  ocaml-zip-devel
43 BuildRequires:  tcl-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _apachepkglibdir        %(%{apxs} -q LIBEXECDIR 2>/dev/null)
47 %define         _apachesysconfdir       %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
48
49 %description
50 Modules for Internet programming in OCaml.
51
52 %description -l pl.UTF-8
53 Moduły ułatwiające pisanie programów internetowych w OCamlu.
54
55 %package doc
56 Summary:        ocaml-net documentation
57 Summary(pl.UTF-8):      Dokumentacja dla pakietów ocaml-net
58 License:        BSD-like
59 Group:          Development/Libraries
60
61 %description doc
62 ocaml-net documentation.
63
64 %description doc -l pl.UTF-8
65 Dokumentacja dla pakietów ocaml-net.
66
67 %package netcgi-devel
68 Summary:        Common Gateway Interface library
69 Summary(pl.UTF-8):      Biblioteka do tworzenia skryptów CGI
70 License:        LGPL v2+ (mod_caml), BSD-like (the rest)
71 Group:          Development/Libraries
72 Requires:       %{name}-netplex-devel = %{version}-%{release}
73 Requires:       %{name}-netstring-devel = %{version}-%{release}
74 Requires:       %{name}-netsys-devel = %{version}-%{release}
75 Obsoletes:      ocaml-net-cgi-devel
76 %requires_eq    ocaml
77
78 %description netcgi-devel
79 Common Gateway Interface library, part of Ocamlnet. This package
80 contains files needed to develop OCaml programs using netcgi library.
81
82 %description netcgi-devel -l pl.UTF-8
83 Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Ten
84 pakiet zawiera pliki niezbędne do tworzenia programów używających
85 biblioteki netcgi.
86
87 %package -n apache-mod_netcgi
88 Summary:        Apache module
89 Summary(pl.UTF-8):      Moduł Apache'a
90 Group:          Networking/Daemons/HTTP
91 Requires:       apache(modules-api) = %apache_modules_api
92
93 %description -n apache-mod_netcgi
94
95 %description -n apache-mod_netcgi -l pl.UTF-8
96
97 %package equeue-devel
98 Summary:        Event queue library for OCaml
99 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla
100 License:        BSD-like
101 Group:          Development/Libraries
102 Requires:       %{name}-netsys-devel = %{version}-%{release}
103 %requires_eq    ocaml
104 Obsoletes:      ocaml-equeue-devel
105
106 %description equeue-devel
107 Equeue provides a generic event queue module, and a specific module
108 for file descriptor events.
109
110 This package contains files needed to develop OCaml programs using
111 equeue library.
112
113 %description equeue-devel -l pl.UTF-8
114 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
115 modułu obsługi zdarzeń na deskryptorach plików.
116
117 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
118 biblioteki equeue.
119
120 %package equeue-gtk2-devel
121 Summary:        GTK2 event queue library for OCaml
122 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń GTK2 dla OCamla
123 License:        BSD-like
124 Group:          Development/Libraries
125 Requires:       %{name}-equeue-devel = %{version}-%{release}
126 Requires:       ocaml-lablgtk2-devel
127 %requires_eq    ocaml
128
129 %description equeue-gtk2-devel
130 Equeue provides a generic event queue module, and a specific module
131 for file descriptor events.
132
133 This package contains files needed to develop OCaml programs using
134 GTK2 equeue library.
135
136 %description equeue-gtk2-devel -l pl.UTF-8
137 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
138 modułu obsługi zdarzeń na deskryptorach plików.
139
140 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
141 biblioteki equeue GTK2.
142
143 %package equeue-ssl
144 Summary:        Event queue library for OCaml, SSL support
145 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla SSL
146 License:        BSD-like
147 Group:          Libraries
148 %requires_eq    ocaml-runtime
149
150 %description equeue-ssl
151 This package makes it possible to let Equeue cooperate with the event
152 queue implementation of SSL.
153
154 This package contains files needed to run bytecode executables using
155 equeue-ssl library.
156
157 %description equeue-ssl -l pl.UTF-8
158 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
159 w SSL.
160
161 Ten pakiet zawiera moduł potrzebny do uruchamiania programów
162 używających biblioteki equeue-ssl.
163
164 %package equeue-ssl-devel
165 Summary:        Equeue SSL support - development part
166 Summary(pl.UTF-8):      Wsparcie dla SSL-a w equeue - cześć programistyczna
167 License:        BSD-like
168 Group:          Development/Libraries
169 Requires:       %{name}-equeue-devel = %{version}-%{release}
170 Requires:       %{name}-equeue-ssl = %{version}-%{release}
171 %requires_eq    ocaml-ssl-devel
172 %requires_eq    ocaml
173
174 %description equeue-ssl-devel
175 This package makes it possible to let Equeue cooperate with the event
176 queue implementation of SSL.
177
178 This package contains files needed to develop OCaml programs using
179 equeue-ssl library.
180
181 %description equeue-ssl-devel -l pl.UTF-8
182 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
183 w SSL.
184
185 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
186 biblioteki equeue-ssl.
187
188 %package equeue-tcl
189 Summary:        Event queue library for OCaml, Tcl support
190 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
191 License:        BSD-like
192 Group:          Libraries
193 %requires_eq    ocaml-runtime
194 %requires_eq    ocaml-labltk
195 Obsoletes:      ocaml-equeue-tcl
196
197 %description equeue-tcl
198 This package makes it possible to let Equeue cooperate with the event
199 queue implementation of Tcl.
200
201 This package contains files needed to run bytecode executables using
202 equeue-tcl library.
203
204 %description equeue-tcl -l pl.UTF-8
205 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
206 w Tcl.
207
208 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
209 używających biblioteki equeue-tcl.
210
211 %package equeue-tcl-devel
212 Summary:        Equeue Tcl support - development part
213 Summary(pl.UTF-8):      Wsparcie dla Tcl-a w equeue - cześć programistyczna
214 License:        BSD-like
215 Group:          Development/Libraries
216 Requires:       %{name}-equeue-devel = %{version}-%{release}
217 Requires:       %{name}-equeue-tcl = %{version}-%{release}
218 %requires_eq    ocaml-labltk-devel
219 %requires_eq    ocaml
220 Obsoletes:      ocaml-equeue-tcl-devel
221
222 %description equeue-tcl-devel
223 This package makes it possible to let Equeue cooperate with the event
224 queue implementation of Tcl.
225
226 This package contains files needed to develop OCaml programs using
227 this library.
228
229 %description equeue-tcl-devel -l pl.UTF-8
230 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
231 w Tcl.
232
233 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
234 biblioteki equeue-tcl.
235
236 %package netcamlbox-devel
237 Summary:        Fast IPC mechanism for OCaml
238 Summary(pl.UTF-8):      Szybki mechanizm IPC dla OCamla
239 License:        BSD-like
240 Group:          Development/Libraries
241 Requires:       %{name}-netsys-devel = %{version}-%{release}
242 %requires_eq    ocaml
243
244 %description netcamlbox-devel
245 Camlboxes are a fast IPC mechanism to send Ocaml values from one
246 process to another. Source and destination processes must run on the
247 same machine (no network). The Ocaml value is copied to a shared
248 memory object where it can be directly accessed by the receiver
249 without unmarshalling step. This means the sender writes the value
250 into the shared memory in a format that can immediately interpreted by
251 the receiver.
252
253 This package contains files needed to develop OCaml programs using
254 netcamlbox library.
255
256 %description netcamlbox-devel -l pl.UTF-8
257 Camlboxy są szybkim mechanizmem IPC do przesyłania danych Ocamla
258 pomiędzy procesami. Nadawca i odbiorca muszą być uruchomione na tej
259 samej maszynie. Dane Ocamla są kopiowane do segmentu pamięci
260 dzielonej, gdzie mogą byc bezpośrednio odczytywane przez odbiorcę.
261
262 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
263 biblioteki netcamlbox.
264
265 %package netclient-devel
266 Summary:        HTTP 1.1 client for OCaml
267 Summary(pl.UTF-8):      Klient HTTP 1.1 dla OCamla
268 License:        BSD-like
269 Group:          Development/Libraries
270 Requires:       %{name}-equeue-devel = %{version}-%{release}
271 Requires:       %{name}-netstring-devel = %{version}-%{release}
272 %requires_eq    ocaml
273 Obsoletes:      ocaml-netclient-devel
274
275 %description netclient-devel
276 Implements much of HTTP/1.1. Implements the following advanced
277 features: chunked messages; persistent connections; connections in
278 pipelining mode ("full duplex" connections); modular authentication
279 methods, currently Basic and Digest; event-driven implementation;
280 allows concurrent service for several network connections.
281
282 This package contains files needed to develop OCaml programs using
283 netclient library.
284
285 %description netclient-devel -l pl.UTF-8
286 Biblioteka netclient implementuje większość HTTP/1.1, a także
287 następujące zaawansowane właściwości: komunikaty w kawałkach;
288 połączenia stałe; połączenia w trybie "full duplex"; modularne metody
289 uwierzytelniania, obecnie Basic i Digest; implementacja oparta na
290 zdarzeniach; umożliwia jednoczesną obsługę kilku połączeń.
291
292 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
293 biblioteki netclient.
294
295 %package netgssapi-devel
296 Summary:        GSS-API generic definition
297 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu GSSAPI
298 License:        GPL v2+
299 Group:          Development/Libraries
300 Requires:       %{name}-netstring-devel = %{version}-%{release}
301 Requires:       %{name}-netsys-devel = %{version}-%{release}
302 %requires_eq    ocaml
303
304 %description netgssapi-devel
305 GSSAPI library, part of Ocamlnet. This package contains the files
306 needed to develop OCaml programs using netgssapi library.
307
308 %description netgssapi-devel -l pl.UTF-8
309 Biblioteka do obsługi protokołu GSSAPI, część pakietu Ocamlnet. Ten
310 pakiet zawiera pliki niezbędne do tworzenia programów używających
311 biblioteki netgssapi.
312
313 %package nethttpd-devel
314 Summary:        HTTPd library
315 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu HTTP
316 License:        GPL v2+
317 Group:          Development/Libraries
318 Requires:       %{name}-equeue-devel = %{version}-%{release}
319 Requires:       %{name}-netcgi-devel = %{version}-%{release}
320 Requires:       %{name}-netplex-devel = %{version}-%{release}
321 %requires_eq    ocaml-pcre-devel
322 %requires_eq    ocaml
323
324 %description nethttpd-devel
325 HTTPd library, part of Ocamlnet. This package contains the files
326 needed to develop OCaml programs using nethttpd library.
327
328 %description nethttpd-devel -l pl.UTF-8
329 Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Ten
330 pakiet zawiera pliki niezbędne do tworzenia programów używających
331 biblioteki nethttpd.
332
333 %package netmech-scram-devel
334 Summary:        SCRAM mechanism for authentication
335 Summary(pl.UTF-8):      Mechanizm autentykacji SCRAM
336 License:        GPL v2+
337 Group:          Development/Libraries
338 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
339 Requires:       %{name}-netplex-devel = %{version}-%{release}
340 %requires_eq    ocaml
341
342 %description netmech-scram-devel
343 Netmech-scram library, part of Ocamlnet. This package contains the
344 files needed to develop OCaml programs using netmech-scram library.
345
346 %description netmech-scram-devel -l pl.UTF-8
347 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
348 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
349 używających biblioteki netmech-scram.
350
351 %package netmulticore-devel
352 Summary:        Multi-processing for compute jobs
353 Summary(pl.UTF-8):      Obsługa wieloprocesorowych obliczeń
354 License:        GPL v2+
355 Group:          Development/Libraries
356 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
357 Requires:       %{name}-netplex-devel = %{version}-%{release}
358 %requires_eq    ocaml
359
360 %description netmulticore-devel
361 Netmcore library, part of Ocamlnet. This package contains the files
362 needed to develop OCaml programs using netmulticore library.
363
364 %description netmulticore-devel -l pl.UTF-8
365 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
366 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
367 używających biblioteki netmulticore.
368
369 %package netplex
370 Summary:        Server framework
371 Summary(pl.UTF-8):      Szkielet serwerowy
372 License:        BSD-like
373 Group:          Libraries
374 %requires_eq    ocaml-runtime
375 %requires_eq    ocaml-labltk
376
377 %description netplex
378 Server framework.
379
380 This package contains files needed to run bytecode executables using
381 netplex library.
382
383 %description netplex -l pl.UTF-8
384 Szkielet serwerowy.
385
386 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
387 używających biblioteki netplex.
388
389 %package netplex-devel
390 Summary:        Server framework - development part
391 Summary(pl.UTF-8):      Szkielet serwerowy - cześć programistyczna
392 License:        BSD-like
393 Group:          Development/Libraries
394 Requires:       %{name}-equeue-devel = %{version}-%{release}
395 Requires:       %{name}-netplex = %{version}-%{release}
396 Requires:       %{name}-netstring-devel = %{version}-%{release}
397 Requires:       %{name}-netsys-devel = %{version}-%{release}
398 Requires:       %{name}-rpc-devel = %{version}-%{release}
399 %requires_eq    ocaml
400
401 %description netplex-devel
402 Server framework.
403
404 This package contains files needed to develop OCaml programs using
405 netplex library.
406
407 %description netplex-devel -l pl.UTF-8
408 Szkielet serwerowy.
409
410 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
411 biblioteki netplex.
412
413 %package netshm-devel
414 Summary:        Shared memory support - development package
415 Summary(pl.UTF-8):      Obsługa pamięci dzielonej - pakiet programistyczny
416 License:        BSD-like
417 Group:          Development/Libraries
418 Requires:       %{name}-netsys-devel = %{version}-%{release}
419 %requires_eq    ocaml
420
421 %description netshm-devel
422 Shared memory support.
423
424 This package contains files needed to develop OCaml programs using
425 netshm library.
426
427 %description netshm-devel -l pl.UTF-8
428 Obsługa pamięci dzielonej.
429
430 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
431 biblioteki netshm.
432
433 %package netstring
434 Summary:        String processing library
435 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
436 License:        BSD-like
437 Group:          Libraries
438 Requires:       %{name}-netsys-devel = %{version}-%{release}
439 %requires_eq    ocaml-pcre-devel
440 %requires_eq    ocaml
441
442 %description netstring
443 String processing library, part of Ocamlnet.
444
445 %description netstring -l pl.UTF-8
446 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet.
447
448 %package netstring-devel
449 Summary:        String processing library
450 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
451 License:        BSD-like
452 Group:          Development/Libraries
453 Requires:       %{name}-netstring = %{version}-%{release}
454 Requires:       %{name}-netsys-devel = %{version}-%{release}
455 %requires_eq    ocaml-pcre-devel
456 %requires_eq    ocaml
457
458 %description netstring-devel
459 String processing library, part of Ocamlnet. This package contains
460 files needed to develop OCaml programs using netstring library.
461
462 %description netstring-devel -l pl.UTF-8
463 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Ten
464 pakiet zawiera pliki niezbędne do tworzenia programów używających
465 biblioteki netstring.
466
467 %package netsys
468 Summary:        OS-specific functions
469 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego
470 License:        BSD-like
471 Group:          Libraries
472 %requires_eq    ocaml-runtime
473
474 %description netsys
475 OS-specific functions.
476
477 This package contains files needed to run bytecode executables using
478 netsys library.
479
480 %description netsys -l pl.UTF-8
481 Funkcje specyficzne dla systemu operacyjnego.
482
483 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
484 używających biblioteki netsys.
485
486 %package netsys-devel
487 Summary:        OS-specific functions - development part
488 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego - cześć programistyczna
489 License:        BSD-like
490 Group:          Development/Libraries
491 Requires:       %{name}-netsys = %{version}-%{release}
492 %requires_eq    ocaml
493
494 %description netsys-devel
495 OS-specific functions.
496
497 This package contains files needed to develop OCaml programs using
498 netsys library.
499
500 %description netsys-devel -l pl.UTF-8
501 Funkcje specyficzne dla systemu operacyjnego.
502
503 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
504 biblioteki netsys.
505
506 %package netzip-devel
507 Summary:        Gzip channels - development part
508 Summary(pl.UTF-8):      Funkcje do kompresji kanałow - cześć programistyczna
509 License:        BSD-like
510 Group:          Development/Libraries
511 Requires:       %{name}-netstring-devel = %{version}-%{release}
512 %requires_eq    ocaml
513
514 %description netzip-devel
515 Gzip channels functions.
516
517 This package contains files needed to develop OCaml programs using
518 netzip library.
519
520 %description netzip-devel -l pl.UTF-8
521 Funkcje do kompresji kanałow.
522
523 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
524 biblioteki netzip.
525
526 %package pop3-devel
527 Summary:        Post Office Protocol (POP3) library
528 Summary(pl.UTF-8):      Biblioteka do obsługi POP3
529 License:        BSD-like
530 Group:          Development/Libraries
531 Requires:       %{name}-netstring-devel = %{version}-%{release}
532 %requires_eq    ocaml
533
534 %description pop3-devel
535 Post Office Protocol (POP3) library, part of Ocamlnet. This package
536 contains files needed to develop OCaml programs using pop library.
537
538 %description pop3-devel -l pl.UTF-8
539 Biblioteka do obsługi POP3, część pakietu Ocamlnet. Ten pakiet zawiera
540 pliki niezbędne do tworzenia programów używających biblioteki pop.
541
542 %package rpc
543 Summary:        Remote Procedure Call (RPC) libraries
544 Summary(pl.UTF-8):      Biblioteki do obsługi RPC
545 License:        BSD-like
546 Group:          Development/Libraries
547 Requires:       %{name}-equeue-ssl = %{version}-%{release}
548 %requires_eq    ocaml
549
550 %description rpc
551 Remote Procedure Call (RPC) libraries.
552
553 %description rpc -l pl.UTF-8
554 Biblioteki do obsługi RPC.
555
556 %package rpc-devel
557 Summary:        Remote Procedure Call (RPC) libraries - development part
558 Summary(pl.UTF-8):      Biblioteki do obsługi RPC - część programistyczna
559 License:        BSD-like
560 Group:          Development/Libraries
561 Requires:       %{name}-equeue-ssl-devel = %{version}-%{release}
562 Requires:       %{name}-rpc = %{version}-%{release}
563 %requires_eq    ocaml
564
565 %description rpc-devel
566 Remote Procedure Call (RPC) libraries - development part.
567
568 %description rpc-devel -l pl.UTF-8
569 Biblioteki do obsługi RPC - część programistyczna.
570
571 %package shell-devel
572 Summary:        Unix shell functions
573 Summary(pl.UTF-8):      Funkcje powłoki uniksowej
574 License:        BSD-like
575 Group:          Development/Libraries
576 Requires:       %{name}-equeue-devel = %{version}-%{release}
577 Requires:       %{name}-netsys-devel = %{version}-%{release}
578 %requires_eq    ocaml
579
580 %description shell-devel
581 Unix shell functions.
582
583 %description shell-devel -l pl.UTF-8
584 Funkcje powłoki uniksowej.
585
586 %package smtp-devel
587 Summary:        Simple Mail Transfer Protocol (SMTP) library
588 Summary(pl.UTF-8):      Biblioteka do obsługi SMTP
589 License:        BSD-like
590 Group:          Development/Libraries
591 Requires:       %{name}-netstring-devel = %{version}-%{release}
592 %requires_eq    ocaml
593
594 %description smtp-devel
595 Interface for the Simple Mail Tranfer Protocol (SMTP) as specified by
596 RFC 2821.
597
598 %description smtp-devel -l pl.UTF-8
599 Interfejs dla protokołu SMTP opisanego w RFC 2821.
600
601 %prep
602 %setup -q -n ocamlnet-%{version}
603 %patch0 -p1
604 %patch1 -p1
605 %patch2 -p1
606
607 %build
608 # no %%configure, please
609 ./configure \
610         -disable-gtk \
611         -enable-gtk2 \
612         -enable-ssl \
613         -enable-zip \
614         -enable-crypto \
615 %if %{with apache}
616         -enable-apache \
617 %else
618         -disable-apache \
619 %endif
620         -with-rpc-auth-dh \
621         -enable-tcl \
622         -equeue-tcl-libs "-ltcl" \
623         -with-nethttpd \
624         -apxs %{apxs} \
625         -apache %{apache}
626
627 %{__make} -j1 all %{?with_ocaml_opt:opt}
628
629 %install
630 rm -rf $RPM_BUILD_ROOT
631 install -d $RPM_BUILD_ROOT{%{_libdir}/ocaml/stublibs,%{_apachepkglibdir},%{_apachesysconfdir}}
632
633 %{__make} -j1 install \
634         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
635         DESTDIR=$RPM_BUILD_ROOT
636
637 cd src
638 for f in e* n* p* r* shell smtp ; do
639         [ -d $RPM_BUILD_ROOT%{_libdir}/ocaml/$f ] || continue
640         install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f
641         mv $RPM_BUILD_ROOT%{_libdir}/ocaml/$f/META \
642                 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/
643         echo "directory = \"+$f\"" \
644                 >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/META
645 done
646 cd ..
647
648 %if %{with apache}
649 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi2-apache/500netcgi_apache.info
650 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/mod_netcgi_apache.so*
651
652 install -p src/netcgi2-apache/mod_netcgi_apache.so $RPM_BUILD_ROOT%{_apachepkglibdir}/mod_netcgi.so
653 cat <<EOF >$RPM_BUILD_ROOT%{_apachesysconfdir}/90_mod_netcgi.conf
654 LoadModule netcgi_module     modules/mod_netcgi.so
655
656 <IfModule netcgi_module>
657         NetcgiLoad pcre/pcre.cma
658         NetcgiLoad netsys/netsys.cma
659         NetcgiLoad netstring/netstring.cma
660         NetcgiLoad str.cma
661         NetcgiLoad netcgi2/netcgi.cma
662         NetcgiLoad netcgi2-apache/netcgi_apache.cma
663
664         NetcgiHandler Netcgi_apache.bytecode
665         AddHandler ocaml-bytecode .cma
666
667 #       Alias /caml-bin/ /path/to/your/scripts/
668 #       <Location /caml-bin>
669 #               SetHandler ocaml-bytecode
670 #               NetcgiHandler Netcgi_apache.bytecode
671 #               Options ExecCGI
672 #               Allow from all
673 #       </Location>
674 </IfModule>
675 EOF
676 %endif
677
678 # not sure about *.o
679 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
680
681 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{netcgi,equeue,netcamlbox,netmulticore,netclient,nethttpd,pop3,rpc}-%{version}
682 cp -r examples/camlbox/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcamlbox-%{version}
683 cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcgi-%{version}
684 cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
685 cp -r examples/multicore/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netmulticore-%{version}
686 cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
687 cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
688 cp -r examples/pop/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-pop3-%{version}
689 cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
690
691 %clean
692 rm -rf $RPM_BUILD_ROOT
693
694 %files doc
695 %defattr(644,root,root,755)
696 %doc LICENSE* ChangeLog RELNOTES doc/html-main
697
698 %files netcgi-devel
699 %defattr(644,root,root,755)
700 %dir %{_libdir}/ocaml/netcgi*
701 %{_libdir}/ocaml/netcgi*/*.cm[ixao]*
702 %if %{with ocaml_opt}
703 %{_libdir}/ocaml/netcgi*/*.a
704 %endif
705 %{_libdir}/ocaml/site-lib/*cgi*
706 %{_examplesdir}/%{name}-netcgi-%{version}
707
708 %if %{with apache}
709 %files -n apache-mod_netcgi
710 %defattr(644,root,root,755)
711 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_apachesysconfdir}/*_mod_netcgi.conf
712 %attr(755,root,root) %{_apachepkglibdir}/mod_netcgi.so
713 %endif
714
715 %files equeue-devel
716 %defattr(644,root,root,755)
717 %dir %{_libdir}/ocaml/equeue
718 %{_libdir}/ocaml/equeue/*.cm[ixao]*
719 %if %{with ocaml_opt}
720 %{_libdir}/ocaml/equeue/*.a
721 %endif
722 %{_libdir}/ocaml/site-lib/equeue
723 %{_examplesdir}/%{name}-equeue-%{version}
724
725 %files equeue-gtk2-devel
726 %defattr(644,root,root,755)
727 %dir %{_libdir}/ocaml/equeue-gtk2
728 %{_libdir}/ocaml/equeue-gtk2/*.cm[ixao]*
729 %if %{with ocaml_opt}
730 %{_libdir}/ocaml/equeue-gtk2/*.a
731 %endif
732 %{_libdir}/ocaml/site-lib/equeue-gtk2
733
734 %files equeue-ssl
735 %defattr(644,root,root,755)
736 %dir %{_libdir}/ocaml/equeue-ssl
737 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_ssl.so
738 %{_libdir}/ocaml/stublibs/dllequeue_ssl.so.owner
739
740 %files equeue-ssl-devel
741 %defattr(644,root,root,755)
742 %{_libdir}/ocaml/equeue-ssl/*.cm[ixao]*
743 %{_libdir}/ocaml/equeue-ssl/libequeue_ssl*.a
744 %if %{with ocaml_opt}
745 %{_libdir}/ocaml/equeue-ssl/equeue_ssl*.a
746 %endif
747 %{_libdir}/ocaml/site-lib/equeue-ssl
748
749 %files equeue-tcl
750 %defattr(644,root,root,755)
751 %dir %{_libdir}/ocaml/equeue-tcl
752 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_tcl.so
753 %{_libdir}/ocaml/stublibs/dllequeue_tcl.so.owner
754
755 %files equeue-tcl-devel
756 %defattr(644,root,root,755)
757 %{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
758 %{_libdir}/ocaml/equeue-tcl/libequeue_tcl*.a
759 %if %{with ocaml_opt}
760 %{_libdir}/ocaml/equeue-tcl/equeue_tcl*.a
761 %endif
762 %{_libdir}/ocaml/site-lib/equeue-tcl
763
764 %files netcamlbox-devel
765 %defattr(644,root,root,755)
766 %dir %{_libdir}/ocaml/netcamlbox
767 %{_libdir}/ocaml/netcamlbox/*.cm[ixao]*
768 %if %{with ocaml_opt}
769 %{_libdir}/ocaml/netcamlbox/*.a
770 %endif
771 %{_libdir}/ocaml/site-lib/netcamlbox
772 %{_examplesdir}/%{name}-netcamlbox-%{version}
773
774 %files netclient-devel
775 %defattr(644,root,root,755)
776 %dir %{_libdir}/ocaml/netclient
777 %{_libdir}/ocaml/netclient/*.cm[ixao]*
778 %if %{with ocaml_opt}
779 %{_libdir}/ocaml/netclient/*.a
780 %endif
781 %{_libdir}/ocaml/site-lib/netclient
782 %{_examplesdir}/%{name}-netclient-%{version}
783
784 %files netgssapi-devel
785 %defattr(644,root,root,755)
786 %dir %{_libdir}/ocaml/netgssapi
787 %{_libdir}/ocaml/netgssapi/*.cm[ixao]*
788 %if %{with ocaml_opt}
789 %{_libdir}/ocaml/netgssapi/*.a
790 %endif
791 %{_libdir}/ocaml/site-lib/netgssapi
792
793 %files nethttpd-devel
794 %defattr(644,root,root,755)
795 %dir %{_libdir}/ocaml/nethttpd
796 %{_libdir}/ocaml/nethttpd/*.cm[ixa]*
797 %if %{with ocaml_opt}
798 %{_libdir}/ocaml/nethttpd/*.a
799 %endif
800 %{_libdir}/ocaml/site-lib/nethttpd
801 %{_examplesdir}/%{name}-nethttpd-%{version}
802
803 %files netmech-scram-devel
804 %defattr(644,root,root,755)
805 %dir %{_libdir}/ocaml/netmech-scram
806 %{_libdir}/ocaml/netmech-scram/*.cm[ixa]*
807 %if %{with ocaml_opt}
808 %{_libdir}/ocaml/netmech-scram/*.a
809 %endif
810 %{_libdir}/ocaml/site-lib/netmech-scram
811
812 %files netmulticore-devel
813 %defattr(644,root,root,755)
814 %dir %{_libdir}/ocaml/netmulticore
815 %{_libdir}/ocaml/netmulticore/*.cm[ixa]*
816 %if %{with ocaml_opt}
817 %{_libdir}/ocaml/netmulticore/*.a
818 %endif
819 %{_libdir}/ocaml/site-lib/netmulticore
820 %{_examplesdir}/%{name}-netmulticore-%{version}
821
822 %files netplex
823 %defattr(644,root,root,755)
824 %attr(755,root,root) %{_bindir}/netplex-admin
825 %dir %{_libdir}/ocaml/netplex
826 %if %{with ocaml_opt}
827 %{_libdir}/ocaml/netplex/*.o
828 %endif
829
830 %files netplex-devel
831 %defattr(644,root,root,755)
832 %{_libdir}/ocaml/netplex/netplex-packlist
833 %{_libdir}/ocaml/netplex/*.cm[ixao]*
834 %if %{with ocaml_opt}
835 %{_libdir}/ocaml/netplex/*.a
836 %endif
837 %{_libdir}/ocaml/site-lib/netplex
838
839 %files netshm-devel
840 %defattr(644,root,root,755)
841 %dir %{_libdir}/ocaml/netshm
842 %{_libdir}/ocaml/netshm/*.cm[ixao]*
843 %if %{with ocaml_opt}
844 %{_libdir}/ocaml/netshm/*.a
845 %endif
846 %{_libdir}/ocaml/site-lib/netshm
847
848 %files netstring
849 %defattr(644,root,root,755)
850 %dir %{_libdir}/ocaml/netstring
851 %if %{with ocaml_opt}
852 %{_libdir}/ocaml/netstring/*.o
853 %endif
854 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetaccel_c.so
855 %{_libdir}/ocaml/stublibs/dllnetaccel_c.so.owner
856
857 %files netstring-devel
858 %defattr(644,root,root,755)
859 %{_libdir}/ocaml/netstring/netdb-packlist
860 %{_libdir}/ocaml/netstring/*.cm[ixao]*
861 %{_libdir}/ocaml/netstring/libnetaccel_c.a
862 %if %{with ocaml_opt}
863 %{_libdir}/ocaml/netstring/netstring*.a
864 %endif
865 %{_libdir}/ocaml/site-lib/netstring
866
867 %files netsys
868 %defattr(644,root,root,755)
869 %dir %{_libdir}/ocaml/netsys
870 %{_libdir}/ocaml/netsys/*.o
871 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetsys.so
872 %{_libdir}/ocaml/stublibs/dllnetsys.so.owner
873
874 %files netsys-devel
875 %defattr(644,root,root,755)
876 %{_libdir}/ocaml/netsys/*.cm[ixao]*
877 %{_libdir}/ocaml/netsys/libnetsys*.a
878 %if %{with ocaml_opt}
879 %{_libdir}/ocaml/netsys/netsys*.a
880 %endif
881 %{_libdir}/ocaml/netsys/netsys_c_event.h
882 %{_libdir}/ocaml/site-lib/netsys
883
884 %files netzip-devel
885 %defattr(644,root,root,755)
886 %dir %{_libdir}/ocaml/netzip
887 %{_libdir}/ocaml/netzip/*.cm[ixao]*
888 %if %{with ocaml_opt}
889 %{_libdir}/ocaml/netzip/*.a
890 %endif
891 %{_libdir}/ocaml/site-lib/netzip
892
893 %files pop3-devel
894 %defattr(644,root,root,755)
895 %dir %{_libdir}/ocaml/pop
896 %{_libdir}/ocaml/pop/*.cm[ixao]*
897 %if %{with ocaml_opt}
898 %{_libdir}/ocaml/pop/*.a
899 %endif
900 %{_libdir}/ocaml/site-lib/pop
901 %{_examplesdir}/%{name}-pop3-%{version}
902
903 %files rpc
904 %defattr(644,root,root,755)
905 %attr(755,root,root) %{_bindir}/ocamlrpcgen
906 %dir %{_libdir}/ocaml/rpc-auth-local
907 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so
908 %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so.owner
909
910 %files rpc-devel
911 %defattr(644,root,root,755)
912 %dir %{_libdir}/ocaml/rpc
913 %dir %{_libdir}/ocaml/rpc-auth-dh
914 %dir %{_libdir}/ocaml/rpc-generator
915 %dir %{_libdir}/ocaml/rpc-ssl
916 %{_libdir}/ocaml/rpc-generator/rpcgen-packlist
917 %{_libdir}/ocaml/rpc*/*.cm[ixao]*
918 %{_libdir}/ocaml/rpc*/librpc_auth_local*.a
919 %if %{with ocaml_opt}
920 %{_libdir}/ocaml/rpc*/rpc*.a
921 %endif
922 %{_libdir}/ocaml/site-lib/rpc*
923 %{_examplesdir}/%{name}-rpc-%{version}
924
925 %files shell-devel
926 %defattr(644,root,root,755)
927 %dir %{_libdir}/ocaml/shell
928 %{_libdir}/ocaml/shell/*.cm[ixao]*
929 %if %{with ocaml_opt}
930 %{_libdir}/ocaml/shell/*.a
931 %endif
932 %{_libdir}/ocaml/site-lib/shell
933
934 %files smtp-devel
935 %defattr(644,root,root,755)
936 %dir %{_libdir}/ocaml/smtp
937 %{_libdir}/ocaml/smtp/*.cm[ixao]*
938 %if %{with ocaml_opt}
939 %{_libdir}/ocaml/smtp/*.a
940 %endif
941 %{_libdir}/ocaml/site-lib/smtp
This page took 0.126804 seconds and 2 git commands to generate.