]> git.pld-linux.org Git - packages/ocaml-net.git/blob - ocaml-net.spec
- fix build
[packages/ocaml-net.git] / ocaml-net.spec
1 # TODO:
2 # - nethttpd needs to be packaged
3 # - apache stuff
4 # - lablgtk2 support
5 #
6 %define         ocaml_ver       1:3.09.2
7 Summary:        Modules for Internet programming in OCaml
8 Summary(pl.UTF-8):      Moduły ułatwiające pisanie programów internetowych w OCamlu
9 Name:           ocaml-net
10 Version:        2.2.9
11 Release:        3
12 License:        GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
13 Group:          Libraries
14 Source0:        http://dl.sourceforge.net/ocamlnet/ocamlnet-%{version}.tar.gz
15 # Source0-md5:  3655e3be3bb2806e0a1f48bb7ce16fb3
16 URL:            http://ocamlnet.sourceforge.net/
17 BuildRequires:  ncurses-devel
18 BuildRequires:  ocaml >= %{ocaml_ver}
19 BuildRequires:  ocaml-findlib
20 BuildRequires:  ocaml-pcre-devel
21 #BuildRequires: ocaml-lablgtk2-devel
22 BuildRequires:  ocaml-ssl-devel
23 BuildRequires:  ocaml-labltk-devel
24 BuildRequires:  tcl-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Modules for Internet programming in OCaml.
29
30 %description -l pl.UTF-8
31 Moduły ułatwiające pisanie programów internetowych w OCamlu.
32
33 %package doc
34 Summary:        ocaml-net documentation
35 Summary(pl.UTF-8):      Dokumentacja dla pakietów ocaml-net
36 License:        BSD-like
37 Group:          Development/Libraries
38
39 %description doc
40 ocaml-net documentation.
41
42 %description doc -l pl.UTF-8
43 Dokumentacja dla pakietów ocaml-net.
44
45 %package cgi-devel
46 Summary:        Common Gateway Interface library
47 Summary(pl.UTF-8):      Biblioteka do tworzenia skryptów CGI
48 License:        LGPL v2+ (mod_caml), BSD-like (the rest)
49 Group:          Development/Libraries
50 Requires:       %{name}-netplex-devel = %{version}-%{release}
51 Requires:       %{name}-netstring-devel = %{version}-%{release}
52 Requires:       %{name}-netsys-devel = %{version}-%{release}
53 %requires_eq    ocaml
54
55 %description cgi-devel
56 Common Gateway Interface library, part of Ocamlnet. This package
57 contains files needed to develop OCaml programs using netcgi library.
58
59 %description cgi-devel -l pl.UTF-8
60 Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Ten
61 pakiet zawiera pliki niezbędne do tworzenia programów używających
62 biblioteki netcgi.
63
64 %package equeue-devel
65 Summary:        Event queue library for OCaml
66 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla
67 License:        BSD-like
68 Group:          Development/Libraries
69 Requires:       %{name}-netsys-devel = %{version}-%{release}
70 %requires_eq    ocaml
71 Obsoletes:      ocaml-equeue-devel
72
73 %description equeue-devel
74 Equeue provides a generic event queue module, and a specific module
75 for file descriptor events.
76
77 This package contains files needed to develop OCaml programs using
78 equeue library.
79
80 %description equeue-devel -l pl.UTF-8
81 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
82 modułu obsługi zdarzeń na deskryptorach plików.
83
84 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
85 biblioteki equeue.
86
87 %package equeue-ssl
88 Summary:        Event queue library for OCaml, SSL support
89 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla SSL
90 License:        BSD-like
91 Group:          Libraries
92 %requires_eq    ocaml-runtime
93
94 %description equeue-ssl
95 This package makes it possible to let Equeue cooperate with the event
96 queue implementation of SSL.
97
98 This package contains files needed to run bytecode executables using
99 equeue-ssl library.
100
101 %description equeue-ssl -l pl.UTF-8
102 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
103 w SSL.
104
105 Ten pakiet zawiera moduł potrzebny do uruchamiania programów
106 używających biblioteki equeue-ssl.
107
108 %package equeue-ssl-devel
109 Summary:        Equeue SSL support - development part
110 Summary(pl.UTF-8):      Wsparcie dla SSL-a w equeue - cześć programistyczna
111 License:        BSD-like
112 Group:          Development/Libraries
113 Requires:       %{name}-equeue-devel = %{version}-%{release}
114 Requires:       %{name}-equeue-ssl = %{version}-%{release}
115 %requires_eq    ocaml-ssl-devel
116 %requires_eq    ocaml
117
118 %description equeue-ssl-devel
119 This package makes it possible to let Equeue cooperate with the event
120 queue implementation of SSL.
121
122 This package contains files needed to develop OCaml programs using
123 equeue-ssl library.
124
125 %description equeue-ssl-devel -l pl.UTF-8
126 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
127 w SSL.
128
129 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
130 biblioteki equeue-ssl.
131
132 %package equeue-tcl
133 Summary:        Event queue library for OCaml, Tcl support
134 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
135 License:        BSD-like
136 Group:          Libraries
137 %requires_eq    ocaml-runtime
138 %requires_eq    ocaml-labltk
139 Obsoletes:      ocaml-equeue-tcl
140
141 %description equeue-tcl
142 This package makes it possible to let Equeue cooperate with the event
143 queue implementation of Tcl.
144
145 This package contains files needed to run bytecode executables using
146 equeue-tcl library.
147
148 %description equeue-tcl -l pl.UTF-8
149 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
150 w Tcl.
151
152 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
153 używających biblioteki equeue-tcl.
154
155 %package equeue-tcl-devel
156 Summary:        Equeue Tcl support - development part
157 Summary(pl.UTF-8):      Wsparcie dla Tcl-a w equeue - cześć programistyczna
158 License:        BSD-like
159 Group:          Development/Libraries
160 Requires:       %{name}-equeue-devel = %{version}-%{release}
161 Requires:       %{name}-equeue-tcl = %{version}-%{release}
162 %requires_eq    ocaml-labltk-devel
163 %requires_eq    ocaml
164 Obsoletes:      ocaml-equeue-tcl-devel
165
166 %description equeue-tcl-devel
167 This package makes it possible to let Equeue cooperate with the event
168 queue implementation of Tcl.
169
170 This package contains files needed to develop OCaml programs using
171 this library.
172
173 %description equeue-tcl-devel -l pl.UTF-8
174 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
175 w Tcl.
176
177 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
178 biblioteki equeue-tcl.
179
180 %package netclient-devel
181 Summary:        HTTP 1.1 client for OCaml
182 Summary(pl.UTF-8):      Klient HTTP 1.1 dla OCamla
183 License:        BSD-like
184 Group:          Development/Libraries
185 Requires:       %{name}-equeue-devel = %{version}-%{release}
186 Requires:       %{name}-netstring-devel = %{version}-%{release}
187 %requires_eq    ocaml
188 Obsoletes:      ocaml-netclient-devel
189
190 %description netclient-devel
191 Implements much of HTTP/1.1. Implements the following advanced
192 features: chunked messages; persistent connections; connections in
193 pipelining mode ("full duplex" connections); modular authentication
194 methods, currently Basic and Digest; event-driven implementation;
195 allows concurrent service for several network connections.
196
197 This package contains files needed to develop OCaml programs using
198 netclient library.
199
200 %description netclient-devel -l pl.UTF-8
201 Biblioteka netclient implementuje większość HTTP/1.1, a także
202 następujące zaawansowane właściwości: komunikaty w kawałkach;
203 połączenia stałe; połączenia w trybie "full duplex"; modularne metody
204 uwierzytelniania, obecnie Basic i Digest; implementacja oparta na
205 zdarzeniach; umożliwia jednoczesną obsługę kilku połączeń.
206
207 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
208 biblioteki netclient.
209
210 %package nethttpd-devel
211 Summary:        HTTPd library
212 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu HTTP
213 License:        GPL v2+
214 Group:          Development/Libraries
215 Requires:       %{name}-cgi-devel = %{version}-%{release}
216 Requires:       %{name}-equeue-devel = %{version}-%{release}
217 Requires:       %{name}-netplex-devel = %{version}-%{release}
218 %requires_eq    ocaml-pcre-devel
219 %requires_eq    ocaml
220
221 %description nethttpd-devel
222 HTTPd library, part of Ocamlnet. This package contains the files
223 needed to develop OCaml programs using nethttpd library.
224
225 %description nethttpd-devel -l pl.UTF-8
226 Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Ten
227 pakiet zawiera pliki niezbędne do tworzenia programów używających
228 biblioteki nethttpd.
229
230 %package netplex
231 Summary:        Server framework
232 Summary(pl.UTF-8):      Szkielet serwerowy
233 License:        BSD-like
234 Group:          Libraries
235 %requires_eq    ocaml-runtime
236 %requires_eq    ocaml-labltk
237
238 %description netplex
239 Server framework.
240
241 This package contains files needed to run bytecode executables using
242 netplex library.
243
244 %description netplex -l pl.UTF-8
245 Szkielet serwerowy.
246
247 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
248 używających biblioteki netplex.
249
250 %package netplex-devel
251 Summary:        Server framework - development part
252 Summary(pl.UTF-8):      Szkielet serwerowy - cześć programistyczna
253 License:        BSD-like
254 Group:          Development/Libraries
255 Requires:       %{name}-netplex = %{version}-%{release}
256 Requires:       %{name}-equeue-devel = %{version}-%{release}
257 Requires:       %{name}-netstring-devel = %{version}-%{release}
258 Requires:       %{name}-rpc-devel = %{version}-%{release}
259 Requires:       %{name}-netsys-devel = %{version}-%{release}
260 %requires_eq    ocaml
261
262 %description netplex-devel
263 Server framework.
264
265 This package contains files needed to develop OCaml programs using
266 netplex library.
267
268 %description netplex-devel -l pl.UTF-8
269 Szkielet serwerowy.
270
271 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
272 biblioteki netplex.
273
274 %package netshm-devel
275 Summary:        Shared memory support - development package
276 Summary(pl.UTF-8):      Obsługa pamięci dzielonej - pakiet programistyczny
277 License:        BSD-like
278 Group:          Development/Libraries
279 Requires:       %{name}-netsys-devel = %{version}-%{release}
280 %requires_eq    ocaml
281
282 %description netshm-devel
283 Shared memory support.
284
285 This package contains files needed to develop OCaml programs using
286 netshm library.
287
288 %description netshm-devel -l pl.UTF-8
289 Obsługa pamięci dzielonej.
290
291 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
292 biblioteki netshm.
293
294 %package netstring-devel
295 Summary:        String processing library
296 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
297 License:        BSD-like
298 Group:          Development/Libraries
299 Requires:       %{name}-netsys-devel = %{version}-%{release}
300 %requires_eq    ocaml-pcre-devel
301 %requires_eq    ocaml
302
303 %description netstring-devel
304 String processing library, part of Ocamlnet. This package contains
305 files needed to develop OCaml programs using netstring library.
306
307 %description netstring-devel -l pl.UTF-8
308 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Ten
309 pakiet zawiera pliki niezbędne do tworzenia programów używających
310 biblioteki netstring.
311
312 %package netsys
313 Summary:        OS-specific functions
314 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego
315 License:        BSD-like
316 Group:          Libraries
317 %requires_eq    ocaml-runtime
318
319 %description netsys
320 OS-specific functions.
321
322 This package contains files needed to run bytecode executables using
323 netsys library.
324
325 %description netsys -l pl.UTF-8
326 Funkcje specyficzne dla systemu operacyjnego.
327
328 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
329 używających biblioteki netsys.
330
331 %package netsys-devel
332 Summary:        OS-specific functions - development part
333 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego - cześć programistyczna
334 License:        BSD-like
335 Group:          Development/Libraries
336 Requires:       %{name}-netsys = %{version}-%{release}
337 %requires_eq    ocaml
338
339 %description netsys-devel
340 OS-specific functions.
341
342 This package contains files needed to develop OCaml programs using
343 netsys library.
344
345 %description netsys-devel -l pl.UTF-8
346 Funkcje specyficzne dla systemu operacyjnego.
347
348 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
349 biblioteki netsys.
350
351 %package pop3-devel
352 Summary:        Post Office Protocol (POP3) library
353 Summary(pl.UTF-8):      Biblioteka do obsługi POP3
354 License:        BSD-like
355 Group:          Development/Libraries
356 Requires:       %{name}-netstring-devel = %{version}-%{release}
357 %requires_eq    ocaml
358
359 %description pop3-devel
360 Post Office Protocol (POP3) library, part of Ocamlnet. This package
361 contains files needed to develop OCaml programs using pop library.
362
363 %description pop3-devel -l pl.UTF-8
364 Biblioteka do obsługi POP3, część pakietu Ocamlnet. Ten pakiet zawiera
365 pliki niezbędne do tworzenia programów używających biblioteki pop.
366
367 %package rpc
368 Summary:        Remote Procedure Call (RPC) libraries
369 Summary(pl.UTF-8):      Biblioteki do obsługi RPC
370 License:        BSD-like
371 Group:          Development/Libraries
372 Requires:       %{name}-equeue-ssl = %{version}-%{release}
373 %requires_eq    ocaml
374
375 %description rpc
376 Remote Procedure Call (RPC) libraries.
377
378 %description rpc -l pl.UTF-8
379 Biblioteki do obsługi RPC.
380
381 %package rpc-devel
382 Summary:        Remote Procedure Call (RPC) libraries - development part
383 Summary(pl.UTF-8):      Biblioteki do obsługi RPC - część programistyczna
384 License:        BSD-like
385 Group:          Development/Libraries
386 Requires:       %{name}-equeue-ssl-devel = %{version}-%{release}
387 Requires:       %{name}-rpc = %{version}-%{release}
388 %requires_eq    ocaml
389
390 %description rpc-devel
391 Remote Procedure Call (RPC) libraries - development part.
392
393 %description rpc-devel -l pl.UTF-8
394 Biblioteki do obsługi RPC - część programistyczna.
395
396 %package shell-devel
397 Summary:        Unix shell functions
398 Summary(pl.UTF-8):      Funkcje powłoki uniksowej
399 License:        BSD-like
400 Group:          Development/Libraries
401 Requires:       %{name}-netsys-devel = %{version}-%{release}
402 Requires:       %{name}-equeue-devel = %{version}-%{release}
403 %requires_eq    ocaml
404
405 %description shell-devel
406 Unix shell functions.
407
408 %description shell-devel -l pl.UTF-8
409 Funkcje powłoki uniksowej.
410
411 %package smtp-devel
412 Summary:        Simple Mail Transfer Protocol (SMTP) library
413 Summary(pl.UTF-8):      Biblioteka do obsługi SMTP
414 License:        BSD-like
415 Group:          Development/Libraries
416 Requires:       %{name}-netstring-devel = %{version}-%{release}
417 %requires_eq    ocaml
418
419 %description smtp-devel
420 Interface for the Simple Mail Tranfer Protocol (SMTP) as specified by
421 RFC 2821.
422
423 %description smtp-devel -l pl.UTF-8
424 Interfejs dla protokołu SMTP opisanego w RFC 2821.
425
426 %prep
427 %setup -q -n ocamlnet-%{version}
428
429 %build
430 # no %%configure, please
431 ./configure \
432         -disable-gtk \
433         -disable-gtk2 \
434         -enable-ssl \
435         -enable-tcl \
436         -equeue-tcl-libs "-ltcl" \
437         -with-nethttpd
438
439 %{__make} -j1 all opt
440
441 %install
442 rm -rf $RPM_BUILD_ROOT
443
444 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml
445
446 %{__make} -j1 install \
447         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
448         DESTDIR=$RPM_BUILD_ROOT
449
450 cd src
451 for f in e* n* p* r* shell smtp ; do
452         [ -d $RPM_BUILD_ROOT%{_libdir}/ocaml/$f ] || continue
453         install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f
454         mv $RPM_BUILD_ROOT%{_libdir}/ocaml/$f/META \
455                 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/
456         echo "directory = \"+$f\"" \
457                 >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/META
458 done
459 # cgi is a special case
460 install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cgi
461 mv $RPM_BUILD_ROOT%{_libdir}/ocaml/cgi/META $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/cgi/
462 cd ..
463
464 # not sure about *.o
465 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
466
467 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{cgi,equeue,netclient,nethttpd,pop3,rpc}-%{version}
468 cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-cgi-%{version}
469 cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
470 cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
471 cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
472 cp -r examples/pop/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-pop3-%{version}
473 cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
474
475 %clean
476 rm -rf $RPM_BUILD_ROOT
477
478 %files doc
479 %defattr(644,root,root,755)
480 %doc LICENSE* ChangeLog RELNOTES doc/html-main
481
482 %files cgi-devel
483 %defattr(644,root,root,755)
484 %dir %{_libdir}/ocaml/netcgi*
485 %{_libdir}/ocaml/netcgi*/*.cm[ixao]*
486 %{_libdir}/ocaml/netcgi*/*.a
487 %{_libdir}/ocaml/site-lib/*cgi*
488 %{_examplesdir}/%{name}-cgi-%{version}
489
490 %files equeue-devel
491 %defattr(644,root,root,755)
492 %dir %{_libdir}/ocaml/equeue
493 %{_libdir}/ocaml/equeue/*.cm[ixao]*
494 %{_libdir}/ocaml/equeue/*.a
495 %{_libdir}/ocaml/equeue/*.o
496 %{_libdir}/ocaml/site-lib/equeue
497 %{_examplesdir}/%{name}-equeue-%{version}
498
499 %files equeue-ssl
500 %defattr(644,root,root,755)
501 %dir %{_libdir}/ocaml/equeue-ssl
502 %attr(755,root,root) %{_libdir}/ocaml/equeue-ssl/*.so
503
504 %files equeue-ssl-devel
505 %defattr(644,root,root,755)
506 %{_libdir}/ocaml/equeue-ssl/*.cm[ixao]*
507 %{_libdir}/ocaml/equeue-ssl/*.a
508 %{_libdir}/ocaml/site-lib/equeue-ssl
509
510 %files equeue-tcl
511 %defattr(644,root,root,755)
512 %dir %{_libdir}/ocaml/equeue-tcl
513 %attr(755,root,root) %{_libdir}/ocaml/equeue-tcl/*.so
514
515 %files equeue-tcl-devel
516 %defattr(644,root,root,755)
517 %{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
518 %{_libdir}/ocaml/equeue-tcl/*.a
519 %{_libdir}/ocaml/site-lib/equeue-tcl
520
521 %files netclient-devel
522 %defattr(644,root,root,755)
523 %dir %{_libdir}/ocaml/netclient
524 %{_libdir}/ocaml/netclient/*.cm[ixao]*
525 %{_libdir}/ocaml/netclient/*.a
526 %{_libdir}/ocaml/netclient/*.o
527 %{_libdir}/ocaml/site-lib/netclient
528 %{_examplesdir}/%{name}-netclient-%{version}
529
530 %files nethttpd-devel
531 %defattr(644,root,root,755)
532 %dir %{_libdir}/ocaml/nethttpd-*
533 %{_libdir}/ocaml/nethttpd-*/*.cm[ixao]*
534 %{_libdir}/ocaml/nethttpd-*/*.a
535 %{_libdir}/ocaml/site-lib/nethttpd*
536 %{_examplesdir}/%{name}-nethttpd-%{version}
537
538 %files netplex
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_bindir}/netplex-admin
541
542 %files netplex-devel
543 %defattr(644,root,root,755)
544 %dir %{_libdir}/ocaml/netplex
545 %{_libdir}/ocaml/netplex/netplex-packlist
546 %{_libdir}/ocaml/netplex/*.cm[ixao]*
547 %{_libdir}/ocaml/netplex/*.a
548 %{_libdir}/ocaml/netplex/*.o
549 %{_libdir}/ocaml/site-lib/netplex
550
551 %files netshm-devel
552 %defattr(644,root,root,755)
553 %dir %{_libdir}/ocaml/netshm
554 %{_libdir}/ocaml/netshm/*.cm[ixao]*
555 %{_libdir}/ocaml/netshm/*.a
556 %{_libdir}/ocaml/site-lib/netshm
557
558 %files netstring-devel
559 %defattr(644,root,root,755)
560 %dir %{_libdir}/ocaml/netstring
561 %{_libdir}/ocaml/netstring/netdb-packlist
562 %{_libdir}/ocaml/netstring/*.cm[ixao]*
563 %{_libdir}/ocaml/netstring/*.a
564 %{_libdir}/ocaml/netstring/*.o
565 %attr(755,root,root) %{_libdir}/ocaml/netstring/*.so
566 %{_libdir}/ocaml/site-lib/netstring
567
568 %files netsys
569 %defattr(644,root,root,755)
570 %dir %{_libdir}/ocaml/netsys
571 %attr(755,root,root) %{_libdir}/ocaml/netsys/*.so
572
573 %files netsys-devel
574 %defattr(644,root,root,755)
575 %{_libdir}/ocaml/netsys/*.cm[ixao]*
576 %{_libdir}/ocaml/netsys/*.a
577 %{_libdir}/ocaml/site-lib/netsys
578
579 %files pop3-devel
580 %defattr(644,root,root,755)
581 %dir %{_libdir}/ocaml/pop
582 %{_libdir}/ocaml/pop/*.cm[ixao]*
583 %{_libdir}/ocaml/pop/*.a
584 %{_libdir}/ocaml/site-lib/pop
585 %{_examplesdir}/%{name}-pop3-%{version}
586
587 %files rpc
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/ocamlrpcgen
590 %dir %{_libdir}/ocaml/rpc-auth-local
591 %dir %{_libdir}/ocaml/rpc-generator
592 %attr(755,root,root) %{_libdir}/ocaml/rpc-auth-local/dllrpc_auth_local.so
593
594 %files rpc-devel
595 %defattr(644,root,root,755)
596 %dir %{_libdir}/ocaml/rpc
597 %dir %{_libdir}/ocaml/rpc-ssl
598 %{_libdir}/ocaml/rpc-generator/rpcgen-packlist
599 %{_libdir}/ocaml/rpc*/*.cm[ixao]*
600 %{_libdir}/ocaml/rpc*/*.a
601 %{_libdir}/ocaml/site-lib/rpc*
602 %{_examplesdir}/%{name}-rpc-%{version}
603
604 %files shell-devel
605 %defattr(644,root,root,755)
606 %dir %{_libdir}/ocaml/shell
607 %{_libdir}/ocaml/shell/*.cm[ixao]*
608 %{_libdir}/ocaml/shell/*.a
609 %{_libdir}/ocaml/shell/*.o
610 %{_libdir}/ocaml/site-lib/shell
611
612 %files smtp-devel
613 %defattr(644,root,root,755)
614 %dir %{_libdir}/ocaml/smtp
615 %{_libdir}/ocaml/smtp/*.cm[ixao]*
616 %{_libdir}/ocaml/smtp/*.a
617 %{_libdir}/ocaml/site-lib/smtp
This page took 0.09888 seconds and 3 git commands to generate.