]> git.pld-linux.org Git - packages/ocaml-net.git/blob - ocaml-net.spec
- rebuild with fixed rpm macros
[packages/ocaml-net.git] / ocaml-net.spec
1 %define         apxs    /usr/sbin/apxs
2 %define         apache  /usr/sbin/httpd
3 Summary:        Modules for Internet programming in OCaml
4 Summary(pl.UTF-8):      Moduły ułatwiające pisanie programów internetowych w OCamlu
5 Name:           ocaml-net
6 Version:        3.6
7 Release:        3
8 License:        GPL v2+ (nethttpd), LGPL v2+ (mod_caml), BSD-like (the rest)
9 Group:          Libraries
10 Source0:        http://download.camlcity.org/download/ocamlnet-%{version}.tar.gz
11 # Source0-md5:  c6a42744c456b3b336c7613f5481650a
12 Patch0:         %{name}-buildfix.patch
13 Patch1:         %{name}-lablgtk2.patch
14 Patch2:         %{name}-zip.patch
15 Patch3:         %{name}-apache-link.patch
16 URL:            http://projects.camlcity.org/projects/ocamlnet.html
17 BuildRequires:  %{apache}
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2.0
20 BuildRequires:  ncurses-devel
21 BuildRequires:  ocaml >= 1:3.09.2
22 BuildRequires:  ocaml-camlp4
23 BuildRequires:  ocaml-cryptgps-devel
24 BuildRequires:  ocaml-cryptokit-devel
25 BuildRequires:  ocaml-findlib
26 BuildRequires:  ocaml-findlib-devel
27 BuildRequires:  ocaml-lablgtk-devel
28 BuildRequires:  ocaml-lablgtk2-devel >= 2.14.2
29 BuildRequires:  ocaml-labltk-devel
30 BuildRequires:  ocaml-pcre-devel
31 BuildRequires:  ocaml-ssl-devel
32 BuildRequires:  ocaml-zip-devel
33 BuildRequires:  tcl-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _apachepkglibdir        %(%{apxs} -q LIBEXECDIR 2>/dev/null)
37 %define         _apachesysconfdir       %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
38
39 %description
40 Modules for Internet programming in OCaml.
41
42 %description -l pl.UTF-8
43 Moduły ułatwiające pisanie programów internetowych w OCamlu.
44
45 %package doc
46 Summary:        ocaml-net documentation
47 Summary(pl.UTF-8):      Dokumentacja dla pakietów ocaml-net
48 License:        BSD-like
49 Group:          Development/Libraries
50
51 %description doc
52 ocaml-net documentation.
53
54 %description doc -l pl.UTF-8
55 Dokumentacja dla pakietów ocaml-net.
56
57 %package netcgi-devel
58 Summary:        Common Gateway Interface library
59 Summary(pl.UTF-8):      Biblioteka do tworzenia skryptów CGI
60 License:        LGPL v2+ (mod_caml), BSD-like (the rest)
61 Group:          Development/Libraries
62 Requires:       %{name}-netplex-devel = %{version}-%{release}
63 Requires:       %{name}-netstring-devel = %{version}-%{release}
64 Requires:       %{name}-netsys-devel = %{version}-%{release}
65 Obsoletes:      ocaml-net-cgi-devel
66 %requires_eq    ocaml
67
68 %description netcgi-devel
69 Common Gateway Interface library, part of Ocamlnet. This package
70 contains files needed to develop OCaml programs using netcgi library.
71
72 %description netcgi-devel -l pl.UTF-8
73 Biblioteka do tworzenia skryptów CGI, część pakietu Ocamlnet. Ten
74 pakiet zawiera pliki niezbędne do tworzenia programów używających
75 biblioteki netcgi.
76
77 %package -n apache-mod_netcgi
78 Summary:        Apache module:
79 Summary(pl.UTF-8):      Moduł Apache'a:
80 Group:          Networking/Daemons/HTTP
81 Requires:       apache(modules-api) = %apache_modules_api
82
83 %description -n apache-mod_netcgi
84
85 %description -n apache-mod_netcgi -l pl.UTF-8
86
87 %package equeue-devel
88 Summary:        Event queue library for OCaml
89 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla
90 License:        BSD-like
91 Group:          Development/Libraries
92 Requires:       %{name}-netsys-devel = %{version}-%{release}
93 %requires_eq    ocaml
94 Obsoletes:      ocaml-equeue-devel
95
96 %description equeue-devel
97 Equeue provides a generic event queue module, and a specific module
98 for file descriptor events.
99
100 This package contains files needed to develop OCaml programs using
101 equeue library.
102
103 %description equeue-devel -l pl.UTF-8
104 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
105 modułu obsługi zdarzeń na deskryptorach plików.
106
107 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
108 biblioteki equeue.
109
110 %package equeue-gtk-devel
111 Summary:        GTK event queue library for OCaml
112 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń GTK dla OCamla
113 License:        BSD-like
114 Group:          Development/Libraries
115 Requires:       %{name}-equeue-devel = %{version}-%{release}
116 Requires:       ocaml-lablgtk-devel
117 %requires_eq    ocaml
118
119 %description equeue-gtk-devel
120 Equeue provides a generic event queue module, and a specific module
121 for file descriptor events.
122
123 This package contains files needed to develop OCaml programs using GTK
124 equeue library.
125
126 %description equeue-gtk-devel -l pl.UTF-8
127 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
128 modułu obsługi zdarzeń na deskryptorach plików.
129
130 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
131 biblioteki equeue GTK.
132
133 %package equeue-gtk2-devel
134 Summary:        GTK2 event queue library for OCaml
135 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń GTK2 dla OCamla
136 License:        BSD-like
137 Group:          Development/Libraries
138 Requires:       %{name}-equeue-devel = %{version}-%{release}
139 Requires:       ocaml-lablgtk2-devel
140 %requires_eq    ocaml
141
142 %description equeue-gtk2-devel
143 Equeue provides a generic event queue module, and a specific module
144 for file descriptor events.
145
146 This package contains files needed to develop OCaml programs using
147 GTK2 equeue library.
148
149 %description equeue-gtk2-devel -l pl.UTF-8
150 Equeue dostarcza ogólnego modułu obsługi kolejki zdarzeń jak również
151 modułu obsługi zdarzeń na deskryptorach plików.
152
153 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
154 biblioteki equeue GTK2.
155
156 %package equeue-ssl
157 Summary:        Event queue library for OCaml, SSL support
158 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla SSL
159 License:        BSD-like
160 Group:          Libraries
161 %requires_eq    ocaml-runtime
162
163 %description equeue-ssl
164 This package makes it possible to let Equeue cooperate with the event
165 queue implementation of SSL.
166
167 This package contains files needed to run bytecode executables using
168 equeue-ssl library.
169
170 %description equeue-ssl -l pl.UTF-8
171 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
172 w SSL.
173
174 Ten pakiet zawiera moduł potrzebny do uruchamiania programów
175 używających biblioteki equeue-ssl.
176
177 %package equeue-ssl-devel
178 Summary:        Equeue SSL support - development part
179 Summary(pl.UTF-8):      Wsparcie dla SSL-a w equeue - cześć programistyczna
180 License:        BSD-like
181 Group:          Development/Libraries
182 Requires:       %{name}-equeue-devel = %{version}-%{release}
183 Requires:       %{name}-equeue-ssl = %{version}-%{release}
184 %requires_eq    ocaml-ssl-devel
185 %requires_eq    ocaml
186
187 %description equeue-ssl-devel
188 This package makes it possible to let Equeue cooperate with the event
189 queue implementation of SSL.
190
191 This package contains files needed to develop OCaml programs using
192 equeue-ssl library.
193
194 %description equeue-ssl-devel -l pl.UTF-8
195 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
196 w SSL.
197
198 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
199 biblioteki equeue-ssl.
200
201 %package equeue-tcl
202 Summary:        Event queue library for OCaml, Tcl support
203 Summary(pl.UTF-8):      Biblioteka obsługująca kolejkę zdarzeń dla OCamla, wsparcie dla Tcl
204 License:        BSD-like
205 Group:          Libraries
206 %requires_eq    ocaml-runtime
207 %requires_eq    ocaml-labltk
208 Obsoletes:      ocaml-equeue-tcl
209
210 %description equeue-tcl
211 This package makes it possible to let Equeue cooperate with the event
212 queue implementation of Tcl.
213
214 This package contains files needed to run bytecode executables using
215 equeue-tcl library.
216
217 %description equeue-tcl -l pl.UTF-8
218 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
219 w Tcl.
220
221 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
222 używających biblioteki equeue-tcl.
223
224 %package equeue-tcl-devel
225 Summary:        Equeue Tcl support - development part
226 Summary(pl.UTF-8):      Wsparcie dla Tcl-a w equeue - cześć programistyczna
227 License:        BSD-like
228 Group:          Development/Libraries
229 Requires:       %{name}-equeue-devel = %{version}-%{release}
230 Requires:       %{name}-equeue-tcl = %{version}-%{release}
231 %requires_eq    ocaml-labltk-devel
232 %requires_eq    ocaml
233 Obsoletes:      ocaml-equeue-tcl-devel
234
235 %description equeue-tcl-devel
236 This package makes it possible to let Equeue cooperate with the event
237 queue implementation of Tcl.
238
239 This package contains files needed to develop OCaml programs using
240 this library.
241
242 %description equeue-tcl-devel -l pl.UTF-8
243 Pakiet ten umożliwia współpracę Equeue z implementacją kolejki zdarzeń
244 w Tcl.
245
246 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
247 biblioteki equeue-tcl.
248
249 %package netcamlbox-devel
250 Summary:        Fast IPC mechanism for OCaml
251 Summary(pl.UTF-8):      Szybki mechanizm IPC dla OCamla
252 License:        BSD-like
253 Group:          Development/Libraries
254 Requires:       %{name}-netsys-devel = %{version}-%{release}
255 %requires_eq    ocaml
256
257 %description netcamlbox-devel
258 Camlboxes are a fast IPC mechanism to send Ocaml values from one
259 process to another. Source and destination processes must run on the
260 same machine (no network). The Ocaml value is copied to a shared
261 memory object where it can be directly accessed by the receiver
262 without unmarshalling step. This means the sender writes the value
263 into the shared memory in a format that can immediately interpreted by
264 the receiver.
265
266 This package contains files needed to develop OCaml programs using
267 netcamlbox library.
268
269 %description netcamlbox-devel -l pl.UTF-8
270 Camlboxy są szybkim mechanizmem IPC do przesyłania danych Ocamla
271 pomiędzy procesami. Nadawca i odbiorca muszą być uruchomione na tej
272 samej maszynie. Dane Ocamla są kopiowane do segmentu pamięci
273 dzielonej, gdzie mogą byc bezpośrednio odczytywane przez odbiorcę.
274
275 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
276 biblioteki netcamlbox.
277
278 %package netclient-devel
279 Summary:        HTTP 1.1 client for OCaml
280 Summary(pl.UTF-8):      Klient HTTP 1.1 dla OCamla
281 License:        BSD-like
282 Group:          Development/Libraries
283 Requires:       %{name}-equeue-devel = %{version}-%{release}
284 Requires:       %{name}-netstring-devel = %{version}-%{release}
285 %requires_eq    ocaml
286 Obsoletes:      ocaml-netclient-devel
287
288 %description netclient-devel
289 Implements much of HTTP/1.1. Implements the following advanced
290 features: chunked messages; persistent connections; connections in
291 pipelining mode ("full duplex" connections); modular authentication
292 methods, currently Basic and Digest; event-driven implementation;
293 allows concurrent service for several network connections.
294
295 This package contains files needed to develop OCaml programs using
296 netclient library.
297
298 %description netclient-devel -l pl.UTF-8
299 Biblioteka netclient implementuje większość HTTP/1.1, a także
300 następujące zaawansowane właściwości: komunikaty w kawałkach;
301 połączenia stałe; połączenia w trybie "full duplex"; modularne metody
302 uwierzytelniania, obecnie Basic i Digest; implementacja oparta na
303 zdarzeniach; umożliwia jednoczesną obsługę kilku połączeń.
304
305 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
306 biblioteki netclient.
307
308 %package netgssapi-devel
309 Summary:        GSS-API generic definition
310 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu GSSAPI
311 License:        GPL v2+
312 Group:          Development/Libraries
313 Requires:       %{name}-netstring-devel = %{version}-%{release}
314 Requires:       %{name}-netsys-devel = %{version}-%{release}
315 %requires_eq    ocaml
316
317 %description netgssapi-devel
318 GSSAPI library, part of Ocamlnet. This package contains the files
319 needed to develop OCaml programs using netgssapi library.
320
321 %description netgssapi-devel -l pl.UTF-8
322 Biblioteka do obsługi protokołu GSSAPI, część pakietu Ocamlnet. Ten
323 pakiet zawiera pliki niezbędne do tworzenia programów używających
324 biblioteki netgssapi.
325
326 %package nethttpd-devel
327 Summary:        HTTPd library
328 Summary(pl.UTF-8):      Biblioteka do obsługi protokołu HTTP
329 License:        GPL v2+
330 Group:          Development/Libraries
331 Requires:       %{name}-equeue-devel = %{version}-%{release}
332 Requires:       %{name}-netcgi-devel = %{version}-%{release}
333 Requires:       %{name}-netplex-devel = %{version}-%{release}
334 %requires_eq    ocaml-pcre-devel
335 %requires_eq    ocaml
336
337 %description nethttpd-devel
338 HTTPd library, part of Ocamlnet. This package contains the files
339 needed to develop OCaml programs using nethttpd library.
340
341 %description nethttpd-devel -l pl.UTF-8
342 Biblioteka do obsługi protokołu HTTP, część pakietu Ocamlnet. Ten
343 pakiet zawiera pliki niezbędne do tworzenia programów używających
344 biblioteki nethttpd.
345
346 %package netmech-scram-devel
347 Summary:        SCRAM mechanism for authentication
348 Summary(pl.UTF-8):      Mechanizm autentykacji SCRAM
349 License:        GPL v2+
350 Group:          Development/Libraries
351 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
352 Requires:       %{name}-netplex-devel = %{version}-%{release}
353 %requires_eq    ocaml
354
355 %description netmech-scram-devel
356 Netmech-scram library, part of Ocamlnet. This package contains the
357 files needed to develop OCaml programs using netmech-scram library.
358
359 %description netmech-scram-devel -l pl.UTF-8
360 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
361 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
362 używających biblioteki netmech-scram.
363
364 %package netmulticore-devel
365 Summary:        Multi-processing for compute jobs
366 Summary(pl.UTF-8):      Obsługa wieloprocesorowych obliczeń
367 License:        GPL v2+
368 Group:          Development/Libraries
369 Requires:       %{name}-netcamlbox-devel = %{version}-%{release}
370 Requires:       %{name}-netplex-devel = %{version}-%{release}
371 %requires_eq    ocaml
372
373 %description netmulticore-devel
374 Netmcore library, part of Ocamlnet. This package contains the files
375 needed to develop OCaml programs using netmulticore library.
376
377 %description netmulticore-devel -l pl.UTF-8
378 Biblioteka do obsługi wieloprocesorowych obliczeń, część pakietu
379 Ocamlnet. Ten pakiet zawiera pliki niezbędne do tworzenia programów
380 używających biblioteki netmulticore.
381
382 %package netplex
383 Summary:        Server framework
384 Summary(pl.UTF-8):      Szkielet serwerowy
385 License:        BSD-like
386 Group:          Libraries
387 %requires_eq    ocaml-runtime
388 %requires_eq    ocaml-labltk
389
390 %description netplex
391 Server framework.
392
393 This package contains files needed to run bytecode executables using
394 netplex library.
395
396 %description netplex -l pl.UTF-8
397 Szkielet serwerowy.
398
399 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
400 używających biblioteki netplex.
401
402 %package netplex-devel
403 Summary:        Server framework - development part
404 Summary(pl.UTF-8):      Szkielet serwerowy - cześć programistyczna
405 License:        BSD-like
406 Group:          Development/Libraries
407 Requires:       %{name}-equeue-devel = %{version}-%{release}
408 Requires:       %{name}-netplex = %{version}-%{release}
409 Requires:       %{name}-netstring-devel = %{version}-%{release}
410 Requires:       %{name}-netsys-devel = %{version}-%{release}
411 Requires:       %{name}-rpc-devel = %{version}-%{release}
412 %requires_eq    ocaml
413
414 %description netplex-devel
415 Server framework.
416
417 This package contains files needed to develop OCaml programs using
418 netplex library.
419
420 %description netplex-devel -l pl.UTF-8
421 Szkielet serwerowy.
422
423 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
424 biblioteki netplex.
425
426 %package netshm-devel
427 Summary:        Shared memory support - development package
428 Summary(pl.UTF-8):      Obsługa pamięci dzielonej - pakiet programistyczny
429 License:        BSD-like
430 Group:          Development/Libraries
431 Requires:       %{name}-netsys-devel = %{version}-%{release}
432 %requires_eq    ocaml
433
434 %description netshm-devel
435 Shared memory support.
436
437 This package contains files needed to develop OCaml programs using
438 netshm library.
439
440 %description netshm-devel -l pl.UTF-8
441 Obsługa pamięci dzielonej.
442
443 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
444 biblioteki netshm.
445
446 %package netstring
447 Summary:        String processing library
448 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
449 License:        BSD-like
450 Group:          Libraries
451 Requires:       %{name}-netsys-devel = %{version}-%{release}
452 %requires_eq    ocaml-pcre-devel
453 %requires_eq    ocaml
454
455 %description netstring
456 String processing library, part of Ocamlnet.
457
458 %description netstring -l pl.UTF-8
459 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet.
460
461 %package netstring-devel
462 Summary:        String processing library
463 Summary(pl.UTF-8):      Biblioteka do przetwarzania napisów
464 License:        BSD-like
465 Group:          Development/Libraries
466 Requires:       %{name}-netstring = %{version}-%{release}
467 Requires:       %{name}-netsys-devel = %{version}-%{release}
468 %requires_eq    ocaml-pcre-devel
469 %requires_eq    ocaml
470
471 %description netstring-devel
472 String processing library, part of Ocamlnet. This package contains
473 files needed to develop OCaml programs using netstring library.
474
475 %description netstring-devel -l pl.UTF-8
476 Biblioteka do przetwarzania napisów, część pakietu Ocamlnet. Ten
477 pakiet zawiera pliki niezbędne do tworzenia programów używających
478 biblioteki netstring.
479
480 %package netsys
481 Summary:        OS-specific functions
482 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego
483 License:        BSD-like
484 Group:          Libraries
485 %requires_eq    ocaml-runtime
486
487 %description netsys
488 OS-specific functions.
489
490 This package contains files needed to run bytecode executables using
491 netsys library.
492
493 %description netsys -l pl.UTF-8
494 Funkcje specyficzne dla systemu operacyjnego.
495
496 Ten pakiet zawiera moduły potrzebne do uruchamiania programów
497 używających biblioteki netsys.
498
499 %package netsys-devel
500 Summary:        OS-specific functions - development part
501 Summary(pl.UTF-8):      Funkcje specyficzne dla systemu operacyjnego - cześć programistyczna
502 License:        BSD-like
503 Group:          Development/Libraries
504 Requires:       %{name}-netsys = %{version}-%{release}
505 %requires_eq    ocaml
506
507 %description netsys-devel
508 OS-specific functions.
509
510 This package contains files needed to develop OCaml programs using
511 netsys library.
512
513 %description netsys-devel -l pl.UTF-8
514 Funkcje specyficzne dla systemu operacyjnego.
515
516 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
517 biblioteki netsys.
518
519 %package netzip-devel
520 Summary:        Gzip channels - development part
521 Summary(pl.UTF-8):      Funkcje do kompresji kanałow - cześć programistyczna
522 License:        BSD-like
523 Group:          Development/Libraries
524 Requires:       %{name}-netstring-devel = %{version}-%{release}
525 %requires_eq    ocaml
526
527 %description netzip-devel
528 Gzip channels functions.
529
530 This package contains files needed to develop OCaml programs using
531 netzip library.
532
533 %description netzip-devel -l pl.UTF-8
534 Funkcje do kompresji kanałow.
535
536 Ten pakiet zawiera pliki niezbędne do tworzenia programów używających
537 biblioteki netzip.
538
539 %package pop3-devel
540 Summary:        Post Office Protocol (POP3) library
541 Summary(pl.UTF-8):      Biblioteka do obsługi POP3
542 License:        BSD-like
543 Group:          Development/Libraries
544 Requires:       %{name}-netstring-devel = %{version}-%{release}
545 %requires_eq    ocaml
546
547 %description pop3-devel
548 Post Office Protocol (POP3) library, part of Ocamlnet. This package
549 contains files needed to develop OCaml programs using pop library.
550
551 %description pop3-devel -l pl.UTF-8
552 Biblioteka do obsługi POP3, część pakietu Ocamlnet. Ten pakiet zawiera
553 pliki niezbędne do tworzenia programów używających biblioteki pop.
554
555 %package rpc
556 Summary:        Remote Procedure Call (RPC) libraries
557 Summary(pl.UTF-8):      Biblioteki do obsługi RPC
558 License:        BSD-like
559 Group:          Development/Libraries
560 Requires:       %{name}-equeue-ssl = %{version}-%{release}
561 %requires_eq    ocaml
562
563 %description rpc
564 Remote Procedure Call (RPC) libraries.
565
566 %description rpc -l pl.UTF-8
567 Biblioteki do obsługi RPC.
568
569 %package rpc-devel
570 Summary:        Remote Procedure Call (RPC) libraries - development part
571 Summary(pl.UTF-8):      Biblioteki do obsługi RPC - część programistyczna
572 License:        BSD-like
573 Group:          Development/Libraries
574 Requires:       %{name}-equeue-ssl-devel = %{version}-%{release}
575 Requires:       %{name}-rpc = %{version}-%{release}
576 %requires_eq    ocaml
577
578 %description rpc-devel
579 Remote Procedure Call (RPC) libraries - development part.
580
581 %description rpc-devel -l pl.UTF-8
582 Biblioteki do obsługi RPC - część programistyczna.
583
584 %package shell-devel
585 Summary:        Unix shell functions
586 Summary(pl.UTF-8):      Funkcje powłoki uniksowej
587 License:        BSD-like
588 Group:          Development/Libraries
589 Requires:       %{name}-equeue-devel = %{version}-%{release}
590 Requires:       %{name}-netsys-devel = %{version}-%{release}
591 %requires_eq    ocaml
592
593 %description shell-devel
594 Unix shell functions.
595
596 %description shell-devel -l pl.UTF-8
597 Funkcje powłoki uniksowej.
598
599 %package smtp-devel
600 Summary:        Simple Mail Transfer Protocol (SMTP) library
601 Summary(pl.UTF-8):      Biblioteka do obsługi SMTP
602 License:        BSD-like
603 Group:          Development/Libraries
604 Requires:       %{name}-netstring-devel = %{version}-%{release}
605 %requires_eq    ocaml
606
607 %description smtp-devel
608 Interface for the Simple Mail Tranfer Protocol (SMTP) as specified by
609 RFC 2821.
610
611 %description smtp-devel -l pl.UTF-8
612 Interfejs dla protokołu SMTP opisanego w RFC 2821.
613
614 %prep
615 %setup -q -n ocamlnet-%{version}
616 %patch0 -p1
617 %patch1 -p1
618 %patch2 -p1
619 %patch3 -p1
620
621 %build
622 # no %%configure, please
623 ./configure \
624         -enable-gtk \
625         -enable-gtk2 \
626         -enable-ssl \
627         -enable-zip \
628         -enable-crypto \
629         -enable-apache \
630         -with-rpc-auth-dh \
631         -enable-tcl \
632         -equeue-tcl-libs "-ltcl" \
633         -with-nethttpd \
634         -apxs %{apxs} \
635         -apache %{apache}
636
637 %{__make} -j1 all opt
638
639 %install
640 rm -rf $RPM_BUILD_ROOT
641 install -d $RPM_BUILD_ROOT{%{_libdir}/ocaml/stublibs,%{_apachepkglibdir},%{_apachesysconfdir}}
642
643 %{__make} -j1 install \
644         OCAMLFIND_DESTDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
645         DESTDIR=$RPM_BUILD_ROOT
646
647 cd src
648 for f in e* n* p* r* shell smtp ; do
649         [ -d $RPM_BUILD_ROOT%{_libdir}/ocaml/$f ] || continue
650         install -d $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f
651         mv $RPM_BUILD_ROOT%{_libdir}/ocaml/$f/META \
652                 $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/
653         echo "directory = \"+$f\"" \
654                 >> $RPM_BUILD_ROOT%{_libdir}/ocaml/site-lib/$f/META
655 done
656 cd ..
657
658 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/500netcgi_apache.info
659 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/netcgi_apache/META
660 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs/mod_netcgi_apache.so*
661
662 install -p src/netcgi2-apache/mod_netcgi_apache.so $RPM_BUILD_ROOT%{_apachepkglibdir}/mod_netcgi.so
663 cat <<EOF >$RPM_BUILD_ROOT%{_apachesysconfdir}/90_mod_netcgi.conf
664 LoadModule netcgi_module     modules/mod_netcgi.so
665
666 <IfModule netcgi_module>
667         NetcgiLoad pcre/pcre.cma
668         NetcgiLoad netsys/netsys.cma
669         NetcgiLoad netstring/netstring.cma
670         NetcgiLoad str.cma
671         NetcgiLoad netcgi2/netcgi.cma
672         NetcgiLoad netcgi2-apache/netcgi_apache.cma
673
674         NetcgiHandler Netcgi_apache.bytecode
675         AddHandler ocaml-bytecode .cma
676
677 #       Alias /caml-bin/ /path/to/your/scripts/
678 #       <Location /caml-bin>
679 #               SetHandler ocaml-bytecode
680 #               NetcgiHandler Netcgi_apache.bytecode
681 #               Options ExecCGI
682 #               Allow from all
683 #       </Location>
684 </IfModule>
685 EOF
686
687 # not sure about *.o
688 rm $RPM_BUILD_ROOT%{_libdir}/ocaml/*/*.mli
689
690 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-{netcgi,equeue,netcamlbox,netmulticore,netclient,nethttpd,pop3,rpc}-%{version}
691 cp -r examples/camlbox/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcamlbox-%{version}
692 cp -r examples/cgi/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netcgi-%{version}
693 cp -r examples/equeue/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-equeue-%{version}
694 cp -r examples/multicore/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netmulticore-%{version}
695 cp -r examples/netclient/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-netclient-%{version}
696 cp -r examples/nethttpd/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-nethttpd-%{version}
697 cp -r examples/pop/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-pop3-%{version}
698 cp -r examples/rpc/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-rpc-%{version}
699
700 %clean
701 rm -rf $RPM_BUILD_ROOT
702
703 %files doc
704 %defattr(644,root,root,755)
705 %doc LICENSE* ChangeLog RELNOTES doc/html-main
706
707 %files netcgi-devel
708 %defattr(644,root,root,755)
709 %dir %{_libdir}/ocaml/netcgi*
710 %{_libdir}/ocaml/netcgi*/*.cm[ixao]*
711 %{_libdir}/ocaml/netcgi*/*.a
712 %{_libdir}/ocaml/site-lib/*cgi*
713 %{_examplesdir}/%{name}-netcgi-%{version}
714
715 %files -n apache-mod_netcgi
716 %defattr(644,root,root,755)
717 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_apachesysconfdir}/*_mod_netcgi.conf
718 %attr(755,root,root) %{_apachepkglibdir}/mod_netcgi.so
719
720 %files equeue-devel
721 %defattr(644,root,root,755)
722 %dir %{_libdir}/ocaml/equeue
723 %{_libdir}/ocaml/equeue/*.cm[ixao]*
724 %{_libdir}/ocaml/equeue/*.a
725 %{_libdir}/ocaml/site-lib/equeue
726 %{_examplesdir}/%{name}-equeue-%{version}
727
728 %files equeue-gtk-devel
729 %defattr(644,root,root,755)
730 %dir %{_libdir}/ocaml/equeue-gtk1
731 %{_libdir}/ocaml/equeue-gtk1/*.cm[ixao]*
732 %{_libdir}/ocaml/equeue-gtk1/*.a
733 %{_libdir}/ocaml/site-lib/equeue-gtk1
734
735 %files equeue-gtk2-devel
736 %defattr(644,root,root,755)
737 %dir %{_libdir}/ocaml/equeue-gtk2
738 %{_libdir}/ocaml/equeue-gtk2/*.cm[ixao]*
739 %{_libdir}/ocaml/equeue-gtk2/*.a
740 %{_libdir}/ocaml/site-lib/equeue-gtk2
741
742 %files equeue-ssl
743 %defattr(644,root,root,755)
744 %dir %{_libdir}/ocaml/equeue-ssl
745 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_ssl.so
746 %{_libdir}/ocaml/stublibs/dllequeue_ssl.so.owner
747
748 %files equeue-ssl-devel
749 %defattr(644,root,root,755)
750 %{_libdir}/ocaml/equeue-ssl/*.cm[ixao]*
751 %{_libdir}/ocaml/equeue-ssl/*.a
752 %{_libdir}/ocaml/site-lib/equeue-ssl
753
754 %files equeue-tcl
755 %defattr(644,root,root,755)
756 %dir %{_libdir}/ocaml/equeue-tcl
757 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllequeue_tcl.so
758 %{_libdir}/ocaml/stublibs/dllequeue_tcl.so.owner
759
760 %files equeue-tcl-devel
761 %defattr(644,root,root,755)
762 %{_libdir}/ocaml/equeue-tcl/*.cm[ixao]*
763 %{_libdir}/ocaml/equeue-tcl/*.a
764 %{_libdir}/ocaml/site-lib/equeue-tcl
765
766 %files netcamlbox-devel
767 %defattr(644,root,root,755)
768 %dir %{_libdir}/ocaml/netcamlbox
769 %{_libdir}/ocaml/netcamlbox/*.cm[ixao]*
770 %{_libdir}/ocaml/netcamlbox/*.a
771 %{_libdir}/ocaml/site-lib/netcamlbox
772 %{_examplesdir}/%{name}-netcamlbox-%{version}
773
774 %files netclient-devel
775 %defattr(644,root,root,755)
776 %dir %{_libdir}/ocaml/netclient
777 %{_libdir}/ocaml/netclient/*.cm[ixao]*
778 %{_libdir}/ocaml/netclient/*.a
779 %{_libdir}/ocaml/site-lib/netclient
780 %{_examplesdir}/%{name}-netclient-%{version}
781
782 %files netgssapi-devel
783 %defattr(644,root,root,755)
784 %dir %{_libdir}/ocaml/netgssapi
785 %{_libdir}/ocaml/netgssapi/*.cm[ixao]*
786 %{_libdir}/ocaml/netgssapi/*.a
787 %{_libdir}/ocaml/site-lib/netgssapi
788
789 %files nethttpd-devel
790 %defattr(644,root,root,755)
791 %dir %{_libdir}/ocaml/nethttpd
792 %{_libdir}/ocaml/nethttpd/*.cm[ixa]*
793 %{_libdir}/ocaml/nethttpd/*.a
794 %{_libdir}/ocaml/site-lib/nethttpd
795 %{_examplesdir}/%{name}-nethttpd-%{version}
796
797 %files netmech-scram-devel
798 %defattr(644,root,root,755)
799 %dir %{_libdir}/ocaml/netmech-scram
800 %{_libdir}/ocaml/netmech-scram/*.cm[ixa]*
801 %{_libdir}/ocaml/netmech-scram/*.a
802 %{_libdir}/ocaml/site-lib/netmech-scram
803
804 %files netmulticore-devel
805 %defattr(644,root,root,755)
806 %dir %{_libdir}/ocaml/netmulticore
807 %{_libdir}/ocaml/netmulticore/*.cm[ixa]*
808 %{_libdir}/ocaml/netmulticore/*.a
809 %{_libdir}/ocaml/site-lib/netmulticore
810 %{_examplesdir}/%{name}-netmulticore-%{version}
811
812 %files netplex
813 %defattr(644,root,root,755)
814 %attr(755,root,root) %{_bindir}/netplex-admin
815 %dir %{_libdir}/ocaml/netplex
816 %{_libdir}/ocaml/netplex/*.o
817
818 %files netplex-devel
819 %defattr(644,root,root,755)
820 %{_libdir}/ocaml/netplex/netplex-packlist
821 %{_libdir}/ocaml/netplex/*.cm[ixao]*
822 %{_libdir}/ocaml/netplex/*.a
823 %{_libdir}/ocaml/site-lib/netplex
824
825 %files netshm-devel
826 %defattr(644,root,root,755)
827 %dir %{_libdir}/ocaml/netshm
828 %{_libdir}/ocaml/netshm/*.cm[ixao]*
829 %{_libdir}/ocaml/netshm/*.a
830 %{_libdir}/ocaml/site-lib/netshm
831
832 %files netstring
833 %defattr(644,root,root,755)
834 %dir %{_libdir}/ocaml/netstring
835 %{_libdir}/ocaml/netstring/*.o
836 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetaccel_c.so
837 %{_libdir}/ocaml/stublibs/dllnetaccel_c.so.owner
838
839 %files netstring-devel
840 %defattr(644,root,root,755)
841 %{_libdir}/ocaml/netstring/netdb-packlist
842 %{_libdir}/ocaml/netstring/*.cm[ixao]*
843 %{_libdir}/ocaml/netstring/*.a
844 %{_libdir}/ocaml/site-lib/netstring
845
846 %files netsys
847 %defattr(644,root,root,755)
848 %dir %{_libdir}/ocaml/netsys
849 %{_libdir}/ocaml/netsys/*.o
850 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllnetsys.so
851 %{_libdir}/ocaml/stublibs/dllnetsys.so.owner
852
853 %files netsys-devel
854 %defattr(644,root,root,755)
855 %{_libdir}/ocaml/netsys/*.cm[ixao]*
856 %{_libdir}/ocaml/netsys/*.a
857 %{_libdir}/ocaml/site-lib/netsys
858
859 %files netzip-devel
860 %defattr(644,root,root,755)
861 %dir %{_libdir}/ocaml/netzip
862 %{_libdir}/ocaml/netzip/*.cm[ixao]*
863 %{_libdir}/ocaml/netzip/*.a
864 %{_libdir}/ocaml/site-lib/netzip
865
866 %files pop3-devel
867 %defattr(644,root,root,755)
868 %dir %{_libdir}/ocaml/pop
869 %{_libdir}/ocaml/pop/*.cm[ixao]*
870 %{_libdir}/ocaml/pop/*.a
871 %{_libdir}/ocaml/site-lib/pop
872 %{_examplesdir}/%{name}-pop3-%{version}
873
874 %files rpc
875 %defattr(644,root,root,755)
876 %attr(755,root,root) %{_bindir}/ocamlrpcgen
877 %dir %{_libdir}/ocaml/rpc-auth-local
878 %attr(755,root,root) %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so
879 %{_libdir}/ocaml/stublibs/dllrpc_auth_local.so.owner
880
881 %files rpc-devel
882 %defattr(644,root,root,755)
883 %dir %{_libdir}/ocaml/rpc
884 %dir %{_libdir}/ocaml/rpc-auth-dh
885 %dir %{_libdir}/ocaml/rpc-generator
886 %dir %{_libdir}/ocaml/rpc-ssl
887 %{_libdir}/ocaml/rpc-generator/rpcgen-packlist
888 %{_libdir}/ocaml/rpc*/*.cm[ixao]*
889 %{_libdir}/ocaml/rpc*/*.a
890 %{_libdir}/ocaml/site-lib/rpc*
891 %{_examplesdir}/%{name}-rpc-%{version}
892
893 %files shell-devel
894 %defattr(644,root,root,755)
895 %dir %{_libdir}/ocaml/shell
896 %{_libdir}/ocaml/shell/*.cm[ixao]*
897 %{_libdir}/ocaml/shell/*.a
898 %{_libdir}/ocaml/site-lib/shell
899
900 %files smtp-devel
901 %defattr(644,root,root,755)
902 %dir %{_libdir}/ocaml/smtp
903 %{_libdir}/ocaml/smtp/*.cm[ixao]*
904 %{_libdir}/ocaml/smtp/*.a
905 %{_libdir}/ocaml/site-lib/smtp
This page took 0.135112 seconds and 3 git commands to generate.