]> git.pld-linux.org Git - packages/ocaml-graphics.git/blame - ocaml-graphics.spec
- missing Groups
[packages/ocaml-graphics.git] / ocaml-graphics.spec
CommitLineData
ff88e9e1
JR
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10%if %{without ocaml_opt}
11%define _enable_debug_packages 0
12%endif
13
14%define module graphics
15Summary: Portable drawing primitives for OCaml
0fcfed96 16Summary(pl.UTF-8): Przenośne funkcje rysujące dla OCamla
ff88e9e1
JR
17Name: ocaml-%{module}
18Version: 5.1.1
19Release: 1
0fcfed96 20License: LGPL v2 with exceptions
db890840 21Group: Libraries
ff88e9e1
JR
22Source0: https://github.com/ocaml/graphics/releases/download/%{version}/%{module}-%{version}.tbz
23# Source0-md5: bc127b5da919b61f4c928a6657c88886
24URL: https://github.com/ocaml/graphics
25BuildRequires: ocaml >= 4.09.0
26BuildRequires: ocaml-dune-devel >= 2.1
27BuildRequires: xorg-lib-libX11-devel
28%requires_eq ocaml-runtime
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32The graphics library provides a set of portable drawing primitives.
33Drawing takes place in a separate window that is created when
34Graphics.open_graph is called.
35
0fcfed96
JB
36%description -l pl.UTF-8
37Biblioteka graphics dostarcza zbiór przenośnych funkcji rysujących.
38Rysowanie jest wykonywane w osobnym oknie, tworzonym przy wywołaniu
39Graphics.open_graph.
40
41%package devel
42Summary: Development files for graphics library
43Summary(pl.UTF-8): Pliki programistyczne biblioteki graphics
db890840 44Group: Development/Libraries
ff88e9e1
JR
45Requires: %{name} = %{version}-%{release}
46Requires: xorg-lib-libX11-devel
47
0fcfed96
JB
48%description devel
49This package contains libraries and signature files for developing
50applications that use OCaml graphics library.
51
52%description devel -l pl.UTF-8
53Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
54wykorzystujących bibliotekę OCamla graphics.
ff88e9e1
JR
55
56%prep
57%setup -q -n %{module}-%{version}
58
59%build
60dune build %{?_smp_mflags} --display=verbose
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65dune install --destdir=$RPM_BUILD_ROOT
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
72%doc CHANGES.md README.md
73%dir %{_libdir}/ocaml/%{module}
74%{_libdir}/ocaml/%{module}/META
75%{_libdir}/ocaml/%{module}/*.cma
76%{_libdir}/ocaml/%{module}/*.cmi
77%if %{with ocaml_opt}
78%attr(755,root,root) %{_libdir}/ocaml/%{module}/*.cmxs
79%endif
80%{_libdir}/ocaml/stublibs/dllgraphics_stubs.so
81
82%files devel
83%defattr(644,root,root,755)
84%{_libdir}/ocaml/%{module}/dune-package
85%{_libdir}/ocaml/%{module}/opam
ff88e9e1 86%{_libdir}/ocaml/%{module}/*.a
8a35dd05 87%if %{with ocaml_opt}
ff88e9e1
JR
88%{_libdir}/ocaml/%{module}/*.cmx
89%{_libdir}/ocaml/%{module}/*.cmxa
90%endif
91%{_libdir}/ocaml/%{module}/*.cmt
92%{_libdir}/ocaml/%{module}/*.cmti
93%{_libdir}/ocaml/%{module}/*.mli
This page took 0.065511 seconds and 4 git commands to generate.