]> git.pld-linux.org Git - packages/ocaml-graphics.git/blame - ocaml-graphics.spec
- pl
[packages/ocaml-graphics.git] / ocaml-graphics.spec
CommitLineData
ff88e9e1
JR
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} %{arm} aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10%if %{without ocaml_opt}
11%define _enable_debug_packages 0
12%endif
13
14%define module graphics
15Summary: Portable drawing primitives for OCaml
0fcfed96 16Summary(pl.UTF-8): Przenośne funkcje rysujące dla OCamla
ff88e9e1
JR
17Name: ocaml-%{module}
18Version: 5.1.1
19Release: 1
0fcfed96 20License: LGPL v2 with exceptions
ff88e9e1
JR
21Source0: https://github.com/ocaml/graphics/releases/download/%{version}/%{module}-%{version}.tbz
22# Source0-md5: bc127b5da919b61f4c928a6657c88886
23URL: https://github.com/ocaml/graphics
24BuildRequires: ocaml >= 4.09.0
25BuildRequires: ocaml-dune-devel >= 2.1
26BuildRequires: xorg-lib-libX11-devel
27%requires_eq ocaml-runtime
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31The graphics library provides a set of portable drawing primitives.
32Drawing takes place in a separate window that is created when
33Graphics.open_graph is called.
34
0fcfed96
JB
35%description -l pl.UTF-8
36Biblioteka graphics dostarcza zbiór przenośnych funkcji rysujących.
37Rysowanie jest wykonywane w osobnym oknie, tworzonym przy wywołaniu
38Graphics.open_graph.
39
40%package devel
41Summary: Development files for graphics library
42Summary(pl.UTF-8): Pliki programistyczne biblioteki graphics
ff88e9e1
JR
43Requires: %{name} = %{version}-%{release}
44Requires: xorg-lib-libX11-devel
45
0fcfed96
JB
46%description devel
47This package contains libraries and signature files for developing
48applications that use OCaml graphics library.
49
50%description devel -l pl.UTF-8
51Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
52wykorzystujących bibliotekę OCamla graphics.
ff88e9e1
JR
53
54%prep
55%setup -q -n %{module}-%{version}
56
57%build
58dune build %{?_smp_mflags} --display=verbose
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63dune install --destdir=$RPM_BUILD_ROOT
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc CHANGES.md README.md
71%dir %{_libdir}/ocaml/%{module}
72%{_libdir}/ocaml/%{module}/META
73%{_libdir}/ocaml/%{module}/*.cma
74%{_libdir}/ocaml/%{module}/*.cmi
75%if %{with ocaml_opt}
76%attr(755,root,root) %{_libdir}/ocaml/%{module}/*.cmxs
77%endif
78%{_libdir}/ocaml/stublibs/dllgraphics_stubs.so
79
80%files devel
81%defattr(644,root,root,755)
82%{_libdir}/ocaml/%{module}/dune-package
83%{_libdir}/ocaml/%{module}/opam
ff88e9e1 84%{_libdir}/ocaml/%{module}/*.a
8a35dd05 85%if %{with ocaml_opt}
ff88e9e1
JR
86%{_libdir}/ocaml/%{module}/*.cmx
87%{_libdir}/ocaml/%{module}/*.cmxa
88%endif
89%{_libdir}/ocaml/%{module}/*.cmt
90%{_libdir}/ocaml/%{module}/*.cmti
91%{_libdir}/ocaml/%{module}/*.mli
This page took 0.040581 seconds and 4 git commands to generate.