]> git.pld-linux.org Git - packages/oath-toolkit.git/commitdiff
up to 2.6.3 auto/th/oath-toolkit-2.6.3-1
authorJan Palus <atler@pld-linux.org>
Tue, 10 Nov 2020 19:43:13 +0000 (20:43 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 10 Nov 2020 19:43:13 +0000 (20:43 +0100)
glibc.patch [deleted file]
intprops.patch [deleted file]
oath-toolkit.spec

diff --git a/glibc.patch b/glibc.patch
deleted file mode 100644 (file)
index eab3315..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-Description: Check _IO_EOF_SEEN instead of _IO_ftrylockfile
- Needed to get fseeko.c to build with glibc 2.28.
- Inspired by https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.
-Author: Sascha Steinbiss <satta@debian.org>
-Last-Update: 2019-02-09
---- a/liboath/gl/fseeko.c
-+++ b/liboath/gl/fseeko.c
-@@ -47,7 +47,7 @@
- #endif
-   /* These tests are based on fpurge.c.  */
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-   if (fp->_IO_read_end == fp->_IO_read_ptr
-       && fp->_IO_write_ptr == fp->_IO_write_base
-       && fp->_IO_save_base == NULL)
-@@ -123,7 +123,7 @@
-           return -1;
-         }
--#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-+#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
-       fp->_flags &= ~_IO_EOF_SEEN;
-       fp->_offset = pos;
- #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
diff --git a/intprops.patch b/intprops.patch
deleted file mode 100644 (file)
index 061d62e..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-diff -ur oath-toolkit-2.6.2.orig/liboath/gl/tests/intprops.h oath-toolkit-2.6.2/liboath/gl/tests/intprops.h
---- oath-toolkit-2.6.2.orig/liboath/gl/tests/intprops.h        2016-08-27 13:15:06.000000000 +0200
-+++ oath-toolkit-2.6.2/liboath/gl/tests/intprops.h     2019-03-14 13:02:37.921000000 +0100
-@@ -230,11 +230,11 @@
-    (e.g., A and B) have the same type as MIN and MAX.  Instead, they assume
-    that the result (e.g., A + B) has that type.  */
- #if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
--# define _GL_ADD_OVERFLOW(a, b, min, max)
-+# define _GL_ADD_OVERFLOW(a, b, min, max)                                \
-    __builtin_add_overflow (a, b, (__typeof__ ((a) + (b)) *) 0)
--# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)
-+# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)                           \
-    __builtin_sub_overflow (a, b, (__typeof__ ((a) - (b)) *) 0)
--# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)
-+# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)                           \
-    __builtin_mul_overflow (a, b, (__typeof__ ((a) * (b)) *) 0)
- #else
- # define _GL_ADD_OVERFLOW(a, b, min, max)                                \
-diff -ur oath-toolkit-2.6.2.orig/libpskc/gl/intprops.h oath-toolkit-2.6.2/libpskc/gl/intprops.h
---- oath-toolkit-2.6.2.orig/libpskc/gl/intprops.h      2016-08-27 13:15:06.000000000 +0200
-+++ oath-toolkit-2.6.2/libpskc/gl/intprops.h   2019-03-14 13:02:54.816000000 +0100
-@@ -230,11 +230,11 @@
-    (e.g., A and B) have the same type as MIN and MAX.  Instead, they assume
-    that the result (e.g., A + B) has that type.  */
- #if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
--# define _GL_ADD_OVERFLOW(a, b, min, max)
-+# define _GL_ADD_OVERFLOW(a, b, min, max)                                \
-    __builtin_add_overflow (a, b, (__typeof__ ((a) + (b)) *) 0)
--# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)
-+# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)                           \
-    __builtin_sub_overflow (a, b, (__typeof__ ((a) - (b)) *) 0)
--# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)
-+# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)                           \
-    __builtin_mul_overflow (a, b, (__typeof__ ((a) * (b)) *) 0)
- #else
- # define _GL_ADD_OVERFLOW(a, b, min, max)                                \
-diff -ur oath-toolkit-2.6.2.orig/oathtool/gl/intprops.h oath-toolkit-2.6.2/oathtool/gl/intprops.h
---- oath-toolkit-2.6.2.orig/oathtool/gl/intprops.h     2016-08-27 13:15:06.000000000 +0200
-+++ oath-toolkit-2.6.2/oathtool/gl/intprops.h  2019-03-14 12:59:53.022000000 +0100
-@@ -230,11 +230,11 @@
-    (e.g., A and B) have the same type as MIN and MAX.  Instead, they assume
-    that the result (e.g., A + B) has that type.  */
- #if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
--# define _GL_ADD_OVERFLOW(a, b, min, max)
-+# define _GL_ADD_OVERFLOW(a, b, min, max)                                \
-    __builtin_add_overflow (a, b, (__typeof__ ((a) + (b)) *) 0)
--# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)
-+# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)                           \
-    __builtin_sub_overflow (a, b, (__typeof__ ((a) - (b)) *) 0)
--# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)
-+# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)                           \
-    __builtin_mul_overflow (a, b, (__typeof__ ((a) * (b)) *) 0)
- #else
- # define _GL_ADD_OVERFLOW(a, b, min, max)                                \
-diff -ur oath-toolkit-2.6.2.orig/pskctool/gl/intprops.h oath-toolkit-2.6.2/pskctool/gl/intprops.h
---- oath-toolkit-2.6.2.orig/pskctool/gl/intprops.h     2016-08-27 13:15:06.000000000 +0200
-+++ oath-toolkit-2.6.2/pskctool/gl/intprops.h  2019-03-14 13:03:17.341000000 +0100
-@@ -230,11 +230,11 @@
-    (e.g., A and B) have the same type as MIN and MAX.  Instead, they assume
-    that the result (e.g., A + B) has that type.  */
- #if _GL_HAS_BUILTIN_OVERFLOW_WITH_NULL
--# define _GL_ADD_OVERFLOW(a, b, min, max)
-+# define _GL_ADD_OVERFLOW(a, b, min, max)                                \
-    __builtin_add_overflow (a, b, (__typeof__ ((a) + (b)) *) 0)
--# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)
-+# define _GL_SUBTRACT_OVERFLOW(a, b, min, max)                           \
-    __builtin_sub_overflow (a, b, (__typeof__ ((a) - (b)) *) 0)
--# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)
-+# define _GL_MULTIPLY_OVERFLOW(a, b, min, max)                           \
-    __builtin_mul_overflow (a, b, (__typeof__ ((a) * (b)) *) 0)
- #else
- # define _GL_ADD_OVERFLOW(a, b, min, max)                                \
index 9e34b9ac91c38a7521171c951e1d11299810ca92..20adfd8f4171469dc3791a2e9b40b970e3f316ce 100644 (file)
@@ -1,14 +1,12 @@
 Summary:       OATH Toolkit - easily build one-time password authentication systems
 Summary(pl.UTF-8):     OATH Toolkit - łatwe tworzenie systemów uwierzytelniania z jednorazowymi hasłami
 Name:          oath-toolkit
-Version:       2.6.2
-Release:       3
+Version:       2.6.3
+Release:       1
 License:       LGPL v2.1+ (libraries), GPL v3+ (utilities and PAM module)
 Group:         Libraries
 Source0:       http://download.savannah.gnu.org/releases/oath-toolkit/%{name}-%{version}.tar.gz
-# Source0-md5: 4a05cd4768764843bd5493609a6bdb17
-Patch0:                glibc.patch
-Patch1:                intprops.patch
+# Source0-md5: f624f867ea186d011406e36a33f092d0
 URL:           http://www.nongnu.org/oath-toolkit/
 BuildRequires: gtk-doc >= 1.1
 BuildRequires: help2man
@@ -79,8 +77,6 @@ Dokumentacja API bibliotek OATH.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
 
 %build
 %configure \
This page took 0.124781 seconds and 4 git commands to generate.