]> git.pld-linux.org Git - packages/nvidiabl.git/blob - nvidiabl.spec
- one more alt_kernel fix
[packages/nvidiabl.git] / nvidiabl.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_with     verbose         # verbose build (V=1)
5
6 # nothing to be placed to debuginfo package
7 %define         _enable_debug_packages  0
8
9 %define         rel     1
10 %define         pname   nvidiabl
11 Summary:        Linux driver for nVidia display back-lights
12 Name:           %{pname}%{_alt_kernel}
13 Version:        0.81
14 Release:        %{rel}
15 License:        GPL v2+
16 URL:            https://github.com/guillaumezin/nvidiabl
17 Source0:        https://github.com/guillaumezin/nvidiabl/archive/v%{version}.tar.gz?/%{pname}-%{version}.tgz
18 # Source0-md5:  f72d90c0fe34b36a0ff3b6d7034e99c4
19 Group:          Base/Kernel
20 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
21 BuildRequires:  rpmbuild(macros) >= 1.379
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This driver drives the smartdimmer register found on modern mobile
26 nVidia graphics adapters such as NV40, NV41, NV43, NV44, NV46, NV47,
27 NV49, NV4B, C51, G84, G86, G92, G94, G96, GT200 architectures to
28 adjust the display backlight.
29
30 On Apple machines this driver allows more fine-grained brightness
31 adjustment than the (mbp_nvidia_bl) driver and is generally preferred.
32
33 %package -n kernel%{_alt_kernel}-video-nvidiabl
34 Summary:        Linux driver for nVidia display back-lights
35 Summary(pl.UTF-8):      Sterownik dla Linuksa do nvidiabl
36 Release:        %{rel}@%{_kernel_ver_str}
37 Group:          Base/Kernel
38 Requires(post,postun):  /sbin/depmod
39 %if %{with dist_kernel}
40 %requires_releq_kernel
41 Requires(postun):       %releq_kernel
42 %endif
43
44 %description -n kernel%{_alt_kernel}-video-nvidiabl
45 This driver drives the smartdimmer register found on modern mobile
46 nVidia graphics adapters such as NV40, NV41, NV43, NV44, NV46, NV47,
47 NV49, NV4B, C51, G84, G86, G92, G94, G96, GT200 architectures to
48 adjust the display backlight.
49
50 On Apple machines this driver allows more fine-grained brightness
51 adjustment than the (mbp_nvidia_bl) driver and is generally preferred.
52
53 %description -n kernel%{_alt_kernel}-video-nvidiabl -l pl.UTF-8
54 Sterownik dla Linuksa do nvidiabl.
55
56 Ten pakiet zawiera moduł jądra Linuksa.
57
58 %prep
59 %setup -qn %{pname}-%{version}
60
61 %build
62 %build_kernel_modules -m nvidiabl
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %install_kernel_modules -m nvidiabl -d misc
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post   -n kernel%{_alt_kernel}-video-nvidiabl
72 %depmod %{_kernel_ver}
73
74 %postun -n kernel%{_alt_kernel}-video-nvidiabl
75 %depmod %{_kernel_ver}
76
77 %files -n kernel%{_alt_kernel}-video-nvidiabl
78 %defattr(644,root,root,755)
79 /lib/modules/%{_kernel_ver}/misc/*.ko*
This page took 0.032131 seconds and 3 git commands to generate.