]> git.pld-linux.org Git - packages/nvidia-settings.git/commitdiff
- build nv-control utils
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 6 May 2012 13:23:51 +0000 (13:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nvidia-settings.spec -> 1.23

nvidia-settings.spec

index 017020061e27da1d3aa471a6edc3a424a6ad6a7a..06938b74583e3304dc15708f60db5f7d5b12ffb7 100644 (file)
@@ -1,6 +1,7 @@
 #
 # Conditional build:
 %bcond_without nvidia_settings # build the main package
+%bcond_without utils   # build utils from samples dir
 %bcond_without libXNVCtrl      # build libXNVCtrl for http://websvn.kde.org/trunk/kdenonbeta/nvidia/
 
 Summary:       Tool for configuring the NVIDIA driver
@@ -88,6 +89,14 @@ sterowników NVIDIA.
        X_CFLAGS="%{rpmcppflags} %{rpmcflags} -fPIC"
 %endif
 
+%if %{with utils}
+%{__make} -C samples \
+       NV_VERBOSE=1 \
+       CC="%{__cc}" \
+       OUTPUTDIR=$(pwd)/_out/utils \
+       X_CFLAGS="%{rpmcppflags} %{rpmcflags} -fPIC"
+%endif
+
 %if %{with nvidia_settings}
 %{__make} \
        NV_VERBOSE=1 \
@@ -117,6 +126,18 @@ cp -p src/libXNVCtrl/NVCtrlLib.h $RPM_BUILD_ROOT%{_includedir}/NVCtrl
 cp -p src/libXNVCtrl/libXNVCtrl.a $RPM_BUILD_ROOT%{_libdir}
 %endif
 
+%if %{with utils}
+install -d $RPM_BUILD_ROOT%{_bindir}
+for prog in _out/utils/nv-control-*; do
+       case "$prog" in
+       *.*)
+               continue
+               ;;
+       esac
+       install -p $prog $RPM_BUILD_ROOT%{_bindir}
+done
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -129,6 +150,17 @@ rm -rf $RPM_BUILD_ROOT
 %{_pixmapsdir}/nvidia-settings.png
 %endif
 
+%if %{with utils}
+%attr(755,root,root) %{_bindir}/nv-control-3dvisionpro
+%attr(755,root,root) %{_bindir}/nv-control-dpy
+%attr(755,root,root) %{_bindir}/nv-control-dvc
+%attr(755,root,root) %{_bindir}/nv-control-events
+%attr(755,root,root) %{_bindir}/nv-control-framelock
+%attr(755,root,root) %{_bindir}/nv-control-gvi
+%attr(755,root,root) %{_bindir}/nv-control-info
+%attr(755,root,root) %{_bindir}/nv-control-targets
+%endif
+
 %if %{with libXNVCtrl}
 %files -n libXNVCtrl-devel
 %defattr(644,root,root,755)
This page took 0.381464 seconds and 4 git commands to generate.