]> git.pld-linux.org Git - packages/nvidia-settings.git/blob - nvidia-settings.spec
- put devel docs and examples to libXNVCtrl-devel
[packages/nvidia-settings.git] / nvidia-settings.spec
1 #
2 # Conditional build:
3 %bcond_without  nvidia_settings # build the main package
4 %bcond_without  libXNVCtrl      # build libXNVCtrl for http://websvn.kde.org/trunk/kdenonbeta/nvidia/
5 #
6 %define         _buildid        20061219
7 %define         _rel    2
8 Summary:        Tool for configuring the NVIDIA driver
9 Name:           nvidia-settings
10 Version:        1.0
11 Release:        0.%{_buildid}.%{_rel}
12 License:        GPL
13 Group:          X11
14 Source0:        ftp://download.nvidia.com/XFree86/nvidia-settings/%{name}-%{version}.tar.gz
15 # Source0-md5:  414a838f01093ceb0ae8535c35e21eac
16 Patch0:         libXNVCtrl-shared.patch
17 Patch1:         %{name}-xlibs.patch
18 URL:            ftp://download.nvidia.com/XFree86/nvidia-settings/
19 BuildRequires:  XFree86-devel
20 %if %{with nvidia_settings}
21 BuildRequires:  gtk+2-devel
22 BuildRequires:  m4
23 BuildRequires:  pkgconfig
24 %endif
25 Requires:       libXNVCtrl = %{version}-%{release}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The `nvidia-settings` utility is a tool for configuring the NVIDIA
30 Linux graphics driver. It operates by communicating with the NVIDIA X
31 driver, querying and updating state as appropriate. This communication
32 is done with the NV-CONTROL X extension.
33
34 Values such as brightness and gamma, XVideo attributes, temperature,
35 and OpenGL settings can be queried and configured via nvidia-settings.
36
37 When nvidia-settings starts, it reads the current settings from its
38 configuration file and sends those settings to the X server. Then, it
39 displays a graphical user interface (GUI) interface for configuring
40 the current settings. When nvidia-settings exits, it queries the
41 current settings from the X server and saves them to the configuration
42 file.
43
44 %description -l pl
45 Narzêdzie nvidia-settings s³u¿y do konfiguracji sterownika do kart
46 graficznych firmy NVIDIA. Dzia³a komunikuj±c siê ze sterownikiem X
47 NVIDIA, sprawdzaj±c i uaktualniaj±c stan w razie potrzeby. Komunikacja
48 odbywa siê poprzez rozszerzenie X NV-CONTROL.
49
50 Za pomoc± nvidia-settings mo¿na odczytywaæ i zmieniaæ warto¶ci takie
51 jak jasno¶æ i korekcja gamma, atrybuty XVideo, temperatura barw i
52 ustawienia OpenGL.
53
54 Przy uruchamianiu nvidia-settings odczytuje bie¿±ce ustawienia z pliku
55 konfiguracyjnego i wysy³a te ustawienia do serwera X. Nastêpnie
56 wy¶wietla graficzny interfejs u¿ytkownika (GUI) do konfiguracji
57 ustawieñ. Przy wy³±czniu nvidia-settings odczytuje bie¿±ce ustawienia
58 z serwera X i zapisuje je do pliku konfiguracyjnego.
59
60 %package -n libXNVCtrl
61 Summary:        libXNVCtrl library
62 Summary(pl):    Biblioteka libXNVCtrl
63 Group:          Libraries
64
65 %description -n libXNVCtrl
66 Library for accessing NV-CONTROL extension in NVIDIA's latest drivers.
67
68 %description -n libXNVCtrl -l pl
69 Biblioteka do obs³ugi rozszerzenia NV-CONTROL z najnowszych
70 sterowników NVIDIA.
71
72 %package -n libXNVCtrl-devel
73 Summary:        libXNVCtrl development headers
74 Summary(pl):    Pliki nag³ówkowe biblioteki libXNVCtrl
75 Group:          Development/Libraries
76 Requires:       XFree86-devel
77 Requires:       libXNVCtrl = %{version}-%{release}
78
79 %description -n libXNVCtrl-devel
80 Development headers for libXNVCtrl.
81
82 %description -n libXNVCtrl-devel -l pl
83 Pliki nag³ówkowe biblioteki libXNVCtrl.
84
85 %package -n libXNVCtrl-static
86 Summary:        libXNVCtrl static library
87 Summary(pl):    Biblioteka statyczna libXNVCtrl
88 Group:          Development/Libraries
89 Requires:       libXNVCtrl-devel = %{version}-%{release}
90
91 %description -n libXNVCtrl-static
92 Static library for libXNVCtrl.
93
94 %description -n libXNVCtrl-static -l pl
95 Biblioteka statyczna libXNVCtrl.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101
102 %build
103 %if %{with libXNVCtrl}
104 cd src/libXNVCtrl
105 xmkmf
106 %{__make} clean
107 %{__make} \
108         CC="%{__cc}" \
109         CFLAGS="%{rpmcflags}"
110 cd ../..
111 %endif
112
113 %if %{with nvidia_settings}
114 %{__make} \
115         CC="%{__cc}" \
116         CFLAGS="%{rpmcflags}" \
117         LDFLAGS="%{rpmldflags}"
118 %endif
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 %if %{with nvidia_settings}
123 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
124 install nvidia-settings $RPM_BUILD_ROOT%{_bindir}
125 install doc/nvidia-settings.1 $RPM_BUILD_ROOT%{_mandir}/man1/nvidia-settings.1
126 %endif
127
128 %if %{with libXNVCtrl}
129 install -d $RPM_BUILD_ROOT%{_examplesdir}/libXNVCtrl-%{version}
130 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/libXNVCtrl-%{version}
131 %{__make} install \
132         -C src/libXNVCtrl \
133         DESTDIR=$RPM_BUILD_ROOT
134 %endif
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -n libXNVCtrl -p /sbin/ldconfig
140 %postun -n libXNVCtrl -p /sbin/ldconfig
141
142 %if %{with nvidia_settings}
143 %files
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/%{name}
146 %{_mandir}/man1/*
147 %endif
148
149 %if %{with libXNVCtrl}
150 %files -n libXNVCtrl
151 %defattr(644,root,root,755)
152 %attr(755,root,root) /usr/X11R6/%{_lib}/libXNVCtrl.so.*.*.*
153
154 %files -n libXNVCtrl-devel
155 %defattr(644,root,root,755)
156 %doc doc/{FRAMELOCK,NV-CONTROL-API}.txt
157 /usr/X11R6/include/X11/extensions/NVCtrl.h
158 /usr/X11R6/include/X11/extensions/NVCtrlLib.h
159 /usr/X11R6/%{_lib}/libXNVCtrl.so
160 %{_examplesdir}/libXNVCtrl-%{version}
161
162 %files -n libXNVCtrl-static
163 %defattr(644,root,root,755)
164 /usr/X11R6/%{_lib}/libXNVCtrl.a
165 %endif
This page took 0.051294 seconds and 4 git commands to generate.