]> git.pld-linux.org Git - packages/nvidia-settings.git/blob - nvidia-settings.spec
- up to 304.43, same version as xorg-driver-video-nvidia
[packages/nvidia-settings.git] / nvidia-settings.spec
1 #
2 # Conditional build:
3 %bcond_without  nvidia_settings # build the main package
4 %bcond_without  utils   # build utils from samples dir
5 %bcond_without  libXNVCtrl      # build libXNVCtrl for http://websvn.kde.org/trunk/kdenonbeta/nvidia/
6
7 Summary:        Tool for configuring the NVIDIA driver
8 Summary(pl.UTF-8):      Narzędzie do konfigurowania sterownika NVIDIA
9 Name:           nvidia-settings
10 # keep the version in sync with xorg-driver-video-nvidia.spec
11 Version:        304.43
12 Release:        1
13 License:        GPL
14 Group:          X11
15 Source0:        ftp://download.nvidia.com/XFree86/nvidia-settings/%{name}-%{version}.tar.bz2
16 # Source0-md5:  5f3b63a621897e5b32e13de114aa58db
17 Source1:        %{name}.desktop
18 Source2:        %{name}.png
19 URL:            ftp://download.nvidia.com/XFree86/nvidia-settings/
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  xorg-lib-libX11-devel
22 BuildRequires:  xorg-lib-libXext-devel
23 BuildRequires:  xorg-lib-libXv-devel
24 BuildRequires:  xorg-lib-libXxf86vm-devel
25 %if %{with nvidia_settings}
26 BuildRequires:  gtk+2-devel
27 BuildRequires:  m4
28 BuildRequires:  pkgconfig
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The `nvidia-settings` utility is a tool for configuring the NVIDIA
34 Linux graphics driver. It operates by communicating with the NVIDIA X
35 driver, querying and updating state as appropriate. This communication
36 is done with the NV-CONTROL X extension.
37
38 Values such as brightness and gamma, XVideo attributes, temperature,
39 and OpenGL settings can be queried and configured via nvidia-settings.
40
41 When nvidia-settings starts, it reads the current settings from its
42 configuration file and sends those settings to the X server. Then, it
43 displays a graphical user interface (GUI) interface for configuring
44 the current settings. When nvidia-settings exits, it queries the
45 current settings from the X server and saves them to the configuration
46 file.
47
48 %description -l pl.UTF-8
49 Narzędzie nvidia-settings służy do konfiguracji sterownika do kart
50 graficznych firmy NVIDIA. Działa komunikując się ze sterownikiem X
51 NVIDIA, sprawdzając i uaktualniając stan w razie potrzeby. Komunikacja
52 odbywa się poprzez rozszerzenie X NV-CONTROL.
53
54 Za pomocą nvidia-settings można odczytywać i zmieniać wartości takie
55 jak jasność i korekcja gamma, atrybuty XVideo, temperatura barw i
56 ustawienia OpenGL.
57
58 Przy uruchamianiu nvidia-settings odczytuje bieżące ustawienia z pliku
59 konfiguracyjnego i wysyła te ustawienia do serwera X. Następnie
60 wyświetla graficzny interfejs użytkownika (GUI) do konfiguracji
61 ustawień. Przy wyłączniu nvidia-settings odczytuje bieżące ustawienia
62 z serwera X i zapisuje je do pliku konfiguracyjnego.
63
64 %package -n libXNVCtrl-devel
65 Summary:        libXNVCtrl development headers
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libXNVCtrl
67 Group:          Development/Libraries
68 Requires:       xorg-lib-libX11-devel
69 Requires:       xorg-lib-libXext-devel
70 Requires:       xorg-lib-libXxf86vm-devel
71 Obsoletes:      libXNVCtrl-static
72
73 %description -n libXNVCtrl-devel
74 Library for accessing NV-CONTROL extension in NVIDIA's latest drivers.
75
76 %description -n libXNVCtrl-devel -l pl.UTF-8
77 Biblioteka do obsługi rozszerzenia NV-CONTROL z najnowszych
78 sterowników NVIDIA.
79
80 %prep
81 %setup -q
82
83 %{__rm} src/libXNVCtrl/libXNVCtrl.a
84
85 %build
86 %if %{with libXNVCtrl}
87 %{__make} -C src/libXNVCtrl \
88         NV_VERBOSE=1 \
89         CC="%{__cc}" \
90         X_CFLAGS="%{rpmcppflags} %{rpmcflags} -fPIC"
91 %endif
92
93 %if %{with utils}
94 %{__make} -C samples \
95         NV_VERBOSE=1 \
96         CC="%{__cc}" \
97         OUTPUTDIR=$(pwd)/_out/utils \
98         X_CFLAGS="%{rpmcppflags} %{rpmcflags} -fPIC"
99 %endif
100
101 %if %{with nvidia_settings}
102 %{__make} \
103         NV_VERBOSE=1 \
104         STRIP_CMD=: \
105         CC="%{__cc}" \
106         X_CFLAGS="%{rpmcppflags} %{rpmcflags}" \
107         X_LDFLAGS="%{rpmldflags}"
108 %endif
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112 %if %{with nvidia_settings}
113 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_desktopdir},%{_pixmapsdir}}
114 %{__make} install \
115         INSTALL="install -p" \
116         PREFIX=%{_prefix} \
117         DESTDIR=$RPM_BUILD_ROOT
118 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
119 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
120 %endif
121
122 %if %{with libXNVCtrl}
123 install -d $RPM_BUILD_ROOT%{_examplesdir}/libXNVCtrl-%{version} \
124         $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/NVCtrl}
125 cp -a samples/* $RPM_BUILD_ROOT%{_examplesdir}/libXNVCtrl-%{version}
126 rm -r $RPM_BUILD_ROOT%{_examplesdir}/libXNVCtrl-%{version}/_out
127 cp -p src/libXNVCtrl/NVCtrl.h $RPM_BUILD_ROOT%{_includedir}/NVCtrl
128 cp -p src/libXNVCtrl/NVCtrlLib.h $RPM_BUILD_ROOT%{_includedir}/NVCtrl
129 cp -p src/libXNVCtrl/libXNVCtrl.a $RPM_BUILD_ROOT%{_libdir}
130 %endif
131
132 %if %{with utils}
133 install -d $RPM_BUILD_ROOT%{_bindir}
134 for prog in _out/utils/nv-control-*; do
135         case "$prog" in
136         *.*)
137                 continue
138                 ;;
139         esac
140         install -p $prog $RPM_BUILD_ROOT%{_bindir}
141 done
142 %endif
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %if %{with nvidia_settings}
148 %files
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/nvidia-settings
151 %{_mandir}/man1/nvidia-settings.1*
152 %{_desktopdir}/nvidia-settings.desktop
153 %{_pixmapsdir}/nvidia-settings.png
154 %endif
155
156 %if %{with utils}
157 %attr(755,root,root) %{_bindir}/nv-control-3dvisionpro
158 %attr(755,root,root) %{_bindir}/nv-control-dpy
159 %attr(755,root,root) %{_bindir}/nv-control-dvc
160 %attr(755,root,root) %{_bindir}/nv-control-events
161 %attr(755,root,root) %{_bindir}/nv-control-framelock
162 %attr(755,root,root) %{_bindir}/nv-control-gvi
163 %attr(755,root,root) %{_bindir}/nv-control-info
164 %attr(755,root,root) %{_bindir}/nv-control-targets
165 %endif
166
167 %if %{with libXNVCtrl}
168 %files -n libXNVCtrl-devel
169 %defattr(644,root,root,755)
170 %doc doc/{FRAMELOCK,NV-CONTROL-API}.txt
171 %dir %{_includedir}/NVCtrl
172 %{_includedir}/NVCtrl/NVCtrl.h
173 %{_includedir}/NVCtrl/NVCtrlLib.h
174 %{_libdir}/libXNVCtrl.a
175 %{_examplesdir}/libXNVCtrl-%{version}
176 %endif
This page took 0.03367 seconds and 4 git commands to generate.