]> git.pld-linux.org Git - packages/ntp.git/commitdiff
- starting upgrade to 4.2.6p1
authorJacek Konieczny <jajcus@pld-linux.org>
Mon, 24 May 2010 17:55:05 +0000 (17:55 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ntp-ipv6.patch -> 1.6
    ntp-openssl_check.patch -> 1.4
    ntp.spec -> 1.132

ntp-ipv6.patch
ntp-openssl_check.patch
ntp.spec

index f28a5936f1932f9c2e11ff6419f464f731abd2c2..674a6a78905e4d1d8b8b45643f81f7c68ee8190d 100644 (file)
@@ -1,6 +1,7 @@
---- ntp-4.2.4p5/ntpdate/ntpdate.c.org  2008-10-08 17:42:22.981586584 +0200
-+++ ntp-4.2.4p5/ntpdate/ntpdate.c      2008-10-08 17:42:36.614918959 +0200
-@@ -1776,11 +1776,13 @@
+diff -durN -x '*.orig' ntp-4.2.6p1.orig/ntpdate/ntpdate.c ntp-4.2.6p1/ntpdate/ntpdate.c
+--- ntp-4.2.6p1.orig/ntpdate/ntpdate.c 2010-05-24 19:28:54.000000000 +0200
++++ ntp-4.2.6p1/ntpdate/ntpdate.c      2010-05-24 19:30:19.000000000 +0200
+@@ -1729,11 +1729,13 @@
                }
  #ifdef IPV6_V6ONLY
                /* Restricts AF_INET6 socket to IPv6 communications (see RFC 2553bis-03) */
@@ -8,8 +9,8 @@
 -                      if (setsockopt(fd[nbsock], IPPROTO_IPV6, IPV6_V6ONLY, (void*) &optval, sizeof(optval)) < 0) {
 +              if (res->ai_family == AF_INET6) {
 +                      int i = setsockopt(fd[nbsock], IPPROTO_IPV6, IPV6_V6ONLY, (void*) &optval, sizeof(optval));
-+                      if (i < 0 && errno != ENOPROTOOPT) {
-                                  netsyslog(LOG_ERR, "setsockopt() IPV6_V6ONLY failed: %m");
++                      if ( i < 0 && errno != ENOPROTOOPT ) {
+                                  msyslog(LOG_ERR, "setsockopt() IPV6_V6ONLY failed: %m");
                                        exit(1);
                                        /*NOTREACHED*/
 +                      }
index d9c404aa9cd2cfd5d967757e2802d820980d32f8..ac1d7190c11c1ad5470933c91fe7376268545ada 100644 (file)
@@ -1,6 +1,6 @@
---- ntp-4.2.4p7/configure.ac.orig      2009-05-19 10:22:32.000000000 +0200
-+++ ntp-4.2.4p7/configure.ac   2009-05-19 10:29:41.000000000 +0200
-@@ -3126,7 +3126,6 @@
+--- ntp-4.2.6p1/configure.ac.orig      2010-05-24 19:32:21.000000000 +0200
++++ ntp-4.2.6p1/configure.ac   2010-05-24 19:36:00.000000000 +0200
+@@ -3247,7 +3247,6 @@
  AC_SUBST(OPENSSL_INC)
  AC_SUBST(OPENSSL_LIB)
  
@@ -8,18 +8,10 @@
  AC_ARG_WITH(openssl-libdir,
        AC_HELP_STRING([--with-openssl-libdir], [+ =/something/reasonable]),
  [ans=$withval],
-@@ -3136,39 +3135,14 @@
- esac])
+@@ -3265,31 +3264,14 @@
+ esac
  case "$ans" in
   no) ;;
-- yes) # Look in:
--    ans="/usr/lib /usr/lib/openssl /usr/sfw/lib /usr/local/lib /usr/local/ssl/lib"
--    ;;
-- *) # Look where they said
--    ;;
--esac
--case "$ans" in
-- no) ;;
 - *) # Look for libcrypto.a and libssl.a:
 -    for i in $ans no
 -    do
 -      OPENSSL_LIB=$ans
 -      ;;
 -    esac
-+  *)
-+   if test "$ans" != "yes" ; then
-+       LDFLAGS="$LDFLAGS -L$ans"
-+   fi
-+   AC_CHECK_LIB([crypto],[DES_crypt],[AC_SUBST(LCRYPTO,[-lcrypto])])
-+   AC_CHECK_LIB([ssl],[SSL_CTX_new],[AC_SUBST(LSSL,[-lssl])])
-     ;;
+-    ;;
++ *)
++  if test "$ans" != "yes" ; then
++      LDFLAGS="$LDFLAGS -L$ans"
++  fi
++  AC_CHECK_LIB([crypto],[DES_crypt],[AC_SUBST(LCRYPTO,[-lcrypto])])
++  AC_CHECK_LIB([ssl],[SSL_CTX_new],[AC_SUBST(LSSL,[-lssl])])
++  ;;
  esac
 -AC_MSG_RESULT([$ans])
  
  AC_MSG_CHECKING([for openssl include directory])
  AC_ARG_WITH(openssl-incdir,
-@@ -3212,19 +3186,17 @@
- case "$ans" in
-  no) ;;
+@@ -3335,7 +3317,7 @@
+  no)
+     ;;
   yes|openssl)
 -    if test -z "$OPENSSL_LIB" -o -z "$OPENSSL_INC"
 +    if test -z "$LCRYPTO" -o -z "$OPENSSL_INC"
      then
        ans=no
      else
-       # We have OpenSSL inc/lib - use them.
-       ans=openssl
-       CPPFLAGS="$CPPFLAGS -I$OPENSSL_INC"
--      LDFLAGS="$LDFLAGS -L$OPENSSL_LIB"
-       case "$need_dash_r" in
-        1) LDFLAGS="$LDFLAGS -R$OPENSSL_LIB"
-           ;;
-       esac
--      AC_SUBST(LCRYPTO, [-lcrypto])
-       AC_DEFINE(OPENSSL, , [Use OpenSSL?])
-       AC_CHECK_FUNCS(EVP_md2 EVP_mdc2)
-     fi
+@@ -3349,11 +3331,9 @@
+  yes)
+     # We have OpenSSL inc/lib - use them.
+     CPPFLAGS="$CPPFLAGS -I$OPENSSL_INC"
+-    LDFLAGS="$LDFLAGS -L$OPENSSL_LIB"
+     case "$need_dash_r" in
+      1) LDFLAGS="$LDFLAGS -R$OPENSSL_LIB"
+     esac
+-    AC_SUBST(LCRYPTO, [-lcrypto])
+     AC_DEFINE(OPENSSL, , [Use OpenSSL?])
+ esac
index 58e2d018636c605b189093d211c758b5e240a41a..2aab031979b4905c681f4aedc01867d72ddc974e 100644 (file)
--- a/ntp.spec
+++ b/ntp.spec
@@ -3,12 +3,12 @@ Summary:      Network Time Protocol utilities
 Summary(pl.UTF-8):     Narzędzia do synchronizacji czasu (Network Time Protocol)
 Summary(pt_BR.UTF-8):  Network Time Protocol versão 4
 Name:          ntp
-Version:       4.2.4p8
-Release:       11
+Version:       4.2.6p1
+Release:       0.1
 License:       distributable
 Group:         Networking/Daemons
 Source0:       http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/%{name}-%{version}.tar.gz
-# Source0-md5: fe137056e7e611798a46971a783567ce
+# Source0-md5: 0510396dfbde40678b92f808ec07c0d2
 Source1:       %{name}.conf
 Source2:       %{name}.keys
 Source3:       %{name}.init
@@ -16,8 +16,8 @@ Source4:      %{name}.sysconfig
 Source5:       %{name}-client.init
 Source6:       %{name}-client.sysconfig
 Source7:       %{name}-manpages.tar.gz
-Source8:       %{name}.upstart
 # Source7-md5: 208fcc9019e19ab26d28e4597290bffb
+Source8:       %{name}.upstart
 Patch0:                %{name}-time.patch
 Patch1:                %{name}-no_libelf.patch
 Patch2:                %{name}-ipv6.patch
This page took 0.042176 seconds and 4 git commands to generate.