]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
- Release: 1 (seems usable)
[packages/ntop.git] / ntop.spec
1 Summary:        Network monitoring tool
2 Summary(pl):    Narzêdzie do monitorowania sieci
3 Name:           ntop
4 Version:        3.0
5 Release:        1
6 License:        GPL
7 Group:          Networking
8 Source0:        http://dl.sourceforge.net/ntop/%{name}-%{version}.tgz
9 # Source0-md5:  1ec6055c75f1acbb5d5600492481ef85
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch1:         %{name}-plugins_makefile.patch
13 Patch2:         %{name}-conf.patch
14 URL:            http://www.ntop.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gd-devel >= 2.0.1
18 BuildRequires:  gdbm-devel >= 1.8.3
19 BuildRequires:  libpcap-devel
20 BuildRequires:  libpng-devel
21 BuildRequires:  libtiff-devel
22 BuildRequires:  libwrap-devel
23 BuildRequires:  libtool
24 BuildRequires:  ncurses-devel >= 5.2
25 BuildRequires:  openssl-devel >= 0.9.7d
26 BuildRequires:  readline-devel >= 4.2
27 BuildRequires:  zlib-devel
28 PreReq:         rc-scripts
29 Requires(pre):  /usr/bin/getgid
30 Requires(pre):  /bin/id
31 Requires(pre):  /usr/sbin/groupadd
32 Requires(pre):  /usr/sbin/useradd
33 Requires(post,preun):   /sbin/chkconfig
34 Requires(post,postun):  /sbin/ldconfig
35 Requires(postun):       /usr/sbin/groupdel
36 Requires(postun):       /usr/sbin/userdel
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 ntop is a tool that shows the network usage, similar to what the
41 popular top Unix command does.
42
43 %description -l pl
44 ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
45 robi to popularna Unixowa komenda top.
46
47 %prep
48 %setup -q
49 %patch1 -p1
50 %patch2 -p1
51
52 %build
53 #mv -f acinclude.m4.in acinclude.m4
54 #rm -f missing
55 #%%{__libtoolize}
56 %{__aclocal}
57 %{__autoconf}
58 %{__automake}
59 %configure \
60         --with-ossl-root=%{_prefix} \
61         --with-gdchart-root=`pwd`/../gdchart0.94c \
62         --enable-tcpwrap \
63         --with-gnu-ld \
64         --enable-i18n \
65         --enable-showoses \
66         --localstatedir=%{_var}/lib/%{name} || true
67
68 %configure \
69         --with-ossl-root=%{_prefix} \
70         --with-gdchart-root=`pwd`/../gdchart0.94c \
71         --enable-tcpwrap \
72         --with-gnu-ld \
73         --localstatedir=%{_var}/lib/%{name}
74
75
76 %{__make}
77 cd plugins
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d      $RPM_BUILD_ROOT{%{_var}/lib/%{name},/etc/{rc.d/init.d,sysconfig}}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ntop
88 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ntop
89 install packages/RedHat/ntop.conf.sample $RPM_BUILD_ROOT/etc/ntop.conf
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %pre
95 if [ -n "`getgid ntop`" ]; then
96         if [ "`getgid ntop`" != "120" ]; then
97                 echo "Error: group ntop doesn't have gid=120. Correct this before installing ntop." 1>&2
98                 exit 1
99         fi
100 else
101         /usr/sbin/groupadd -g 120 -r -f ntop
102 fi
103 if [ -n "`id -u ntop 2>/dev/null`" ]; then
104         if [ "`id -u ntop`" != "120" ]; then
105                 echo "Error: user ntop doesn't have uid=120. Correct this before installing ntop." 1>&2
106                 exit 1
107         fi
108 else
109         /usr/sbin/useradd -u 120 -r -d /var/lib/ntop -s /bin/false -c "ntop User" -g ntop ntop 1>&2
110 fi
111
112 %post
113 /sbin/ldconfig
114 /sbin/chkconfig --add ntop
115 if [ -f /var/lock/subsys/ntop ]; then
116         /etc/rc.d/init.d/ntop restart >&2
117 else
118         echo "Run \"/etc/rc.d/init.d/ntop start\" to start ntop daemon." >&2
119 fi
120
121 %preun
122 if [ "$1" = "0" ]; then
123         if [ -f /var/lock/subsys/ntop ]; then
124                 /etc/rc.d/init.d/ntop stop 1>&2
125         fi
126         /sbin/chkconfig --del ntop
127 fi
128
129 %postun
130 /sbin/ldconfig
131 if [ "$1" = "0" ]; then
132         /usr/sbin/userdel ntop
133         /usr/sbin/groupdel ntop
134 fi
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS ChangeLog NEWS README THANKS
139 %attr(770,root,ntop) %dir %{_var}/lib/%{name}
140 %attr(755,root,root) %{_bindir}/*
141 %attr(755,root,root) %{_libdir}/lib*
142 %attr(755,root,root) %{_datadir}/%{name}
143 %dir %{_libdir}/%{name}
144 %attr(755,root,root) %{_libdir}/%{name}/plugins
145 %{_mandir}/man*/*
146 %attr(754,root,root) /etc/rc.d/init.d/ntop
147 %attr(640,root,root) /etc/sysconfig/ntop
148 %attr(640,root,ntop) %config(noreplace) %verify(not size mtime md5) /etc/ntop
149 %attr(644,root,ntop) %config(noreplace) %verify(not size mtime md5) /etc/ntop.conf
This page took 0.086018 seconds and 3 git commands to generate.