]> git.pld-linux.org Git - packages/ntop.git/blob - ntop.spec
- rel 2 (rebuild with fixed %useradd/%groupadd macros)
[packages/ntop.git] / ntop.spec
1 Summary:        Network monitoring tool
2 Summary(pl):    Narzêdzie do monitorowania sieci
3 Name:           ntop
4 Version:        3.2
5 Release:        2
6 License:        GPL
7 Group:          Networking
8 Source0:        http://dl.sourceforge.net/ntop/%{name}-%{version}.tgz
9 # Source0-md5:  cd29a876b34a7dd76555e9acd8f160bb
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Patch0:         %{name}-plugins_makefile.patch
13 Patch1:         %{name}-conf.patch
14 Patch2:         %{name}-nolibs.patch
15 Patch3:         %{name}-config.patch
16 Patch4:         %{name}-am.patch
17 URL:            http://www.ntop.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake >= 1.6
20 BuildRequires:  gawk
21 BuildRequires:  gd-devel >= 2.0.1
22 BuildRequires:  gdbm-devel >= 1.8.3
23 BuildRequires:  gdome2-devel
24 BuildRequires:  glib2-devel
25 BuildRequires:  libpcap-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libtiff-devel
28 BuildRequires:  libtool
29 BuildRequires:  libwrap-devel
30 BuildRequires:  ncurses-devel >= 5.2
31 BuildRequires:  openssl-devel >= 0.9.7d
32 BuildRequires:  readline-devel >= 4.2
33 BuildRequires:  rpmbuild(macros) >= 1.202
34 BuildRequires:  rpmbuild(macros) >= 1.268
35 BuildRequires:  rrdtool-devel >= 1.1.0
36 BuildRequires:  zlib-devel
37 Requires(post,postun):  /sbin/ldconfig
38 Requires(post,preun):   /sbin/chkconfig
39 Requires(postun):       /usr/sbin/groupdel
40 Requires(postun):       /usr/sbin/userdel
41 Requires(pre):  /bin/id
42 Requires(pre):  /usr/bin/getgid
43 Requires(pre):  /usr/sbin/groupadd
44 Requires(pre):  /usr/sbin/useradd
45 Requires:       rc-scripts
46 Provides:       group(ntop)
47 Provides:       user(ntop)
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         _localstatedir          /var/lib
51
52 %description
53 ntop is a tool that shows the network usage, similar to what the
54 popular top Unix command does.
55
56 %description -l pl
57 ntop to narzêdzie, które pokazuje u¿ycie sieci w podobny sposób jak
58 robi to popularna uniksowa komenda top.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65 %patch3 -p1
66 %patch4 -p1
67
68 # kill libtool.m4 copy
69 cp -f acinclude.m4.ntop acinclude.m4
70
71 %build
72 %{__libtoolize}
73 %{__aclocal}
74 %{__autoconf}
75 %{__automake}
76 # "verified.awk -u" calls require gawk
77 %configure \
78         AWK=gawk \
79         --disable-static \
80         --enable-i18n \
81         --with-gnu-ld \
82         --with-ossl-root=%{_prefix} \
83         --with-tcpwrap
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_localstatedir}/ntop/rrd,/etc/{rc.d/init.d,sysconfig},%{_sbindir}}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ntop
95 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/ntop
96 install packages/RedHat/ntop.conf.sample $RPM_BUILD_ROOT%{_sysconfdir}/ntop.conf
97
98 # no -devel
99 rm -f $RPM_BUILD_ROOT%{_libdir}{,/ntop/plugins}/*.la
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %pre
105 %groupadd -g 120 ntop
106 %useradd -u 120 -d %{_localstatedir}/ntop -s /bin/false -c "ntop User" -g ntop ntop
107
108 %post
109 /sbin/ldconfig
110 /sbin/chkconfig --add ntop
111 %service ntop restart "ntop daemon"
112
113 %preun
114 if [ "$1" = "0" ]; then
115         %service ntop stop
116         /sbin/chkconfig --del ntop
117 fi
118
119 %postun
120 /sbin/ldconfig
121 if [ "$1" = "0" ]; then
122         %userremove ntop
123         %groupremove ntop
124 fi
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README THANKS docs/{1STRUN.txt,FAQ}
129 %attr(770,root,ntop) %dir %{_localstatedir}/ntop
130 %attr(770,root,ntop) %dir %{_localstatedir}/ntop/rrd
131 %attr(755,root,root) %{_sbindir}/*
132 %attr(755,root,root) %{_libdir}/lib*.so
133 %attr(755,root,root) %{_datadir}/%{name}
134 %dir %{_libdir}/%{name}
135 %attr(755,root,root) %{_libdir}/%{name}/plugins
136 %{_mandir}/man*/*
137 %attr(754,root,root) /etc/rc.d/init.d/ntop
138 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ntop
139 %attr(750,root,ntop) %dir %{_sysconfdir}/ntop
140 %attr(640,root,ntop) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ntop/*
141 %attr(660,root,ntop) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ntop.conf
This page took 0.080128 seconds and 3 git commands to generate.