]> git.pld-linux.org Git - packages/nss.git/blob - nss.spec
- rel 2
[packages/nss.git] / nss.spec
1 %define foover  %(echo %{version} | tr . _)
2 Summary:        NSS - Network Security Services
3 Summary(pl):    NSS - Network Security Services
4 Name:           nss
5 Version:        3.11.3
6 Release:        2
7 Epoch:          1
8 License:        GPL
9 Group:          Libraries
10 # :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot mozilla/dbm -r DBM_1_61_RTM
11 # :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot mozilla/security/dbm -r DBM_1_61_RTM
12 # :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot mozilla/security/coreconf -r NSS_3_9_4_RTM
13 # :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot mozilla/security/nss -r NSS_3_9_4_RTM
14 #Source0:       %{name}-%{version}.tar.bz2
15 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/NSS_%{foover}_RTM/src/%{name}-%{version}.tar.gz
16 # Source0-md5:  196c8d2746bd75d3561d129f64bbf9cf
17 Source1:        %{name}-mozilla-nss.pc
18 Source2:        %{name}-config.in
19 Patch0:         %{name}-Makefile.patch
20 URL:            http://www.mozilla.org/projects/security/pki/nss/
21 BuildRequires:  nspr-devel >= 1:4.6.3
22 BuildRequires:  zlib-devel
23 BuildConflicts: mozilla < 0.9.6-3
24 Requires:       nspr >= 1:4.6.3
25 Obsoletes:      libnss3
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         specflags       -fno-strict-aliasing
29
30 %description
31 NSS supports cross-platform development of security-enabled server
32 applications. Applications built with NSS can support PKCS #5,
33 PKCS #7, PKCS #11, PKCS #12, S/MIME, TLS, SSL v2 and v3, X.509 v3
34 certificates, and other security standards.
35
36 %description -l pl
37 NSS wspomaga pisanie wieloplatformowych bezpiecznych serwerów.
38 Aplikacja u¿ywaj±ca NSS jest w stanie obs³u¿yæ PKCS #5, PKCS #7,
39 PKCS #11, PKCS #12, S/MIME, TLS, SSL v2 oraz v3, certyfikaty X.509 v3,
40 i wiele innych bezpiecznych standardów.
41
42 %package tools
43 Summary:        NSS command line tools and utilities
44 Summary(pl):    Narzêdzia NSS
45 Group:          Applications
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47
48 %description tools
49 The NSS Toolkit command line tool.
50
51 %description tools -l pl
52 Narzêdzia NSS obs³ugiwane z linii poleceñ.
53
54 %package devel
55 Summary:        NSS - header files
56 Summary(pl):    NSS - pliki nag³ówkowe
57 Group:          Development/Libraries
58 Requires:       %{name} = %{epoch}:%{version}-%{release}
59 Obsoletes:      libnss3-devel
60
61 %description devel
62 Development part of NSS library.
63
64 %description devel -l pl
65 Czê¶æ biblioteki NSS przeznaczona dla programistów.
66
67 %package static
68 Summary:        NSS - static library
69 Summary(pl):    NSS - biblioteka statyczna
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Static NSS Toolkit libraries.
75
76 %description static -l pl
77 Statyczne wersje bibliotek z NSS.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82
83 %build
84 cd mozilla/security/nss
85
86 %ifarch %{x8664} ppc64
87 export USE_64=1
88 %endif
89
90 %{__make} -j1 build_coreconf \
91         NSDISTMODE=copy \
92         NS_USE_GCC=1 \
93         MOZILLA_CLIENT=1 \
94         NO_MDUPDATE=1 \
95         USE_PTHREADS=1 \
96         BUILD_OPT=1 \
97         OPTIMIZER="%{rpmcflags}"
98
99 %{__make} -j1 build_dbm \
100         NSDISTMODE=copy \
101         NS_USE_GCC=1 \
102         MOZILLA_CLIENT=1 \
103         NO_MDUPDATE=1 \
104         USE_PTHREADS=1 \
105         BUILD_OPT=1 \
106         OPTIMIZER="%{rpmcflags}" \
107         PLATFORM="pld"
108
109 %{__make} -j1 all \
110         NSDISTMODE=copy \
111         NS_USE_GCC=1 \
112         MOZILLA_CLIENT=1 \
113         NO_MDUPDATE=1 \
114         USE_PTHREADS=1 \
115         BUILD_OPT=1 \
116         USE_SYSTEM_ZLIB=1 \
117         ZLIB_LIBS="-lz" \
118         OPTIMIZER="%{rpmcflags}" \
119         PLATFORM="pld"
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/nss,%{_libdir},%{_pkgconfigdir}}
124
125 install mozilla/dist/private/nss/*      $RPM_BUILD_ROOT%{_includedir}/nss
126 install mozilla/dist/public/dbm/*       $RPM_BUILD_ROOT%{_includedir}/nss
127 install mozilla/dist/public/nss/*       $RPM_BUILD_ROOT%{_includedir}/nss
128 install mozilla/dist/pld/bin/*          $RPM_BUILD_ROOT%{_bindir}
129 install mozilla/dist/pld/lib/*          $RPM_BUILD_ROOT%{_libdir}
130
131 %{__sed} -e '
132         s#libdir=.*#libdir=%{_libdir}#g
133         s#includedir=.*#includedir=%{_includedir}#g
134         s#VERSION#%{version}#g
135 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_pkgconfigdir}/mozilla-nss.pc
136 ln -s mozilla-nss.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/nss.pc
137
138 NSS_VMAJOR=$(awk '/#define.*NSS_VMAJOR/ {print $3}' mozilla/security/nss/lib/nss/nss.h)
139 NSS_VMINOR=$(awk '/#define.*NSS_VMINOR/ {print $3}' mozilla/security/nss/lib/nss/nss.h)
140 NSS_VPATCH=$(awk '/#define.*NSS_VPATCH/ {print $3}' mozilla/security/nss/lib/nss/nss.h)
141 %{__sed} -e "
142         s,@libdir@,%{_libdir},g
143         s,@prefix@,%{_prefix},g
144         s,@exec_prefix@,%{_prefix},g
145         s,@includedir@,%{_includedir}/nss,g
146         s,@version@,%{version},g
147 " %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/nss-config
148 chmod +x $RPM_BUILD_ROOT%{_bindir}/nss-config
149
150 # resolve conflict with squid
151 mv -f $RPM_BUILD_ROOT%{_bindir}/{,nss-}client
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/lib*.so
162 %{_libdir}/lib*.chk
163
164 %files devel
165 %defattr(644,root,root,755)
166 %{_includedir}/nss
167 %{_libdir}/libcrmf.a
168 %{_pkgconfigdir}/*.pc
169 %attr(755,root,root) %{_bindir}/nss-config
170
171 %files tools
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/*
174 %exclude %{_bindir}/nss-config
175
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/lib*.a
179 %exclude %{_libdir}/libcrmf.a
This page took 0.076167 seconds and 4 git commands to generate.