]> git.pld-linux.org Git - packages/nomacs.git/blob - nomacs.spec
- rebuild with opencv 3.4
[packages/nomacs.git] / nomacs.spec
1 # TODO: add plugins (https://github.com/nomacs/nomacs-plugins/)
2 Summary:        Lightweight image viewer
3 Summary(pl.UTF-8):      Lekka przeglądarka obrazków
4 Name:           nomacs
5 Version:        3.4.1
6 Release:        4
7 License:        GPL v3+
8 Group:          X11/Applications
9 Source0:        https://github.com/nomacs/nomacs/archive/%{version}/%{name}-%{version}-source.tar.gz
10 # Source0-md5:  1daf7458717eb545b2da8534cff36d6e
11 Patch0:         quazip-qt5.patch
12 Patch1:         %{name}-libqpsd.patch
13 URL:            http://nomacs.org/
14 BuildRequires:  Qt5Concurrent-devel >= 5.2.1
15 BuildRequires:  Qt5Core-devel >= 5.2.1
16 BuildRequires:  Qt5Gui-devel >= 5.2.1
17 BuildRequires:  Qt5Network-devel >= 5.2.1
18 BuildRequires:  Qt5Svg-devel >= 5.2.1
19 BuildRequires:  cmake >= 2.8
20 BuildRequires:  desktop-file-utils
21 BuildRequires:  dos2unix
22 BuildRequires:  exiv2-devel >= 0.25
23 BuildRequires:  libqpsd-qt5-devel
24 BuildRequires:  libraw-devel >= 0.17
25 BuildRequires:  libstdc++-devel >= 6:4.3
26 BuildRequires:  libtiff-devel
27 BuildRequires:  libwebp-devel >= 0.3.1
28 BuildRequires:  opencv-devel >= 2.4.6
29 BuildRequires:  pkgconfig
30 BuildRequires:  qt5-build >= 5.2.1
31 BuildRequires:  qt5-linguist >= 5.2.1
32 BuildRequires:  qt5-qmake >= 5.2.1
33 BuildRequires:  quazip-qt5-devel >= 0.7
34 Requires:       Qt5Concurrent >= 5.2.1
35 Requires:       Qt5Core >= 5.2.1
36 Requires:       Qt5Gui >= 5.2.1
37 Requires:       Qt5Network >= 5.2.1
38 Requires:       Qt5Svg >= 5.2.1
39 Requires:       exiv2-libs >= 0.25
40 Requires:       libraw >= 0.17
41 Requires:       opencv >= 2.4.6
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 nomacs is image viewer based on Qt library.
46
47 nomacs is small, fast and able to handle the most common image
48 formats. Additionally it is possible to synchronize multiple viewers
49 running on the same computer or via LAN is possible. It allows to
50 compare images and spot the differences e.g. schemes of architects to
51 show the progress).
52
53 %description -l pl.UTF-8
54 nomacs to przeglądarka obrazków oparta na bibliotece Qt.
55
56 nomacs jest mała, szybka i potrafi obsłużyć większość popularnych
57 formatów obrazów. Ponadto możliwa jest synchronizacja wielu
58 przeglądarek działających na tym samym komputerze lub poprzez sieć
59 lokalną. Przeglądarka pozwala porównywać obrazki i wskazywać różnice,
60 np. projekty architektów w celu pokazania postępów.
61
62 %prep
63 %setup -q
64 cd ImageLounge
65 %patch0 -p1
66 %patch1 -p1
67
68 dos2unix Readme/*
69
70 %{__rm} -r 3rdparty/{libqpsd,quazip-0.7}
71
72 %build
73 install -d build
74 cd build
75 %cmake ../ImageLounge \
76         -DENABLE_PLUGINS=ON \
77         -DENABLE_RAW=1 \
78         -DUSE_SYSTEM_LIBQPSD=ON \
79         -DUSE_SYSTEM_QUAZIP=ON \
80         -DUSE_SYSTEM_WEBP=ON
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C build install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # unify
91 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/nomacs_{zh,zh_CN}.qm
92 # translation to German "Vorarlbergerisch" dialect - should be de_AT@Vorarlberg?
93 # ("als" is wrong code - it's Tosk Albanian in iso-639-3)
94 %{__rm} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/nomacs_als.qm
95
96 # API not exported, so keep only library files + soname symlinks
97 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnomacs*.so
98
99 desktop-file-validate $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
100
101 %find_lang %{name} --with-qm --without-mo
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 /sbin/ldconfig
108 %update_desktop_database
109
110 %postun
111 /sbin/ldconfig
112 %update_desktop_database
113
114 %files -f %{name}.lang
115 %defattr(644,root,root,755)
116 %doc ImageLounge/Readme/{COPYRIGHT,LICENSE.OPENCV,README}
117 %attr(755,root,root) %{_bindir}/nomacs
118 %attr(755,root,root) %{_libdir}/libnomacsCore.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libnomacsCore.so.3
120 %attr(755,root,root) %{_libdir}/libnomacsGui.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libnomacsGui.so.3
122 %attr(755,root,root) %{_libdir}/libnomacsLoader.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libnomacsLoader.so.3
124 %{_mandir}/man1/nomacs.1*
125 %dir %{_datadir}/%{name}
126 %dir %{_datadir}/%{name}/translations
127 %{_datadir}/appdata/nomacs.appdata.xml
128 %{_desktopdir}/nomacs.desktop
129 %{_pixmapsdir}/nomacs.svg
This page took 0.104791 seconds and 3 git commands to generate.