]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
up to 0.10.33, insecure ssl protocols not negotiation by default auto/th/nodejs-0.10.33-1
authorElan Ruusamäe <glen@delfi.ee>
Wed, 19 Nov 2014 19:13:51 +0000 (21:13 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 19 Nov 2014 19:23:38 +0000 (21:23 +0200)
use node commandline to enable (--enable-ssl2, --enable-ssl3)

nodejs-revert-utf8-node.patch
nodejs-revert-utf8-v8.patch
nodejs.spec

index f8c8f37a61a001228c29eae888bcb1776a278435..a5a3d597201e63d0e760f1f56541b24129d23f65 100644 (file)
@@ -22,15 +22,6 @@ diff --git a/src/cares_wrap.cc b/src/cares_wrap.cc
 index 321e144..b7ba828 100644
 --- a/src/cares_wrap.cc
 +++ b/src/cares_wrap.cc
-@@ -31,8 +31,6 @@
- #include "tree.h"
- #include "uv.h"
--#include "util.h"
--
- #if defined(__OpenBSD__) || defined(__MINGW32__) || defined(_MSC_VER)
- # include <nameser.h>
- #else
 @@ -741,7 +739,7 @@ static Handle<Value> Query(const Arguments& args) {
    // object reference, causing wrap->GetObject() to return undefined.
    Local<Object> object = Local<Object>::New(wrap->GetObject());
@@ -83,15 +74,6 @@ diff --git a/src/node.cc b/src/node.cc
 index e9696cd..8257604 100644
 --- a/src/node.cc
 +++ b/src/node.cc
-@@ -82,8 +82,6 @@ typedef int mode_t;
- #include "node_script.h"
- #include "v8_typed_array.h"
--#include "util.h"
--
- using namespace v8;
- # ifdef __APPLE__
 @@ -1102,7 +1100,7 @@ enum encoding ParseEncoding(Handle<Value> encoding_v, enum encoding _default) {
  
    if (!encoding_v->IsString()) return _default;
@@ -262,14 +244,6 @@ diff --git a/src/node_crypto.cc b/src/node_crypto.cc
 index 46faba2..0ae1f8a 100644
 --- a/src/node_crypto.cc
 +++ b/src/node_crypto.cc
-@@ -26,7 +26,6 @@
- #include "node.h"
- #include "node_buffer.h"
- #include "string_bytes.h"
--#include "util.h"
- #include <string.h>
- #ifdef _MSC_VER
 @@ -242,7 +241,7 @@ Handle<Value> SecureContext::Init(const Arguments& args) {
    OPENSSL_CONST SSL_METHOD *method = SSLv23_method();
  
@@ -409,15 +383,6 @@ diff --git a/src/node_dtrace.cc b/src/node_dtrace.cc
 index 0b2d0f4..4b851e3 100644
 --- a/src/node_dtrace.cc
 +++ b/src/node_dtrace.cc
-@@ -20,8 +20,6 @@
- // USE OR OTHER DEALINGS IN THE SOFTWARE.
--#include "util.h"
--
- #ifdef HAVE_DTRACE
- #include "node_dtrace.h"
- #include <string.h>
 @@ -68,7 +66,7 @@ using namespace v8;
      return (ThrowException(Exception::Error(String::New("expected " \
        "object for " #obj " to contain string member " #member)))); \
@@ -440,14 +405,6 @@ diff --git a/src/node_file.cc b/src/node_file.cc
 index 3c35e0b..f665b19 100644
 --- a/src/node_file.cc
 +++ b/src/node_file.cc
-@@ -24,7 +24,6 @@
- #include "node_buffer.h"
- #include "node_stat_watcher.h"
- #include "req_wrap.h"
--#include "util.h"
- #include <fcntl.h>
- #include <sys/types.h>
 @@ -404,7 +403,7 @@ static Handle<Value> Stat(const Arguments& args) {
    if (args.Length() < 1) return TYPE_ERROR("path required");
    if (!args[0]->IsString()) return TYPE_ERROR("path must be a string");
@@ -589,14 +546,6 @@ diff --git a/src/node_stat_watcher.cc b/src/node_stat_watcher.cc
 index fd3e5d1..c3f668c 100644
 --- a/src/node_stat_watcher.cc
 +++ b/src/node_stat_watcher.cc
-@@ -20,7 +20,6 @@
- // USE OR OTHER DEALINGS IN THE SOFTWARE.
- #include "node_stat_watcher.h"
--#include "util.h"
- #include <assert.h>
- #include <string.h>
 @@ -105,7 +104,7 @@ Handle<Value> StatWatcher::Start(const Arguments& args) {
    HandleScope scope;
  
@@ -610,14 +559,6 @@ diff --git a/src/process_wrap.cc b/src/process_wrap.cc
 index ac63e4b..784300f 100644
 --- a/src/process_wrap.cc
 +++ b/src/process_wrap.cc
-@@ -25,7 +25,6 @@
- #include "tty_wrap.h"
- #include "tcp_wrap.h"
- #include "udp_wrap.h"
--#include "util.h"
- #include <string.h>
- #include <stdlib.h>
 @@ -188,7 +187,7 @@ class ProcessWrap : public HandleWrap {
  
      // options.file
@@ -658,14 +599,6 @@ diff --git a/src/udp_wrap.cc b/src/udp_wrap.cc
 index 31a4e78..b33f4e8 100644
 --- a/src/udp_wrap.cc
 +++ b/src/udp_wrap.cc
-@@ -25,7 +25,6 @@
- #include "req_wrap.h"
- #include "handle_wrap.h"
- #include "udp_wrap.h"
--#include "util.h"
- #include <stdlib.h>
 @@ -161,7 +160,7 @@ Handle<Value> UDPWrap::DoBind(const Arguments& args, int family) {
    // bind(ip, port, flags)
    assert(args.Length() == 3);
@@ -696,40 +629,12 @@ index 31a4e78..b33f4e8 100644
    switch (family) {
    case AF_INET:
 diff --git a/src/util.h b/src/util.h
-deleted file mode 100644
-index 0dbf7f4..0000000
 --- a/src/util.h
-+++ /dev/null
-@@ -1,78 +0,0 @@
--// Copyright Joyent, Inc. and other Node contributors.
--//
--// Permission is hereby granted, free of charge, to any person obtaining a
--// copy of this software and associated documentation files (the
--// "Software"), to deal in the Software without restriction, including
--// without limitation the rights to use, copy, modify, merge, publish,
--// distribute, sublicense, and/or sell copies of the Software, and to permit
--// persons to whom the Software is furnished to do so, subject to the
--// following conditions:
--//
--// The above copyright notice and this permission notice shall be included
--// in all copies or substantial portions of the Software.
--//
--// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
--// OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
--// MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN
--// NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM,
--// DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
--// OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
--// USE OR OTHER DEALINGS IN THE SOFTWARE.
--
--#ifndef SRC_UTIL_H_
--#define SRC_UTIL_H_
--
--#include "v8.h"
--#include "string_bytes.h"
--
--namespace node {
--
++++ b/src/util.h
+@@ -41,52 +41,6 @@
+   obj->Set(domain_symbol, domain);
+ }
 -class Utf8Value {
 -  public:
 -    explicit Utf8Value(v8::Handle<v8::Value> value)
@@ -776,9 +681,9 @@ index 0dbf7f4..0000000
 -    char* str_;
 -};
 -
--}  // namespace node
--
--#endif  // SRC_UTIL_H_
+ }  // namespace node
+ #endif  // SRC_UTIL_H_
 -- 
 1.9.3
 
index f617cf3c85724aeaef8d419be4ab52a6ee06526c..6b16de68e7d726214709900b5915016cc127959f 100644 (file)
@@ -15,17 +15,18 @@ diff --git a/src/node.cc b/src/node.cc
 index 4223973..e9696cd 100644
 --- a/src/node.cc
 +++ b/src/node.cc
-@@ -178,8 +178,6 @@ static uv_async_t dispatch_debug_messages_async;
+@@ -180,9 +180,6 @@ static uv_async_t dispatch_debug_messages_async;
  // Declared in node_internals.h
  Isolate* node_isolate = NULL;
  
 -int WRITE_UTF8_FLAGS = v8::String::HINT_MANY_WRITES_EXPECTED |
 -                       v8::String::NO_NULL_TERMINATION;
+-
  static void Spin(uv_idle_t* handle, int status) {
    assert((uv_idle_t*) handle == &tick_spinner);
-@@ -3046,11 +3044,6 @@ static char **copy_argv(int argc, char **argv) {
- }
+   assert(status == 0);
+@@ -3077,11 +3074,6 @@ static char **copy_argv(int argc, char **argv) {
  
  int Start(int argc, char *argv[]) {
 -  const char* replaceInvalid = getenv("NODE_INVALID_UTF8");
index 3d0a0ed67a2919d55da84d8fdd50afc9369a5465..0ad2b5f6239566e0c3b6b51ffc26b064701275d1 100644 (file)
@@ -1,11 +1,11 @@
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.10.30
-Release:       2
+Version:       0.10.33
+Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: bae597a31bf6d23da1c4217bfed611dc
+# Source0-md5: 626ca8a4f8fec4df49c78ed53d46f1f7
 Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
This page took 0.171632 seconds and 4 git commands to generate.