]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
Use internal v8 include-v8
authorAria <aredridel@nbtsc.org>
Sun, 27 Oct 2013 01:26:50 +0000 (19:26 -0600)
committerAria <aredridel@nbtsc.org>
Sun, 27 Oct 2013 01:26:50 +0000 (19:26 -0600)
This is needed because the new v8 shipped breaks extensions like node-expat
with undefined symbol: _ZN2v86Object25SetPointerInInternalFieldEiPv

nodejs.spec

index 1127bfb0b31168c0d2ffb2b6317232d58daf208a..922a841a91fe31d682241ad440833d2313bdaf94 100644 (file)
@@ -25,7 +25,6 @@ BuildRequires:        python-jsmin
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
-BuildRequires: v8-devel >= 3.15.11.10
 BuildRequires: zlib-devel
 BuildConflicts:        eio
 Obsoletes:     nodejs-waf
@@ -51,7 +50,6 @@ Requires:     http-parser-devel
 Requires:      libstdc++-devel
 Requires:      libuv-devel
 Requires:      openssl-devel
-Requires:      v8-devel
 Requires:      zlib-devel
 
 %description devel
@@ -80,15 +78,12 @@ This package contains the documentation for nodejs.
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-rm -r deps
-
 %build
 # CC used only to detect if CC is clang, not used for compiling
 CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-v8 \
        --shared-zlib \
        --shared-openssl \
        --shared-cares \
This page took 0.491765 seconds and 4 git commands to generate.