]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
- 0.4.2
authoraredridel <aredridel@pld-linux.org>
Thu, 3 Mar 2011 05:44:50 +0000 (05:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nodejs-sharedlib.patch -> 1.2
    nodejs-soname.patch -> 1.2
    nodejs.spec -> 1.17

nodejs-sharedlib.patch [deleted file]
nodejs-soname.patch
nodejs.spec

diff --git a/nodejs-sharedlib.patch b/nodejs-sharedlib.patch
deleted file mode 100644 (file)
index e1cd205..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/deps/libeio/wscript b/deps/libeio/wscript
-index 5194ead..280dca6 100644
---- a/deps/libeio/wscript
-+++ b/deps/libeio/wscript
-@@ -125,5 +125,7 @@ def build(bld):
-   libeio.install_path = None
-   if bld.env["USE_DEBUG"]:
-     libeio.clone("debug");
-+  if Options.options.product_type != 'program':
-+    libeio.ccflags = "-fPIC"
-   bld.install_files('${PREFIX}/include/node/', 'eio.h');
-diff --git a/wscript b/wscript
-index de5ee45..51a46ec 100644
---- a/wscript
-+++ b/wscript
-@@ -619,6 +619,8 @@ def build(bld):
-   http_parser.install_path = None
-   if bld.env["USE_DEBUG"]:
-     http_parser.clone("debug")
-+  if product_type_is_lib:
-+    http_parser.ccflags = '-fPIC'
-   ### src/native.cc
-   def make_macros(loc, content):
index 6df55b4ce84e77bd64bb6333f9c000d862eff587..00b4a804de86dfcad71d12a2f170407dac3ee7dd 100644 (file)
@@ -1,12 +1,25 @@
-diff --git a/wscript b/wscript
-index de5ee45..c14a5d6 100644
---- a/wscript
-+++ b/wscript
-@@ -761,6 +761,7 @@ def build(bld):
+diff -ur node-v0.4.2-o/wscript node-v0.4.2/wscript
+--- node-v0.4.2-o/wscript      2011-03-02 22:30:21.000000000 -0700
++++ node-v0.4.2/wscript        2011-03-02 22:32:27.000000000 -0700
+@@ -779,6 +779,7 @@
    node.add_objects = 'eio http_parser'
    if product_type_is_lib:
-     node.install_path = '${PREFIX}/lib'
+     node.install_path = '${LIBDIR}'
 +    node.vnum = "4.0.0" # FIXME: Should probably be based on VERSION
    else:
      node.install_path = '${PREFIX}/bin'
    node.chmod = 0755
+diff -ur node-v0.4.2-o/wscript.orig node-v0.4.2/wscript.orig
+--- node-v0.4.2-o/wscript.orig 2011-03-02 22:24:17.000000000 -0700
++++ node-v0.4.2/wscript.orig   2011-03-02 22:30:21.000000000 -0700
+@@ -436,7 +436,6 @@
+   # LFS
+   conf.env.append_value('CPPFLAGS',  '-D_LARGEFILE_SOURCE')
+   conf.env.append_value('CPPFLAGS',  '-D_FILE_OFFSET_BITS=64')
+-  conf.env.append_value('CPPFLAGS',  '-DEV_MULTIPLICITY=0')
+   # Makes select on windows support more than 64 FDs
+   if sys.platform.startswith("win32"):
+Only in node-v0.4.2: wscript.rej
+Only in node-v0.4.2: wscript.rej~
+Only in node-v0.4.2: wscript~
index 0bd478d003730c90e649e6b8a227736758ff11b3..70780a4bc1f13ed5cfa7f8fa92c0a269df38a530 100644 (file)
@@ -1,17 +1,15 @@
 
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.4.1
+Version:       0.4.2
 Release:       0
 License:       BSD
 Group:         Libraries
 URL:           http://nodejs.org/
 Source0:       http://nodejs.org/dist/node-v%{version}.tar.gz
-# Source0-md5: 9566bdbd05c18cc2bbe1fa0fba60dd0a
+# Source0-md5: de4754e23bb382172bc3bbbc288fb884
 Patch0:                %{name}-ev-multiplicity.patch
-Patch1:                %{name}-sharedlib.patch
 Patch2:                %{name}-soname.patch
-Patch3:                %{name}-libdir.patch
 BuildRequires: c-ares-devel
 BuildRequires: c-ares-devel >= 1.7.4
 BuildRequires: gcc >= 5:4.0
@@ -25,6 +23,8 @@ BuildRequires:        waf
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define _plainlibdir %{_prefix}/lib
+
 %description
 Node's goal is to provide an easy way to build scalable network
 programs. In the above example, the two second delay does not prevent
@@ -47,9 +47,7 @@ Development headers for nodejs.
 %prep
 %setup -q -n node-v%{version}
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
-%patch3 -p0
 
 %build
 # build library
@@ -80,7 +78,7 @@ $CC -o node -Isrc src/node_main.cc -lnode -Lbuild/default
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}/node/libraries,%{_libdir}/waf/wafadmin/Tools}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}/node/libraries,%{_plainlibdir}/waf/wafadmin/Tools}
 
 export PYTHONPATH=tools
 %waf install \
@@ -90,7 +88,7 @@ export PYTHONPATH=tools
 install node $RPM_BUILD_ROOT%{_bindir}/node
 
 cp -a lib/*.js $RPM_BUILD_ROOT%{_libdir}/node/libraries
-cp tools/wafadmin/Tools/node_addon.py $RPM_BUILD_ROOT%{_libdir}/waf/wafadmin/Tools
+cp tools/wafadmin/Tools/node_addon.py $RPM_BUILD_ROOT%{_plainlibdir}/waf/wafadmin/Tools
 
 rm $RPM_BUILD_ROOT%{_bindir}/node-waf
 # ? really required?
@@ -117,5 +115,5 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/node
 %attr(755,root,root) %{_bindir}/node-waf
 %{_libdir}/libnode.so
-%{_libdir}/waf/wafadmin/Tools/node_addon.py
+%{_plainlibdir}/waf/wafadmin/Tools/node_addon.py
 %{_libdir}/pkgconfig/nodejs.pc
This page took 0.038459 seconds and 4 git commands to generate.