]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
- up to 0.6.6 auto/th/nodejs-0_6_6-1
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 19 Dec 2011 12:01:02 +0000 (12:01 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nodejs-lib64path.patch -> 1.1
    nodejs-libpath.patch -> 1.1
    nodejs.spec -> 1.25

nodejs-lib64path.patch [new file with mode: 0644]
nodejs-libpath.patch [new file with mode: 0644]
nodejs.spec

diff --git a/nodejs-lib64path.patch b/nodejs-lib64path.patch
new file mode 100644 (file)
index 0000000..9bdc86e
--- /dev/null
@@ -0,0 +1,11 @@
+--- ../node-v0.4.11.original/lib/module.js     2011-08-17 18:18:10.000000000 -0700
++++ ./lib/module.js    2011-08-22 14:37:06.590597180 -0700
+@@ -422,7 +422,7 @@
+ };
+ Module._initPaths = function() {
+-  var paths = [path.resolve(process.execPath, '..', '..', 'lib', 'node')];
++  var paths = ["/usr/lib/node", "/usr/lib64/node"];
+   if (process.env['HOME']) {
+     paths.unshift(path.resolve(process.env['HOME'], '.node_libraries'));
diff --git a/nodejs-libpath.patch b/nodejs-libpath.patch
new file mode 100644 (file)
index 0000000..81cf518
--- /dev/null
@@ -0,0 +1,11 @@
+--- ../node-v0.4.11.original/lib/module.js     2011-08-17 18:18:10.000000000 -0700
++++ ./lib/module.js    2011-08-22 14:36:11.662283878 -0700
+@@ -422,7 +422,7 @@
+ };
+ Module._initPaths = function() {
+-  var paths = [path.resolve(process.execPath, '..', '..', 'lib', 'node')];
++  var paths = ["/usr/lib/node"];
+   if (process.env['HOME']) {
+     paths.unshift(path.resolve(process.env['HOME'], '.node_libraries'));
index 8112d5ef946992a0047cc5726336be9024e23fa8..5b19b134ddde05e43db0a1adfa1f2bd088e9af38 100644 (file)
@@ -1,23 +1,26 @@
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.4.12
-Release:       2
+Version:       0.6.6
+Release:       1
 License:       BSD
 Group:         Libraries
 URL:           http://nodejs.org/
-Source0:       http://nodejs.org/dist/node-v%{version}.tar.gz
-# Source0-md5: a6375eaa43db5356bf443e25b828ae16
-Patch0:                %{name}-ev-multiplicity.patch
+Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
+# Source0-md5: 43836ebd6e8e9059c4584e3b5ab50009
 Patch1:                %{name}-soname.patch
-BuildRequires: c-ares-devel
+# force node to use /usr/lib/node as the systemwide module directory
+Patch2:                %{name}-libpath.patch
+# use /usr/lib64/node as an arch-specific module dir when appropriate
+Patch3:                %{name}-lib64path.patch
 BuildRequires: c-ares-devel >= 1.7.4
 BuildRequires: gcc >= 5:4.0
 BuildRequires: libeio-devel
 BuildRequires: libev-devel >= 4.0.0
 BuildRequires: libstdc++-devel
-BuildRequires: python
+BuildRequires: python >= 1:2.5.2
+BuildRequires: python-jsmin
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: v8-devel >= 3.1.5
+BuildRequires: v8-devel >= 3.6
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -39,15 +42,44 @@ Requires:   %{name} = %{version}-%{release}
 %description devel
 Development headers for nodejs.
 
+%package doc
+Summary:       Evented I/O for V8 JavaScript - documentation
+Group:         Documentation
+
+%description doc
+Node.js is a server-side JavaScript environment that uses an
+asynchronous event-driven model. Node's goal is to provide an easy way
+to build scalable network programs.
+
+This package contains the documentation for nodejs.
+
+%package waf
+Summary:       Evented I/O for V8 JavaScript - customized WAF build system
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description waf
+Node.js is a server-side JavaScript environment that uses an
+asynchronous event-driven model. Node's goal is to provide an easy way
+to build scalable network programs.
+
+This package contains the customized version of the WAF build system
+used by Node.js and many of its modules.
+
 %prep
 %setup -q -n node-v%{version}
-%patch0 -p1
 %patch1 -p1
+%if %{_lib} == "lib64"
+%patch3 -p1
+%else
+%patch2 -p1
+%endif
 
 %build
+%undefine      with_ccache
 # build library
-CFLAGS="%{rpmcflags}"
-CXXFLAGS="%{rpmcxxflags}"
+CFLAGS="%{rpmcflags} -fPIC"
+CXXFLAGS="%{rpmcxxflags} -fPIC"
 LDFLAGS="%{rpmcflags}"
 %if "%{pld_release}" == "ac"
 CC="%{__cc}4"
@@ -58,29 +90,60 @@ CXX="%{__cxx}"
 %endif
 export CFLAGS LDFLAGS CXXFLAGS CC CXX
 
+# NOT autoconf so dont use macro
 export PYTHONPATH=tools
-%{__python} tools/waf-light configure \
-       --shared-v8 \
+./configure \
        --shared-cares \
-       --shared-libev \
+       --shared-v8 \
+       --shared-zlib \
        --libdir=%{_libdir} \
        --prefix=%{_prefix}
 
-%{__python} tools/waf-light build \
-       --product-type='cshlib'
+%{__make} dynamiclib
+%{__make} program
 
-$CC -o build/default/node -Isrc src/node_main.cc -lnode -Lbuild/default
+# relink with shared lib
+$CC -o out/Release/node src/node_main.cc -Isrc -Ideps/uv/include -lnode -Lout/Release
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+# install shared lib
 export PYTHONPATH=tools
 %{__python} tools/waf-light install \
        --product-type=cshlib \
        --destdir=$RPM_BUILD_ROOT
 
-install -p build/default/node $RPM_BUILD_ROOT%{_bindir}/node
+# create pkgconfig
+install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
+version=%{version}
+prefix=/usr
+libdir=${prefix}/lib
+includedir=${prefix}/include/node
+
+Name: nodejs
+Description: Evented I/O for V8 JavaScript.
+Version: ${version}
+Cflags: -I${includedir}
+EOF
 
-chmod a+x $RPM_BUILD_ROOT%{_libdir}/*.so*
+# install documentation
+install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
+cp -a doc/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
+cd $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
+install -d api
+mv html/api/*.markdown api
+mv html/api/api/* html/api
+rm -rf html/api/api
+cd -
+
+# remove NPM; it's buggy in 0.6.3
+# but really we package npm from separate spec
+rm -rf $RPM_BUILD_ROOT%{_libdir}/node_modules
+rm $RPM_BUILD_ROOT%{_bindir}/npm
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -90,7 +153,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog LICENSE
+%doc README.md AUTHORS ChangeLog LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
 %ghost %{_libdir}/libnode.so.4
@@ -101,9 +164,16 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libnode.so
 %{_includedir}/node
+%{_pkgconfigdir}/nodejs.pc
+
+%files doc
+%defattr(644,root,root,755)
+%doc %{_docdir}/%{name}-doc-%{version}
+
+%files waf
+%defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/node-waf
 %dir %{_libdir}/node/wafadmin
 %dir %{_libdir}/node/wafadmin/Tools
 %{_libdir}/node/wafadmin/*.py
 %{_libdir}/node/wafadmin/Tools/*.py
-%{_pkgconfigdir}/nodejs.pc
This page took 0.102708 seconds and 4 git commands to generate.