]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
upstream (v8) fix for gcc 13
authorJan Palus <atler@pld-linux.org>
Fri, 30 Jun 2023 14:34:21 +0000 (16:34 +0200)
committerJan Palus <atler@pld-linux.org>
Fri, 30 Jun 2023 14:34:21 +0000 (16:34 +0200)
from https://chromium-review.googlesource.com/c/v8/v8/+/3934140

gcc13.patch [new file with mode: 0644]
nodejs.spec

diff --git a/gcc13.patch b/gcc13.patch
new file mode 100644 (file)
index 0000000..2732acc
--- /dev/null
@@ -0,0 +1,41 @@
+From c2792e58035fcbaa16d0cb70998852fbeb5df4cc Mon Sep 17 00:00:00 2001
+From: WANG Xuerui <git@xen0n.name>
+Date: Fri, 07 Oct 2022 00:23:49 +0800
+Subject: [PATCH] [base] Fix build with gcc-13
+
+See https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes.
+
+Also see Gentoo Linux bug report: https://bugs.gentoo.org/865981
+
+Change-Id: I421f396b02ba37e12ee70048ee33e034f8113566
+Reviewed-on: https://chromium-review.googlesource.com/c/v8/v8/+/3934140
+Reviewed-by: Clemens Backes <clemensb@chromium.org>
+Reviewed-by: Simon Zünd <szuend@chromium.org>
+Commit-Queue: Clemens Backes <clemensb@chromium.org>
+Cr-Commit-Position: refs/heads/main@{#83587}
+---
+
+diff --git a/src/base/logging.h b/src/base/logging.h
+index 08db24a..38be165 100644
+--- a/src/base/logging.h
++++ b/src/base/logging.h
+@@ -5,6 +5,7 @@
+ #ifndef V8_BASE_LOGGING_H_
+ #define V8_BASE_LOGGING_H_
++#include <cstdint>
+ #include <cstring>
+ #include <sstream>
+ #include <string>
+diff --git a/src/inspector/v8-string-conversions.h b/src/inspector/v8-string-conversions.h
+index c1d69c1..eb33c68 100644
+--- a/src/inspector/v8-string-conversions.h
++++ b/src/inspector/v8-string-conversions.h
+@@ -5,6 +5,7 @@
+ #ifndef V8_INSPECTOR_V8_STRING_CONVERSIONS_H_
+ #define V8_INSPECTOR_V8_STRING_CONVERSIONS_H_
++#include <cstdint>
+ #include <string>
+ // Conversion routines between UT8 and UTF16, used by string-16.{h,cc}. You may
index c1f49560cd03697bbc697cbd37b3ee446617d1b7..a5c065d8ddbfe722dced9afc9fe18d0e3f0efed8 100644 (file)
@@ -42,6 +42,7 @@ Patch2:               %{name}-libpath.patch
 Patch3:                %{name}-lib64path.patch
 Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
 Patch5:                0002-Install-both-binaries-and-use-libdir.patch
+Patch6:                gcc13.patch
 URL:           https://nodejs.org/
 BuildRequires: c-ares-devel >= 1.17.2
 BuildRequires: gcc >= 6:6.3
@@ -162,6 +163,7 @@ Sondy systemtap/dtrace dla Node.js.
 %endif
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1 -d deps/v8
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
 
This page took 0.175687 seconds and 4 git commands to generate.