]> git.pld-linux.org Git - packages/nodejs.git/commitdiff
- disable system uv (does not build with current libuv)
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 1 Jan 2016 16:33:34 +0000 (17:33 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 1 Jan 2016 16:33:34 +0000 (17:33 +0100)
nodejs.spec
uv-fpic.patch

index 75a95d34844b5000c0fa3d216e7834bb8e9eab3a..42c8830d455650abecdafc68e8571107e9e71478 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Conditional build:
 %bcond_without system_v8       # system v8
 #
 # Conditional build:
 %bcond_without system_v8       # system v8
-%bcond_without system_uv       # system uv
+%bcond_with    system_uv       # system uv
 %bcond_without shared  # build libnode.so shared library
 
 # NOTES:
 %bcond_without shared  # build libnode.so shared library
 
 # NOTES:
index 339f4be1db7f2e0c27608d22772cd40ad48999d5..6c26e78fac21b9a51e3d9545c7a443385ac6a0b0 100644 (file)
@@ -8,3 +8,13 @@
  
  OBJS += src/unix/core.o
  OBJS += src/unix/dl.o
  
  OBJS += src/unix/core.o
  OBJS += src/unix/dl.o
+--- node-v0.10.40/deps/uv/uv.gyp~      2015-07-09 23:19:36.000000000 +0200
++++ node-v0.10.40/deps/uv/uv.gyp       2016-01-01 17:30:58.139553119 +0100
+@@ -126,6 +126,7 @@
+             '-Wall',
+             '-Wextra',
+             '-Wno-unused-parameter',
++            '-fPIC',
+           ],
+           'sources': [
+             'include/uv-private/uv-unix.h',
This page took 0.069919 seconds and 4 git commands to generate.