]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
no system c-ares support
[packages/nodejs.git] / nodejs.spec
index e75c332e31b00e6a2df426d3fe6d190b1c256c80..e19171cc6f562734635b73b4d71731dd8ce89aa2 100644 (file)
@@ -1,30 +1,50 @@
+# TODO
+# - unpackaged files
+#   /usr/share/doc/node/gdbinit
+#   /usr/share/systemtap/tapset/node.stp
+
+# Conditional build:
+%bcond_without system_uv       # system uv
+%bcond_with    shared  # build libnode.so shared library
+
+# NOTES:
+# - https://nodejs.org/en/download/releases/
+
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.10.3
-Release:       2
+Version:       4.2.3
+Release:       0.1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 4daca92618515708a4631e98a8e8c779
+Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
+# Source0-md5: 529a8abd4ca5a2225636767d3f14c382
 Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
+Patch4:                %{name}-use-system-certs.patch
 Patch5:                uv-fpic.patch
-URL:           http://www.nodejs.org/
+URL:           https://nodejs.org/
 BuildRequires: gcc >= 5:4.0
+BuildRequires: http-parser-devel >= 2.5.0
 BuildRequires: libstdc++-devel
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.6.0}
+BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5.2
 BuildRequires: python-jsmin
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
-BuildRequires: v8-devel >= 3.15.11.10
-BuildConflicts: eio
+BuildRequires: sed >= 4.0
+BuildRequires: zlib-devel
+Requires:      ca-certificates
 Obsoletes:     nodejs-waf
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                sover   %(echo %{version} | cut -d. -f2)
+
 %description
 Node.js is a platform built on Chrome's JavaScript runtime for easily
 building fast, scalable network applications. Node.js uses an
@@ -37,8 +57,11 @@ Summary:     Development headers for nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gcc
+Requires:      http-parser-devel >= 2.5.0
 Requires:      libstdc++-devel
-Requires:      v8-devel
+%{?with_system_uv:Requires:    libuv-devel >= 1.6.0}
+Requires:      openssl-devel
+Requires:      zlib-devel
 
 %description devel
 Development headers for nodejs.
@@ -46,6 +69,9 @@ Development headers for nodejs.
 %package doc
 Summary:       Evented I/O for V8 JavaScript - documentation
 Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -56,60 +82,59 @@ This package contains the documentation for nodejs.
 
 %prep
 %setup -q -n node-v%{version}
-%patch1 -p1
+%{?with_shared:%patch1 -p1}
+#%patch1 -p1
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
-%patch5 -p1
+%patch4 -p1
+#%{?with_system_uv:%patch5 -p1}
 
-%build
-# Error: V8 doesn't like ccache. Please set your CC env var to 'gcc'
-CC=${CC#ccache }
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
+
+rm -r deps/npm
+rm -r deps/http_parser
+rm -r deps/openssl
+%{?with_system_uv:rm -r deps/uv}
+rm -r deps/zlib
 
-# NOT autoconf so dont use macro
-export PYTHONPATH=tools
+%build
+# CC used only to detect if CC is clang, not used for compiling
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-v8 \
        --shared-zlib \
        --shared-openssl \
+       %{?0:--shared-cares} \
+       %{?with_system_uv:--shared-libuv} \
+       --shared-http-parser \
        --without-npm \
+       --without-dtrace \
        --prefix=%{_prefix}
 
-%{__make} -C out \
-       BUILDTYPE=Release \
-       V=1 \
-       CFLAGS.host="%{rpmcflags} -fPIC" \
-       CXXFLAGS.host="%{rpmcppflags} -fPIC" \
-       LDFLAGS.host="%{rpmcflags}" \
-       CFLAGS.target="%{rpmcflags} -fPIC" \
-       CXXFLAGS.target="%{rpmcppflags} -fPIC" \
-       LDFLAGS.target="%{rpmcflags}" \
-       CC.host="%{__cc}" \
-       CXX.host="%{__cxx}" \
-       CC.target="%{__cc}" \
-       CXX.target="%{__cxx}"
+# add LFS defines from libuv (RHBZ#892601)
+# CXXFLAGS must be exported, as it is needed for make, not gyp
+CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
+LDFLAGS="%{rpmldflags}" \
+%{__make} -C out V=1 BUILDTYPE=Release
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} justinstall \
-       DESTDIR=$RPM_BUILD_ROOT \
-       LIBDIR=%{_lib}
-
-# no dtrace on linux
-%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/lib/dtrace/node.d
+%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
 
-lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*)
+%if %{with shared}
+lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
+%endif
 
 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
 
 install -d $RPM_BUILD_ROOT%{_includedir}/node
 cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
-cp -p deps/uv/include/uv.h $RPM_BUILD_ROOT%{_includedir}/node
-cp -a deps/uv/include/uv-private $RPM_BUILD_ROOT%{_includedir}/node
 
 # install for node-gyp
 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
@@ -148,16 +173,20 @@ rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with shared}
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
+%endif
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS ChangeLog LICENSE
+%doc README.md AUTHORS CHANGELOG.md ROADMAP.md LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
+%if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
 %ghost %{_libdir}/libnode.so.10
+%endif
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
 %endif
@@ -168,7 +197,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%if %{with shared}
 %{_libdir}/libnode.so
+%endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
 %{_usrsrc}/%{name}
This page took 0.061077 seconds and 4 git commands to generate.