]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
no system c-ares support
[packages/nodejs.git] / nodejs.spec
index 745fbc9fd1ad743d908a8470fac9e9010dfc2fac..e19171cc6f562734635b73b4d71731dd8ce89aa2 100644 (file)
@@ -1,31 +1,50 @@
+# TODO
+# - unpackaged files
+#   /usr/share/doc/node/gdbinit
+#   /usr/share/systemtap/tapset/node.stp
+
+# Conditional build:
+%bcond_without system_uv       # system uv
+%bcond_with    shared  # build libnode.so shared library
+
+# NOTES:
+# - https://nodejs.org/en/download/releases/
+
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.6.21
-Release:       1
-License:       BSD and MIT and ASL 2.0 and GPLv3
+Version:       4.2.3
+Release:       0.1
+License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-URL:           http://www.nodejs.org/
-Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 0da985a0bf820400af92363b9f453fe4
-Patch1:                %{name}-soname.patch
+Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
+# Source0-md5: 529a8abd4ca5a2225636767d3f14c382
+Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
+Patch4:                %{name}-use-system-certs.patch
 Patch5:                uv-fpic.patch
-BuildRequires: c-ares-devel >= 1.7.4
+URL:           https://nodejs.org/
 BuildRequires: gcc >= 5:4.0
-BuildRequires: libeio-devel
-BuildRequires: libev-devel >= 4.0.0
+BuildRequires: http-parser-devel >= 2.5.0
 BuildRequires: libstdc++-devel
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.6.0}
+BuildRequires: openssl-devel >= 1.0.1
+BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5.2
 BuildRequires: python-jsmin
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
-BuildRequires: v8-devel >= 3.6
+BuildRequires: sed >= 4.0
+BuildRequires: zlib-devel
+Requires:      ca-certificates
+Obsoletes:     nodejs-waf
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                sover   %(echo %{version} | cut -d. -f2)
+
 %description
 Node.js is a platform built on Chrome's JavaScript runtime for easily
 building fast, scalable network applications. Node.js uses an
@@ -37,10 +56,12 @@ across distributed devices.
 Summary:       Development headers for nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      %{name}-waf = %{version}-%{release}
 Requires:      gcc
+Requires:      http-parser-devel >= 2.5.0
 Requires:      libstdc++-devel
-Requires:      v8-devel
+%{?with_system_uv:Requires:    libuv-devel >= 1.6.0}
+Requires:      openssl-devel
+Requires:      zlib-devel
 
 %description devel
 Development headers for nodejs.
@@ -48,6 +69,9 @@ Development headers for nodejs.
 %package doc
 Summary:       Evented I/O for V8 JavaScript - documentation
 Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -56,73 +80,67 @@ to build scalable network programs.
 
 This package contains the documentation for nodejs.
 
-%package waf
-Summary:       Evented I/O for V8 JavaScript - customized WAF build system
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description waf
-Node.js is a server-side JavaScript environment that uses an
-asynchronous event-driven model. Node's goal is to provide an easy way
-to build scalable network programs.
-
-This package contains the customized version of the WAF build system
-used by Node.js and many of its modules.
-
 %prep
 %setup -q -n node-v%{version}
-%patch1 -p1
+%{?with_shared:%patch1 -p1}
+#%patch1 -p1
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
-%patch5 -p1
+%patch4 -p1
+#%{?with_system_uv:%patch5 -p1}
 
-# fix #!/usr/bin/env python -> #!/usr/bin/python:
-grep -rl 'bin/env python' tools | xargs %{__sed} -i -e '1s,^#!.*python,#!%{__python},'
-
-%build
-CFLAGS="%{rpmcflags} -fPIC"
-CPPFLAGS="%{rpmcppflags} -fPIC"
-CXXFLAGS="%{rpmcxxflags} -fPIC"
-LDFLAGS="%{rpmcflags}"
-%if "%{pld_release}" == "ac"
-CC="%{__cc}4"
-CXX="%{__cxx}4"
-%else
-CC="%{__cc}"
-CXX="%{__cxx}"
-%endif
-export CFLAGS LDFLAGS CXXFLAGS CC CXX LINKFLAGS_UV
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-# Error: V8 doesn't like ccache. Please set your CC env var to 'gcc'
-CC=${CC#ccache }
+rm -r deps/npm
+rm -r deps/http_parser
+rm -r deps/openssl
+%{?with_system_uv:rm -r deps/uv}
+rm -r deps/zlib
 
-# NOT autoconf so dont use macro
-export PYTHONPATH=tools
+%build
+# CC used only to detect if CC is clang, not used for compiling
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-cares \
-       --shared-v8 \
        --shared-zlib \
+       --shared-openssl \
+       %{?0:--shared-cares} \
+       %{?with_system_uv:--shared-libuv} \
+       --shared-http-parser \
        --without-npm \
-       --libdir=%{_libdir} \
+       --without-dtrace \
        --prefix=%{_prefix}
 
-# build library
-%{__make} dynamiclib
-%{__make} program
-
-# relink with shared lib
-$CC -o out/Release/node src/node_main.cc -Isrc -Ideps/uv/include -lnode -Lout/Release
+# add LFS defines from libuv (RHBZ#892601)
+# CXXFLAGS must be exported, as it is needed for make, not gyp
+CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
+LDFLAGS="%{rpmldflags}" \
+%{__make} -C out V=1 BUILDTYPE=Release
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
+
+%if %{with shared}
+lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
+ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
+ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
+%endif
 
 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
 
+install -d $RPM_BUILD_ROOT%{_includedir}/node
+cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
+
+# install for node-gyp
+install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
+
 # for compat of fedora derivered scripts (shebangs)
 ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
 
@@ -132,14 +150,6 @@ install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
 # default searchpaths
 install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
 
-# install shared lib
-export PYTHONPATH=tools
-%{__python} tools/waf-light install \
-       --product-type=cshlib \
-       --destdir=$RPM_BUILD_ROOT
-
-chmod a+x $RPM_BUILD_ROOT%{_libdir}/*.so*
-
 # create pkgconfig
 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
@@ -154,11 +164,6 @@ Version: ${version}
 Cflags: -I${includedir}
 EOF
 
-%py_ocomp $RPM_BUILD_ROOT%{_libdir}/node/wafadmin
-%py_comp $RPM_BUILD_ROOT%{_libdir}/node/wafadmin
-# TODO: check it first
-#%%py_postclean %{_libdir}/node/wafadmin
-
 # install documentation
 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
 cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
@@ -168,16 +173,20 @@ rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%if %{with shared}
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
+%endif
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS ChangeLog LICENSE
+%doc README.md AUTHORS CHANGELOG.md ROADMAP.md LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
+%if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.6
+%ghost %{_libdir}/libnode.so.10
+%endif
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
 %endif
@@ -188,20 +197,13 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%if %{with shared}
 %{_libdir}/libnode.so
+%endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
+%{_usrsrc}/%{name}
 
 %files doc
 %defattr(644,root,root,755)
 %doc %{_docdir}/%{name}-doc-%{version}
-
-%files waf
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/node-waf
-%dir %{_libdir}/node/wafadmin
-%dir %{_libdir}/node/wafadmin/Tools
-%{_libdir}/node/wafadmin/*.py[co]
-%{_libdir}/node/wafadmin/*.py
-%{_libdir}/node/wafadmin/Tools/*.py
-%{_libdir}/node/wafadmin/Tools/*.py[co]
This page took 0.104884 seconds and 4 git commands to generate.