]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
- package systemtap probes
[packages/nodejs.git] / nodejs.spec
index fd49c9f683ef9e6e21994f81b8fe24b6724c8e69..d61f710e88d72d1a07cc7cd8f8b9442ed4cf24af 100644 (file)
@@ -1,20 +1,31 @@
-#
+# TODO
+# - unpackaged files
+#   /usr/share/doc/node/gdbinit
+
 # Conditional build:
-%bcond_with    system_v8       # system v8
-%bcond_with    system_uv       # system uv
-%bcond_with    shared  # build libnode.so shared library
+%bcond_without system_uv       # system uv
+%bcond_with    shared          # build libnode.so shared library
 
 # NOTES:
 # - https://nodejs.org/en/download/releases/
 
+# NODE_MODULE_VERSION refers to the ABI (application binary interface) version
+# number of Node.js, used to determine which versions of Node.js compiled C++
+# add-on binaries can be loaded in to without needing to be re-compiled. It
+# used to be stored as hex value in earlier versions, but is now represented as
+# an integer.
+%define                node_module_version     48
 Summary:       Asynchronous JavaScript Engine
+Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
-Version:       4.2.1
-Release:       0.1
+# 6.9 is LTS, Active LTS: 2018-04-18, EOL: 2019-04-18
+# https://github.com/nodejs/LTS
+Version:       6.9.4
+Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 41d2b9fb5220af3fd98dd70fb33a2a10
+# Source0-md5: 3795199b5950b25179248847b1a5fc86
 Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
@@ -22,33 +33,30 @@ Patch2:             %{name}-libpath.patch
 Patch3:                %{name}-lib64path.patch
 Patch4:                %{name}-use-system-certs.patch
 Patch5:                uv-fpic.patch
-# The invalid UTF8 fix has been reverted since this breaks v8 API, which cannot
-# be done in a stable distribution release.  This build of nodejs will behave as
-# if NODE_INVALID_UTF8 was set.  For more information on the implications, see:
-# http://blog.nodejs.org/2014/06/16/openssl-and-breaking-utf-8-change/
-Patch6:                %{name}-revert-utf8-v8.patch
-Patch7:                %{name}-revert-utf8-node.patch
 URL:           https://nodejs.org/
-BuildRequires: c-ares-devel
-BuildRequires: gcc >= 5:4.0
-BuildRequires: http-parser-devel >= 2.0
-BuildRequires: libstdc++-devel
-%{?with_system_uv:BuildRequires:       libuv-devel >= 0.10}
-BuildRequires: openssl-devel
+BuildRequires: gcc >= 6:4.8
+BuildRequires: http-parser-devel >= 2.7.0
+BuildRequires: libstdc++-devel >= 6:4.8
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.6.0}
+BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
-BuildRequires: python >= 1:2.5.2
+BuildRequires: python >= 1:2.7
 BuildRequires: python-jsmin
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
-%{?with_system_v8:BuildRequires:       v8-devel >= 3.15.11.18-2}
 BuildRequires: zlib-devel
 Requires:      ca-certificates
+Provides:      nodejs(engine) = %{version}
+Provides:      nodejs(module-version) = %{node_module_version}
 Obsoletes:     nodejs-waf
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                sover   %(echo %{version} | cut -d. -f2)
+# add macro, so adapter won't replace it back literal
+%define                doc_ver %{version}
 
 %description
 Node.js is a platform built on Chrome's JavaScript runtime for easily
@@ -57,25 +65,38 @@ event-driven, non-blocking I/O model that makes it lightweight and
 efficient, perfect for data-intensive real-time applications that run
 across distributed devices.
 
+%description -l pl.UTF-8
+Node.js to platforma zbudowana w opacriu o silnik JavaScriptu
+przeglądarki Chrome, służąca do tworzenia szybkich, skalowalnych
+aplikacji sieciowych. Node.js wykorzystuje nieblokujący model
+wejścia/wyjścia sterowany zdarzeniami, dzięki czemu jest lekki i
+wydajny, dobrze nadający się do aplikacji przetwarzających duże
+ilości danych w czasie rzeczywistym, uruchamianych na rozproszonych
+urządzeniach.
+
 %package devel
 Summary:       Development headers for nodejs
+Summary(pl.UTF-8):     Pliki nagłówkowe nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      c-ares-devel
 Requires:      gcc
-Requires:      http-parser-devel
+Requires:      http-parser-devel >= 2.5.0
 Requires:      libstdc++-devel
-%{?with_system_uv:Requires:    libuv-devel}
+%{?with_system_uv:Requires:    libuv-devel >= 1.6.0}
 Requires:      openssl-devel
-%{?with_system_v8:Requires:    v8-devel}
 Requires:      zlib-devel
 
 %description devel
 Development headers for nodejs.
 
+%description devel -l pl.UTF-8
+Pliki nagłówkowe nodejs.
+
 %package doc
-Summary:       Evented I/O for V8 JavaScript - documentation
+Summary:       Documentation for Node.js engine
+Summary(pl.UTF-8):     Dokumentacja silnika Node.js
 Group:         Documentation
+URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
 %if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
 %endif
@@ -85,7 +106,28 @@ Node.js is a server-side JavaScript environment that uses an
 asynchronous event-driven model. Node's goal is to provide an easy way
 to build scalable network programs.
 
-This package contains the documentation for nodejs.
+This package contains the documentation for Node.js.
+
+%description doc -l pl.UTF-8
+Node.js to serwerowe środowisko JavaScriptu wykorzystujące
+asynchroniczny model sterowany zdarzeniami. Celem Node jest
+zapewnienie łatwego sposobu tworzenia skalowalnych programów
+sieciowych.
+
+Ten pakiet zawiera dokumentację Node.js.
+
+%package -n systemtap-nodejs
+Summary:       systemtap/dtrace probes for Node.js
+Summary(pl.UTF-8):     Sondy systemtap/dtrace dla Node.js
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+Requires:      systemtap-client
+
+%description -n systemtap-nodejs
+systemtap/dtrace probes for Node.js.
+
+%description -n systemtap-nodejs -l pl.UTF-8
+Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
@@ -97,32 +139,31 @@ This package contains the documentation for nodejs.
 %patch2 -p1
 %endif
 %patch4 -p1
+%{__rm} src/node_root_certs.h
 #%{?with_system_uv:%patch5 -p1}
-#%patch6 -p1
-#%patch7 -p1
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-rm -r deps/npm
-#rm -r deps/cares
-rm -r deps/http_parser
-rm -r deps/openssl
-%{?with_system_uv:rm -r deps/uv}
-%{?with_system_v8:rm -r deps/v8}
-rm -r deps/zlib
+%{__rm} -r deps/npm
+%{__rm} -r deps/http_parser
+%{__rm} -r deps/openssl
+%{?with_system_uv:%{__rm} -r deps/uv}
+%{__rm} -r deps/zlib
 
 %build
+ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
+test "$ver" = "%{node_module_version}"
+
 # CC used only to detect if CC is clang, not used for compiling
 CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       %{?with_system_v8:--shared-v8} \
-       --shared-zlib \
-       --shared-openssl \
        %{?0:--shared-cares} \
-       %{?with_system_uv:--shared-libuv} \
+       --shared-openssl \
        --shared-http-parser \
+       %{?with_system_uv:--shared-libuv} \
+       --shared-zlib \
        --without-npm \
        --without-dtrace \
        --prefix=%{_prefix}
@@ -131,11 +172,14 @@ GYP_DEFINES="soname_version=%{sover}" \
 # CXXFLAGS must be exported, as it is needed for make, not gyp
 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
 LDFLAGS="%{rpmldflags}" \
-%{__make} -C out V=1 BUILDTYPE=Release
+%{__make} -C out \
+       BUILDTYPE=Release \
+       V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_lib}"
+
+%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
 
 %if %{with shared}
 lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
@@ -179,8 +223,8 @@ EOF
 # install documentation
 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
 cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.markdown
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -192,12 +236,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS ChangeLog LICENSE
+%doc README.md AUTHORS CHANGELOG.md ROADMAP.md LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
 %if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.10
+%attr(755,root,root) %ghost %{_libdir}/libnode.so.10
 %endif
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
@@ -205,12 +249,12 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_prefix}/lib/node
 %dir %{_prefix}/lib/node_modules
 %{_mandir}/man1/node.1*
-%{_mandir}/man1/nodejs.1
+%{_mandir}/man1/nodejs.1*
 
 %files devel
 %defattr(644,root,root,755)
 %if %{with shared}
-%{_libdir}/libnode.so
+%attr(755,root,root) %{_libdir}/libnode.so
 %endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
@@ -219,3 +263,7 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 %doc %{_docdir}/%{name}-doc-%{version}
+
+%files -n systemtap-nodejs
+%defattr(644,root,root,755)
+%{_datadir}/systemtap/tapset/node.stp
This page took 0.084871 seconds and 4 git commands to generate.