]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
- openssl 1.0.2g rebuild
[packages/nodejs.git] / nodejs.spec
index 53f2a899a8de1f776bdbd985ee72ca0eead6e07b..a249b4b78db5a67b03411e3a63d7d492b5500117 100644 (file)
@@ -1,30 +1,61 @@
+#
+# Conditional build:
+%bcond_without system_v8       # system v8
+%bcond_with    system_uv       # system uv
+%bcond_without shared  # build libnode.so shared library
+
+# NOTES:
+# - https://nodejs.org/en/download/releases/
+
+# see "Modules" column in https://nodejs.org/en/download/releases/
+%define                node_module_version     11
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.6.15
-Release:       1
-License:       BSD and MIT and ASL 2.0 and GPLv3
+Version:       0.10.41
+Release:       2
+License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-URL:           http://www.nodejs.org/
-Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 852cfb1ed8125a4cdba456446d869d19
-Patch1:                %{name}-soname.patch
+Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
+# Source0-md5: 23822b192b74640551a20b680c150273
+Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
-BuildRequires: c-ares-devel >= 1.7.4
+Patch4:                %{name}-use-system-certs.patch
+Patch5:                uv-fpic.patch
+# The invalid UTF8 fix has been reverted since this breaks v8 API, which cannot
+# be done in a stable distribution release.  This build of nodejs will behave as
+# if NODE_INVALID_UTF8 was set.  For more information on the implications, see:
+# http://blog.nodejs.org/2014/06/16/openssl-and-breaking-utf-8-change/
+Patch6:                %{name}-revert-utf8-v8.patch
+Patch7:                %{name}-revert-utf8-node.patch
+URL:           https://nodejs.org/
+BuildRequires: c-ares-devel
 BuildRequires: gcc >= 5:4.0
-BuildRequires: libeio-devel
-BuildRequires: libev-devel >= 4.0.0
+BuildRequires: http-parser-devel >= 2.0
 BuildRequires: libstdc++-devel
+%{?with_system_uv:BuildRequires:       libuv-devel >= 0.10}
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5.2
 BuildRequires: python-jsmin
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
-BuildRequires: v8-devel >= 3.6
+BuildRequires: sed >= 4.0
+%{?with_system_v8:BuildRequires:       v8-devel >= 3.15.11.18-2}
+BuildRequires: zlib-devel
+Requires:      ca-certificates
+Provides:      nodejs(engine) = %{version}
+Provides:      nodejs(module-version) = %{node_module_version}
+Obsoletes:     nodejs-waf
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                sover   %(echo %{version} | cut -d. -f2)
+# add macro, so adapter won't replace it back literal
+%define                doc_ver %{version}
+
 %description
 Node.js is a platform built on Chrome's JavaScript runtime for easily
 building fast, scalable network applications. Node.js uses an
@@ -36,10 +67,14 @@ across distributed devices.
 Summary:       Development headers for nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
-Requires:      %{name}-waf = %{version}-%{release}
+Requires:      c-ares-devel
 Requires:      gcc
+Requires:      http-parser-devel
 Requires:      libstdc++-devel
-Requires:      v8-devel
+%{?with_system_uv:Requires:    libuv-devel}
+Requires:      openssl-devel
+%{?with_system_v8:Requires:    v8-devel}
+Requires:      zlib-devel
 
 %description devel
 Development headers for nodejs.
@@ -47,6 +82,10 @@ Development headers for nodejs.
 %package doc
 Summary:       Evented I/O for V8 JavaScript - documentation
 Group:         Documentation
+URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -55,68 +94,76 @@ to build scalable network programs.
 
 This package contains the documentation for nodejs.
 
-%package waf
-Summary:       Evented I/O for V8 JavaScript - customized WAF build system
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description waf
-Node.js is a server-side JavaScript environment that uses an
-asynchronous event-driven model. Node's goal is to provide an easy way
-to build scalable network programs.
-
-This package contains the customized version of the WAF build system
-used by Node.js and many of its modules.
-
 %prep
 %setup -q -n node-v%{version}
-%patch1 -p1
+%{?with_shared:%patch1 -p1}
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
-# fix #!/usr/bin/env python -> #!/usr/bin/python:
-grep -rl 'bin/env python' tools | xargs %{__sed} -i -e '1s,^#!.*python,#!%{__python},'
-
-%build
-CFLAGS="%{rpmcflags} -fPIC"
-CXXFLAGS="%{rpmcxxflags} -fPIC"
-LDFLAGS="%{rpmcflags}"
-%if "%{pld_release}" == "ac"
-CC="%{__cc}4"
-CXX="%{__cxx}4"
-%else
-CC="%{__cc}"
-CXX="%{__cxx}"
-%endif
-export CFLAGS LDFLAGS CXXFLAGS CC CXX
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-# Error: V8 doesn't like ccache. Please set your CC env var to 'gcc'
-CC=${CC#ccache }
+rm -r deps/npm
+rm -r deps/cares
+rm -r deps/http_parser
+rm -r deps/openssl
+%{?with_system_uv:rm -r deps/uv}
+%{?with_system_v8:rm -r deps/v8}
+rm -r deps/zlib
 
-# NOT autoconf so dont use macro
-export PYTHONPATH=tools
+%build
+ver=$(awk '/#define NODE_MODULE_VERSION/{print $NF}' src/node.h)
+if [ $ver != %{node_module_version} ]; then
+       echo "Set %%define node_module_version to $ver and re-run."
+       exit 1
+fi
+
+# CC used only to detect if CC is clang, not used for compiling
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-cares \
-       --shared-v8 \
+       %{?with_system_v8:--shared-v8} \
        --shared-zlib \
+       --shared-openssl \
+       --shared-cares \
+       %{?with_system_uv:--shared-libuv} \
+       --shared-http-parser \
        --without-npm \
-       --libdir=%{_libdir} \
+       --without-dtrace \
        --prefix=%{_prefix}
 
-# build library
-%{__make} dynamiclib
-%{__make} program
-
-# relink with shared lib
-$CC -o out/Release/node src/node_main.cc -Isrc -Ideps/uv/include -lnode -Lout/Release
+# add LFS defines from libuv (RHBZ#892601)
+# CXXFLAGS must be exported, as it is needed for make, not gyp
+CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
+LDFLAGS="%{rpmldflags}" \
+%{__make} -C out V=1 BUILDTYPE=Release
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_lib}"
+
+%if %{with shared}
+lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
+ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
+ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
+%endif
+
+echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
+
+install -d $RPM_BUILD_ROOT%{_includedir}/node
+cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
+
+# install for node-gyp
+install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
 
 # for compat of fedora derivered scripts (shebangs)
 ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
@@ -127,14 +174,6 @@ install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
 # default searchpaths
 install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
 
-# install shared lib
-export PYTHONPATH=tools
-%{__python} tools/waf-light install \
-       --product-type=cshlib \
-       --destdir=$RPM_BUILD_ROOT
-
-chmod a+x $RPM_BUILD_ROOT%{_libdir}/*.so*
-
 # create pkgconfig
 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
@@ -149,55 +188,46 @@ Version: ${version}
 Cflags: -I${includedir}
 EOF
 
-%py_ocomp $RPM_BUILD_ROOT%{_libdir}/node/wafadmin
-%py_comp $RPM_BUILD_ROOT%{_libdir}/node/wafadmin
-# TODO: check it first
-#%%py_postclean %{_libdir}/node/wafadmin
-
 # install documentation
-install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
-cp -a doc/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
-cd $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
-install -d api
-mv html/api/*.markdown api
-mv html/api/api/* html/api
-rm -rf html/api/api
-cd -
+install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
+cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
+rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.markdown
+rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%if %{with shared}
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
+%endif
 
 %files
 %defattr(644,root,root,755)
 %doc README.md AUTHORS ChangeLog LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
+%if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.6
+%ghost %{_libdir}/libnode.so.10
+%endif
+%if "%{_lib}" != "lib"
 %dir %{_libdir}/node
+%endif
 %dir %{_prefix}/lib/node
 %dir %{_prefix}/lib/node_modules
 %{_mandir}/man1/node.1*
+%{_mandir}/man1/nodejs.1
 
 %files devel
 %defattr(644,root,root,755)
+%if %{with shared}
 %{_libdir}/libnode.so
+%endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
+%{_usrsrc}/%{name}
 
 %files doc
 %defattr(644,root,root,755)
 %doc %{_docdir}/%{name}-doc-%{version}
-
-%files waf
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/node-waf
-%dir %{_libdir}/node/wafadmin
-%dir %{_libdir}/node/wafadmin/Tools
-%{_libdir}/node/wafadmin/*.py[co]
-%{_libdir}/node/wafadmin/*.py
-%{_libdir}/node/wafadmin/Tools/*.py
-%{_libdir}/node/wafadmin/Tools/*.py[co]
This page took 0.222753 seconds and 4 git commands to generate.