]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
Use OpenSSL supplied CA store instead of compiled-in Mozilla CA copy.
[packages/nodejs.git] / nodejs.spec
index 055f829118b21f643dcbfb74d75240f706540e9d..9c6abaddb36936f668d73355cadc231ba0922c6b 100644 (file)
@@ -1,11 +1,10 @@
 # TODO
 # - unpackaged files
 #   /usr/share/doc/node/gdbinit
-#   /usr/share/systemtap/tapset/node.stp
 
 # Conditional build:
 %bcond_without system_uv       # system uv
-%bcond_with    shared  # build libnode.so shared library
+%bcond_with    shared          # build libnode.so shared library
 
 # NOTES:
 # - https://nodejs.org/en/download/releases/
 # an integer.
 %define                node_module_version     48
 Summary:       Asynchronous JavaScript Engine
+Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
-# 6.9 is LTS, Active LTS: 2018-04-18, EOL: 2019-04-18
-# https://github.com/nodejs/LTS
-Version:       6.9.1
+# 6.x LTS - https://github.com/nodejs/LTS:
+# Active start: 2016-10-18
+# Maintenance start: April 2018
+# Maintenance end: April 2019
+Version:       6.11.5
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 0d3117846c6704b36108fcdbf30e03c1
+# Source0-md5: 7a3159a3245a45ff6e6f546ffdfa1160
 Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
-Patch4:                %{name}-use-system-certs.patch
 Patch5:                uv-fpic.patch
 URL:           https://nodejs.org/
-BuildRequires: gcc >= 5:4.0
+BuildRequires: gcc >= 6:4.8
 BuildRequires: http-parser-devel >= 2.7.0
-BuildRequires: libstdc++-devel
+BuildRequires: libstdc++-devel >= 6:4.8
 %{?with_system_uv:BuildRequires:       libuv-devel >= 1.6.0}
 BuildRequires: openssl-devel >= 1.0.1
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.7
 BuildRequires: python-jsmin
-BuildRequires: python-modules
+BuildRequires: python-modules >= 1:2.7
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
@@ -65,8 +66,18 @@ event-driven, non-blocking I/O model that makes it lightweight and
 efficient, perfect for data-intensive real-time applications that run
 across distributed devices.
 
+%description -l pl.UTF-8
+Node.js to platforma zbudowana w opacriu o silnik JavaScriptu
+przeglądarki Chrome, służąca do tworzenia szybkich, skalowalnych
+aplikacji sieciowych. Node.js wykorzystuje nieblokujący model
+wejścia/wyjścia sterowany zdarzeniami, dzięki czemu jest lekki i
+wydajny, dobrze nadający się do aplikacji przetwarzających duże
+ilości danych w czasie rzeczywistym, uruchamianych na rozproszonych
+urządzeniach.
+
 %package devel
 Summary:       Development headers for nodejs
+Summary(pl.UTF-8):     Pliki nagłówkowe nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      gcc
@@ -79,8 +90,12 @@ Requires:    zlib-devel
 %description devel
 Development headers for nodejs.
 
+%description devel -l pl.UTF-8
+Pliki nagłówkowe nodejs.
+
 %package doc
-Summary:       Evented I/O for V8 JavaScript - documentation
+Summary:       Documentation for Node.js engine
+Summary(pl.UTF-8):     Dokumentacja silnika Node.js
 Group:         Documentation
 URL:           https://nodejs.org/dist/v%{doc_ver}/docs/api
 %if "%{_rpmversion}" >= "5"
@@ -92,7 +107,28 @@ Node.js is a server-side JavaScript environment that uses an
 asynchronous event-driven model. Node's goal is to provide an easy way
 to build scalable network programs.
 
-This package contains the documentation for nodejs.
+This package contains the documentation for Node.js.
+
+%description doc -l pl.UTF-8
+Node.js to serwerowe środowisko JavaScriptu wykorzystujące
+asynchroniczny model sterowany zdarzeniami. Celem Node jest
+zapewnienie łatwego sposobu tworzenia skalowalnych programów
+sieciowych.
+
+Ten pakiet zawiera dokumentację Node.js.
+
+%package -n systemtap-nodejs
+Summary:       systemtap/dtrace probes for Node.js
+Summary(pl.UTF-8):     Sondy systemtap/dtrace dla Node.js
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+Requires:      systemtap-client
+
+%description -n systemtap-nodejs
+systemtap/dtrace probes for Node.js.
+
+%description -n systemtap-nodejs -l pl.UTF-8
+Sondy systemtap/dtrace dla Node.js.
 
 %prep
 %setup -q -n node-v%{version}
@@ -103,17 +139,15 @@ This package contains the documentation for nodejs.
 %else
 %patch2 -p1
 %endif
-%patch4 -p1
-rm src/node_root_certs.h
 #%{?with_system_uv:%patch5 -p1}
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-rm -r deps/npm
-rm -r deps/http_parser
-rm -r deps/openssl
-%{?with_system_uv:rm -r deps/uv}
-rm -r deps/zlib
+%{__rm} -r deps/npm
+%{__rm} -r deps/http_parser
+%{__rm} -r deps/openssl
+%{?with_system_uv:%{__rm} -r deps/uv}
+%{__rm} -r deps/zlib
 
 %build
 ver=$(awk '/#define NODE_MODULE_VERSION/{print $3}' src/node_version.h)
@@ -124,11 +158,12 @@ CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-zlib \
-       --shared-openssl \
+       --openssl-use-def-ca-store \
        %{?0:--shared-cares} \
-       %{?with_system_uv:--shared-libuv} \
+       --shared-openssl \
        --shared-http-parser \
+       %{?with_system_uv:--shared-libuv} \
+       --shared-zlib \
        --without-npm \
        --without-dtrace \
        --prefix=%{_prefix}
@@ -137,10 +172,13 @@ GYP_DEFINES="soname_version=%{sover}" \
 # CXXFLAGS must be exported, as it is needed for make, not gyp
 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
 LDFLAGS="%{rpmldflags}" \
-%{__make} -C out V=1 BUILDTYPE=Release
+%{__make} -C out \
+       BUILDTYPE=Release \
+       V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
 
 %if %{with shared}
@@ -185,8 +223,8 @@ EOF
 # install documentation
 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
 cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
-rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.md
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -198,12 +236,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS CHANGELOG.md ROADMAP.md LICENSE
+%doc README.md AUTHORS CHANGELOG.md LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
 %if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.10
+%attr(755,root,root) %ghost %{_libdir}/libnode.so.10
 %endif
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
@@ -211,12 +249,12 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_prefix}/lib/node
 %dir %{_prefix}/lib/node_modules
 %{_mandir}/man1/node.1*
-%{_mandir}/man1/nodejs.1
+%{_mandir}/man1/nodejs.1*
 
 %files devel
 %defattr(644,root,root,755)
 %if %{with shared}
-%{_libdir}/libnode.so
+%attr(755,root,root) %{_libdir}/libnode.so
 %endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
@@ -225,3 +263,7 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 %doc %{_docdir}/%{name}-doc-%{version}
+
+%files -n systemtap-nodejs
+%defattr(644,root,root,755)
+%{_datadir}/systemtap/tapset/node.stp
This page took 0.041953 seconds and 4 git commands to generate.