]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
up to 16.20.2 (fixes CVE-2023-32002 CVE-2023-32006 CVE-2023-32559)
[packages/nodejs.git] / nodejs.spec
index 43983cdab51e30f784e8bc7b581e740ea0ce13e9..83a74ff045fc0c2c0343e6e8552e6b6822a46dbb 100644 (file)
@@ -1,3 +1,7 @@
+# BUILD NOTE:
+# until we get binutils with https://sourceware.org/bugzilla/show_bug.cgi?id=28138 fixed
+# build requires >1024 available file descriptors (4096 seems sufficient)
+#
 # TODO
 # - unpackaged files
 #   /usr/share/doc/node/gdbinit
 Summary:       Asynchronous JavaScript Engine
 Summary(pl.UTF-8):     Asynchroniczny silnik JavaScriptu
 Name:          nodejs
-# 14.x LTS - https://github.com/nodejs/Release
-# Active start: 2020-10-27
-# Maintenance start: October 2020
-# Maintenance end: April 2023
-Version:       16.10.0
+# 16.x LTS - https://github.com/nodejs/Release
+# Active start: 2021-10-26
+# Maintenance start: October 2022
+# Maintenance end: September 2023
+Version:       16.20.2
 Release:       1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 8c5f13de865ad83d4d759414fe12e261
+Source0:       https://nodejs.org/download/release/latest-v16.x/node-v%{version}.tar.xz
+# Source0-md5: c3bdaf2ababf0c753d42c0acef1a154a
 Patch0:                system_cares.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
 Patch4:                0001-Disable-running-gyp-on-shared-deps.patch
-Patch5:                0002-Install-both-binaries-and-use-libdir.patch
 URL:           https://nodejs.org/
 BuildRequires: c-ares-devel >= 1.17.2
 BuildRequires: gcc >= 6:6.3
@@ -58,8 +61,11 @@ BuildRequires:       pkgconfig
 BuildRequires: python3 >= 1:3.6
 BuildRequires: python3-modules >= 1:3.6
 BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.752
+BuildRequires: tar >= 1:1.22
 BuildRequires: sed >= 4.0
+BuildRequires: xz
 BuildRequires: zlib-devel >= 1.2.11
 Requires:      c-ares >= 1.17.1
 Requires:      ca-certificates
@@ -70,7 +76,7 @@ Requires:     nghttp2-libs >= 1.42.0
 Requires:      zlib >= 1.2.11
 Provides:      nodejs(engine) = %{version}
 Provides:      nodejs(module-version) = %{node_module_version}
-Obsoletes:     nodejs-waf
+Obsoletes:     nodejs-waf < 0.9
 ExclusiveArch: %{ix86} %{x8664} %{arm} aarch64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -156,9 +162,8 @@ Sondy systemtap/dtrace dla Node.js.
 %patch2 -p1
 %endif
 %patch4 -p1
-%patch5 -p1
 
-grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python3},'
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python$,#!%{__python3},'
 
 %{?with_system_brotli:%{__rm} -r deps/brotli}
 %{__rm} -r deps/cares
@@ -194,6 +199,7 @@ GYP_DEFINES="soname_version=%{sover}" \
        --shared-openssl \
        --shared-zlib \
        --with-intl=system-icu \
+       --without-corepack \
        --without-dtrace \
        --without-npm
 
@@ -201,6 +207,7 @@ GYP_DEFINES="soname_version=%{sover}" \
 # CXXFLAGS must be exported, as it is needed for make, not gyp
 CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
 LDFLAGS="%{rpmldflags}" \
+PATH="$(pwd)/out/tools/bin:$PATH" \
 %{__make} -C out \
        BUILDTYPE=Release \
        V=1
This page took 3.28741 seconds and 4 git commands to generate.