]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
- disable system uv (does not build with current libuv)
[packages/nodejs.git] / nodejs.spec
index 1fc8929b1ea66130f683cf4981d7a93d66cde534..42c8830d455650abecdafc68e8571107e9e71478 100644 (file)
@@ -1,29 +1,59 @@
+#
+# Conditional build:
+%bcond_without system_v8       # system v8
+%bcond_with    system_uv       # system uv
+%bcond_without shared  # build libnode.so shared library
+
+# NOTES:
+# - https://nodejs.org/en/download/releases/
+
+# see "Modules" column in https://nodejs.org/en/download/releases/
+%define                node_module_version     11
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.9.12
-Release:       1
-License:       BSD and MIT and ASL 2.0 and GPLv3
+Version:       0.10.40
+Release:       3
+License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-URL:           http://www.nodejs.org/
-Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 0521950111ba1b2165b125b0832ffef8
+Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
+# Source0-md5: f6ef20f327ecd6cb1586c41c7184290c
 Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
+Patch4:                %{name}-use-system-certs.patch
 Patch5:                uv-fpic.patch
+# The invalid UTF8 fix has been reverted since this breaks v8 API, which cannot
+# be done in a stable distribution release.  This build of nodejs will behave as
+# if NODE_INVALID_UTF8 was set.  For more information on the implications, see:
+# http://blog.nodejs.org/2014/06/16/openssl-and-breaking-utf-8-change/
+Patch6:                %{name}-revert-utf8-v8.patch
+Patch7:                %{name}-revert-utf8-node.patch
+URL:           https://nodejs.org/
+BuildRequires: c-ares-devel
 BuildRequires: gcc >= 5:4.0
+BuildRequires: http-parser-devel >= 2.0
 BuildRequires: libstdc++-devel
+%{?with_system_uv:BuildRequires:       libuv-devel >= 0.10}
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5.2
 BuildRequires: python-jsmin
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
-BuildRequires: v8-devel >= 3.15.11.10
+BuildRequires: sed >= 4.0
+%{?with_system_v8:BuildRequires:       v8-devel >= 3.15.11.18-2}
+BuildRequires: zlib-devel
+Requires:      ca-certificates
+Provides:      nodejs(engine) = %{version}
+Provides:      nodejs(module-version) = %{node_module_version}
 Obsoletes:     nodejs-waf
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                sover   %(echo %{version} | cut -d. -f2)
+
 %description
 Node.js is a platform built on Chrome's JavaScript runtime for easily
 building fast, scalable network applications. Node.js uses an
@@ -35,9 +65,14 @@ across distributed devices.
 Summary:       Development headers for nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      c-ares-devel
 Requires:      gcc
+Requires:      http-parser-devel
 Requires:      libstdc++-devel
-Requires:      v8-devel
+%{?with_system_uv:Requires:    libuv-devel}
+Requires:      openssl-devel
+%{?with_system_v8:Requires:    v8-devel}
+Requires:      zlib-devel
 
 %description devel
 Development headers for nodejs.
@@ -45,6 +80,9 @@ Development headers for nodejs.
 %package doc
 Summary:       Evented I/O for V8 JavaScript - documentation
 Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -55,62 +93,74 @@ This package contains the documentation for nodejs.
 
 %prep
 %setup -q -n node-v%{version}
-%patch1 -p1
+%{?with_shared:%patch1 -p1}
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
+%patch4 -p1
 %patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
-%build
+grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-# Error: V8 doesn't like ccache. Please set your CC env var to 'gcc'
-CC=${CC#ccache }
+rm -r deps/npm
+rm -r deps/cares
+rm -r deps/http_parser
+rm -r deps/openssl
+%{?with_system_uv:rm -r deps/uv}
+%{?with_system_v8:rm -r deps/v8}
+rm -r deps/zlib
 
-# NOT autoconf so dont use macro
-export PYTHONPATH=tools
+%build
+ver=$(awk '/#define NODE_MODULE_VERSION/{print $NF}' src/node.h)
+if [ $ver != %{node_module_version} ]; then
+       echo "Set %%define node_module_version to $ver and re-run."
+       exit 1
+fi
+
+# CC used only to detect if CC is clang, not used for compiling
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-v8 \
+       %{?with_system_v8:--shared-v8} \
        --shared-zlib \
        --shared-openssl \
+       --shared-cares \
+       %{?with_system_uv:--shared-libuv} \
+       --shared-http-parser \
        --without-npm \
+       --without-dtrace \
        --prefix=%{_prefix}
 
-%{__make} -C out \
-       BUILDTYPE=Release \
-       V=1 \
-       CFLAGS.host="%{rpmcflags} -fPIC" \
-       CXXFLAGS.host="%{rpmcppflags} -fPIC" \
-       LDFLAGS.host="%{rpmcflags}" \
-       CFLAGS.target="%{rpmcflags} -fPIC" \
-       CXXFLAGS.target="%{rpmcppflags} -fPIC" \
-       LDFLAGS.target="%{rpmcflags}" \
-%if "%{pld_release}" == "ac"
-       CC.host="%{__cc}4" \
-       CXX.host="%{__cxx}4" \
-       CC.target="%{__cc}4" \
-       CXX.target="%{__cxx}4" \
-%else
-       CC.host="%{__cc}" \
-       CXX.host="%{__cxx}" \
-       CC.target="%{__cc}" \
-       CXX.target="%{__cxx}"
-%endif
+# add LFS defines from libuv (RHBZ#892601)
+# CXXFLAGS must be exported, as it is needed for make, not gyp
+CXXFLAGS="%{rpmcxxflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fPIC" \
+LDFLAGS="%{rpmldflags}" \
+%{__make} -C out V=1 BUILDTYPE=Release
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} justinstall \
-       DESTDIR=$RPM_BUILD_ROOT \
-    LIBDIR=%{_lib}
+%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_lib}"
 
-ln -s libnode.so.9.0.0 $RPM_BUILD_ROOT%{_libdir}/libnode.so.9
-ln -s libnode.so.9.0.0 $RPM_BUILD_ROOT%{_libdir}/libnode.so
+%if %{with shared}
+lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
+ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
+ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
+%endif
 
 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
 
 install -d $RPM_BUILD_ROOT%{_includedir}/node
-install src/*.h $RPM_BUILD_ROOT%{_includedir}/node
+cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
+
+# install for node-gyp
+install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
 
 # for compat of fedora derivered scripts (shebangs)
 ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
@@ -144,16 +194,20 @@ rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%if %{with shared}
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
+%endif
 
 %files
 %defattr(644,root,root,755)
 %doc README.md AUTHORS ChangeLog LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
+%if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.9
+%ghost %{_libdir}/libnode.so.10
+%endif
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
 %endif
@@ -164,9 +218,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%if %{with shared}
 %{_libdir}/libnode.so
+%endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
+%{_usrsrc}/%{name}
 
 %files doc
 %defattr(644,root,root,755)
This page took 0.70058 seconds and 4 git commands to generate.