]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
drop system v8 support; upstream has dropped any support
[packages/nodejs.git] / nodejs.spec
index b920260256902b18c4cf71d61c63b36a643ac118..42b9b5320b120a618eaf8e1c0083a5d4bfd18d6d 100644 (file)
@@ -1,7 +1,10 @@
-#
+# TODO
+# - unpackaged files
+#   /usr/share/doc/node/gdbinit
+#   /usr/share/systemtap/tapset/node.stp
+
 # Conditional build:
-%bcond_with    system_v8       # system v8
-%bcond_with    system_uv       # system uv
+%bcond_without system_uv       # system uv
 %bcond_with    shared  # build libnode.so shared library
 
 # NOTES:
 
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       4.2.1
+Version:       4.2.3
 Release:       0.1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
 Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 41d2b9fb5220af3fd98dd70fb33a2a10
+# Source0-md5: 529a8abd4ca5a2225636767d3f14c382
 Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
@@ -33,7 +36,7 @@ BuildRequires:        c-ares-devel
 BuildRequires: gcc >= 5:4.0
 BuildRequires: http-parser-devel >= 2.5.0
 BuildRequires: libstdc++-devel
-%{?with_system_uv:BuildRequires:       libuv-devel >= 0.10}
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.6.0}
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5.2
@@ -41,7 +44,6 @@ BuildRequires:        python-jsmin
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
-%{?with_system_v8:BuildRequires:       v8-devel >= 3.15.11.18-2}
 BuildRequires: zlib-devel
 Requires:      ca-certificates
 Obsoletes:     nodejs-waf
@@ -67,7 +69,6 @@ Requires:     http-parser-devel
 Requires:      libstdc++-devel
 %{?with_system_uv:Requires:    libuv-devel}
 Requires:      openssl-devel
-%{?with_system_v8:Requires:    v8-devel}
 Requires:      zlib-devel
 
 %description devel
@@ -108,7 +109,6 @@ rm -r deps/npm
 rm -r deps/http_parser
 rm -r deps/openssl
 %{?with_system_uv:rm -r deps/uv}
-%{?with_system_v8:rm -r deps/v8}
 rm -r deps/zlib
 
 %build
@@ -117,7 +117,6 @@ CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       %{?with_system_v8:--shared-v8} \
        --shared-zlib \
        --shared-openssl \
        %{?0:--shared-cares} \
This page took 0.233926 seconds and 4 git commands to generate.