]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
drop system v8 support; upstream has dropped any support
[packages/nodejs.git] / nodejs.spec
index 3d0a0ed67a2919d55da84d8fdd50afc9369a5465..42b9b5320b120a618eaf8e1c0083a5d4bfd18d6d 100644 (file)
@@ -1,11 +1,23 @@
+# TODO
+# - unpackaged files
+#   /usr/share/doc/node/gdbinit
+#   /usr/share/systemtap/tapset/node.stp
+
+# Conditional build:
+%bcond_without system_uv       # system uv
+%bcond_with    shared  # build libnode.so shared library
+
+# NOTES:
+# - https://nodejs.org/en/download/releases/
+
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.10.30
-Release:       2
+Version:       4.2.3
+Release:       0.1
 License:       BSD and MIT and Apache v2.0 and GPL v3
 Group:         Development/Languages
-Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: bae597a31bf6d23da1c4217bfed611dc
+Source0:       https://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
+# Source0-md5: 529a8abd4ca5a2225636767d3f14c382
 Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
@@ -19,12 +31,12 @@ Patch5:             uv-fpic.patch
 # http://blog.nodejs.org/2014/06/16/openssl-and-breaking-utf-8-change/
 Patch6:                %{name}-revert-utf8-v8.patch
 Patch7:                %{name}-revert-utf8-node.patch
-URL:           http://www.nodejs.org/
+URL:           https://nodejs.org/
 BuildRequires: c-ares-devel
 BuildRequires: gcc >= 5:4.0
-BuildRequires: http-parser-devel >= 2.0
+BuildRequires: http-parser-devel >= 2.5.0
 BuildRequires: libstdc++-devel
-BuildRequires: libuv-devel >= 0.10
+%{?with_system_uv:BuildRequires:       libuv-devel >= 1.6.0}
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5.2
@@ -32,7 +44,6 @@ BuildRequires:        python-jsmin
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: sed >= 4.0
-BuildRequires: v8-devel >= 3.15.11.10
 BuildRequires: zlib-devel
 Requires:      ca-certificates
 Obsoletes:     nodejs-waf
@@ -56,9 +67,8 @@ Requires:     c-ares-devel
 Requires:      gcc
 Requires:      http-parser-devel
 Requires:      libstdc++-devel
-Requires:      libuv-devel
+%{?with_system_uv:Requires:    libuv-devel}
 Requires:      openssl-devel
-Requires:      v8-devel
 Requires:      zlib-devel
 
 %description devel
@@ -67,6 +77,9 @@ Development headers for nodejs.
 %package doc
 Summary:       Evented I/O for V8 JavaScript - documentation
 Group:         Documentation
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description doc
 Node.js is a server-side JavaScript environment that uses an
@@ -77,20 +90,26 @@ This package contains the documentation for nodejs.
 
 %prep
 %setup -q -n node-v%{version}
-%patch1 -p1
+%{?with_shared:%patch1 -p1}
+#%patch1 -p1
 %if %{_lib} == "lib64"
 %patch3 -p1
 %else
 %patch2 -p1
 %endif
 %patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
+#%{?with_system_uv:%patch5 -p1}
+#%patch6 -p1
+#%patch7 -p1
 
 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python,#!%{__python},'
 
-rm -r deps
+rm -r deps/npm
+#rm -r deps/cares
+rm -r deps/http_parser
+rm -r deps/openssl
+%{?with_system_uv:rm -r deps/uv}
+rm -r deps/zlib
 
 %build
 # CC used only to detect if CC is clang, not used for compiling
@@ -98,11 +117,10 @@ CC="%{__cc}" \
 CXX="%{__cxx}" \
 GYP_DEFINES="soname_version=%{sover}" \
 ./configure \
-       --shared-v8 \
        --shared-zlib \
        --shared-openssl \
-       --shared-cares \
-       --shared-libuv \
+       %{?0:--shared-cares} \
+       %{?with_system_uv:--shared-libuv} \
        --shared-http-parser \
        --without-npm \
        --without-dtrace \
@@ -116,13 +134,13 @@ LDFLAGS="%{rpmldflags}" \
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} justinstall \
-       DESTDIR=$RPM_BUILD_ROOT \
-       LIBDIR=%{_lib}
+%{__python} tools/install.py install "$RPM_BUILD_ROOT" "%{_prefix}"
 
+%if %{with shared}
 lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*.*)
 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
 ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
+%endif
 
 echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
 
@@ -166,16 +184,20 @@ rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with shared}
 %post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
+%endif
 
 %files
 %defattr(644,root,root,755)
-%doc README.md AUTHORS ChangeLog LICENSE
+%doc README.md AUTHORS CHANGELOG.md ROADMAP.md LICENSE
 %attr(755,root,root) %{_bindir}/node
 %attr(755,root,root) %{_bindir}/nodejs
+%if %{with shared}
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
 %ghost %{_libdir}/libnode.so.10
+%endif
 %if "%{_lib}" != "lib"
 %dir %{_libdir}/node
 %endif
@@ -186,7 +208,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%if %{with shared}
 %{_libdir}/libnode.so
+%endif
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
 %{_usrsrc}/%{name}
This page took 0.039183 seconds and 4 git commands to generate.