]> git.pld-linux.org Git - packages/nodejs.git/blobdiff - nodejs.spec
use system libuv
[packages/nodejs.git] / nodejs.spec
index 7bd39d66586a51ca0778be9271f25b08bd6d9f90..362939456cb820926a9927e1960b9a91c8bc5c62 100644 (file)
@@ -1,43 +1,49 @@
 Summary:       Asynchronous JavaScript Engine
 Name:          nodejs
-Version:       0.6.6
-Release:       2
-License:       BSD
-Group:         Libraries
-URL:           http://nodejs.org/
+Version:       0.10.3
+Release:       3
+License:       BSD and MIT and Apache v2.0 and GPL v3
+Group:         Development/Languages
 Source0:       http://nodejs.org/dist/v%{version}/node-v%{version}.tar.gz
-# Source0-md5: 43836ebd6e8e9059c4584e3b5ab50009
-Patch1:                %{name}-soname.patch
+# Source0-md5: 4daca92618515708a4631e98a8e8c779
+Patch1:                %{name}-shared.patch
 # force node to use /usr/lib/node as the systemwide module directory
 Patch2:                %{name}-libpath.patch
 # use /usr/lib64/node as an arch-specific module dir when appropriate
 Patch3:                %{name}-lib64path.patch
-BuildRequires: c-ares-devel >= 1.7.4
+Patch5:                uv-fpic.patch
+URL:           http://www.nodejs.org/
+BuildRequires: c-ares-devel
 BuildRequires: gcc >= 5:4.0
-BuildRequires: libeio-devel
-BuildRequires: libev-devel >= 4.0.0
 BuildRequires: libstdc++-devel
+BuildRequires: libuv-devel >= %{version}
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5.2
 BuildRequires: python-jsmin
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: v8-devel >= 3.6
+BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: v8-devel >= 3.15.11.10
+BuildRequires: zlib-devel
+BuildConflicts:        eio
+Obsoletes:     nodejs-waf
 ExclusiveArch: %{ix86} %{x8664} arm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Node's goal is to provide an easy way to build scalable network
-programs. In the above example, the two second delay does not prevent
-the server from handling new requests. Node tells the operating system
-(through epoll, kqueue, /dev/poll, or select) that it should be
-notified when the 2 seconds are up or if a new connection is made --
-then it goes to sleep. If someone new connects, then it executes the
-callback, if the timeout expires, it executes the inner callback. Each
-connection is only a small heap allocation.
+Node.js is a platform built on Chrome's JavaScript runtime for easily
+building fast, scalable network applications. Node.js uses an
+event-driven, non-blocking I/O model that makes it lightweight and
+efficient, perfect for data-intensive real-time applications that run
+across distributed devices.
 
 %package devel
 Summary:       Development headers for nodejs
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      gcc
+Requires:      libstdc++-devel
+Requires:      v8-devel
 
 %description devel
 Development headers for nodejs.
@@ -53,19 +59,6 @@ to build scalable network programs.
 
 This package contains the documentation for nodejs.
 
-%package waf
-Summary:       Evented I/O for V8 JavaScript - customized WAF build system
-Group:         Libraries
-Requires:      %{name} = %{version}-%{release}
-
-%description waf
-Node.js is a server-side JavaScript environment that uses an
-asynchronous event-driven model. Node's goal is to provide an easy way
-to build scalable network programs.
-
-This package contains the customized version of the WAF build system
-used by Node.js and many of its modules.
-
 %prep
 %setup -q -n node-v%{version}
 %patch1 -p1
@@ -74,55 +67,81 @@ used by Node.js and many of its modules.
 %else
 %patch2 -p1
 %endif
+%patch5 -p1
 
 %build
-%undefine      with_ccache
-# build library
-CFLAGS="%{rpmcflags} -fPIC"
-CXXFLAGS="%{rpmcxxflags} -fPIC"
-LDFLAGS="%{rpmcflags}"
-%if "%{pld_release}" == "ac"
-CC="%{__cc}4"
-CXX="%{__cxx}4"
-%else
-CC="%{__cc}"
-CXX="%{__cxx}"
-%endif
-export CFLAGS LDFLAGS CXXFLAGS CC CXX
+# Error: V8 doesn't like ccache. Please set your CC env var to 'gcc'
+CC=${CC#ccache }
 
-# NOT autoconf so dont use macro
+# add defines from libuv (RHBZ#892601)
+export CFLAGS="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+export CXXFLAGS="%{rpmcppflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+
+# NOT autoconf so don't use macro
 export PYTHONPATH=tools
 ./configure \
-       --shared-cares \
        --shared-v8 \
        --shared-zlib \
-       --libdir=%{_libdir} \
+       --shared-openssl \
+       --shared-cares \
+       --shared-libuv \
+       --without-npm \
+       --without-dtrace \
        --prefix=%{_prefix}
 
-%{__make} dynamiclib
-%{__make} program
-
-# relink with shared lib
-$CC -o out/Release/node src/node_main.cc -Isrc -Ideps/uv/include -lnode -Lout/Release
+%{__make} -C out \
+       BUILDTYPE=Release \
+       V=1 \
+       CFLAGS.host="%{rpmcflags} -fPIC" \
+       CXXFLAGS.host="%{rpmcppflags} -fPIC" \
+       LDFLAGS.host="%{rpmcflags}" \
+       CFLAGS.target="%{rpmcflags} -fPIC" \
+       CXXFLAGS.target="%{rpmcppflags} -fPIC" \
+       LDFLAGS.target="%{rpmcflags}" \
+       CC.host="%{__cc}" \
+       CXX.host="%{__cxx}" \
+       CC.target="%{__cc}" \
+       CXX.target="%{__cxx}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+%{__make} justinstall \
+       DESTDIR=$RPM_BUILD_ROOT \
+       LIBDIR=%{_lib}
 
-# install shared lib
-export PYTHONPATH=tools
-%{__python} tools/waf-light install \
-       --product-type=cshlib \
-       --destdir=$RPM_BUILD_ROOT
+# no dtrace on linux
+%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/lib/dtrace/node.d
+
+lib=$(basename $RPM_BUILD_ROOT%{_libdir}/libnode.so.*.*)
+ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so.10
+ln -s $lib $RPM_BUILD_ROOT%{_libdir}/libnode.so
+
+echo '.so man1/node.1' > $RPM_BUILD_ROOT%{_mandir}/man1/nodejs.1
+
+install -d $RPM_BUILD_ROOT%{_includedir}/node
+cp -p src/*.h $RPM_BUILD_ROOT%{_includedir}/node
+cp -p deps/uv/include/uv.h $RPM_BUILD_ROOT%{_includedir}/node
+cp -a deps/uv/include/uv-private $RPM_BUILD_ROOT%{_includedir}/node
+
+# install for node-gyp
+install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+cp -p common.gypi $RPM_BUILD_ROOT%{_usrsrc}/%{name}
+ln -s %{_includedir}/node $RPM_BUILD_ROOT%{_usrsrc}/%{name}/src
 
-chmod a+x $RPM_BUILD_ROOT%{_libdir}/*.so*
+# for compat of fedora derivered scripts (shebangs)
+ln -s node $RPM_BUILD_ROOT%{_bindir}/nodejs
+
+# globally installed node modules (noarch)
+install -d $RPM_BUILD_ROOT%{_prefix}/lib/node_modules
+
+# default searchpaths
+install -d $RPM_BUILD_ROOT{%{_libdir},%{_prefix}/lib}/node
 
 # create pkgconfig
 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_pkgconfigdir}/%{name}.pc
 version=%{version}
-prefix=/usr
+prefix=%{_prefix}
 libdir=${prefix}/%{_lib}
 includedir=${prefix}/include/node
 
@@ -133,49 +152,39 @@ Cflags: -I${includedir}
 EOF
 
 # install documentation
-install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
-cp -a doc/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/html
-cd $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
-install -d api
-mv html/api/*.markdown api
-mv html/api/api/* html/api
-rm -rf html/api/api
-cd -
-
-# remove NPM; it's buggy in 0.6.3
-# but really we package npm from separate spec
-rm -rf $RPM_BUILD_ROOT%{_libdir}/node_modules
-rm $RPM_BUILD_ROOT%{_bindir}/npm
+install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
+cp -a doc/api/* $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}
+rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.markdown
+rm $RPM_BUILD_ROOT%{_docdir}/%{name}-doc-%{version}/*.json
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post   -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %doc README.md AUTHORS ChangeLog LICENSE
 %attr(755,root,root) %{_bindir}/node
+%attr(755,root,root) %{_bindir}/nodejs
 %attr(755,root,root) %{_libdir}/libnode.so.*.*.*
-%ghost %{_libdir}/libnode.so.4
+%ghost %{_libdir}/libnode.so.10
+%if "%{_lib}" != "lib"
 %dir %{_libdir}/node
+%endif
+%dir %{_prefix}/lib/node
+%dir %{_prefix}/lib/node_modules
 %{_mandir}/man1/node.1*
+%{_mandir}/man1/nodejs.1
 
 %files devel
 %defattr(644,root,root,755)
 %{_libdir}/libnode.so
 %{_includedir}/node
 %{_pkgconfigdir}/nodejs.pc
+%{_usrsrc}/%{name}
 
 %files doc
 %defattr(644,root,root,755)
 %doc %{_docdir}/%{name}-doc-%{version}
-
-%files waf
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/node-waf
-%dir %{_libdir}/node/wafadmin
-%dir %{_libdir}/node/wafadmin/Tools
-%{_libdir}/node/wafadmin/*.py
-%{_libdir}/node/wafadmin/Tools/*.py
This page took 0.11589 seconds and 4 git commands to generate.