]> git.pld-linux.org Git - packages/nginx.git/blob - nginx.spec
update config from fedora
[packages/nginx.git] / nginx.spec
1 # TODO
2 # - /etc/sysconfig/nginx file
3 # - missing perl build/install requires
4 #
5 # Conditional build for nginx:
6 # Features
7 %bcond_with     debug           # enable debug logging: http://nginx.org/en/docs/debugging_log.html
8 %bcond_without  threads         # thread pool support
9 # Modules
10 %bcond_without  addition        # http addition module
11 %bcond_without  auth_request    # auth_request module
12 %bcond_without  dav             # WebDAV
13 %bcond_without  flv             # http FLV module
14 %bcond_without  gd              # without http image filter module
15 %bcond_without  geoip           # without http geoip module and stream geoip module
16 %bcond_without  http2           # HTTP/2 module
17 %bcond_without  mail            # don't build imap/mail proxy
18 %bcond_without  perl            # don't build with perl module
19 %bcond_without  poll            # poll module
20 %bcond_without  realip          # real ip (behind proxy)
21 %bcond_without  select          # select module
22 %bcond_without  ssl             # ssl support and http ssl module
23 %bcond_without  stream          # TCP/UDP proxy module
24 %bcond_without  stub_status     # http stub status module
25 %bcond_without  sub             # ngx_http_sub_module
26 %bcond_without  xslt            # without http xslt module
27 %bcond_with     http_browser    # http browser module (header "User-agent" parser)
28 %bcond_with     modsecurity     # modsecurity module
29 %bcond_with     rtmp            # rtmp support
30
31 %ifarch x32
32 %undefine       with_rtsig
33 %endif
34
35 %define         ssl_version     1.0.2
36 %define         rtmp_version    1.1.7
37 %define         modsecurity_version     2.9.1
38 Summary:        High perfomance HTTP and reverse proxy server
39 Summary(pl.UTF-8):      Serwer HTTP i odwrotne proxy o wysokiej wydajności
40 # nginx lines:
41 # - stable: production quality with stable API
42 # - mainline: production quality but API can change
43 Name:           nginx
44 Version:        1.11.5
45 Release:        0.1
46 License:        BSD-like
47 Group:          Networking/Daemons/HTTP
48 Source0:        http://nginx.org/download/%{name}-%{version}.tar.gz
49 # Source0-md5:  db43f2b19746f6f47401c3afc3924dc6
50 Source1:        http://nginx.net/favicon.ico
51 # Source1-md5:  2aaf2115c752cbdbfb8a2f0b3c3189ab
52 Source2:        proxy.conf
53 Source3:        %{name}.logrotate
54 Source4:        %{name}.mime
55 Source6:        %{name}.monitrc
56 Source7:        %{name}.init
57 Source14:       %{name}.conf
58 Source17:       %{name}-mime.types.sh
59 Source18:       %{name}.service
60 Source22:       http://www.modsecurity.org/tarball/%{modsecurity_version}/modsecurity-%{modsecurity_version}.tar.gz
61 # Source22-md5: 0fa92b852abc857a20b9e24f83f814cf
62 Source101:      https://github.com/arut/nginx-rtmp-module/archive/v%{rtmp_version}/%{name}-rtmp-module-%{rtmp_version}.tar.gz
63 # Source101-md5:        8006de2560db3e55bb15d110220076ac
64 Patch0:         %{name}-no-Werror.patch
65 Patch1:         %{name}-modsecurity-xheaders.patch
66 URL:            http://nginx.net/
67 BuildRequires:  mailcap
68 BuildRequires:  pcre-devel
69 BuildRequires:  rpmbuild(macros) >= 1.644
70 BuildRequires:  zlib-devel
71 %if %{with geoip}
72 BuildRequires:  GeoIP-devel
73 %endif
74 %if %{with gd}
75 BuildRequires:  gd-devel
76 %endif
77 %if %{with modsecurity}
78 BuildRequires:  lua-devel
79 %endif
80 %if %{with perl}
81 BuildRequires:  perl-CGI
82 BuildRequires:  perl-devel
83 BuildRequires:  python
84 BuildRequires:  rpm-perlprov
85 %endif
86 %if %{with ssl}
87 BuildRequires:  openssl-devel >= %{ssl_version}
88 Requires:       openssl >= %{ssl_version}
89 %endif
90 %if %{with xslt}
91 BuildRequires:  libxslt-devel
92 %endif
93 Provides:       group(http)
94 Provides:       group(nginx)
95 Provides:       user(nginx)
96 Provides:       webserver
97 Provides:       webserver(access)
98 Provides:       webserver(alias)
99 Provides:       webserver(auth)
100 Provides:       webserver(expires)
101 Provides:       webserver(headers)
102 Provides:       webserver(indexfile)
103 Provides:       webserver(log)
104 Provides:       webserver(mime)
105 Provides:       webserver(reqtimeout)
106 Provides:       webserver(rewrite)
107 Provides:       webserver(setenv)
108 Conflicts:      logrotate < 3.8.0
109 Requires(post,preun):   /sbin/chkconfig
110 Requires(post,preun,postun):    systemd-units >= 38
111 Requires(postun):       /usr/sbin/groupdel
112 Requires(postun):       /usr/sbin/userdel
113 Requires(pre):  /bin/id
114 Requires(pre):  /usr/bin/getgid
115 Requires(pre):  /usr/sbin/groupadd
116 Requires(pre):  /usr/sbin/useradd
117 Requires:       rc-scripts >= 0.2.0
118 Requires:       systemd-units >= 38
119 Suggests:       vim-syntax-nginx
120 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
121
122 %define         _sysconfdir     /etc/%{name}
123 %define         _nginxdir       /home/services/%{name}
124
125 %description
126 nginx ("engine x") is a high-performance HTTP server and reverse
127 proxy, as well as an IMAP/POP3 proxy server. nginx was written by Igor
128 Sysoev for Rambler.ru, Russia's second-most visited website, where it
129 has been running in production for over two and a half years. Igor has
130 released the source code under a BSD-like license. Although still in
131 beta, nginx is known for its stability, rich feature set, simple
132 configuration, and low resource consumption.
133
134 %description -l pl.UTF-8
135 nginx ("engine x") jest wysokowydajnym serwerem HTTP, odwrotnym proxy
136 a także IMAP/POP3 proxy. nginx został napisany przez Igora Sysoeva na
137 potrzeby serwisu Rambler.ru. Jest to drugi pod względem ilości
138 odwiedzin serwis w Rosji i działa od ponad dwóch i pół roku. Igor
139 opublikował źródła na licencji BSD. Mimo, że projekt jest ciągle w
140 fazie beta, już zasłynął dzięki stabilności, bogactwu dodatków,
141 prostej konfiguracji oraz małej "zasobożerności".
142
143 %package mod_http_geoip
144 Summary:        Nginx HTTP geoip module
145 Group:          Daemons
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       GeoIP
148
149 %description mod_http_geoip
150 Nginx HTTP geoip module.
151
152 %package mod_stream_geoip
153 Summary:        Nginx stream geoip module
154 Group:          Daemons
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       GeoIP
157
158 %description mod_stream_geoip
159 Nginx stream geoip module.
160
161 %package mod_http_image_filter
162 Summary:        Nginx HTTP image filter module
163 Group:          Daemons
164 Requires:       %{name} = %{version}-%{release}
165
166 %description mod_http_image_filter
167 Nginx HTTP image filter module.
168
169 %package mod_http_perl
170 Summary:        Nginx HTTP Perl module
171 Group:          Networking/Daemons/HTTP
172 Requires:       %{name} = %{version}-%{release}
173
174 %description mod_http_perl
175 Nginx HTTP Perl module.
176
177 %package mod_http_xslt_filter
178 Summary:        Nginx XSLT module
179 Group:          Daemons
180 Requires:       %{name} = %{version}-%{release}
181
182 %description mod_http_xslt_filter
183 Nginx XSLT module.
184
185 %package mod_mail
186 Summary:        Nginx mail module
187 Group:          Networking/Daemons/HTTP
188 Requires:       %{name} = %{version}-%{release}
189
190 %description mod_mail
191 Nginx mail module.
192
193 %package mod_stream
194 Summary:        Nginx stream modules
195 Group:          Daemons
196 Requires:       %{name} = %{version}-%{release}
197
198 %description mod_stream
199 Nginx stream modules.
200
201 %package -n monit-rc-nginx
202 Summary:        nginx support for monit
203 Summary(pl.UTF-8):      Wsparcie nginx dla monit
204 Group:          Applications/System
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       monit
207
208 %description -n monit-rc-nginx
209 monitrc file for monitoring nginx webserver.
210
211 %description -n monit-rc-nginx -l pl.UTF-8
212 Plik monitrc do monitorowania serwera WWW nginx.
213
214 %prep
215 %setup -q %{?with_rtmp:-a101} %{?with_modsecurity:-a22}
216 %patch0 -p0
217 %{?with_modsecurity:%patch1 -p0}
218
219 %if %{with rtmp}
220 mv nginx-rtmp-module-%{rtmp_version} nginx-rtmp-module
221 %endif
222
223 # build mime.types.conf
224 #sh %{SOURCE17} /etc/mime.types
225
226 %build
227 # NB: not autoconf generated configure
228 cp -f configure auto/
229
230 ./configure \
231         --prefix=%{_prefix} \
232         --modules-path=%{_libdir}/%{name}/modules \
233         --sbin-path=%{_sbindir}/%{name} \
234         --conf-path=%{_sysconfdir}/%{name}.conf \
235         --error-log-path=%{_localstatedir}/log/%{name}/error.log \
236         --http-log-path=%{_localstatedir}/log/%{name}/access.log \
237         --pid-path=%{_localstatedir}/run/%{name}.pid \
238         --lock-path=%{_localstatedir}/lock/subsys/%{name} \
239         --http-client-body-temp-path=%{_localstatedir}/cache/%{name}/client_body_temp \
240         --http-fastcgi-temp-path=%{_localstatedir}/cache/%{name}/fastcgi_temp \
241         --http-proxy-temp-path=%{_localstatedir}/cache/%{name}/proxy_temp \
242         --user=nginx \
243         --group=nginx \
244         %{?with_select:--with-select_module} \
245         %{?with_poll:--with-poll_module} \
246         %{?with_rtsig:--with-rtsig_module} \
247         %{?with_perl:--with-http_perl_module=dynamic} \
248         %{?with_gd:--with-http_image_filter_module=dynamic} \
249         %{?with_xslt:--with-http_xslt_module=dynamic} \
250         %{?with_geoip:--with-http_geoip_module=dynamic} \
251         %{?with_geoip:--with-stream_geoip_module=dynamic} \
252 %if %{with mail}
253         --with-mail=dynamic \
254         --with-mail_ssl_module \
255 %endif
256 %if %{with stream}
257         --with-stream=dynamic \
258         --with-stream_ssl_module \
259 %endif
260         --with-cc="%{__cc}" \
261         --with-cc-opt="%{rpmcflags}" \
262         --with-ld-opt="%{rpmldflags}" \
263         %{?with_debug:--with-debug} \
264         %{?with_addition:--with-http_addition_module} \
265         %{?with_dav:--with-http_dav_module} \
266         %{?with_flv:--with-http_flv_module} \
267         %{?with_sub:--with-http_sub_module} \
268         %{?with_realip:--with-http_realip_module} \
269         %{?with_stub_status:--with-http_stub_status_module} \
270         %{?with_ssl:--with-http_ssl_module} \
271         %{!?with_http_browser:--without-http_browser_module} \
272         %{?with_rtmp:--add-module=./nginx-rtmp-module} \
273         %{?with_auth_request:--with-http_auth_request_module} \
274         %{?with_threads:--with-threads} \
275         %{?with_http2:--with-http_v2_module} \
276         %{?with_modsecurity:--add-module=modsecurity-%{modsecurity_version}/nginx/modsecurity} \
277         --with-http_secure_link_module \
278         %{nil}
279
280 %{__make}
281
282 %if %{with modsecurity}
283 cd modsecurity-%{modsecurity_version}
284 ./autogen.sh
285 %configure \
286         --enable-standalone-module \
287         --disable-mlogc \
288         --enable-alp2 \
289         --with-lua=/usr
290 %{__make}
291 cd ..
292 %endif
293
294 %install
295 rm -rf $RPM_BUILD_ROOT
296 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d \
297         $RPM_BUILD_ROOT%{_nginxdir}/{cgi-bin,html,errors} \
298         $RPM_BUILD_ROOT%{_localstatedir}/log/{%{name},archive/%{name}} \
299         $RPM_BUILD_ROOT%{_localstatedir}/cache/%{name} \
300         $RPM_BUILD_ROOT%{_localstatedir}/lock/subsys/%{name} \
301         $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{vhosts,webapps}.d} \
302         $RPM_BUILD_ROOT/etc/{logrotate.d,monit} \
303         $RPM_BUILD_ROOT{%{systemdunitdir},/etc/systemd/system}
304
305 %{__make} install \
306         INSTALLDIRS=vendor \
307         DESTDIR=$RPM_BUILD_ROOT
308
309 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/*.default
310
311 cp -p %{_sourcedir}/%{name}.conf $RPM_BUILD_ROOT%{_sysconfdir}
312 cp -p %{_sourcedir}/%{name}.service $RPM_BUILD_ROOT%{systemdunitdir}
313 cp -p %{_sourcedir}/%{name}.monitrc $RPM_BUILD_ROOT/etc/monit
314 install -p %{SOURCE7} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
315
316 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
317 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/proxy.conf
318 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/mime.types
319 rm -r $RPM_BUILD_ROOT%{_prefix}/html
320 cp -p html/index.html $RPM_BUILD_ROOT%{_nginxdir}/html
321 cp -p html/50x.html $RPM_BUILD_ROOT%{_nginxdir}/errors
322 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_nginxdir}/html/favicon.ico
323
324 %if %{with perl}
325 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
326 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/nginx/.packlist
327 %endif
328
329 # only touch these for ghost packaging
330 touch $RPM_BUILD_ROOT%{_sysconfdir}/{fastcgi,scgi,uwsgi}.params
331
332 %clean
333 rm -rf $RPM_BUILD_ROOT
334
335 %pre
336 %groupadd -r -g 213 %{name}
337 %groupadd -g 51 http
338 %useradd -r -u 213 -d /usr/share/empty -s /bin/false -c "Nginx HTTP User" -g %{name} %{name}
339 %addusertogroup %{name} http
340
341 %post
342 for a in access.log error.log; do
343         if [ ! -f /var/log/%{name}/$a ]; then
344                 umask 022
345                 touch /var/log/%{name}/$a
346                 chown nginx:nginx /var/log/%{name}/$a
347                 chmod 644 /var/log/%{name}/$a
348         fi
349 done
350 /sbin/chkconfig --add %{name}
351 %systemd_post %{name}.service
352 %service %{name} force-reload
353
354 %preun
355 if [ "$1" = "0" ];then
356         %service %{name} stop
357         /sbin/chkconfig --del %{name}
358 fi
359 %systemd_preun %{name}.service
360
361 %postun
362 if [ "$1" = "0" ]; then
363         %userremove %{name}
364         %groupremove %{name}
365 fi
366 %systemd_reload
367
368 %triggerpostun -- %{name} < 1.8.0-2
369 # skip *this* trigger on downgrade
370 [ $1 -le 1 ] && exit 0
371 ln -sf fastcgi_params %{_sysconfdir}/fastcgi.params
372 ln -sf scgi_params %{_sysconfdir}/scgi.params
373 ln -sf uwsgi_params %{_sysconfdir}/uwsgi.params
374 exit 0
375
376 %files
377 %defattr(644,root,root,755)
378 %doc CHANGES LICENSE README html/index.html conf/nginx.conf
379 %doc %lang(ru) CHANGES.ru
380 %dir %attr(750,root,nginx) %{_sysconfdir}
381 %dir %{_nginxdir}
382 %dir %{_nginxdir}/cgi-bin
383 %dir %{_nginxdir}/html
384 %dir %{_nginxdir}/errors
385 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
386 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/proxy.conf
387 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fastcgi_params
388 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scgi_params
389 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/uwsgi_params
390 %ghost %{_sysconfdir}/fastcgi.params
391 %ghost %{_sysconfdir}/scgi.params
392 %ghost %{_sysconfdir}/uwsgi.params
393 %attr(640,root,root) %{_sysconfdir}/mime.types
394 %attr(640,root,root) %{_sysconfdir}/koi-utf
395 %attr(640,root,root) %{_sysconfdir}/koi-win
396 %attr(640,root,root) %{_sysconfdir}/win-utf
397 %dir %{_sysconfdir}/webapps.d
398 %dir %{_sysconfdir}/vhosts.d
399 %attr(750,nginx,logs) %dir /var/log/archive/%{name}
400 %attr(750,nginx,logs) /var/log/%{name}
401 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/html/*
402 %config(noreplace,missingok) %verify(not md5 mtime size) %{_nginxdir}/errors/*
403
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_sbindir}/%{name}
406 %attr(770,root,%{name}) /var/cache/%{name}
407 %attr(754,root,root) /etc/rc.d/init.d/%{name}
408 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
409 %dir %{_libdir}/%{name}
410 %dir %{_libdir}/%{name}/modules
411 %{systemdunitdir}/%{name}.service
412
413 %if %{with geoip}
414 %files mod_http_geoip
415 %defattr(644,root,root,755)
416 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_geoip_module.so
417
418 %files mod_stream_geoip
419 %defattr(644,root,root,755)
420 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_geoip_module.so
421 %endif
422
423 %if %{with gd}
424 %files mod_http_image_filter
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_image_filter_module.so
427 %endif
428
429 %if %{with perl}
430 %files mod_http_perl
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_perl_module.so
433 %dir %{perl_vendorarch}/auto/%{name}
434 %attr(755,root,root) %{perl_vendorarch}/auto/%{name}/%{name}.so
435 %{perl_vendorarch}/%{name}.pm
436 %{_mandir}/man3/nginx.3pm*
437 %endif
438
439 %if %{with xslt}
440 %files mod_http_xslt_filter
441 %defattr(644,root,root,755)
442 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_http_xslt_filter_module.so
443 %endif
444
445 %if %{with mail}
446 %files mod_mail
447 %defattr(644,root,root,755)
448 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_mail_module.so
449 %endif
450
451 %if %{with stream}
452 %files mod_stream
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_libdir}/%{name}/modules/ngx_stream_module.so
455 %endif
456
457 %files -n monit-rc-nginx
458 %defattr(644,root,root,755)
459 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.713357 seconds and 3 git commands to generate.