]> git.pld-linux.org Git - packages/netsurf.git/blob - netsurf.spec
- deleted obsolete patches
[packages/netsurf.git] / netsurf.spec
1 Summary:        Light WWW browser
2 Name:           netsurf
3 Version:        3.1
4 Release:        1
5 License:        GPL v2
6 Group:          Applications/Networking
7 Source0:        http://download.netsurf-browser.org/netsurf/releases/source/%{name}-%{version}-src.tar.gz
8 # Source0-md5:  b83932b311716054a5189f121cdd5fd4
9 Source1:        %{name}.desktop
10 Patch0:         nsfb-ldflags.patch
11 URL:            http://netsurf-browser.org/
12 BuildRequires:  SDL-devel
13 BuildRequires:  curl-devel
14 BuildRequires:  freetype-devel
15 BuildRequires:  libCSS-devel >= 0.3.0
16 BuildRequires:  libdom-devel >= 0.1.0
17 BuildRequires:  libglade2-devel
18 BuildRequires:  libhubbub-devel >= 0.3.0
19 BuildRequires:  libjpeg-devel
20 BuildRequires:  libmng-devel
21 BuildRequires:  libnsbmp-devel >= 0.1.1
22 BuildRequires:  libnsfb-devel >= 0.1.1
23 BuildRequires:  libnsgif-devel >= 0.1.1
24 BuildRequires:  libparserutils-devel >= 0.2.0
25 BuildRequires:  libpng-devel
26 BuildRequires:  librsvg-devel
27 BuildRequires:  libsvgtiny-devel >= 0.1.1
28 BuildRequires:  libwapcaplet-devel >= 0.2.1
29 BuildRequires:  netsurf-buildsystem >= 1.1
30 BuildRequires:  nsgenbind >= 0.1.0
31 BuildRequires:  perl-HTML-Parser
32 BuildRequires:  pkgconfig
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Small web browser with CSS support. NetSurf is a multi-platform
37 lightweight web browser. Its aim is to provide comprehensive rendering
38 of HTML 5 with CSS 2 in a small resource footprint while remaining
39 fast.
40
41 %package common
42 Summary:        netsurf - common files
43 Summary(pl.UTF-8):      netsurf - pliki wspólne
44 Group:          Applications/Networking
45
46 %description common
47 netsurf - common files.
48
49 %description common -l pl.UTF-8
50 netsurf - wspólne pliki.
51
52 %package gtk
53 Summary:        Netsurf browser GTK version
54 Summary(pl.UTF-8):      Wersja gtk netsurfa
55 Group:          Applications/Networking
56 Requires:       %{name}-common = %{version}-%{release}
57
58 %description gtk
59 Small web browser with CSS support. NetSurf is a multi-platform
60 lightweight web browser. Its aim is to provide comprehensive rendering
61 of HTML 5 with CSS 2 in a small resource footprint while remaining
62 fast.
63
64 This is GTK version.
65
66 %package sdl
67 Summary:        netsurf browser SDL version
68 Summary(pl.UTF-8):      Wersja SDL netsurfa
69 Group:          Applications/Networking
70 Requires:       %{name}-common = %{version}-%{release}
71
72 %description sdl
73 Small web browser with CSS support. NetSurf is a multi-platform
74 lightweight web browser. Its aim is to provide comprehensive rendering
75 of HTML 5 with CSS 2 in a small resource footprint while remaining
76 fast.
77
78 This is SDL version.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 cat << EOF > Makefile.config
85 NETSURF_FB_FONTLIB := freetype
86 NETSURF_FB_FONTPATH := %{_datadir}/fonts/TTF
87 EOF
88
89 %build
90 export CC="%{__cc}"
91 # while cxx not needed, somewhy it helps race condition on carme build
92 export CXX="%{__cxx}"
93 # silence -Werror:
94 #src/surface/vnc.c: In function 'vnc_input':
95 #src/surface/vnc.c:489:9: error: variable 'ret' set but not used [-Werror=unused-but-set-variable]
96 export CFLAGS="%{rpmcflags} -Wno-error=unused-but-set-variable"
97 export LDFLAGS="%{rpmldflags}"
98
99 # make -j1 or it won't find libwapcaplet/libwapcaplet.h
100
101 %{__make} -j1 \
102         PREFIX=%{_prefix} \
103         Q='' \
104         TARGET=gtk
105
106 %{__make} -j1 \
107         PREFIX=%{_prefix} \
108         Q='' \
109         TARGET=framebuffer
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 rm -rf $RPM_BUILD_ROOT
114 %{__make} install \
115         Q='' \
116         PREFIX=%{_prefix} \
117         TARGET=gtk \
118         DESTDIR=$RPM_BUILD_ROOT
119
120
121 %{__make} install \
122         Q='' \
123         PREFIX=%{_prefix} \
124         TARGET=framebuffer \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 # this is binary from last "make install", we install more specific binary ourself
128 %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/netsurf
129
130 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
131 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
132 install nsfb $RPM_BUILD_ROOT/%{_bindir}
133 install nsgtk $RPM_BUILD_ROOT/%{_bindir}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files common
139 %defattr(644,root,root,755)
140 %doc README
141 %dir %{_datadir}/%{name}
142 %{_datadir}/%{name}/*
143
144 %files gtk
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/nsgtk
147 %{_desktopdir}/netsurf.desktop
148
149 %files sdl
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/nsfb
This page took 0.200661 seconds and 4 git commands to generate.