]> git.pld-linux.org Git - packages/netpbm.git/commitdiff
- up to 10.35.90 auto/th/netpbm-10.35.90-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 31 Oct 2013 17:12:25 +0000 (18:12 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 31 Oct 2013 17:12:25 +0000 (18:12 +0100)
netpbm-build.patch
netpbm.spec

index f5b149d5499758900474590f8f000ce7cdb06f3d..f4ca06177b2d147cb7a8b56f511833f824a94358 100644 (file)
          
          png_init_io(pngP, ofP);
  
+--- netpbm-10.35.90/converter/other/tifftopnm.c~       2006-08-19 05:12:28.000000000 +0200
++++ netpbm-10.35.90/converter/other/tifftopnm.c        2013-10-31 17:58:49.296479893 +0100
+@@ -902,14 +902,14 @@
+                 
+                 ok = TIFFRGBAImageBegin(&img, tif, stopOnErrorFalse, emsg) ;
+                 if (!ok) {
+-                    pm_message(emsg);
++                    pm_message("%s", emsg);
+                     *statusP = CONV_FAILED;
+                 } else {
+                     int ok;
+                     ok = TIFFRGBAImageGet(&img, raster, cols, rows);
+                     TIFFRGBAImageEnd(&img) ;
+                     if (!ok) {
+-                        pm_message(emsg);
++                        pm_message("%s", emsg);
+                         *statusP = CONV_FAILED;
+                     } else {
+                         *statusP = CONV_DONE;
+--- netpbm-10.35.90/converter/other/tifftopnm.c~       2013-10-31 17:59:04.000000000 +0100
++++ netpbm-10.35.90/converter/other/tifftopnm.c        2013-10-31 18:00:05.761780998 +0100
+@@ -882,7 +882,7 @@
+         int ok;
+         ok = TIFFRGBAImageOK(tif, emsg);
+         if (!ok) {
+-            pm_message(emsg);
++            pm_message("%s", emsg);
+             *statusP = CONV_UNABLE;
+         } else {
+             uint32* raster ;
+--- netpbm-10.35.90/converter/other/fiasco/pnmtofiasco.c~      2006-08-19 05:12:28.000000000 +0200
++++ netpbm-10.35.90/converter/other/fiasco/pnmtofiasco.c       2013-10-31 18:02:13.731936837 +0100
+@@ -176,7 +176,7 @@
+       return 0;
+    else
+    {
+-      fprintf (stderr, fiasco_get_error_message ());
++      fprintf (stderr, "%s", fiasco_get_error_message ());
+       fprintf (stderr, "\n");
+       return 1;
+    }
+--- netpbm-10.35.90/converter/other/fiasco/params.c~   2006-08-19 05:12:28.000000000 +0200
++++ netpbm-10.35.90/converter/other/fiasco/params.c    2013-10-31 18:05:00.869560937 +0100
+@@ -652,7 +652,7 @@
+    fprintf (stderr, "Usage: %s [OPTION]...%s\n", progname,
+           non_opt_string ? non_opt_string : " ");
+    if (synopsis != NULL)
+-      fprintf (stderr, synopsis);
++      fprintf (stderr, "%s", synopsis);
+    fprintf (stderr, "\n\n");
+    fprintf (stderr, "Mandatory or optional arguments to long options "
+           "are mandatory or optional\nfor short options too. "
index 9406d024d2f9336a746bbb3ce22a94bb5e8e9ee8..2d8390d44af7de4f991882929828f8a3f293b4ae 100644 (file)
@@ -10,14 +10,14 @@ Summary(pt_BR.UTF-8):       Ferramentas para manipular arquivos graficos nos formatos
 Summary(ru.UTF-8):     Набор библиотек для работы с различными графическими файлами
 Summary(uk.UTF-8):     Набір бібліотек для роботи з різними графічними файлами
 Name:          netpbm
-Version:       10.35.83
-Release:       3
+Version:       10.35.90
+Release:       1
 License:       Freeware
 Group:         Libraries
 #  svn export https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable netpbm-%{version} (where version from doc/HISTORY)
 #  svn export https://netpbm.svn.sourceforge.net/svnroot/netpbm/userguide netpbm-%{version}/userguide
 Source0:       http://downloads.sourceforge.net/netpbm/%{name}-%{version}.tgz
-# Source0-md5: 00ead6b73a9755f75e135a9b9ebb5d1d
+# Source0-md5: bfa840c9285394bbb689b222e4c37d54
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 8fb174f8da02ea01bf72a9dc61be10f1
 Source2:       %{name}-docs-20030520.tar.bz2
@@ -318,28 +318,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files progs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*topam
-%attr(755,root,root) %{_bindir}/*topbm
-%attr(755,root,root) %{_bindir}/*topgm
-%attr(755,root,root) %{_bindir}/*topnm
-%attr(755,root,root) %{_bindir}/*toppm
-%attr(755,root,root) %{_bindir}/manweb
-%attr(755,root,root) %{_bindir}/pam*
-%attr(755,root,root) %{_bindir}/pbm*
-%attr(755,root,root) %{_bindir}/pgm*
-%attr(755,root,root) %{_bindir}/pnm*
-%attr(755,root,root) %{_bindir}/ppm*
-%{_mandir}/man1/*topam.1*
-%{_mandir}/man1/*topbm.1*
-%{_mandir}/man1/*topgm.1*
-%{_mandir}/man1/*topnm.1*
-%{_mandir}/man1/*toppm.1*
-%{_mandir}/man1/manweb.1*
-%{_mandir}/man1/pam*.1*
-%{_mandir}/man1/pbm*.1*
-%{_mandir}/man1/pgm*.1*
-%{_mandir}/man1/pnm*.1*
-%{_mandir}/man1/ppm*.1*
+%attr(755,root,root) %{_bindir}/*
+%{_mandir}/man1/*.1*
 %{_mandir}/man5/pam.5*
 %{_mandir}/man5/pbm.5*
 %{_mandir}/man5/pgm.5*
This page took 0.263277 seconds and 4 git commands to generate.