]> git.pld-linux.org Git - packages/net-snmp.git/blob - net-snmp.spec
Provide hrMIB data via librpm for rpm 4.16
[packages/net-snmp.git] / net-snmp.spec
1 # TODO
2 # - make noarch -n mibs-net-snmp package (need separate .spec then)
3 # - FHS: #define NETSNMP_AGENTX_SOCKET "/var/agentx/master"
4 #
5 # Conditional build:
6 %bcond_without  rpm             # RPM support
7 %bcond_with     rpm5            # Use RPM5 provided /var/cache/hrmib for hrSWInstalledTable data
8 %bcond_without  kerberos5       # Kerberos support
9 %bcond_without  lm_sensors      # LM sensors support
10 %bcond_without  perl            # Perl modules and utils
11 %bcond_without  python          # Python (3.x) modules
12 %bcond_without  python2         # Python 2.x modules
13 %bcond_without  static_libs     # static library
14
15 %ifnarch %{ix86} %{x8664} x32
16 %undefine       with_lm_sensors
17 %endif
18
19 %define         so_version      40
20 Summary:        A collection of SNMP protocol tools
21 Summary(es.UTF-8):      Agente SNMP de la UCD
22 Summary(pl.UTF-8):      Kolekcja narzędzi do obsługi protokołu SNMP
23 Summary(pt_BR.UTF-8):   Agente SNMP da UCD
24 Summary(ru.UTF-8):      Набор утилит для протокола SNMP от UC-Davis
25 Summary(uk.UTF-8):      Набір утиліт для протоколу SNMP від UC-Davis
26 Name:           net-snmp
27 Version:        5.9
28 Release:        4
29 License:        BSD-like
30 Group:          Networking/Daemons
31 Source0:        http://downloads.sourceforge.net/net-snmp/%{name}-%{version}.tar.gz
32 # Source0-md5:  382da80138897f294299badf9c62c699
33 Source1:        %{name}d.init
34 Source2:        %{name}d.conf
35 Source3:        %{name}d.sysconfig
36 Source4:        %{name}trapd.init
37 Source5:        %{name}trapd.conf
38 Source6:        %{name}trapd.sysconfig
39 Source7:        ucd-ipchains.tar.gz
40 # Source7-md5:  29949f1008f1a04d6efefd5b3ea607da
41 Source9:        snmpd.logrotate
42 Patch0:         %{name}-acfix.patch
43 Patch1:         %{name}-rpm-implicit-libs.patch
44 Patch2:         %{name}-config-noflags.patch
45 Patch3:         %{name}-manpage.patch
46 Patch4:         %{name}-link.patch
47 Patch6:         %{name}-kernel_headers.patch
48 Patch7:         %{name}-rpmpath.patch
49 Patch8:         %{name}-python.patch
50 Patch9:         %{name}-lvalue.patch
51 Patch10:        %{name}-defaultconfig.patch
52 Patch11:        %{name}-use-rpm-hrmib.patch
53 Patch12:        %{name}-TCP_STATS_CACHE_TIMEOUT.patch
54 Patch13:        %{name}-logging.patch
55 Patch14:        %{name}-Remove-U64-typedef.patch
56 Patch15:        1314610.patch
57 URL:            http://www.net-snmp.org/
58 BuildRequires:  autoconf >= 2.63
59 BuildRequires:  automake
60 BuildRequires:  elfutils-devel
61 %{?with_kerberos5:BuildRequires:        heimdal-devel}
62 BuildRequires:  libnl-devel >= 1:3.2
63 BuildRequires:  libpcap-devel
64 BuildRequires:  libssh2-devel
65 BuildRequires:  libtool >= 1.4
66 BuildRequires:  libwrap-devel
67 %{?with_lm_sensors:BuildRequires:       lm_sensors-devel >= 3.0.1}
68 BuildRequires:  ncurses-devel
69 BuildRequires:  openssl-devel >= 0.9.7d
70 BuildRequires:  pciutils-devel
71 BuildRequires:  pcre-devel
72 BuildRequires:  perl-devel >= 1:5.8.0
73 BuildRequires:  pkgconfig >= 1:0.9.0
74 %if %{with python}
75 %if %{with python2}
76 BuildRequires:  python-devel >= 1:2.5
77 BuildRequires:  python-modules >= 1:2.5
78 BuildRequires:  python-setuptools
79 %endif
80 BuildRequires:  python3-devel >= 1:3.2
81 BuildRequires:  python3-modules >= 1:3.2
82 BuildRequires:  python3-setuptools
83 BuildRequires:  rpm-pythonprov
84 %endif
85 %if %{with rpm}
86 BuildRequires:  rpm
87 BuildRequires:  rpm-perlprov >= 3.0.3-16
88 %if %{without rpm5}
89 BuildRequires:  rpm-devel
90 %endif
91 %endif
92 BuildRequires:  rpmbuild(macros) >= 1.527
93 Requires(post,preun):   /sbin/chkconfig
94 Requires:       %{name}-agent-libs = %{version}-%{release}
95 Requires:       %{name}-libs = %{version}-%{release}
96 Requires:       /usr/bin/setsid
97 Requires:       mibs-%{name} = %{version}-%{release}
98 Requires:       rc-scripts >= 0.4.3.0
99 Provides:       snmpd
100 Obsoletes:      cmu-snmp
101 Obsoletes:      snmpd
102 Obsoletes:      ucd-snmp
103 Conflicts:      pciutils < 3.1.7-5
104 Conflicts:      rpm < 4.4.9-43.11
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 # linking libraries is ugly in this package
108 %define         no_install_post_check_so        1
109
110 %define         logfile         /var/log/snmpd.log
111
112 %description
113 SNMP (Simple Network Management Protocol) is a protocol used for
114 network management (hence the name). The net-snmp project includes
115 various SNMP tools: an extensible agent, an SNMP library, tools for
116 requesting or setting information from SNMP agents, tools for
117 generating and handling SNMP traps, a version of the netstat command
118 which uses SNMP, and a Tk/Perl mib browser. This package contains the
119 snmpd daemon, documentation, etc.
120
121 %description -l es.UTF-8
122 Este paquete se deriva de la implementación del Protocolo Simple de
123 Gestión de Redes versión 2 (SNMPv2) de la Universidad Carnegie Mellon.
124 Útil para administrar redes y hacer contabilidad.
125
126 %description -l pl.UTF-8
127 SNMP (Simple Network Management Protocol) jest protokołem używanym do
128 zarządzania sieciami. Pakiet zawiera narzędzia: rozbudowywalnego
129 agenta, bibliotekę SNMP, narzędzia do odpytywania oraz ustawiania
130 informacji poprzez agentów SNMP, narzędzia do generowania i obsługi
131 pułapek SNMP, wersję komendy netstat używającą SNMP, przeglądarkę mib
132 w Tk/Perl, demona, dokumentację itp.
133
134 %description -l pt_BR.UTF-8
135 Este pacote é derivado da implementação do Protocolo Simples de
136 Gerenciamento de Redes versão 2 (SNMPv2) da Universidade Carnegie
137 Mellon. Útil para gerenciar redes e fazer contabilidade.
138
139 %description -l ru.UTF-8
140 SNMP (Simple Network Management Protocol) - это протокол, используемый
141 для управления сетью (отсюда и название). Проект net-snmp включает
142 разнообразные SNMP-утилиты: расширяемый агент, библиотека SNMP,
143 утилиты для запроса или установки информации от SNMP-агентов, утилиты
144 для генерации и обработки SNMP-трапов, версия команды netstat,
145 использующей SNMP, и mib-браузер на Tk/Perl. Этот пакет содержит
146 демоны snmpd и snmptrapd, документацию и т.д.
147
148 %description -l uk.UTF-8
149 SNMP (Simple Network Management Protocol) - це протокол, який
150 використовують для керування мережею (звідси і назва). Проект net-snmp
151 містить різноманітні SNMP-утиліти: розширюваний агент, бібліотека
152 SNMP, утиліти для запросу та встановлення інформації від NMP-агентів,
153 утиліти для генерації та обробки SNMP-трапів, версія команди netstat,
154 яка використовує SNMP, та mib-браузер на Tk/Perl. Цей пакет містить
155 демони snmpd та snmptrapd, документацію і т.і.
156
157 %package libs
158 Summary:        NET SNMP libraries
159 Summary(pl.UTF-8):      Biblioteki SNMP
160 Group:          Libraries
161 Suggests:       mibs-%{name}
162 Obsoletes:      net-snmp-compat-libs
163 Obsoletes:      ucd-snmp-libs
164
165 %description libs
166 NET SNMP libraries.
167
168 %description libs -l pl.UTF-8
169 Biblioteki SNMP.
170
171 %package agent-libs
172 Summary:        The NET-SNMP runtime agent libraries
173 Summary(pl.UTF-8):      Biblioteki uruchomieniowe agenta NET-SNMP
174 Group:          Libraries
175 Requires:       %{name}-libs = %{version}-%{release}
176
177 %description agent-libs
178 The net-snmp-agent-libs package contains the runtime agent libraries
179 for shared binaries and applications.
180
181 %description agent-libs -l pl.UTF-8
182 Ten pakiet zawiera biblioteki uruchomieniowe agenta SNMP.
183
184 %package devel
185 Summary:        The development environment for the net-snmp project
186 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo en el SNMP de la UCD
187 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek net-snmp
188 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para desenvolvimento no SNMP da UCD
189 Summary(ru.UTF-8):      Среда разработки для проекта NET-SNMP
190 Summary(uk.UTF-8):      Середовище розробки для проекту NET-SNMP
191 Group:          Development/Libraries
192 Requires:       %{name}-agent-libs = %{version}-%{release}
193 Requires:       %{name}-libs = %{version}-%{release}
194 Requires:       elfutils-devel
195 %{?with_kerberos5:Requires:     heimdal-devel}
196 Requires:       libnl-devel >= 1:3.2
197 Requires:       libwrap-devel
198 %{?with_lm_sensors:Requires:    lm_sensors-devel >= 3.0.1}
199 Requires:       openssl-devel >= 0.9.7c
200 Requires:       pciutils-devel
201 Obsoletes:      ucd-snmp-devel
202
203 %description devel
204 The ucd-snmp-devel package contains the development libraries and
205 header files for use with the net-snmp project's network management
206 tools.
207
208 %description devel -l es.UTF-8
209 Estas son las bibliotecas y archivos de inclusión para desarrollo con
210 el SNMP de la UCD. Con este paquete es posible la creación de
211 programas para uso en la gestión de redes.
212
213 %description devel -l pl.UTF-8
214 Pakiet zawiera pliki nagłówkowe i biblioteki potrzebne do rozwoju
215 aplikacji używających protokołu SNMP.
216
217 %description devel -l pt_BR.UTF-8
218 Estas são as bibliotecas e arquivos de inclusão para desenvolvimento
219 com o SNMP da UCD. Com este pacote é possível a criação de programas
220 para uso no gerenciamento de redes.
221
222 %description devel -l ru.UTF-8
223 Пакет ucd-snmp-devel содержит библиотеки разработчика и хедера для
224 использования с утилитами управления сетью проекта net-snmp.
225
226 %description devel -l uk.UTF-8
227 Пакет ucd-snmp-devel містить бібліотеки програміста та хедери для
228 використання з утилітами керування мережею проекту net-snmp.
229
230 %package static
231 Summary:        Static net-snmp libraries
232 Summary(pl.UTF-8):      Statyczne biblioteki net-snmp
233 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com ucd-snmp
234 Summary(ru.UTF-8):      Статические библиотеки для проекта net-snmp
235 Summary(uk.UTF-8):      Статичні бібліотеки для проекту net-snmp
236 Group:          Development/Libraries
237 Requires:       %{name}-devel = %{version}-%{release}
238 Obsoletes:      ucd-snmp-static
239
240 %description static
241 Static net-snmp libraries.
242
243 %description static -l pl.UTF-8
244 Statyczne biblioteki net-snmp.
245
246 %description static -l pt_BR.UTF-8
247 Bibliotecas estáticas para desenvolvimento com net-snmp.
248
249 %package compat-devel
250 Summary:        The development environment for the NET-SNMP project
251 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo en el SNMP de la UCD
252 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek NET-SNMP
253 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para desenvolvimento no SNMP da UCD
254 Summary(ru.UTF-8):      Среда разработки для проекта NET-SNMP
255 Summary(uk.UTF-8):      Середовище розробки для проекту NET-SNMP
256 Group:          Development/Libraries
257 Requires:       %{name}-devel = %{version}-%{release}
258 Requires:       openssl-devel >= 0.9.7d
259 Obsoletes:      cmu-snmp-devel
260 Obsoletes:      ucd-snmp-devel
261
262 %description compat-devel
263 The ucd-snmp-devel package contains the development libraries and
264 header files for use with the NET-SNMP project's network management
265 tools.
266
267 %description compat-devel -l es.UTF-8
268 Estas son las bibliotecas y archivos de inclusión para desarrollo con
269 el SNMP de la UCD. Con este paquete es posible la creación de
270 programas para uso en la gestión de redes.
271
272 %description compat-devel -l pl.UTF-8
273 Pakiet zawiera pliki nagłówkowe i biblioteki potrzebne do rozwoju
274 aplikacji używających protokołu SNMP.
275
276 %description compat-devel -l pt_BR.UTF-8
277 Estas são as bibliotecas e arquivos de inclusão para desenvolvimento
278 com o SNMP da UCD. Com este pacote é possível a criação de programas
279 para uso no gerenciamento de redes.
280
281 %description compat-devel -l ru.UTF-8
282 Пакет ucd-snmp-devel содержит библиотеки разработчика и хедера для
283 использования с утилитами управления сетью проекта NET-SNMP.
284
285 %description compat-devel -l uk.UTF-8
286 Пакет ucd-snmp-devel містить бібліотеки програміста та хедери для
287 використання з утилітами керування мережею проекту NET-SNMP.
288
289 %package compat-static
290 Summary:        Static NET-SNMP libraries
291 Summary(pl.UTF-8):      Statyczne biblioteki NET-SNMP
292 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com ucd-snmp
293 Summary(ru.UTF-8):      Статические библиотеки для проекта NET-SNMP
294 Summary(uk.UTF-8):      Статичні бібліотеки для проекту NET-SNMP
295 Group:          Development/Libraries
296 Requires:       %{name}-compat-devel = %{version}-%{release}
297 Obsoletes:      ucd-snmp-static
298
299 %description compat-static
300 Static NET-SNMP libraries.
301
302 %description compat-static -l pl.UTF-8
303 Statyczne biblioteki NET-SNMP.
304
305 %description compat-static -l pt_BR.UTF-8
306 Bibliotecas estáticas para desenvolvimento com ucd-snmp.
307
308 %package -n mibs-net-snmp
309 Summary:        Net-SNMP provided MIBs
310 Summary(pl.UTF-8):      Baza danych MIB
311 Group:          Applications/System
312 Requires:       mibs-dirs
313 Obsoletes:      net-snmp-mibs
314 Conflicts:      ucd-snmp-libs
315 BuildArch:      noarch
316
317 %description -n mibs-net-snmp
318 Net-SNMP provided MIBs (Management Information Base).
319
320 %description -n mibs-net-snmp -l pl.UTF-8
321 Baza danych MIB.
322
323 %package snmptrapd
324 Summary:        SNMP trap daemon
325 Summary(pl.UTF-8):      Demon obsługujący pułapki SNMP
326 Group:          Applications/System
327 Requires(post,preun):   /sbin/chkconfig
328 Requires:       %{name} = %{version}-%{release}
329 Requires:       rc-scripts >= 0.2.0
330 Obsoletes:      cmu-snmp-utils
331 Obsoletes:      ucd-snmp-snmptrapd
332
333 %description snmptrapd
334 The ucd-snmp-snmptrapd package contains snmp trap daemon.
335
336 %description snmptrapd -l pl.UTF-8
337 Pakiet zawiera demon obsługujący pułapki SNMP.
338
339 %package utils
340 Summary:        Network management utilities using SNMP, from the NET-SNMP project
341 Summary(es.UTF-8):      Utilitarios del SNMP de la UCD
342 Summary(pl.UTF-8):      Narzędzia używające protokołu SNMP
343 Summary(pt_BR.UTF-8):   Utilitários do SNMP da UCD
344 Summary(ru.UTF-8):      Утилиты управления сетью по SNMP из проекта NET-SNMP
345 Summary(uk.UTF-8):      Утиліти керування мережею по SNMP з проекту NET-SNMP
346 Group:          Applications/System
347 Requires:       %{name}-libs = %{version}-%{release}
348 Requires:       %{name}-agent-libs = %{version}-%{release}
349 Suggests:       mibs-%{name} = %{version}-%{release}
350 Obsoletes:      cmu-snmp-utils
351 Obsoletes:      ucd-snmp-utils
352
353 %description utils
354 This package contains various utilities for managing your network
355 using the SNMP protocol.
356
357 %description utils -l es.UTF-8
358 Varios utilitarios para uso con el SNMP de la UCD. Contiene
359 utilitarios como: snmpwalk, snmptest y otros.
360
361 %description utils -l pl.UTF-8
362 Różnego rodzaju narzędzia do zarządzania siecią przy użyciu protokołu
363 SNMP.
364
365 %description utils -l pt_BR.UTF-8
366 Vários utilitários para uso com o SNMP da UCD. Contém utilitários
367 como: snmpwalk, snmptest e outros.
368
369 %description utils -l ru.UTF-8
370 Пакет ucd-snmp-utils содержит разнообразные утилиты для использования
371 в проекте управления сетью net-snmp.
372
373 %description utils -l uk.UTF-8
374 Пакет ucd-snmp-utils містить різноманітні утиліти для використання в
375 проекті керування мережею net-snmp.
376
377 %package -n perl-SNMP
378 Summary:        SNMP and NetSNMP::* Perl modules
379 Summary(pl.UTF-8):      Moduły Perla SNMP oraz NetSNMP::*
380 Group:          Development/Languages/Perl
381 Requires:       %{name}-agent-libs = %{version}-%{release}
382 Requires:       %{name}-libs = %{version}-%{release}
383 Conflicts:      ucd-snmp-utils-perl
384
385 %description -n perl-SNMP
386 SNMP and NetSNMP::* Perl modules - Perl interface to net-snmp.
387
388 %description -n perl-SNMP -l pl.UTF-8
389 Moduły Perla SNMP oraz NetSNMP::* - perlowy interfejs do net-snmp.
390
391 %package utils-perl
392 Summary:        Perl utilities for network management using SNMP
393 Summary(pl.UTF-8):      Perlowe narzędzia używające protokołu SNMP
394 Group:          Applications/System
395 Requires:       perl-SNMP = %{version}-%{release}
396 Obsoletes:      cmu-snmp-utils
397 Obsoletes:      ucd-snmp-utils-perl
398
399 %description utils-perl
400 This package contains various Perl utilities for managing your network
401 using the SNMP protocol.
402
403 %description utils-perl -l pl.UTF-8
404 Perlowe narzędzia do zarządzania siecią przy użyciu protokołu SNMP.
405
406 %package snmpconf
407 Summary:        snmpconf - creating and modifying SNMP configuration files
408 Summary(pl.UTF-8):      snmpconf - tworzenie i modyfikowanie plików konfiguracyjnych SNMP
409 Group:          Applications/System
410 Requires:       %{name} = %{version}-%{release}
411 Requires:       perl-SNMP = %{version}-%{release}
412
413 %description snmpconf
414 snmpconf is a simple Perl script that walks you through setting up a
415 configuration file step by step. It should be fairly straight forward
416 to use.
417
418 %description snmpconf -l pl.UTF-8
419 snmpconf to prosty skrypt Perla pozwalający na tworzenie pliku
420 konfiguracyjnego krok po kroku. Powinien być w miarę prosty w użyciu.
421
422 %package tkmib
423 Summary:        MIB browser in Tk
424 Summary(pl.UTF-8):      Przeglądarka MIB-ów w Tk
425 Group:          Applications/System
426 Requires:       perl-SNMP = %{version}-%{release}
427 Requires:       perl-Tk
428
429 %description tkmib
430 MIB browser in Tk.
431
432 %description tkmib -l pl.UTF-8
433 Przeglądarka MIB-ów w Tk.
434
435 %package -n python-netsnmp
436 Summary:        Python 2 netsnmp extension module
437 Summary(pl.UTF-8):      Moduł rozszerzenia netsnmp dla Pythona 2
438 Group:          Libraries/Python
439 Requires:       %{name}-libs = %{version}-%{release}
440
441 %description -n python-netsnmp
442 The 'netsnmp' Python extension module provides a full featured,
443 tri-lingual SNMP (SNMPv3, SNMPv2c, SNMPv1) client API.
444
445 %description -n python-netsnmp -l pl.UTF-8
446 Moduł rozszerzenia netsnmp dla Pythona udostępnia pełne API klienckie
447 SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
448
449 %package -n python3-netsnmp
450 Summary:        Python 3 netsnmp extension module
451 Summary(pl.UTF-8):      Moduł rozszerzenia netsnmp dla Pythona 3
452 Group:          Libraries/Python
453 Requires:       %{name}-libs = %{version}-%{release}
454
455 %description -n python3-netsnmp
456 The 'netsnmp' Python extension module provides a full featured,
457 tri-lingual SNMP (SNMPv3, SNMPv2c, SNMPv1) client API.
458
459 %description -n python3-netsnmp -l pl.UTF-8
460 Moduł rozszerzenia netsnmp dla Pythona udostępnia pełne API klienckie
461 SNMP dla trzech wersji tego protokołu (SNMPv3, SNMPv2c, SNMPv1).
462
463 %prep
464 %setup -q -a7
465 %patch1 -p1
466 %patch2 -p1
467 %patch3 -p1
468 %patch4 -p1
469 %patch6 -p1
470 %patch7 -p1
471 %patch8 -p1
472 %patch9 -p1
473 %patch10 -p1
474 %if %{with rpm5}
475 %patch11 -p1
476 %endif
477 %patch12 -p1
478 %patch13 -p1
479 %patch14 -p1
480 %patch15 -p1
481
482 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' \
483       perl/SNMP/examples/pingmib.pl
484
485 %build
486 %{__libtoolize}
487 %{__aclocal} -I m4
488 %{__autoconf}
489 %{__autoheader}
490
491 MIBS="\
492 host agentx smux \
493 mibII/mta_sendmail \
494 disman/event disman/schedule \
495 ucd-snmp/diskio \
496 target \
497 misc/ipfwacc \
498 "
499
500 %if %{with lm_sensors}
501 MIBS="$MIBS ucd-snmp/lmsensorsMib"
502 %endif
503
504 # ksm must be first in --with-security-modules
505 # usm is always enabled
506 %configure \
507         ac_cv_path_DPKG_QUERY_PATH= \
508         --enable-as-needed \
509         %{__disable static_libs static} \
510         --with-cflags="%{rpmcflags} %{rpmcppflags} -I/usr/include/et" \
511         --with-ldflags="%{rpmldflags}" \
512         --with-defaults \
513         --with-default-snmp-version=3 \
514         %{__with_without kerberos5 krb5} \
515         --with-openssl \
516         --with-libwrap \
517         --with-logfile=%{logfile} \
518         --with-zlib\
519         --with-bzip2 \
520         --with-nl \
521         %{__with_without perl perl-modules} \
522         %{__with_without python python-modules} \
523         --enable-local-smux \
524         --with-mibdirs='$HOME/.snmp/mibs:/usr/share/mibs' \
525         --with-mib-modules="$MIBS" \
526         --with-security-modules="%{?with_kerberos5:ksm }tsm" \
527         --with-sys-contact="root@localhost" \
528         --with-sys-location="Unknown" \
529         --with-transports="UDP UDPIPv6 TCP TCPIPv6 Unix Callback Alias DTLSUDP TLSTCP SSH" \
530         --with-persistent-directory="/var/lib/net-snmp" \
531         --enable-ucd-snmp-compatibility \
532         --enable-ipv6 \
533         %{!?debug:--disable-debugging} \
534         %{__with_without rpm}
535
536 %{__make} -j1
537
538 TOPDIR="$(pwd)"
539
540 cd perl
541 %{__perl} -I. Makefile.PL \
542         -NET-SNMP-CONFIG="${TOPDIR}/net-snmp-config" \
543         -NET-SNMP-IN-SOURCE=true \
544         INSTALLDIRS=vendor \
545         OPTIMIZE="%{rpmcflags} %{rpmcppflags}" \
546         </dev/null
547
548 # avoid rpaths generated by MakeMaker
549 %{__perl} -pi -e 's@LD_RUN_PATH="\$\(LD_RUN_PATH\)" @@' */Makefile */*/Makefile
550
551 %{__make} \
552         LDFLAGS="%{rpmldflags} -L${TOPDIR}/snmplib/.libs/ -L${TOPDIR}/agent/.libs/"
553 cd ..
554
555 %if %{with python2}
556 cd python
557 %py_build \
558         --basedir=$TOPDIR
559 cd ..
560 %endif
561
562 %install
563 rm -rf $RPM_BUILD_ROOT
564 install -d $RPM_BUILD_ROOT{/etc/{rc.d/init.d,logrotate.d,sysconfig,snmp},/var/log,/var/lib/net-snmp,%{_libdir}/snmp/dlmod}
565
566 %{__make} -j1 install \
567         mibdir=%{_datadir}/mibs \
568         DESTDIR=$RPM_BUILD_ROOT
569
570 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
571 :> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.local.conf
572 :> $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmp.conf
573 :> $RPM_BUILD_ROOT%{logfile}
574
575 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmpd
576 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmpd.conf
577 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/snmpd
578
579 install -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/snmptrapd
580 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/snmp/snmptrapd.conf
581 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/snmptrapd
582
583 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/logrotate.d/snmpd
584
585 cd perl
586 %{__make} -j1 install \
587         DESTDIR=$RPM_BUILD_ROOT
588
589 install -d $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
590 install -p SNMP/examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/perl-SNMP-%{version}
591 cd ..
592
593 # IP-Filter (non-Linux)
594 %{__rm} $RPM_BUILD_ROOT%{_bindir}/ipf-mod.pl
595
596 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Bundle/MakefileSubs.pm
597 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
598 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Bundle/NetSNMP/.packlist
599
600 %if %{with static_libs}
601 # hack: convert DynaLoader.a inside .a file to .o, as strip(1) would otherwise say invalid argument
602 for a in $RPM_BUILD_ROOT%{_libdir}/libnet*.a; do
603         rm -f *.o *.a
604         ar x $a DynaLoader.a
605         if [ -f DynaLoader.a ]; then
606                 ar x DynaLoader.a
607                 ar cr $a DynaLoader.o
608                 ar d $a DynaLoader.a
609                 # remove second file too
610                 ar d $a DynaLoader.a
611         fi
612 done
613 %else
614 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsnmp.a
615 %endif
616
617 %if %{with python}
618 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitedir}/netsnmp/tests
619 %endif
620
621 %if %{with python2}
622 cd python
623 %py_install \
624         --basedir=$TOPDIR
625 cd ..
626
627 %{__rm} -r $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/tests
628 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/netsnmp/*.py
629 %endif
630
631 %clean
632 rm -rf $RPM_BUILD_ROOT
633
634 %post
635 touch %{logfile}
636 chmod 640 %{logfile}
637 /sbin/chkconfig --add snmpd
638 %service snmpd restart "snmpd daemon"
639
640 %preun
641 if [ "$1" = "0" ]; then
642         %service snmpd stop
643         /sbin/chkconfig --del snmpd
644 fi
645
646 %post   libs -p /sbin/ldconfig
647 %postun libs -p /sbin/ldconfig
648
649 %post   agent-libs -p /sbin/ldconfig
650 %postun agent-libs -p /sbin/ldconfig
651
652 %triggerpostun -- ucd-snmp
653 /sbin/chkconfig --add snmpd
654
655 %post snmptrapd
656 touch %{logfile}
657 chmod 640 %{logfile}
658 /sbin/chkconfig --add snmptrapd
659 %service snmptrapd restart "snmp trap daemon"
660
661 %preun snmptrapd
662 if [ "$1" = "0" ]; then
663         %service snmptrapd stop
664         /sbin/chkconfig --del snmptrapd
665 fi
666
667 %triggerpostun snmptrapd -- ucd-snmp-snmptrapd
668 /sbin/chkconfig --add snmptrapd
669
670 %files
671 %defattr(644,root,root,755)
672 %doc AGENT.txt CHANGES COPYING ChangeLog EXAMPLE.conf{,.def} FAQ NEWS README{,.agent-mibs,.agentx,.snmpv3,.sql,.thread} TODO local
673
674 %attr(754,root,root) /etc/rc.d/init.d/snmpd
675 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/snmpd
676 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/snmpd
677
678 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmpd.conf
679 %attr(640,root,root) %config(missingok,noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmpd.local.conf
680
681 %attr(755,root,root) %{_sbindir}/snmpd
682 %attr(755,root,root) %{_bindir}/net-snmp-create-v3-user
683 %attr(755,root,root) %{_bindir}/sshtosnmp
684 %dir %{_libdir}/snmp
685 %dir %{_libdir}/snmp/dlmod
686 %attr(755,root,root) %{_datadir}/snmp/snmp_perl.pl
687 %{_mandir}/man1/net-snmp-create-v3-user.1*
688 %{_mandir}/man5/snmpd.conf.5*
689 %{_mandir}/man5/snmpd.examples.5*
690 %{_mandir}/man5/snmpd.internal.5*
691 %{_mandir}/man5/variables.5*
692 %{_mandir}/man8/snmpd.8*
693
694 %dir %attr(700,root,root) /var/lib/net-snmp
695
696 %attr(640,root,root) %ghost %{logfile}
697
698 %files libs
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/libnetsnmp.so.*.*.*
701 %attr(755,root,root) %ghost %{_libdir}/libnetsnmp.so.%{so_version}
702 %dir %{_sysconfdir}/snmp
703 %dir %{_datadir}/snmp
704
705 %files agent-libs
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/libnetsnmpagent.so.*.*.*
708 %attr(755,root,root) %ghost %{_libdir}/libnetsnmpagent.so.%{so_version}
709 %attr(755,root,root) %{_libdir}/libnetsnmphelpers.so.*.*.*
710 %attr(755,root,root) %ghost %{_libdir}/libnetsnmphelpers.so.%{so_version}
711 %attr(755,root,root) %{_libdir}/libnetsnmpmibs.so.*.*.*
712 %attr(755,root,root) %ghost %{_libdir}/libnetsnmpmibs.so.%{so_version}
713 %attr(755,root,root) %{_libdir}/libnetsnmptrapd.so.*.*.*
714 %attr(755,root,root) %ghost %{_libdir}/libnetsnmptrapd.so.%{so_version}
715
716 %files devel
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_bindir}/mib2c
719 %attr(755,root,root) %{_bindir}/mib2c-update
720 %attr(755,root,root) %{_bindir}/net-snmp-config
721 %attr(755,root,root) %{_libdir}/libnetsnmp.so
722 %attr(755,root,root) %{_libdir}/libnetsnmpagent.so
723 %attr(755,root,root) %{_libdir}/libnetsnmphelpers.so
724 %attr(755,root,root) %{_libdir}/libnetsnmpmibs.so
725 %attr(755,root,root) %{_libdir}/libnetsnmptrapd.so
726 %{_libdir}/libnetsnmp.la
727 %{_libdir}/libnetsnmpagent.la
728 %{_libdir}/libnetsnmphelpers.la
729 %{_libdir}/libnetsnmpmibs.la
730 %{_libdir}/libnetsnmptrapd.la
731 %{_includedir}/net-snmp
732 %{_pkgconfigdir}/netsnmp.pc
733 %{_pkgconfigdir}/netsnmp-agent.pc
734 %{_datadir}/snmp/mib2c*
735 %{_mandir}/man1/mib2c.1*
736 %{_mandir}/man1/mib2c-update.1*
737 %{_mandir}/man1/net-snmp-config.1*
738 %{_mandir}/man3/[!NS]*
739 %{_mandir}/man5/mib2c.conf.5*
740
741 %if %{with static_libs}
742 %files static
743 %defattr(644,root,root,755)
744 %{_libdir}/libnetsnmp.a
745 %{_libdir}/libnetsnmpagent.a
746 %{_libdir}/libnetsnmphelpers.a
747 %{_libdir}/libnetsnmpmibs.a
748 %{_libdir}/libnetsnmptrapd.a
749 %endif
750
751 %files compat-devel
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_libdir}/libsnmp.so
754 %{_libdir}/libsnmp.la
755 %{_includedir}/ucd-snmp
756
757 %if %{with static_libs}
758 %files compat-static
759 %defattr(644,root,root,755)
760 %{_libdir}/libsnmp.a
761 %endif
762
763 %files -n mibs-net-snmp
764 %defattr(644,root,root,755)
765 %{_datadir}/mibs/*.txt
766
767 %files snmptrapd
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_sbindir}/snmptrapd
770 %attr(754,root,root) /etc/rc.d/init.d/snmptrapd
771 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/snmptrapd
772 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmptrapd.conf
773 %if %{with perl}
774 %attr(755,root,root) %{_datadir}/snmp/snmp_perl_trapd.pl
775 %endif
776 %{_mandir}/man5/snmptrapd.conf.5*
777 %{_mandir}/man8/snmptrapd.8*
778
779 %files utils
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_bindir}/agentxtrap
782 %attr(755,root,root) %{_bindir}/encode_keychange
783 %attr(755,root,root) %{_bindir}/snmpbulkget
784 %attr(755,root,root) %{_bindir}/snmpbulkwalk
785 %attr(755,root,root) %{_bindir}/snmpdelta
786 %attr(755,root,root) %{_bindir}/snmpdf
787 %attr(755,root,root) %{_bindir}/snmpget
788 %attr(755,root,root) %{_bindir}/snmpgetnext
789 %attr(755,root,root) %{_bindir}/snmpinform
790 %attr(755,root,root) %{_bindir}/snmpnetstat
791 %attr(755,root,root) %{_bindir}/snmppcap
792 %attr(755,root,root) %{_bindir}/snmpping
793 %attr(755,root,root) %{_bindir}/snmpps
794 %attr(755,root,root) %{_bindir}/snmpset
795 %attr(755,root,root) %{_bindir}/snmpstatus
796 %attr(755,root,root) %{_bindir}/snmptable
797 %attr(755,root,root) %{_bindir}/snmptest
798 %attr(755,root,root) %{_bindir}/snmptls
799 %attr(755,root,root) %{_bindir}/snmptop
800 %attr(755,root,root) %{_bindir}/snmptranslate
801 %attr(755,root,root) %{_bindir}/snmptrap
802 %attr(755,root,root) %{_bindir}/snmpusm
803 %attr(755,root,root) %{_bindir}/snmpvacm
804 %attr(755,root,root) %{_bindir}/snmpwalk
805 %{_mandir}/man1/agentxtrap.1*
806 %{_mandir}/man1/encode_keychange.1*
807 %{_mandir}/man1/snmpbulkget.1*
808 %{_mandir}/man1/snmpbulkwalk.1*
809 %{_mandir}/man1/snmpcmd.1*
810 %{_mandir}/man1/snmpdelta.1*
811 %{_mandir}/man1/snmpdf.1*
812 %{_mandir}/man1/snmpget.1*
813 %{_mandir}/man1/snmpgetnext.1*
814 %{_mandir}/man1/snmpinform.1*
815 %{_mandir}/man1/snmpnetstat.1*
816 %{_mandir}/man1/snmpps.1*
817 %{_mandir}/man1/snmpset.1*
818 %{_mandir}/man1/snmpstatus.1*
819 %{_mandir}/man1/snmptable.1*
820 %{_mandir}/man1/snmptest.1*
821 %{_mandir}/man1/snmptop.1*
822 %{_mandir}/man1/snmptranslate.1*
823 %{_mandir}/man1/snmptrap.1*
824 %{_mandir}/man1/snmpusm.1*
825 %{_mandir}/man1/snmpvacm.1*
826 %{_mandir}/man1/snmpwalk.1*
827 %{_mandir}/man5/snmp.conf.5*
828 %{_mandir}/man5/snmp_config.5*
829
830 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/snmp/snmp.conf
831
832 %if %{with perl}
833 %files -n perl-SNMP
834 %defattr(644,root,root,755)
835 %doc perl/SNMP/{BUG,README,TODO} perl/SNMP/examples
836 %{perl_vendorarch}/SNMP.pm
837 %{perl_vendorarch}/NetSNMP
838 %dir %{perl_vendorarch}/auto/SNMP
839 %{perl_vendorarch}/auto/SNMP/autosplit.ix
840 %attr(755,root,root) %{perl_vendorarch}/auto/SNMP/SNMP.so
841 %dir %{perl_vendorarch}/auto/NetSNMP
842 %dir %{perl_vendorarch}/auto/NetSNMP/*
843 %{perl_vendorarch}/auto/NetSNMP/*/autosplit.ix
844 %attr(755,root,root) %{perl_vendorarch}/auto/NetSNMP/*/*.so
845 %dir %{perl_vendorarch}/auto/NetSNMP/agent/default_store
846 %{perl_vendorarch}/auto/NetSNMP/agent/default_store/autosplit.ix
847 %attr(755,root,root) %{perl_vendorarch}/auto/NetSNMP/agent/default_store/default_store.so
848 %{_mandir}/man3/NetSNMP::*.3*
849 %{_mandir}/man3/SNMP.3*
850 %{_examplesdir}/perl-SNMP-%{version}
851
852 %files utils-perl
853 %defattr(644,root,root,755)
854 %attr(755,root,root) %{_bindir}/checkbandwidth
855 %attr(755,root,root) %{_bindir}/fixproc
856 %attr(755,root,root) %{_bindir}/net-snmp-cert
857 %attr(755,root,root) %{_bindir}/snmp-bridge-mib
858 %attr(755,root,root) %{_bindir}/snmpcheck
859 %attr(755,root,root) %{_bindir}/traptoemail
860 %{_mandir}/man1/fixproc.1*
861 %{_mandir}/man1/snmp-bridge-mib.1*
862 %{_mandir}/man1/traptoemail.1*
863 %endif
864
865 %files snmpconf
866 %defattr(644,root,root,755)
867 %attr(755,root,root) %{_bindir}/snmpconf
868 %{_mandir}/man1/snmpconf.1*
869 %{_datadir}/snmp/snmpconf-data
870
871 %if %{with perl}
872 %files tkmib
873 %defattr(644,root,root,755)
874 %attr(755,root,root) %{_bindir}/tkmib
875 %{_mandir}/man1/tkmib.1*
876 %endif
877
878 %if %{with python2}
879 %files -n python-netsnmp
880 %defattr(644,root,root,755)
881 %dir %{py_sitedir}/netsnmp
882 %attr(755,root,root) %{py_sitedir}/netsnmp/client_intf.so
883 %{py_sitedir}/netsnmp/*.py[co]
884 %{py_sitedir}/netsnmp_python-*.egg-info
885 %endif
886
887 %if %{with python}
888 %files -n python3-netsnmp
889 %defattr(644,root,root,755)
890 %dir %{py3_sitedir}/netsnmp
891 %attr(755,root,root) %{py3_sitedir}/netsnmp/client_intf.cpython-*.so
892 %{py3_sitedir}/netsnmp/*.py
893 %{py3_sitedir}/netsnmp/__pycache__
894 %{py3_sitedir}/netsnmp_python-*.egg-info
895 %endif
This page took 0.153112 seconds and 3 git commands to generate.