]> git.pld-linux.org Git - packages/neovim.git/blob - neovim.spec
d9d146be682100b1e2abf4649063197b04990597
[packages/neovim.git] / neovim.spec
1 # TODO
2 # - -rt subpackage? -lang subpackage?
3 #
4 # Conditional build:
5 %bcond_with     lua             # LUA
6
7 Summary:        Vim-fork focused on extensibility and agility
8 Name:           neovim
9 Version:        0.1.5
10 Release:        0.4
11 License:        Apache v2.0
12 Group:          Applications/Editors/Vim
13 Source0:        https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
14 URL:            https://neovim.io/
15 Source1:        %{name}.desktop
16 Source2:        %{name}.svg
17 BuildRequires:  cmake >= 2.8.7
18 BuildRequires:  fdupes
19 BuildRequires:  gcc >= 6:4.4
20 BuildRequires:  hicolor-icon-theme
21 BuildRequires:  jemalloc-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtermkey-devel
24 BuildRequires:  libuv-devel
25 BuildRequires:  libvterm-devel
26 BuildRequires:  msgpack-devel >= 1.1.0
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.596
29 BuildRequires:  unibilium-devel
30 %if %{with lua}
31 BuildRequires:  lua-lpeg
32 BuildRequires:  lua-mpack >= 1.0.2
33 BuildRequires:  lua51-BitOp
34 BuildRequires:  luajit-devel
35 %endif
36 Requires:       desktop-file-utils
37 Requires:       gtk-update-icon-cache
38 Requires:       hicolor-icon-theme
39 Suggests:       python-neovim
40 Suggests:       python3-neovim
41 Suggests:       xsel
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 # gcc 4.0 and better turn on _FORTIFY_SOURCE=2 automatically. This currently
45 # does not work with Neovim due to some uses of dynamically-sized structures.
46 # See https://github.com/neovim/neovim/issues/223 for details.
47 %define         filterout_c     -Wp,-D_FORTIFY_SOURCE=2
48
49 %description
50 Neovim is a refactor - and sometimes redactor - in the tradition of
51 Vim, which itself derives from Stevie. It is not a rewrite, but a
52 continuation and extension of Vim. Many rewrites, clones, emulators
53 and imitators exist; some are very clever, but none are Vim. Neovim
54 strives to be a superset of Vim, notwithstanding some intentionally
55 removed misfeatures; excepting those few and carefully-considered
56 excisions, Neovim is Vim. It is built for users who want the good
57 parts of Vim, without compromise, and more.
58
59 %prep
60 %setup -q
61
62 %build
63 install -d .deps build
64 cd .deps
65 %cmake \
66         -DUSE_BUNDLED=OFF \
67         -DUSE_BUNDLED_JEMALLOC=OFF \
68         -DUSE_BUNDLED_UNIBILIUM=OFF \
69         -DUSE_BUNDLED_LIBTERMKEY=OFF \
70         -DUSE_BUNDLED_LIBVTERM=OFF \
71         -DUSE_BUNDLED_LIBUV=OFF \
72         -DUSE_BUNDLED_MSGPACK=OFF \
73         -DUSE_BUNDLED_LUAJIT=ON \
74         -DUSE_BUNDLED_LUAROCKS=ON \
75         -DUSE_BUNDLED_LUV=ON \
76         ../third-party
77 %{__make}
78
79 cd ../build
80 %cmake \
81         -DLUA_PRG=/usr/bin/luajit \
82         -DENABLE_JEMALLOC=ON \
83         -DLUAJIT_USE_BUNDLED=OFF \
84         -DLIBUV_USE_BUNDLED=OFF \
85         -DMSGPACK_USE_BUNDLED=OFF \
86         -DUNIBILIUM_USE_BUNDLED=OFF \
87         -DLIBTERMKEY_USE_BUNDLED=OFF \
88         -DLIBVTERM_USE_BUNDLED=OFF \
89         -DJEMALLOC_USE_BUNDLED=OFF \
90         ..
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 %{__make} -C build install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_iconsdir}/hicolor/scalable/apps}
100 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/neovim.desktop
101 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/neovim.svg
102
103 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/cs.cp1250
104 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.euc-jp
105 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ja.sjis
106 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ko.UTF-8
107 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/no
108 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/pl.UTF-8
109 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/pl.cp1250
110 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru.cp1251
111 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sk.cp1250
112 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/uk.cp1251
113 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.UTF-8
114 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_CN.cp936
115 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/zh_TW.UTF-8
116
117 %find_lang nvim
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 %update_desktop_database
124 %update_icon_cache hicolor
125 %banner -e -o %{name} << 'EOF'
126
127 The Neovim executable is called 'nvim'. To use your existing Vim
128 configuration:
129     ln -s ~/.vim ~/.config/nvim
130     ln -s ~/.vimrc ~/.config/nvim/init.vim
131 See ':help nvim' for more information on Neovim.
132
133 If you want support for Python plugins such as YouCompleteMe, you need
134 to install a Python module in addition to Neovim itself.
135
136 See ':help provider-python' or this page for more information:
137     http://neovim.io/doc/user/provider.html
138
139 If you have any questions, have a look at:
140     https://github.com/neovim/neovim/wiki/FAQ.
141 EOF
142
143 %postun
144 %update_desktop_database
145 %update_icon_cache hicolor
146
147 %files -f nvim.lang
148 %defattr(644,root,root,755)
149 %doc BACKERS.md CONTRIBUTING.md LICENSE README.md
150 %attr(755,root,root) %{_bindir}/nvim
151 %{_datadir}/nvim
152 %{_desktopdir}/%{name}.desktop
153 %{_iconsdir}/hicolor/*/apps/%{name}.svg
154 %{_mandir}/man1/nvim.1*
This page took 0.048421 seconds and 2 git commands to generate.