]> git.pld-linux.org Git - packages/neovim.git/blob - neovim.spec
26ecdf74f58dbf40042b5a1aaf588dd534ccb44a
[packages/neovim.git] / neovim.spec
1 # TODO
2 # - -rt subpackage? -lang subpackage?
3 #
4 # Conditional build:
5 %bcond_with     lua             # LUA
6
7 Summary:        Vim-fork focused on extensibility and agility
8 Name:           neovim
9 Version:        0.1.5
10 Release:        0.4
11 License:        Apache v2.0
12 Group:          Applications/Editors/Vim
13 Source0:        https://github.com/neovim/neovim/archive/v%{version}/%{name}-%{version}.tar.gz
14 URL:            https://neovim.io/
15 Source1:        %{name}.desktop
16 Source2:        %{name}.svg
17 BuildRequires:  cmake >= 2.8.7
18 BuildRequires:  fdupes
19 BuildRequires:  gcc >= 6:4.4
20 BuildRequires:  hicolor-icon-theme
21 BuildRequires:  jemalloc-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtermkey-devel
24 BuildRequires:  libuv-devel
25 BuildRequires:  libvterm-devel
26 BuildRequires:  msgpack-devel >= 1.1.0
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.596
29 BuildRequires:  unibilium-devel
30 %if %{with lua}
31 BuildRequires:  lua-lpeg
32 BuildRequires:  lua-mpack >= 1.0.2
33 BuildRequires:  lua51-BitOp
34 BuildRequires:  luajit-devel
35 %endif
36 Requires:       desktop-file-utils
37 Requires:       gtk-update-icon-cache
38 Requires:       hicolor-icon-theme
39 Suggests:       python-neovim
40 Suggests:       python3-neovim
41 Suggests:       xsel
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Neovim is a refactor - and sometimes redactor - in the tradition of
46 Vim, which itself derives from Stevie. It is not a rewrite, but a
47 continuation and extension of Vim. Many rewrites, clones, emulators
48 and imitators exist; some are very clever, but none are Vim. Neovim
49 strives to be a superset of Vim, notwithstanding some intentionally
50 removed misfeatures; excepting those few and carefully-considered
51 excisions, Neovim is Vim. It is built for users who want the good
52 parts of Vim, without compromise, and more.
53
54 %prep
55 %setup -q
56
57 %if 0
58 # Remove __DATE__ and __TIME__.
59 BUILD_TIME=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{H}:%{M}')
60 BUILD_DATE=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{b} %{d} %{Y}')
61 sed -i "s/__TIME__/\"$BUILD_TIME\"/" $(grep -rl '__TIME__')
62 sed -i "s/__DATE__/\"$BUILD_DATE\"/" $(grep -rl '__DATE__')
63 %endif
64
65 %build
66 install -d .deps build
67 cd .deps
68 %cmake \
69         -DUSE_BUNDLED=OFF \
70         -DUSE_BUNDLED_JEMALLOC=OFF \
71         -DUSE_BUNDLED_UNIBILIUM=OFF \
72         -DUSE_BUNDLED_LIBTERMKEY=OFF \
73         -DUSE_BUNDLED_LIBVTERM=OFF \
74         -DUSE_BUNDLED_LIBUV=OFF \
75         -DUSE_BUNDLED_MSGPACK=OFF \
76         -DUSE_BUNDLED_LUAJIT=ON \
77         -DUSE_BUNDLED_LUAROCKS=ON \
78         -DUSE_BUNDLED_LUV=ON \
79         ../third-party
80 %{__make}
81
82 cd ../build
83 %cmake \
84         -DLUA_PRG=/usr/bin/luajit \
85         -DENABLE_JEMALLOC=ON \
86         -DLUAJIT_USE_BUNDLED=OFF \
87         -DLIBUV_USE_BUNDLED=OFF \
88         -DMSGPACK_USE_BUNDLED=OFF \
89         -DUNIBILIUM_USE_BUNDLED=OFF \
90         -DLIBTERMKEY_USE_BUNDLED=OFF \
91         -DLIBVTERM_USE_BUNDLED=OFF \
92         -DJEMALLOC_USE_BUNDLED=OFF \
93         ..
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %{__make} -C build install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_iconsdir}/hicolor/scalable/apps}
103 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/neovim.desktop
104 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/neovim.svg
105
106 %find_lang nvim
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %update_desktop_database
113 %update_icon_cache hicolor
114 %banner -e -o %{name} << 'EOF'
115
116 The Neovim executable is called 'nvim'. To use your existing Vim
117 configuration:
118     ln -s ~/.vim ~/.config/nvim
119     ln -s ~/.vimrc ~/.config/nvim/init.vim
120 See ':help nvim' for more information on Neovim.
121
122 If you want support for Python plugins such as YouCompleteMe, you need
123 to install a Python module in addition to Neovim itself.
124
125 See ':help provider-python' or this page for more information:
126     http://neovim.io/doc/user/provider.html
127
128 If you have any questions, have a look at:
129     https://github.com/neovim/neovim/wiki/FAQ.
130 EOF
131
132 %postun
133 %update_desktop_database
134 %update_icon_cache hicolor
135
136 %files -f nvim.lang
137 %defattr(644,root,root,755)
138 %doc BACKERS.md CONTRIBUTING.md LICENSE README.md
139 %attr(755,root,root) %{_bindir}/nvim
140 %{_datadir}/nvim
141 %{_desktopdir}/%{name}.desktop
142 %{_iconsdir}/hicolor/*/apps/%{name}.svg
143 %{_mandir}/man1/nvim.1*
This page took 0.036257 seconds and 2 git commands to generate.