]> git.pld-linux.org Git - packages/ncmpcpp.git/commitdiff
new patch to fix build on 32bit archs; rel 2 auto/th/ncmpcpp-0.7.6-2
authorJan Palus <atler@pld-linux.org>
Mon, 31 Oct 2016 22:21:09 +0000 (23:21 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 31 Oct 2016 22:21:09 +0000 (23:21 +0100)
explicitly create size_t instead of guessing underlying type

ncmpcpp-size_t.patch [new file with mode: 0644]
ncmpcpp.spec

diff --git a/ncmpcpp-size_t.patch b/ncmpcpp-size_t.patch
new file mode 100644 (file)
index 0000000..8f77502
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN ncmpcpp-0.7.6.orig/src/utility/html.cpp ncmpcpp-0.7.6/src/utility/html.cpp
+--- ncmpcpp-0.7.6.orig/src/utility/html.cpp    2016-10-31 23:17:38.007041389 +0100
++++ ncmpcpp-0.7.6/src/utility/html.cpp 2016-10-31 23:18:00.243521920 +0100
+@@ -66,7 +66,7 @@
+       for (size_t i = s.find("<"); i != std::string::npos; i = s.find("<"))
+       {
+               size_t j = s.find(">", i)+1;
+-              if (s.compare(i, std::min(3ul, j-i), "<p ") == 0 || s.compare(i, j-i, "</p>") == 0)
++              if (s.compare(i, std::min(std::size_t{3}, j-i), "<p ") == 0 || s.compare(i, j-i, "</p>") == 0)
+                       s.replace(i, j-i, "\n");
+               else
+                       s.replace(i, j-i, "");
index 8ecf3813e597f7ee8c3e5eebc8af87d8be9831e4..7624dd3e5c294210d205aa1991671ccb3a6a3cfe 100644 (file)
@@ -2,11 +2,12 @@ Summary:      ncurses mpd client inspired by ncmpc
 Summary(pl.UTF-8):     klient mpd wzorowany na ncmpc
 Name:          ncmpcpp
 Version:       0.7.6
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         Applications
 Source0:       http://ncmpcpp.rybczak.net/stable/%{name}-%{version}.tar.bz2
 # Source0-md5: cd8b478d6968dc361f6e062acbe2d255
+Patch0:                %{name}-size_t.patch
 URL:           http://ncmpcpp.rybczak.net
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -38,6 +39,7 @@ plików lokalnych oraz inne drobne udogodnienia.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__libtoolize}
This page took 0.053409 seconds and 4 git commands to generate.