]> git.pld-linux.org Git - packages/nautilus.git/commitdiff
- adds support for new exempi API auto/th/nautilus-2_20_0-5 auto/ti/nautilus-2_20_0-5
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Fri, 4 Jan 2008 13:22:59 +0000 (13:22 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nautilus-exempi-new-api.patch -> 1.1

nautilus-exempi-new-api.patch [new file with mode: 0644]

diff --git a/nautilus-exempi-new-api.patch b/nautilus-exempi-new-api.patch
new file mode 100644 (file)
index 0000000..50d1234
--- /dev/null
@@ -0,0 +1,38 @@
+diff -urN nautilus-2.20.0/configure.in nautilus-2.20.0.new/configure.in
+--- nautilus-2.20.0/configure.in       2007-09-18 08:55:14.000000000 +0200
++++ nautilus-2.20.0.new/configure.in   2008-01-04 14:06:18.000000000 +0100
+@@ -22,6 +22,7 @@
+ m4_define(beagle_minver,               0.0.12)
+ m4_define(tracker_minver,              0.0.1)
+ m4_define(exempi_minver,               1.99.2)
++m4_define(exempi_new_api_minver,       1.99.5)
+ dnl 1. If the library code has changed at all since last release, then increment revision.
+ dnl 2. If any interfaces have been added, then increment current and set revision to 0.
+@@ -266,6 +267,11 @@
+                 AC_DEFINE(HAVE_EXEMPI, 1, [Define to enable XMP support])
+                 ], [AM_CONDITIONAL(HAVE_EXEMPI, false)])
++PKG_CHECK_MODULES(EXEMPI_NEW_API, exempi-2.0 >= exempi_new_api_minver, [
++                AM_CONDITIONAL(HAVE_EXEMPI_NEW_API, true)
++                AC_DEFINE(HAVE_EXEMPI_NEW_API, 1, [Define if your Exempi has new API])
++                ], [AM_CONDITIONAL(HAVE_EXEMPI_NEW_API, false)])
++
+ AC_SUBST(EXEMPI_CFLAGS)
+ AC_SUBST(EXEMPI_LIBS)
+diff -urN nautilus-2.20.0/src/nautilus-image-properties-page.c nautilus-2.20.0.new/src/nautilus-image-properties-page.c
+--- nautilus-2.20.0/src/nautilus-image-properties-page.c       2007-07-24 11:56:20.000000000 +0200
++++ nautilus-2.20.0.new/src/nautilus-image-properties-page.c   2008-01-04 13:51:50.000000000 +0100
+@@ -266,7 +266,11 @@
+ {
+       uint32_t options;
+       XmpStringPtr  value = xmp_string_new();
++#ifdef HAVE_EXEMPI_NEW_API
++      if(xmp_get_property(xmp, ns, propname, value, &options)) {
++#else
+       if(xmp_get_property_and_bits(xmp, ns, propname, value, &options)) {
++#endif
+               if(XMP_IS_PROP_SIMPLE(options)) {
+                       g_string_append_printf(string, "<b>%s:</b> %s\n", descr, xmp_string_cstr(value));
+               }
This page took 0.643805 seconds and 4 git commands to generate.