]> git.pld-linux.org Git - packages/nautilus.git/commitdiff
- patches from rawhide.
authorkloczek <kloczek@pld-linux.org>
Sat, 9 Feb 2002 11:16:27 +0000 (11:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nautilus-ac25.patch -> 1.1
    nautilus-mozilla-profile-startup.patch -> 1.1
    nautilus-omf-encoding.patch -> 1.1

nautilus-ac25.patch [new file with mode: 0644]
nautilus-mozilla-profile-startup.patch [new file with mode: 0644]
nautilus-omf-encoding.patch [new file with mode: 0644]

diff --git a/nautilus-ac25.patch b/nautilus-ac25.patch
new file mode 100644 (file)
index 0000000..58f855c
--- /dev/null
@@ -0,0 +1,40 @@
+--- nautilus-1.0.6/configure.in.ac25   Wed Nov  7 20:52:37 2001
++++ nautilus-1.0.6/configure.in        Tue Jan 22 15:57:23 2002
+@@ -98,10 +98,10 @@
+ FAM_MISSING_WARNING="Nautilus depends on FAM to provide notification when files are altered (either through filesystem polling, or a kernel notification mechanism). If Nautilus is built without FAM support, directories viewed with Nautilus will not remain in synch with the actual filesystem when they are altered by external processes. Particularly if you are a distributor please compile Nautilus with FAM support. FAM is available from http://oss.sgi.com/projects/fam/. A patch to add Linux Kernel 2.4 directory notify support to FAM (highly desirable) is available from http://people.redhat.com/alexl/files/"
+ FAM_LIBS=
+ AC_CHECK_LIB(fam, FAMOpen,
+-  AC_CHECK_HEADERS(fam.h,
++  [ AC_CHECK_HEADERS(fam.h,
+     [AC_DEFINE(HAVE_LIBFAM)
+      FAM_LIBS="-lfam"],
+-    AC_MSG_WARN(*** FAM support will not be built (header files not found) $FAM_MISSING_WARNING ***)),
++    AC_MSG_WARN(*** FAM support will not be built (header files not found) $FAM_MISSING_WARNING ***)) ],
+   AC_MSG_WARN(*** FAM support will not be built (FAM library not found) $FAM_MISSING_WARNING ***))
+ AC_SUBST(FAM_LIBS)
+@@ -585,9 +585,9 @@
+ dnl ====================================
+   if test -z "$LIBPNG"; then
+     AC_CHECK_LIB(png, png_read_info,
+-      AC_CHECK_HEADER(png.h,
+-        png_ok=yes,
+-        png_ok=no),
++      [ AC_CHECK_HEADER(png.h,
++         png_ok=yes,
++         png_ok=no) ],
+       AC_MSG_ERROR(*** (PNG library not found) ***), -lz -lm)
+     if test "$png_ok" = yes; then
+       AC_MSG_CHECKING([for png_structp in png.h])
+@@ -616,9 +616,9 @@
+ dnl ====================================
+   if test -z "$LIBJPEG"; then
+     AC_CHECK_LIB(jpeg, jpeg_start_decompress,
+-      AC_CHECK_HEADER(jpeglib.h,
++      [ AC_CHECK_HEADER(jpeglib.h,
+         jpeg_ok=yes,
+-        jpeg_ok=no),
++        jpeg_ok=no) ],
+       AC_MSG_WARN(*** (jpeg library not found) ***), -lm)
+     if test "$jpeg_ok" = yes; then
+       JPEG='jpeg'; LIBJPEG='-ljpeg'
diff --git a/nautilus-mozilla-profile-startup.patch b/nautilus-mozilla-profile-startup.patch
new file mode 100644 (file)
index 0000000..c8852db
--- /dev/null
@@ -0,0 +1,123 @@
+--- nautilus-1.0.6/components/mozilla/main.c~  Tue Oct  9 17:03:21 2001
++++ nautilus-1.0.6/components/mozilla/main.c   Fri Dec 28 22:38:58 2001
+@@ -190,6 +190,41 @@
+       g_free (mozilla_path);
+ }
++/* The "Mozilla Profile" directory is the place where mozilla stores 
++ * things like cookies and cache.  Here we tell the mozilla embedding
++ * widget to use ~/.nautilus/MozillaProfile for this purpose.
++ *
++ * We need mozilla 0.8 to support this feature.
++ */
++
++static void
++set_up_mozilla_profile(void)
++{
++      const char *profile_directory_name = "MozillaProfile";
++      char *profile_base_path;
++      char *profile_path;
++      char *cache_path;
++      
++      profile_base_path = g_strdup_printf ("%s/.nautilus", g_get_home_dir ());
++      profile_path = g_strdup_printf ("%s/.nautilus/%s", g_get_home_dir (), profile_directory_name);
++      cache_path = g_strdup_printf ("%s/.nautilus/%s/Cache", g_get_home_dir (), profile_directory_name);
++
++      /* Create directories if they don't already exist */ 
++      mkdir (profile_path, 0777);
++      mkdir (cache_path, 0777);
++
++#ifdef MOZILLA_HAVE_PROFILES_SUPPORT
++      /* this will be in Mozilla 0.8 */
++      /* Its a bug in mozilla embedding that we need to cast the const away */
++      gtk_moz_embed_set_profile_path (profile_base_path, (char *) profile_directory_name);
++#endif
++
++      g_free (cache_path);
++      g_free (profile_path);
++      g_free (profile_base_path);
++}
++
++
+ int
+ main (int argc, char *argv[])
+ {
+@@ -201,6 +236,12 @@
+       DEBUG_MSG (("nautilus-mozilla-content-view: starting...\n"));
++      /* Set up the default mozilla profile directory.  This has to
++           happen before push_startup below otherwise the profile
++           directory will never be set so things like the cache and
++           global history won't work. */
++      set_up_mozilla_profile();
++
+       /* set MOZILLA_FIVE_HOME if it's not already set */
+       set_up_MOZILLA_FIVE_HOME();
+--- nautilus-1.0.6/components/mozilla/nautilus-mozilla-content-view.c~ Tue Oct  9 17:09:04 2001
++++ nautilus-1.0.6/components/mozilla/nautilus-mozilla-content-view.c  Fri Dec 28 22:39:43 2001
+@@ -234,7 +234,6 @@
+                                                                guint                          num_strings,
+                                                                const char                     *string);
+-static void   pre_widget_initialize                           (void);
+ static void   post_widget_initialize                          (void);
+ /* BonoboControl callbacks */
+@@ -255,8 +254,6 @@
+       object_class = GTK_OBJECT_CLASS (klass);
+       object_class->destroy = nautilus_mozilla_content_view_destroy;
+-
+-      pre_widget_initialize ();
+ }
+@@ -1900,46 +1897,6 @@
+ }
+-/*
+- * one-time initialization that need to happen before the first GtkMozEmbed widget
+- * is created
+- */ 
+-
+-/* The "Mozilla Profile" directory is the place where mozilla stores 
+- * things like cookies and cache.  Here we tell the mozilla embedding
+- * widget to use ~/.nautilus/MozillaProfile for this purpose.
+- *
+- * We need mozilla 0.8 to support this feature.
+- */
+-
+-static void
+-pre_widget_initialize (void)
+-{
+-      const char *profile_directory_name = "MozillaProfile";
+-      char *profile_base_path;
+-      char *profile_path;
+-      char *cache_path;
+-      
+-      profile_base_path = g_strdup_printf ("%s/.nautilus", g_get_home_dir ());
+-      profile_path = g_strdup_printf ("%s/.nautilus/%s", g_get_home_dir (), profile_directory_name);
+-      cache_path = g_strdup_printf ("%s/.nautilus/%s/Cache", g_get_home_dir (), profile_directory_name);
+-
+-      /* Create directories if they don't already exist */ 
+-      mkdir (profile_path, 0777);
+-      mkdir (cache_path, 0777);
+-
+-#ifdef MOZILLA_HAVE_PROFILES_SUPPORT
+-      /* this will be in Mozilla 0.8 */
+-      /* Its a bug in mozilla embedding that we need to cast the const away */
+-      gtk_moz_embed_set_profile_path (profile_base_path, (char *) profile_directory_name);
+-#endif
+-
+-      g_free (cache_path);
+-      g_free (profile_path);
+-      g_free (profile_base_path);
+-}
+-
+-
+ /*
+  * one-time initialization that need to happen after the first GtkMozEmbed widget
+  * is created
diff --git a/nautilus-omf-encoding.patch b/nautilus-omf-encoding.patch
new file mode 100644 (file)
index 0000000..88720ba
--- /dev/null
@@ -0,0 +1,16 @@
+--- nautilus-1.0.6/help/nautilus-user-manual/ko/nautilus-user-manual-ko.omf.omf_encoding       Thu Jan 31 15:33:31 2002
++++ nautilus-1.0.6/help/nautilus-user-manual/ko/nautilus-user-manual-ko.omf    Thu Jan 31 15:33:39 2002
+@@ -1,4 +1,4 @@
+-<?xml version="1.0" standalone="no"?>
++<?xml version="1.0" standalone="no" encoding="EUC-KR"?>
+ <omf>
+   <resource>
+     <title>
+--- nautilus-1.0.6/help/nautilus-quick-reference/ko/nautilus-quick-reference-ko.omf.omf_encoding       Thu Jan 31 15:27:55 2002
++++ nautilus-1.0.6/help/nautilus-quick-reference/ko/nautilus-quick-reference-ko.omf    Thu Jan 31 15:32:18 2002
+@@ -1,4 +1,4 @@
+-<?xml version="1.0" standalone="no"?>
++<?xml version="1.0" standalone="no" encoding="EUC-KR"?>
+ <omf>
+   <resource>
+     <title>
This page took 0.041899 seconds and 4 git commands to generate.