]> git.pld-linux.org Git - packages/nasm.git/blob - nasm.spec
- next typo.
[packages/nasm.git] / nasm.spec
1 Summary:        Nasm is a free assembler for the 80x86 series of microprocessors
2 Name:           nasm
3 Version:        0.98
4 Release:        4
5 License:        GPL
6 Group:          Development/Tools
7 Group(fr):      Development/Outils
8 Group(pl):      Programowanie/Narzêdzia
9 URL:            http://www.cryogen.com/nasm/
10 Source0:        ftp://sunsite.unc.edu/pub/Linux/devel/lang/assemblers/%{name}-%{version}.tar.bz2
11 Patch0:         nasm-info.patch
12 Prereq:         /usr/sbin/fix-info-dir
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14 Obsoletes:      nasm-doc
15
16 %description
17 NASM is an 80x86 assembler designed for portability and modularity. It
18 supports a range of object file formats including Linux a.out and ELF,
19 COFF, Microsoft 16-bit OBJ and Win32. It will also output plain binary
20 files. Its syntax is designed to be simple and easy to understand, similar
21 to Intel's but less complex. It supports Pentium, P6 and MMX opcodes, and
22 has macro capability. It includes a disassembler as well.
23
24 %package rdoff
25 Summary:        Tools for the RDOFF binary format, sometimes used with NASM
26 Group:          Development/Tools
27 Group(fr):      Development/Outils
28 Group(pl):      Programowanie/Narzêdzia
29 Requires:       %{name} = %{version}
30
31 %description rdoff
32 Tools for the operating-system independent RDOFF binary format, which is
33 sometimes used with the Netwide Assembler (NASM). These tools include
34 linker, library manager, loader, and information dump.
35
36 %prep
37 %setup -q
38 %patch -p1
39
40 %build
41 autoconf
42 LDFLAGS="-s"; export LDFLAGS
43 %configure
44
45 make all rdf
46
47 (cd doc; make nasmdoc.texi; makeinfo nasmdoc.texi)
48
49 %install 
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_bindir},%{_infodir},%{_mandir}/man1}
52 make INSTALLROOT=$RPM_BUILD_ROOT install install_rdf
53
54 install doc/nasm.info* $RPM_BUILD_ROOT%{_infodir}
55 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*,%{_mandir}/man?/*} \
56         Changes Licence Readme Wishlist MODIFIED \
57         rdoff/README rdoff/Changes
58
59 %post
60 /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
61
62 %postun
63 /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc *gz
71 %attr(755,root,root) %{_bindir}/*
72 %attr(755,root,root) %{_bindir}/nasm
73 %attr(755,root,root) %{_bindir}/ndisasm
74 %{_infodir}/nasm.info*gz
75 %{_mandir}/man?/*
76
77 %files rdoff
78 %defattr(644,root,root,755)
79 %doc rdoff/README.gz rdoff/Changes.gz
80 %attr(755,root,root) %{_bindir}/ldrdf
81 %attr(755,root,root) %{_bindir}/rdf2bin
82 %attr(755,root,root) %{_bindir}/rdf2com
83 %attr(755,root,root) %{_bindir}/rdfdump
84 %attr(755,root,root) %{_bindir}/rdflib
85 %attr(755,root,root) %{_bindir}/rdx
This page took 0.030308 seconds and 3 git commands to generate.