]> git.pld-linux.org Git - packages/nagios.git/commitdiff
- use system jquery package
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 28 May 2012 21:18:56 +0000 (21:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    nagios.spec -> 1.183
    system-jquery.patch -> 1.1

nagios.spec
system-jquery.patch [new file with mode: 0644]

index 90016eb745fd55e4e719dfc358064d885cc6b099..28f02aa50b2159cc44f91ec283e99688e44f1ae1 100644 (file)
@@ -40,6 +40,7 @@ Patch6:               %{name}-googlemap.patch
 Patch7:                %{name}-doc-usermacros.patch
 Patch8:                archivelog-timeformat.patch
 Patch9:                system-magpierss.patch
+Patch10:       system-jquery.patch
 URL:           http://www.nagios.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -141,6 +142,7 @@ Requires:   %{name} = %{version}-%{release}
 Requires:      %{name}-imagepaks
 Requires:      %{name}-theme
 Requires:      group(http)
+Requires:      jquery
 Requires:      php-magpierss >= 0.72
 Requires:      webapps
 Requires:      webserver
@@ -238,6 +240,7 @@ mv %{name}/* .
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
 
 find -name .cvsignore -o -name .gitignore | xargs rm
 
diff --git a/system-jquery.patch b/system-jquery.patch
new file mode 100644 (file)
index 0000000..a89bf09
--- /dev/null
@@ -0,0 +1,44 @@
+--- nagios-3.4.1/html/main.php~        2012-05-12 03:00:53.000000000 +0300
++++ nagios-3.4.1/html/main.php 2012-05-28 23:55:54.310721306 +0300
+@@ -12,7 +12,7 @@
+ <meta name="ROBOTS" content="NOINDEX, NOFOLLOW" />
+ <title>Nagios Core</title>
+ <link rel='stylesheet' type='text/css' href='stylesheets/common.css' />
+-<script type="text/javascript" src="js/jquery-1.7.1.min.js"></script>
++<script type="text/javascript" src="/js/jquery/jquery.js"></script>
+ <script type='text/javascript'>
+--- nagios-3.4.1/include/cgiutils.h~   2012-05-24 17:15:30.000000000 +0300
++++ nagios-3.4.1/include/cgiutils.h    2012-05-28 23:56:18.921757228 +0300
+@@ -80,7 +80,7 @@
+ #define SUMMARY_CSS             "summary.css"
+       /********************************* JAVASCRIPT INCLUDES **********************/
+-#define JQUERY_JS             "jquery-1.7.1.min.js"   
++#define JQUERY_JS             "/js/jquery/jquery.js"
+       /********************************* ICONS ************************************/
+--- nagios-3.4.1/cgi/status.c~ 2012-05-24 17:15:30.000000000 +0300
++++ nagios-3.4.1/cgi/status.c  2012-05-28 23:57:04.933694000 +0300
+@@ -558,7 +558,7 @@
+               }
+       
+       /* added jquery library 1/31/2012 */    
+-      printf("<script type='text/javascript' src='%s%s'></script>\n",url_js_path, JQUERY_JS); 
++      printf("<script type='text/javascript' src='%s'></script>\n", JQUERY_JS); 
+       /* JS function to append content to elements on page */ 
+       printf("<script type='text/javascript'>\n"); 
+       printf("$(document).ready(function() { $('#top_page_numbers').append($('#bottom_page_numbers').html() ); });"); 
+--- nagios-3.4.1/html/Makefile.in~     2012-05-28 23:52:30.000000000 +0300
++++ nagios-3.4.1/html/Makefile.in      2012-05-28 23:59:43.973722231 +0300
+@@ -61,8 +61,6 @@
+       do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/stylesheets; done
+       for file in contexthelp/*.html; \
+       do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/contexthelp; done
+-      for file in js/*.js; \
+-      do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/js; done
+ #     for file in docs/*.html; \
+ #     do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/docs; done
+ #     for file in docs/images/*.*; \
This page took 0.127565 seconds and 4 git commands to generate.