]> git.pld-linux.org Git - packages/nagios.git/blob - nagios.spec
- up to 4.3.3
[packages/nagios.git] / nagios.spec
1 # TODO
2 # - /var/log/nagios/archives -> /var/log/archive/nagios
3 # - bundled jquery in themes
4 #
5 # Conditional build:
6 %bcond_without  gd      # without statusmap and trends, which require gd library
7 %bcond_without  doc     # don't build html docs
8 # reeenable when http://tracker.nagios.org/view.php?id=51 is fixed
9 %bcond_with     tests
10
11 Summary:        Open Source host, service and network monitoring program
12 Summary(pl.UTF-8):      Program do monitorowania serwerów/usług/sieci
13 Summary(pt_BR.UTF-8):   Programa para monitoração de máquinas e serviços
14 Name:           nagios
15 Version:        4.3.3
16 Release:        1
17 License:        GPL v2+
18 Group:          Networking
19 Source0:        https://assets.nagios.com/downloads/nagioscore/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  b733310c87b8eb6ce0f7a5768829c94c
21 Source1:        %{name}-apache.conf
22 Source2:        %{name}.init
23 Source3:        %{name}.sysconfig
24 # http://git.pld-linux.org/projects/nagios-config/
25 Source4:        %{name}-config-20150805.tar.xz
26 # Source4-md5:  16683172c72cc2c09662261c82abef40
27 Source5:        %{name}-lighttpd.conf
28 Source6:        http://www.google.com/mapfiles/shadow50.png
29 # Source6-md5:  eff99f302f21b95a900d321743fce72b
30 Source7:        http://www.google.com/mapfiles/marker.png
31 # Source7-md5:  edefef4bdfc29e1c953694651f05b466
32 Source8:        googlemap.js
33 Source9:        %{name}wall.php
34 Patch0:         %{name}-resources.patch
35 Patch1:         %{name}-iconv-in-libc.patch
36 Patch2:         %{name}-webapps.patch
37
38 Patch4:         %{name}-cmd-typo.patch
39 Patch5:         config.patch
40 Patch6:         %{name}-googlemap.patch
41 Patch7:         %{name}-doc-usermacros.patch
42 Patch8:         archivelog-timeformat.patch
43
44 Patch10:        system-jquery.patch
45 Patch11:        do-not-fetch-rss.patch
46 URL:            https://www.nagios.org/projects/nagios-core/
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 %{?with_doc:BuildRequires:      doxygen}
50 BuildRequires:  rpmbuild(macros) >= 1.268
51 BuildRequires:  sed >= 4.0
52 BuildRequires:  tar >= 1:1.22
53 BuildRequires:  xz
54 %if %{with gd}
55 BuildRequires:  gd-devel
56 BuildRequires:  libjpeg-devel
57 BuildRequires:  libpng-devel
58 %endif
59 %if %{with tests}
60 BuildRequires:  perl-HTML-Lint
61 BuildRequires:  perl-Test-WWW-Mechanize-CGI
62 %endif
63 Requires(post,preun):   /sbin/chkconfig
64 Requires:       %{name}-common = %{version}-%{release}
65 Requires:       rc-scripts >= 0.4.5.5
66 Requires:       sh-utils
67 Suggests:       nagios-notify >= 0.13
68 Suggests:       nagios-plugin-check_load
69 Suggests:       nagios-plugin-check_ping
70 Suggests:       nagios-plugins
71 Provides:       nagios-core
72 Obsoletes:      netsaint
73 Conflicts:      iputils-ping < 1:ss020124
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _sysconfdir     /etc/%{name}
77 %define         cgidir          %{_libdir}/%{name}/cgi
78 %define         htmldir         %{_prefix}/share/%{name}
79 %define         _localstatedir  /var/lib/%{name}
80 %define         nagioshome      %{_localstatedir}
81 %define         _webapps        /etc/webapps
82 %define         _webapp         %{name}
83
84 %description
85 Nagios is a program that will monitor hosts and services on your
86 network. It has the ability to email or page you when a problem arises
87 and when a problem is resolved. Nagios is written in C and is designed
88 to run under Linux (and some other *NIX variants) as a background
89 process, intermittently running checks on various services that you
90 specify.
91
92 The actual service checks are performed by separate "plugin" programs
93 which return the status of the checks to Nagios. The plugins are
94 available in nagios-plugins packages.
95
96 Nagios is successor to NetSaint.
97
98 %description -l pl.UTF-8
99 Nagios to program, który monitoruje serwery oraz usługi w naszej
100 sieci. Posiada on możliwość wysyłania informacji o wystąpieniu oraz
101 rozwiązaniu problemu. Nagios został napisany w C oraz jest
102 zaprojektowany do pracy pod Linuksem (i niektórymi innymi uniksami)
103 jako proces pracujący w tle i bezustannie wykonujący pewne operacje
104 sprawdzające.
105
106 Właściwe sprawdzanie jest wykonywane przez osobne programy
107 ("wtyczki"), które zwracają informacje o statusie do Nagiosa. Wtyczki
108 są dostępne na stronie w pakietach nagios-plugins.
109
110 Nagios jest następcą NetSainta.
111
112 %description -l pt_BR.UTF-8
113 O Nagios é um programa que monitora máquinas e serviços na sua rede.
114 Ele pode enviar um email ou um aviso de pager para o administrador
115 quando surgir um problema e quando ele for resolvido. Nagios é escrito
116 em C e foi desenvolvido para rodar em plataformas Linux (e algumas
117 variações de *NIX) como um processo em segundo plano, periodicamente
118 executando checagens nos diversos serviços que forem especificados.
119
120 %package common
121 Summary:        Common files needed by both nagios and nrpe
122 Summary(pl.UTF-8):      Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe
123 Group:          Networking
124 Requires(postun):       /usr/sbin/groupdel
125 Requires(postun):       /usr/sbin/userdel
126 Requires(pre):  /bin/id
127 Requires(pre):  /usr/bin/getgid
128 Requires(pre):  /usr/sbin/groupadd
129 Requires(pre):  /usr/sbin/groupmod
130 Requires(pre):  /usr/sbin/useradd
131 Requires(pre):  /usr/sbin/usermod
132 Provides:       group(nagcmd)
133 Provides:       group(nagios)
134 Provides:       user(nagios)
135
136 %description common
137 Common files needed by both nagios and nrpe.
138
139 %description common -l pl.UTF-8
140 Wspólne pliki wymagane zarówno przez nagiosa jak i nrpe.
141
142 %package cgi
143 Summary:        CGI webinterface for Nagios
144 Summary(pl.UTF-8):      Interfejs WWW/CGI dla Nagiosa
145 Group:          Applications/WWW
146 # for dirs... and accessing local logs, nagios config
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       %{name}-imagepaks
149 Requires:       %{name}-theme
150 Requires:       group(http)
151 Requires:       jquery
152 Requires:       webapps
153 Requires:       webserver
154 Requires:       webserver(access)
155 Requires:       webserver(alias)
156 Requires:       webserver(auth)
157 Requires:       webserver(cgi)
158 Requires:       webserver(indexfile)
159 Suggests:       %{name}-doc
160
161 %description cgi
162 CGI webinterface for Nagios.
163
164 %description cgi -l pl.UTF-8
165 Interfejs CGI dla Nagiosa.
166
167 %package mrtggraphs
168 Summary:        MRTG Graphs: Nagios Statistics
169 Group:          Applications/Networking
170 Requires:       %{name} = %{version}-%{release}
171 Provides:       mrtg-start
172 %if "%{_rpmversion}" >= "5"
173 BuildArch:      noarch
174 %endif
175
176 %description mrtggraphs
177 This pacakge graphs several Nagios statistics which can be useful for
178 debugging and trending purposes. The nagiostats binary is used to
179 generate the data.
180
181 %package doc
182 Summary:        HTML Documentation for Nagios
183 Group:          Documentation
184 %if "%{_rpmversion}" >= "5"
185 BuildArch:      noarch
186 %endif
187 # does not require base
188
189 %description doc
190 HTML Documentation for Nagios.
191
192 %package theme-classicui
193 Summary:        ClassicUI Nagios theme
194 Group:          Applications/WWW
195 Requires:       %{name}-cgi = %{version}-%{release}
196 Requires:       webserver(php)
197 Provides:       nagios-theme
198 Obsoletes:      nagios-theme
199 %if "%{_rpmversion}" >= "5"
200 BuildArch:      noarch
201 %endif
202
203 %description theme-classicui
204 Original theme from Nagios.
205
206 %description theme-classicui -l pl.UTF-8
207 Oryginalny motyw z Nagiosa.
208
209 %package theme-default
210 Summary:        Virtual package to handle Nagios theme migration
211 Group:          Applications/WWW
212 Requires:       nagios-theme
213 Suggests:       nagios-theme-classicui
214 Suggests:       nagios-theme-exfoliation
215 Suggests:       nagios-theme-nuvola
216 Obsoletes:      nagios-theme-default < 3.3.1-1.4
217 %if "%{_rpmversion}" >= "5"
218 BuildArch:      noarch
219 %endif
220
221 %description theme-default
222 Virtual package to handle Nagios theme migration
223
224 %package devel
225 Summary:        Include files that Nagios-related applications may compile against
226 Summary(pl.UTF-8):      Pliki nagłówkowe, wykorzystywane przez aplikacje nagiosa
227 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho necessários para desenvolvimento de aplicativos para o Nagios
228 Group:          Development/Libraries
229 # doesn't require base
230
231 %description devel
232 This package contains the header files, static libraries and
233 development documentation for Nagios. If you are a NEB-module author
234 or wish to write addons for Nagios using Nagios' own API's, you should
235 install this package.
236
237 %description devel -l pl.UTF-8
238 Ten pakiet dostarcza pliki nagłówkowe, które mogą być wykorzystywane
239 przez aplikacje związane z nagiosem podczas kompilacji.
240
241 %description devel -l pt_BR.UTF-8
242 Este pacote contém arquivos de cabeçalho usados no desenvolvimento de
243 aplicativos para o Nagios.
244
245 %prep
246 %setup -qc -a4
247 mv %{name}-%{version}/* .
248 %undos cgi/*.c
249 %undos include/*.h
250 %undos base/*
251 %patch0 -p0
252 %patch1 -p1
253 %patch2 -p1
254
255 #fixed
256 #%patch4 -p1
257 %patch5 -p1
258 %patch6 -p1
259 %patch7 -p1
260 %patch8 -p1
261
262 %patch10 -p1
263 %patch11 -p1
264
265 find -name .cvsignore -o -name .gitignore | xargs rm
266
267 mv nagios-config-*/objects/*.cfg sample-config/template-object
268 mv nagios-config-*/*.cfg sample-config
269
270 # cleanup backups after patching
271 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
272
273 sed -i -e '
274         s,".*/var/rw/%{name}.cmd,"%{_localstatedir}/rw/%{name}.cmd,
275         s,".*/libexec/eventhandlers,"%{_libdir}/%{name}/eventhandlers,
276 ' $(find contrib/eventhandlers -type f)
277
278 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE1} > apache.conf
279 sed -e 's,%{_prefix}/lib/,%{_libdir}/,' %{SOURCE5} > lighttpd.conf
280
281 # fixup cgi config
282 %{__sed} -i -e '
283         # kill trailing spaces
284         s, \+$,,
285         # use real paths
286         s,/usr/local/%{name}/share,@datadir@,g
287         # we want all authorized users have default access
288         s,=nagiosadmin,=*,g
289 ' sample-config/*.cfg.in
290
291 #rm t/611cgistatus-hosturgencies.t
292
293 %build
294 cp -f /usr/share/automake/config.sub .
295 %{__aclocal}
296 %{__autoconf}
297 %if %{with tests}
298 cd tap
299 %{__libtoolize}
300 %{__aclocal}
301 %{__autoconf}
302 cd ..
303 %endif
304 %configure \
305         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
306         --bindir=%{_sbindir} \
307         --sbindir=%{cgidir} \
308         --datadir=%{htmldir} \
309         --with-nagios-user=%{name} \
310         --with-nagios-grp=%{name} \
311         --with-command-user=%{name} \
312         --with-command-grp=%{name} \
313         --with-lockfile=%{_localstatedir}/%{name}.pid \
314         --with-checkresult-dir=%{_var}/spool/%{name}/checkresults \
315         --with-ping_command='/bin/ping -n %%s -c %%d' \
316         %{!?with_gd:--disable-statusmap --disable-trends} \
317         %{?with_tests:--enable-libtap} \
318         --enable-event-broker
319
320 %{__make} all
321
322 %{?with_doc:%{__make} dox}
323
324 %{?with_tests:%{__make} test}
325
326 %install
327 rm -rf $RPM_BUILD_ROOT
328 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_webapps}/%{_webapp}} \
329         $RPM_BUILD_ROOT{%{_var}/log/%{name}/archives,%{_localstatedir}/rw} \
330         $RPM_BUILD_ROOT%{_sysconfdir}/{plugins,objects} \
331         $RPM_BUILD_ROOT%{_libdir}/%{name}/{eventhandlers,plugins,brokers} \
332 %if "%{_lib}" != "lib"
333         $RPM_BUILD_ROOT%{_prefix}/lib/%{name}/{eventhandlers,plugins} \
334 %endif
335
336 %{__make} install-unstripped install-devel \
337         DESTDIR=$RPM_BUILD_ROOT \
338         INSTALL_OPTS="" \
339         INIT_OPTS="" \
340         COMMAND_OPTS=""
341
342 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
343 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
344
345 # install templated configuration files
346 for a in %{name}.cfg resource.cfg commands.cfg contactgroups.cfg contacts.cfg templates.cfg timeperiods.cfg; do
347         cp -p sample-config/$a $RPM_BUILD_ROOT%{_sysconfdir}
348 done
349
350 # webserver files
351 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
352 cp -p apache.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
353 cp -p lighttpd.conf $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/lighttpd.conf
354 cp -p sample-config/cgi.cfg $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
355 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{htmldir}/images
356 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{htmldir}/images
357 cp -p %{SOURCE8} $RPM_BUILD_ROOT%{htmldir}/images
358 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{htmldir}
359 > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/passwd
360 echo 'nagios:' > $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/group
361
362 # install event handlers, sample config
363 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
364 cp -a contrib/eventhandlers $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
365 cp -a sample-config $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
366 find $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} -name '*.in' | xargs rm
367
368 # mrtg script
369 install -d $RPM_BUILD_ROOT/etc/mrtg/conf.d
370 cp -p sample-config/mrtg.cfg $RPM_BUILD_ROOT/etc/mrtg/conf.d/%{name}.cfg
371
372 # Object data/cache files
373 for i in {objects.{cache,precache},{retention,status}.dat,%{name}.{tmp,pid}}; do
374         > $RPM_BUILD_ROOT%{_localstatedir}/$i
375 done
376 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.cmd
377 > $RPM_BUILD_ROOT%{_localstatedir}/rw/%{name}.qh
378
379 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}
380 %{?with_doc:%{__cp} -a Documentation/html/* $RPM_BUILD_ROOT%{_docdir}/%{name}}
381
382 %clean
383 rm -rf $RPM_BUILD_ROOT
384
385 %post
386 for i in %{_localstatedir}/{objects.{cache,precache},{retention,status}.dat}; do
387         [ ! -f $i ] && touch $i
388         chown root:nagios $i
389         chmod 664 $i
390 done
391
392 /sbin/chkconfig --add %{name}
393 %service %{name} restart "Nagios service"
394
395 %preun
396 if [ "$1" = "0" ] ; then
397         %service %{name} stop
398         /sbin/chkconfig --del %{name}
399 fi
400
401 %pre common
402 # rename group netsaint -> nagios
403 if [ "$(getgid netsaint 2>/dev/null)" = "72" ]; then
404         /usr/sbin/groupmod -n nagios netsaint
405 fi
406 # rename group nagios-data -> nagcmd
407 if [ "$(getgid nagios-data 2>/dev/null)" = "147" ]; then
408         /usr/sbin/groupmod -n nagcmd nagios-data
409 fi
410 %groupadd -g 72 nagios
411 %groupadd -g 147 -f nagcmd
412 if [ -n "$(id -u netsaint 2>/dev/null)" ] && [ "$(id -u netsaint)" = "72" ]; then
413         /usr/sbin/usermod -d %{nagioshome} -l nagios -c "Nagios Daemon" -G nagcmd netsaint
414 fi
415 %useradd -u 72 -d %{nagioshome} -s /bin/false -c "Nagios Daemon" -g nagios -G nagcmd nagios
416 # update nagios user home
417 home=$(IFS=:; set -- $(getent passwd nagios); echo $6)
418 if [ "$home" != %{nagioshome} ]; then
419         /usr/sbin/usermod -d %{nagioshome} nagios
420 fi
421
422 %postun common
423 if [ "$1" = "0" ]; then
424         %userremove nagios
425         %groupremove nagios
426         %groupremove nagcmd
427 fi
428
429 %post cgi
430 if [ "$1" = 1 ]; then
431 %banner %{name} -e <<EOF
432 NOTE:
433 You need to add user to %{_webapps}/%{_webapp}/passwd and
434 %{_webapps}/%{_webapp}/group to access Nagios via web.
435
436 EOF
437 fi
438
439 %triggerin cgi -- apache1 < 1.3.37-3, apache1-base
440 %addusertogroup http nagcmd
441 %webapp_register apache %{_webapp}
442
443 %triggerun cgi -- apache1 < 1.3.37-3, apache1-base
444 %webapp_unregister apache %{_webapp}
445
446 %triggerin cgi -- apache < 2.2.0, apache-base
447 %addusertogroup http nagcmd
448 %webapp_register httpd %{_webapp}
449
450 %triggerun cgi -- apache < 2.2.0, apache-base
451 %webapp_unregister httpd %{_webapp}
452
453 %triggerin cgi -- lighttpd
454 %addusertogroup lighttpd nagcmd
455 %webapp_register lighttpd %{_webapp}
456
457 %triggerun cgi -- lighttpd
458 %webapp_unregister lighttpd %{_webapp}
459
460 %triggerpostun -- nagios-cgi < 2.0-0.b3.21
461 chown root:http %{_sysconfdir}/cgi.cfg
462
463 %triggerpostun -- nagios < 3.1.2-4
464 # restore lost files
465 for a in dependencies.cfg services.cfg serviceextinfo.cfg hosts.cfg hostgroups.cfg hostextinfo.cfg escalations.cfg checkcommands.cfg misccommands.cfg; do
466         if [ -f %{_sysconfdir}/$a.rpmsave -a ! -f %{_sysconfdir}/$a ]; then
467                 mv -f %{_sysconfdir}/$a{.rpmsave,}
468         fi
469 done
470 %{__sed} -i -e 's,^check_result_path=.*,check_result_path=%{_var}/spool/%{name}/checkresults,' %{_sysconfdir}/%{name}.cfg
471
472
473 %triggerpostun -- nagios-common < 4.0.8-2.2
474 %banner -e %{name}-common <<EOF
475
476 IMPORTANT: nagios user home changed to %{nagioshome}, you may need to move files from previous location %{_libdir}/%{name}.
477
478 EOF
479
480 %files
481 %defattr(644,root,root,755)
482 %doc Changelog README* UPGRADING INSTALLING LICENSE
483 %attr(750,root,nagios) %dir %{_sysconfdir}/objects
484
485 # leave main nagios config readable for -cgi.
486 %attr(640,root,nagcmd) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.cfg
487
488 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/commands.cfg
489 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contactgroups.cfg
490 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/contacts.cfg
491 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/resource.cfg
492 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/templates.cfg
493 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timeperiods.cfg
494
495 %attr(754,root,root) /etc/rc.d/init.d/%{name}
496 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
497
498 %attr(755,root,root) %{_sbindir}/%{name}
499 %attr(755,root,root) %{_sbindir}/nagiostats
500 %dir %{_libdir}/%{name}/brokers
501
502 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}
503 %attr(770,root,nagcmd) %dir %{_var}/log/%{name}/archives
504
505 %attr(770,root,nagcmd) %dir %{_localstatedir}
506 %attr(2770,root,nagcmd) %dir %{_localstatedir}/rw
507 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.cmd
508 %attr(660,nagios,nagcmd) %ghost %{_localstatedir}/rw/%{name}.qh
509 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.cache
510 %attr(664,root,nagios) %ghost %{_localstatedir}/objects.precache
511 %attr(664,root,nagios) %ghost %{_localstatedir}/*.dat
512 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.tmp
513 %attr(664,root,nagios) %ghost %{_localstatedir}/%{name}.pid
514
515 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}/checkresults
516
517 %{_examplesdir}/%{name}-%{version}
518
519 %files common
520 %defattr(644,root,root,755)
521 %attr(750,root,nagcmd) %dir %{_sysconfdir}
522 %attr(750,root,nagios) %dir %{_sysconfdir}/plugins
523 %dir %{_libdir}/%{name}
524 %dir %{_libdir}/%{name}/plugins
525 %dir %{_libdir}/%{name}/eventhandlers
526
527 %if "%{_lib}" != "lib"
528 %dir %{_prefix}/lib/%{name}
529 %dir %{_prefix}/lib/%{name}/plugins
530 %dir %{_prefix}/lib/%{name}/eventhandlers
531 %endif
532
533 %attr(770,root,nagcmd) %dir %{_var}/spool/%{name}
534
535 %files mrtggraphs
536 %defattr(644,root,root,755)
537 %config(noreplace) %verify(not md5 mtime size) /etc/mrtg/conf.d/%{name}.cfg
538
539 %if %{with doc}
540 %files doc
541 %defattr(644,root,root,755)
542 %{_docdir}/%{name}
543 %endif
544
545 %files cgi
546 %defattr(644,root,root,755)
547 %dir %attr(750,root,http) %{_webapps}/%{_webapp}
548 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
549 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
550 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/lighttpd.conf
551 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/cgi.cfg
552 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/passwd
553 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/group
554 %dir %{cgidir}
555 %attr(755,root,root) %{cgidir}/*.cgi
556
557 %dir %{htmldir}
558 %dir %{htmldir}/includes
559 %dir %{htmldir}/images
560 %dir %{htmldir}/stylesheets
561 %{htmldir}/robots.txt
562 %{htmldir}/contexthelp
563 %{htmldir}/jsonquery.html
564 %{htmldir}/media
565 %{htmldir}/ssi
566 %{htmldir}/images/favicon.ico
567 %{htmldir}/images/marker.png
568 %{htmldir}/images/shadow50.png
569 %{htmldir}/nagioswall.php
570
571 %{htmldir}/angularjs
572 %{htmldir}/bootstrap-3.3.0
573 %{htmldir}/d3
574 %{htmldir}/spin
575 %{htmldir}/graph-header.html
576 %{htmldir}/histogram-form.html
577 %{htmldir}/histogram-graph.html
578 %{htmldir}/histogram-links.html
579 %{htmldir}/histogram.html
580 %{htmldir}/infobox.html
581 %{htmldir}/map-directive.html
582 %{htmldir}/map-form.html
583 %{htmldir}/map-links.html
584 %{htmldir}/map-popup.html
585 %{htmldir}/trends-form.html
586 %{htmldir}/trends-graph.html
587 %{htmldir}/trends-host-yaxis.html
588 %{htmldir}/trends-links.html
589 %{htmldir}/trends-service-yaxis.html
590 %{htmldir}/trends.html
591
592 %files theme-classicui
593 %defattr(644,root,root,755)
594 %exclude %{htmldir}/nagioswall.php
595 %{htmldir}/*.php
596 %{htmldir}/includes/*
597 %{htmldir}/images/*
598 %exclude %{htmldir}/images/favicon.ico
599 %exclude %{htmldir}/images/marker.png
600 %exclude %{htmldir}/images/shadow50.png
601 %{htmldir}/stylesheets/*
602
603 %files theme-default
604 %defattr(644,root,root,755)
605
606 %files devel
607 %defattr(644,root,root,755)
608 %dir %{_includedir}/%{name}
609 %{_includedir}/%{name}/*.h
610 %{_includedir}/%{name}/lib
611 %{_libdir}/libnagios.a
This page took 0.074989 seconds and 3 git commands to generate.