]> git.pld-linux.org Git - packages/nagios-nrpe.git/blob - nagios-nrpe.spec
- remove unneeded deps
[packages/nagios-nrpe.git] / nagios-nrpe.spec
1 Summary:        Nagios remote plugin execution service/plugin
2 Summary(pl):    Demon i wtyczka zdalnego wywo³ywania wtyczek Nagios
3 Name:           nagios-nrpe
4 Version:        2.0
5 Release:        3
6 License:        GPL v2
7 Group:          Networking
8 Source0:        http://dl.sourceforge.net/nagios/nrpe-%{version}.tar.gz
9 # Source0-md5:  70ef9502a3b7e49fa520dbceabfa04d0
10 Source1:        nrpe.init
11 URL:            http://www.nagios.org/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  rpmbuild(macros) >= 1.202
15 BuildRequires:  openssl-tools
16 Requires(post,postun):  /sbin/chkconfig
17 Requires:       nagios-common
18 Requires:       nagios-plugins
19 Provides:       nagios-core
20 Obsoletes:      netsaint-nrpe
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sysconfdir     /etc/nagios
24 %define         _datadir        %{_prefix}/share/%{name}
25 %define         _plugindir      %{_libdir}/nagios/plugins
26 %define         _localstatedir  %{_var}/log/nagios
27 %define         nsport          5666
28
29 %description
30 Nagios nrpe allows you to remotely execute plugins on other hosts
31 and report the plugin output back to the monitoring host.
32
33 %description -l pl
34 Nagios npre pozwala zdalnie uruchamiaæ wtyczki na innych hostach,
35 a wynik ich dzia³ania zwracaæ z powrotem do hosta monitoruj±cego.
36
37 %package plugin
38 Summary:        check_nrpe plugin for Nagios
39 Summary(pl):    Wtyczka check_nrpe dla Nagiosa
40 Group:          Networking
41 Requires:       nagios-core
42
43 %description plugin
44 check_nrpe plugin for Nagios. This plugin allows running plugins on
45 remote machines using nrpe service.
46
47 %description plugin -l pl
48 Wtyczka check_nrpe dla Nagiosa. Pozwala na zdalne uruchamianie
49 wtyczek na innych komputerach za pomoc± demona nrpe.
50
51 %prep
52 %setup -q -n nrpe-%{version}
53
54 %build
55 %{__aclocal}
56 %{__autoconf}
57
58 %configure \
59         --with-init-dir=/etc/rc.d/init.d \
60         --with-nrpe-port=%{nsport} \
61         --with-nrpe-user=nagios \
62         --with-nrpe-grp=nagios \
63         --prefix=%{_prefix} \
64         --exec-prefix=%{_sbindir} \
65         --bindir=%{_sbindir} \
66         --libexecdir=%{_plugindir} \
67         --datadir=%{_prefix}/share/nagios \
68         --sysconfdir=%{_sysconfdir} \
69         --localstatedir=%{_localstatedir} 
70
71 %{__make} all
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir},%{_libdir}/nagios/plugins,%{_sbindir}} \
76         $RPM_BUILD_ROOT%{_localstatedir}
77
78 install nrpe.cfg $RPM_BUILD_ROOT/etc/nagios/nrpe.cfg
79 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/nrpe
80 install src/nrpe $RPM_BUILD_ROOT%{_sbindir}
81 install src/check_nrpe $RPM_BUILD_ROOT%{_plugindir}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post
87 /sbin/chkconfig --add nrpe
88 if [ -f /var/lock/subsys/nrpe ]; then
89         /etc/rc.d/init.d/nrpe restart 1>&2
90 fi
91
92 %preun
93 if [ "$1" = "0" ] ; then
94         if [ -f /var/lock/subsys/nrpe ]; then
95                 /etc/rc.d/init.d/nrpe stop 1>&2
96         fi
97         /sbin/chkconfig --del nrpe
98 fi
99
100 %files
101 %defattr(644,root,root,755)
102 %doc Changelog LEGAL README* SECURITY
103 %attr(754,root,root) /etc/rc.d/init.d/nrpe
104 %attr(640,root,nagios) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/nrpe.cfg
105 %attr(755,root,root) %{_sbindir}/nrpe
106
107 %files plugin
108 %defattr(644,root,root,755)
109 %dir %{_plugindir}
110 %attr(755,root,root) %{_plugindir}/*
This page took 0.096522 seconds and 4 git commands to generate.