]> git.pld-linux.org Git - packages/nagios-nrpe.git/blob - nagios-nrpe.spec
da8d0cfbbefbc3c6a2df6db7fdf7cb18ed19d6d9
[packages/nagios-nrpe.git] / nagios-nrpe.spec
1 Summary:        Nagios remote plugin execution service/plugin
2 Summary(pl.UTF-8):      Demon i wtyczka zdalnego wywoływania wtyczek Nagios
3 Name:           nagios-nrpe
4 Version:        4.0.3
5 Release:        3
6 License:        GPL v2
7 Group:          Networking
8 Source0:        https://github.com/NagiosEnterprises/nrpe/releases/download/nrpe-%{version}/nrpe-%{version}.tar.gz
9 # Source0-md5:  42252d3c721c87ebb5e38b748f187e8d
10 Source1:        nrpe.init
11 Source2:        nrpe-command.cfg
12 Source3:        %{name}.tmpfiles
13 Source4:        commands.cfg
14 Patch0:         %{name}-config.patch
15 Patch1:         nrpe_check_control.patch
16 Patch2:         11_reproducible_dh.h.patch
17 URL:            https://exchange.nagios.org/directory/Addons/Monitoring-Agents/NRPE--2D-Nagios-Remote-Plugin-Executor/details
18 BuildRequires:  openssl-devel
19 BuildRequires:  openssl-tools
20 BuildRequires:  rpmbuild(macros) >= 1.647
21 Requires(post,preun):   /sbin/chkconfig
22 Requires:       nagios-common >= 4.3.3-2
23 Requires:       rc-scripts >= 0.4.1.26
24 Provides:       nagios-core
25 Obsoletes:      netsaint-nrpe
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _sysconfdir     /etc/nagios
29 %define         _datadir        %{_prefix}/share/%{name}
30 %define         _plugindir      %{_libdir}/nagios/plugins
31 %define         _localstatedir  %{_var}/log/nagios
32 %define         nsport          5666
33
34 %description
35 NPRE (Nagios Remote Plugin Executor) is a system daemon that will
36 execute various Nagios plugins locally on behalf of a remote
37 (monitoring) host that uses the check_nrpe plugin.
38
39 %description -l pl.UTF-8
40 NRPE to dodatek do Nagiosa pozwalający na wywoływanie "lokalnych"
41 wtyczek (takich jak check_disk, check_procs itp.) na zdalnych
42 maszynach. Wtyczka check_nrpe jest wywoływana z poziomu Nagiosa i
43 wysyła żądania uruchomienia wtyczek do demona NRPE działającego na
44 zdalnej maszynie (jako samodzielny demon lub usługa inetd). Obsługuje
45 przekazywanie argumentów poleceń do serwera, a także natywne
46 szyfrowanie SSL/TLS (w trybie anonimowego DH).
47
48 %package -n nagios-plugin-check_nrpe
49 Summary:        check_nrpe plugin for Nagios
50 Summary(pl.UTF-8):      Wtyczka check_nrpe dla Nagiosa
51 Group:          Networking
52 Requires:       nagios-common
53 Provides:       %{name}-plugin = %{version}-%{release}
54 Obsoletes:      nagios-nrpe-plugin < 2.12-6
55
56 %description -n nagios-plugin-check_nrpe
57 The check_nrpe plugin is called from Nagios and makes plugin execution
58 requests to the NRPE daemon running on the remote host. Supports
59 passing command arguments to server, as well as native SSL/TLS
60 encryption (anonymous DH mode).
61
62 %description -n nagios-plugin-check_nrpe -l pl.UTF-8
63 Wtyczka check_nrpe dla Nagiosa. Pozwala na zdalne uruchamianie wtyczek
64 na innych komputerach za pomocą demona nrpe.
65
66 %prep
67 %setup -q -n nrpe-%{version}
68 %undos contrib/nrpe_check_control.c
69 %patch0 -p1
70 %patch1 -p1
71 %patch2 -p1
72
73 %build
74 %{__aclocal}
75 %{__autoconf}
76 %configure \
77         --with-nrpe-port=%{nsport} \
78         --with-nrpe-user=nagios \
79         --with-nrpe-group=nagios \
80         --with-piddir=/var/run/nrpe \
81         --enable-ssl \
82         --with-ssl-lib=%{_libdir} \
83         --enable-command-args
84
85 %{__make} all
86
87 %{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} contrib/nrpe_check_control.c -o contrib/nrpe_check_control
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/{plugins,nrpe.d},%{_libdir}/nagios/plugins,%{_sbindir}} \
92         $RPM_BUILD_ROOT{%{_localstatedir},/var/run/nrpe} \
93         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
94
95 cp -p sample-config/nrpe.cfg $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.cfg
96 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.d
97 sed -e 's,@plugindir@,%{_plugindir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/plugins/check_nrpe.cfg
98 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/nrpe
99 install -p src/nrpe $RPM_BUILD_ROOT%{_sbindir}
100 install -p src/check_nrpe $RPM_BUILD_ROOT%{_plugindir}
101 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 /sbin/chkconfig --add nrpe
108 %service nrpe restart
109
110 %preun
111 if [ "$1" = "0" ] ; then
112         %service nrpe stop
113         /sbin/chkconfig --del nrpe
114 fi
115
116 %triggerpostun -- %{name} < 2.6-1.1
117 # < 2.15-5
118 # skip *this* trigger on downgrade
119 [ $1 -le 1 ] && exit 0
120
121 # ensure there's include_dir directive
122 if ! grep -q '^include_dir=%{_sysconfdir}/nrpe.d' %{_sysconfdir}/nrpe.cfg; then
123         echo 'include_dir=%{_sysconfdir}/nrpe.d' >> %{_sysconfdir}/nrpe.cfg
124 fi
125
126 # check if need to migrate
127 grep -q '^command\[' %{_sysconfdir}/nrpe.cfg || exit 0
128
129 # move command definitions to separate file
130 mv -f  %{_sysconfdir}/nrpe.d/commands.cfg{,.rpmnew}
131 grep '^command\['  %{_sysconfdir}/nrpe.cfg > %{_sysconfdir}/nrpe.d/commands.cfg
132 cp -f %{_sysconfdir}/nrpe.cfg{,.rpmsave}
133 sed -i -e '/^command\[/d' %{_sysconfdir}/nrpe.cfg
134
135 %service nrpe restart
136
137 # < 2.6-1.1
138 %{__sed} -i -e 's,/var/run/nrpe.pid,/var/run/nrpe/nrpe.pid,' %{_sysconfdir}/nrpe.cfg
139
140 %triggerpostun -n nagios-plugin-check_nrpe -- nagios-plugin-check_nrpe < 2.12-7.1
141 if [ -f %{_sysconfdir}/plugins/nrpe.cfg.rpmsave ]; then
142         cp -f %{_sysconfdir}/plugins/check_nrpe.cfg{,.rpmnew}
143         mv -f %{_sysconfdir}/plugins/{nrpe.cfg.rpmsave,check_nrpe.cfg}
144         sed -i -e 's,-c \$ARG1\$,$ARG1$,' %{_sysconfdir}/plugins/check_nrpe.cfg
145 fi
146
147 %files
148 %defattr(644,root,root,755)
149 %doc CHANGELOG.md LEGAL README* SECURITY.md update-cfg.pl
150 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.cfg
151 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.d/commands.cfg
152 %attr(755,root,root) %{_sbindir}/nrpe
153 %attr(754,root,root) /etc/rc.d/init.d/nrpe
154 %dir %attr(775,root,nagios) /var/run/nrpe
155 %{systemdtmpfilesdir}/%{name}.conf
156
157 %files -n nagios-plugin-check_nrpe
158 %defattr(644,root,root,755)
159 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugins/check_nrpe.cfg
160 %attr(755,root,root) %{_plugindir}/check_nrpe
This page took 0.069084 seconds and 3 git commands to generate.