]> git.pld-linux.org Git - packages/nagios-nrpe.git/blob - nagios-nrpe.spec
- rename -plugin to nagios-plugin-check_nrpe
[packages/nagios-nrpe.git] / nagios-nrpe.spec
1 Summary:        Nagios remote plugin execution service/plugin
2 Summary(pl.UTF-8):      Demon i wtyczka zdalnego wywoływania wtyczek Nagios
3 Name:           nagios-nrpe
4 Version:        2.12
5 Release:        6
6 License:        GPL v2
7 Group:          Networking
8 Source0:        http://dl.sourceforge.net/nagios/nrpe-%{version}.tar.gz
9 # Source0-md5:  b2d75e2962f1e3151ef58794d60c9e97
10 Source1:        nrpe.init
11 Source2:        nrpe-command.cfg
12 Patch0:         %{name}-config.patch
13 URL:            http://www.nagios.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  openssl-devel
17 BuildRequires:  openssl-tools
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(post,preun):   /sbin/chkconfig
20 Requires:       nagios-common
21 Requires:       rc-scripts
22 Provides:       nagios-core
23 Obsoletes:      netsaint-nrpe
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sysconfdir     /etc/nagios
27 %define         _datadir        %{_prefix}/share/%{name}
28 %define         _plugindir      %{_libdir}/nagios/plugins
29 %define         _libexecdir     %{_plugindir}
30 %define         _localstatedir  %{_var}/log/nagios
31 %define         nsport          5666
32
33 %description
34 NRPE is an addon for Nagios that allows you to execute "local" plugins
35 (like check_disk, check_procs, etc.) on remote hosts. The check_nrpe
36 plugin is called from Nagios and makes plugin execution requests to
37 the NRPE daemon running on the remote host (either as a standalone
38 daemon or as a service under inetd). Supports passing command
39 arguments to server, as well as native SSL/TLS encryption (anonymous
40 DH mode).
41
42 %description -l pl.UTF-8
43 NRPE to dodatek do Nagiosa pozwalający na wywoływanie "lokalnych"
44 wtyczek (takich jak check_disk, check_procs itp.) na zdalnych
45 maszynach. Wtyczka check_nrpe jest wywoływana z poziomu Nagiosa i
46 wysyła żądania uruchomienia wtyczek do demona NRPE działającego na
47 zdalnej maszynie (jako samodzielny demon lub usługa inetd). Obsługuje
48 przekazywanie argumentów poleceń do serwera, a także natywne
49 szyfrowanie SSL/TLS (w trybie anonimowego DH).
50
51 %package -n nagios-plugin-check_nrpe
52 Summary:        check_nrpe plugin for Nagios
53 Summary(pl.UTF-8):      Wtyczka check_nrpe dla Nagiosa
54 Group:          Networking
55 Requires:       nagios-core
56 Provides:       %{name}-plugin = %{version}-%{release}
57 Obsoletes:      %{name}-plugin < 2.12-6
58
59 %description -n nagios-plugin-check_nrpe
60 check_nrpe plugin for Nagios. This plugin allows running plugins on
61 remote machines using nrpe service.
62
63 %description -n nagios-plugin-check_nrpe -l pl.UTF-8
64 Wtyczka check_nrpe dla Nagiosa. Pozwala na zdalne uruchamianie wtyczek
65 na innych komputerach za pomocą demona nrpe.
66
67 %prep
68 %setup -q -n nrpe-%{version}
69 %patch0 -p1
70
71 %build
72 %{__aclocal}
73 %{__autoconf}
74
75 %configure \
76         --with-init-dir=/etc/rc.d/init.d \
77         --with-nrpe-port=%{nsport} \
78         --with-nrpe-user=nagios \
79         --with-nrpe-grp=nagios \
80         --enable-ssl \
81         --enable-command-args
82
83 %{__make} all
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/plugins,%{_libdir}/nagios/plugins,%{_sbindir}} \
88         $RPM_BUILD_ROOT{%{_localstatedir},/var/run/nrpe}
89
90 install sample-config/nrpe.cfg $RPM_BUILD_ROOT%{_sysconfdir}/nrpe.cfg
91 sed -e 's,@plugindir@,%{_plugindir},' %{SOURCE2} > $RPM_BUILD_ROOT%{_sysconfdir}/plugins/nrpe.cfg
92 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/nrpe
93 install src/nrpe $RPM_BUILD_ROOT%{_sbindir}
94 install src/check_nrpe $RPM_BUILD_ROOT%{_plugindir}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 /sbin/chkconfig --add nrpe
101 %service nrpe restart
102
103 %preun
104 if [ "$1" = "0" ] ; then
105         %service nrpe stop
106         /sbin/chkconfig --del nrpe
107 fi
108
109 %triggerpostun -- %{name} < 2.6-1.1
110 %{__sed} -i -e 's,/var/run/nrpe.pid,/var/run/nrpe/nrpe.pid,' %{_sysconfdir}/nrpe.cfg
111
112 %files
113 %defattr(644,root,root,755)
114 %doc Changelog LEGAL README* SECURITY
115 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nrpe.cfg
116 %attr(755,root,root) %{_sbindir}/nrpe
117 %attr(754,root,root) /etc/rc.d/init.d/nrpe
118 %dir %attr(775,root,nagios) /var/run/nrpe
119
120 %files -n nagios-plugin-check_nrpe
121 %defattr(644,root,root,755)
122 %attr(640,root,nagios) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plugins/nrpe.cfg
123 %attr(755,root,root) %{_plugindir}/check_nrpe
This page took 0.079498 seconds and 3 git commands to generate.